RPI MQTT gateway stops communicating



  • Hi
    I have a RPI3 MQTT gateway with RFM69 that stops working after a few hours. I can still log in to the PI from Putty and the daemon is still active. Checking the log file, everything seems fine up the the point when it stops communicating and from there on there are no more entries in the log.
    I have tried with both master and development branch.
    If I stop and restart the daemon it will work fine for a few more hours before the same thing happens again.
    Power supply should be good, I think it must be something else going on. Any ideas?

    this seems to be same problem as described in this post: Re: pi gateway just stops communicating



  • An update; As a work around I disabled the wifi and connected the RPI with ethernet cable (I intended to do that anyway), and now it has been working fine for 48 hours. So the issue seems to be wifi related somehow.


  • Mod

    Thanks for reporting this info @olka

    The thread you linked mentioned unstable wired networking. Maybe the issue is related to unstable networking, regardless whether it is wifi or wired, and your wired connection is more stable than the wifi?



  • Yes, you are probably right. I both cases the RPI still have connection with the router and the deamon is (apperently) still active but not communicating.
    I have a wifi mesh network, and I have seen that clients are sometimes disconnected and reconnected. That might have something to do with it.


Log in to reply
 

Suggested Topics

  • 6
  • 10
  • 6
  • 4
  • 3
  • 8
  • 4

197
Online

9.7k
Users

10.3k
Topics

106.4k
Posts