sending battery voltage - openhab mysensors binding



  • Hello
    hope someone can help me with a problem I spent many hours on meanwhile.
    I'm using a MySensors serial gateway which is connected to a Rasberry Pi running Openhab. The connection to the nodes is realized by nrf24.
    The nodes report temperature and humidity to the gateway . These values are forwarded to Openhab and displayed - which works pretty well.
    Now I would like to send the value of the nodes' battery voltage to Openhab in the same way. I believe the value is sent out properly because of the debug output of my node:

    1.PNG

    but only temperature and humidity seem to be received by openhab:

    2.PNG

    The relevant parts of my sketch are:

    #define CHILD_ID_TEMP    0 
    #define CHILD_ID_HUM     1
    #define CHILD_ID_VOLT    2
    ....
    
    MyMessage msgTemp (CHILD_ID_TEMP, V_TEMP);
    MyMessage msgHum  (CHILD_ID_HUM,  V_HUM);
    MyMessage msgVolt (CHILD_ID_VOLT, V_VOLTAGE);
    ....
    
    present(CHILD_ID_TEMP, S_TEMP);
    present(CHILD_ID_HUM,  S_HUM);
    present(CHILD_ID_VOLT, S_MULTIMETER);
    ....
    
    send(msgTemp.set(temperature, 1));
    send(msgHum.set(humidity, 1));
    send(msgVolt.set(batteryV,1));
    
    

    things defined in Openhab:

    	Thing temperature	tempe_N01	[ nodeId=1, childId=0 ]				
    	Thing humidity		humid_N01	[ nodeId=1, childId=1 ]
    	Thing multimeter	batVol_N01	[ nodeId=1, childId=2 ]
    

    items defined in Openhab:

    Number tempe_N01		" Temperature [%.1f °C]"	    		<temperature>	    { channel="mysensors:temperature:gateway:tempe_N01:temp"}
    Number humid_N01		"Humidity[%.1f %%]"       <temperature>		    { channel="mysensors:humidity:gateway:humid_N01:hum"}
    Number batVol_N01		"Node 01 - Batterie/Volt [%.2f V]"			<battery>				    { channel="mysensors:multimeter:gateway:batVol_N01:volt"}
    

    Any help would be greatly appreciated
    Eric



  • OK got it !!! It was a combination of more failures - with the main one not having read the name of the status message carefully enough : ItemStateChanged(!!!)Event. So as long as battery level is the same ...


Log in to reply
 

Suggested Topics

  • 1
  • 2
  • 23
  • 5
  • 4
  • 3
  • 4
  • 9

125
Online

9.4k
Users

10.0k
Topics

104.4k
Posts