Sensebender. Still same problems with NEW board and radio



  • Re: Trouble with Sensebender gateway initialisation

    Hi.
    I'm having the same issues with a NEW Sensebender gateway board, fitted with a diffrent RFM69 radio.

    Diagnostics STILL fail at the eeprom reading.

    See log

    What can I possibly be doing wrong, given that the first one of these I built, worked fine?

    Regards Nigel

    Sensebender GateWay test routine
    Mysensors core version : 2.2.0
    GateWay sketch version : 0.2
    ----------------------------------
    
    - > SHA204 Ok (serial : 01234DB597196D83EE)
    - > SD CARD SD CARD did not initialize!
     -> EEPROM 0;255;hu;0;hu;3 MCO:BGN:INIT GW,CP=RRNGS---,VER=2.2.0
    0;255;hu;0;hu;3 TSF:LRT:OK
    0;255;hu;0;hu;3 TSM:INIT
    0;255;hu;0;hu;3 TSF:WUR:MS=0
    0;255;hu;0;hu;3 !TSM:INIT:TSP FAIL
    0;255;hu;0;hu;3 TSM:FAIL:CNT=hu
    0;255;hu;0;hu;3 TSM:FAIL:DIS
    0;255;hu;0;hu;3 TSF:TDI:TSL
    0;255;hu;0;hu;3 TSM:FAIL:RE-INIT
    0;255;hu;0;hu;3 TSM:INIT
    0;255;hu;0;hu;3 !TSM:INIT:TSP FAIL
    0;255;hu;0;hu;3 TSM:FAIL:CNT=hu
    0;255;hu;0;hu;3 TSM:FAIL:DIS
    0;255;hu;0;hu;3 TSF:TDI:TSL
    0;255;hu;0;hu;3 TSM:FAIL:RE-INIT
    0;255;hu;0;hu;3 TSM:INIT
    0;255;hu;0;hu;3 !TSM:INIT:TSP FAIL
    0;255;hu;0;hu;3 TSM:FAIL:CNT=hu
    0;255;hu;0;hu;3 TSM:FAIL:DIS
    0;255;hu;0;hu;3 TSF:TDI:TSL
    0;255;hu;0;hu;3 TSM:FAIL:RE-INIT
    0;255;hu;0;hu;3 TSM:INIT
    0;255;hu;0;hu;3 !TSM:INIT:TSP FAIL
    0;255;hu;0;hu;3 TSM:FAIL:CNT=hu
    0;255;hu;0;hu;3 TSM:FAIL:DIS
    0;255;hu;0;hu;3 TSF:TDI:TSL
    
    


  • Is there any specific reason for using 2.2 and not either 2.3 or even 2.4 (development tree)?
    Afaik, there's been especially some changes around the RFM drivers, so giving newer versions a try might be a good idea 😉 .



  • @rejoe2
    The reason for 2.2.0 is that when I (when 2.3.0) came out, I upgraded, and quite simply nothing worked, even though in theory, no significant "breaking" changes had been made.
    I could try upgrading, and building the gateway under 2.3.x, just to see if it works, but I am loth to change things, unless I can run some offline trials. I have about 20 nodes, including the whole central heating system. given it's now summer, I can give it a go, time depending.

    The NEW rfm69 driver, is it wirelessly compatible with the OLD driver? i.e. can old talk to new?
    the first Sensebender gateway, which I inadvertantly killed, by upping the max power, was built under 2.2.0.

    regards Nigel


  • Mod

    @Njwyborn said in Sensebender. Still same problems with NEW board and radio:

    The NEW rfm69 driver, is it wirelessly compatible with the OLD driver? i.e. can old talk to new?

    No, the on - air payload is different. All nodes in a network must use the same rfm driver.



  • @Yveaux Thank you for the clarification, big job to upgrade!

    Question. Anyone know if I can run two mysensors serial gateways on Domoticz? Different network ID's? That would enable me to move nodes over to the latest release / drivers, and only have the node I was working on at the time offline! Assuming I can ever get my sensebender working!


  • Mod

    @Njwyborn said in Sensebender. Still same problems with NEW board and radio:

    big job to upgrade

    Or stick with the old driver



  • Question.
    Would using the "ClearEepromConfig" sketch, do anything nasty to the sencebender gateway eeprom?


Log in to reply
 

Suggested Topics

  • 8
  • 2
  • 2
  • 3
  • 8
  • 1
  • 1
  • 7

80
Online

10.3k
Users

10.7k
Topics

109.7k
Posts