unable to compile for ATmega168 16M 5v



  • Hi, I'm totaly new with Arduino/Mysensors. I bought a bunch of sensors and boards, the problem I have is to upload mysensors sketches to the Amega168 board, it will fail when compiling the sketch with the error below.
    I can succesfully upload blink for example. Can't this ATmega168 not be used for Mysensors?
    running IDE 1.6.3

    In file included from /Users/pieterblom/Documents/Arduino/libraries/MySensors/utility/LowPower.cpp:27:0:
    /Users/pieterblom/Documents/Arduino/libraries/MySensors/utility/LowPower.cpp: In member function 'void LowPowerClass::powerExtStandby(period_t, adc_t, bod_t, timer2_t)':
    /Users/pieterblom/Documents/Arduino/libraries/MySensors/utility/LowPower.cpp:823:18: error: 'SLEEP_MODE_EXT_STANDBY' was not declared in this scope
    lowPowerBodOn(SLEEP_MODE_EXT_STANDBY);

    After some troubleshooting I tried allso IDE1.0.6 which gives me a more clear error message:
    Binaire sketch-grootte: 15.754 bytes (van een 14.336-byte maximum?

    I tried another sketch(motion_sensor) which does fit on the ATmega168. Any ideas how to fit the DallasTemparatureSensor on the ATmega168?



  • @pjeterinfo Hello, maybe here [remove debug]](http://www.mysensors.org/build/debug)



  • Hi,

    I'm new and getting started with this amazing project.

    I'm having exactly the same problem as described by pjeterinfo trying to upload the relay code.

    LowPower.cpp:823: error: 'SLEEP_MODE_EXT_STANDBY' was not declared in this scope
    lowPowerBodOn(SLEEP_MODE_EXT_STANDBY);

    Can anybody help me out on this one? I've been debugging code but not finding out what's going wrong. Seen and done as suggested by Totche, still same problem.

    pjeterinfo did you sort it out? If so what did you do?

    Thank´s


  • Contest Winner

    @pjeterinfo said:

    After some troubleshooting I tried allso IDE1.0.6 which gives me a more clear error message:
    Binaire sketch-grootte: 15.754 bytes (van een 14.336-byte maximum?

    ATMega 168 is too small on memory as the error message clearly indicates. It has 16k Flash memory for program where some is needed for the bootloader which is round about 2k 16-2 = 14k. The sketch is 15.7k big which does obviously not fit into 14k. You need 32k ATMega like ATMEGA328p on Arudino nano/uno.

    There are some efforts of some people to strip down the libs to fit into smaller devices. However especially in the beginning I'd recommend to not spend this effort.



  • @hugo1975 I removed debug for the ATmega168 16M and use them for motion sensors, that will fit this board. Other sensors I run on the ATmega328p.



  • Hi guys

    I've been banging on the wall for hours.

    Thank´s a lot, this is a major set back "for now" i'll order new arduino in a minute.

    All though something is concerning me. Compiling the RelayActuator or the RelayOutlet with out the FTDI connected the compiling message still appears, using Arduino 1.6.4, via Codebender it gives the lack of space or error compiling.

    Arduino 1.6.4 message
    "
    LowPower.cpp:823: error: 'SLEEP_MODE_EXT_STANDBY' was not declared in this scope
    lowPowerBodOn(SLEEP_MODE_EXT_STANDBY);
    "

    The motion sensor doesn't fit as well. I'm using http://www.mysensors.org/build/motion

    Thanks again


Log in to reply
 

Suggested Topics

  • 3
  • 3
  • 15
  • 2
  • 2
  • 24

0
Online

11.2k
Users

11.1k
Topics

112.5k
Posts