UI 7 Ethernet Gateway Problem

  • I just got a Vera Edge UI 7, Software version: 1.7.1018 and I'm trying setup the gateway. I have followed the steps on My Sensor but for some reason I'm getting an error on Vera. I was wondering if any of you have a solution to this issue. Cheers!Screen Shot 2015-04-09 at 9.06.41 PM.png

    Screen Shot 2015-04-09 at 9.05.17 PM.png

  • Admin

    @jeylites Make sure that you are using the UI7 branch in the Vera github repo. https://github.com/mysensors/Vera/tree/UI7

    I recently setup a VeraEdge with an Ethernet gateway for development and it has been working flawlessly...

    Screen Shot 2015-04-09 at 10.40.54 PM.png

  • @jeylites Ethernet or serial gateway?
    You can try this http://forum.mysensors.org/topic/838/windows-gui-controller-for-mysensors program it is excellent for troubleshooting, with this you can verify that your gateway and sensors work correct.

  • @blacey I tried to ping the gateway but its not showing up. I'm using UI7 from the Vera Github. For the Gateway I'm using a 1.4 sketch running on a Uno with an Ethernet shield.

    @olaeke that software looks great. I'm going to try run it on Mac using wine.

  • If you are not able to ping the gateway, you have an issue with either the network connection or the gateway self.
    You can also debug your gateway by connect it via USB to your computer and use the serial monitoring function of Arduino IDE (on my windows machine that is activated via " Shift - Ctrl - M "

    Which components did you use for your gateway ?
    As in which arduino and which Ethershield ?

  • Admin

    @jeylites In the original screenshot that you posted, it seems the Vera is able to connect to your Ethernet gateway. Confirm that you have changed the IP address in the Ethernet Gateway Sketch to ensure it is a unique IP address within your subnet and that you can ping it.

    #define IP_PORT 5003        // The port you want to open 
    IPAddress myIp (192, 168, 178, 66);  // Configure your static ip-address here    COMPILE  ERROR HERE? Use Arduino IDE 1.5.7 or later!

    Then connect the gateway to your Ethernet segment and try to ping it from a terminal.

    blacey$ ping
    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=128 time=14.615 ms
    64 bytes from icmp_seq=1 ttl=128 time=2.410 ms
    64 bytes from icmp_seq=2 ttl=128 time=1.279 ms
    64 bytes from icmp_seq=3 ttl=128 time=4.616 ms
    64 bytes from icmp_seq=4 ttl=128 time=2.268 ms
    64 bytes from icmp_seq=5 ttl=128 time=1.507 ms
    64 bytes from icmp_seq=6 ttl=128 time=1.190 ms
    --- ping statistics ---
    7 packets transmitted, 7 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 1.190/3.984/14.615/4.474 ms

    If you can ping your gateway, then you can try to connect to it using Telnet to see if it will process commands:

    telnet 5003
    blacey$ telnet 5003
    Connected to
    Escape character is '^]'.
    0;0;3;0;2;Get Version
    0;0;3;0;14;Gateway startup complete.
    telnet> quit
    Connection closed.

    In the above telnet session, you can see that I successfully connected to the IP and port of the Ethernet Gateway and issued the command 0;0;3;0;2;Get Version to which the gateway successfully responded with the startup complete and reported the version number 1.4.1. This is the same way that the UI7 plugin communicates with the gateway so at this point, you would know that the gateway is properly configured and can switch to examining the VeraEdge plugin configuration.

    If you are able to make it to this point with your gateway, then it must be a UI7 configuration issue. If you confirm that the Adruino Gateway device is configured properly to communicate using the correct IP and Port, then you could connect the Arduino console to your Gateway and restart the UI7 Luup engine so that it reloads the gateway plugin and confirm that the VeraEdge is handshaking with the Gateway. If you don't see any messages in the console log, then consider replacing the UI7 plugin files on your gateway to ensure they are all there and not corrupted.

    Finally, you can also ssh into your VeraEdge using the password on the bottom of the unit and search the log file for all Arduino messages which can be quite informative (this is usually the first place that I look).

    $ ssh veraedge
    BusyBox v1.19.4 (2014-09-04 04:42:20 PDT) built-in shell (ash)
    Enter 'help' for a list of built-in commands.
      _______                     ________        __
     |       |.-----.-----.-----.|  |  |  |.----.|  |_
     |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
     |_______||   __|_____|__|__||________||__|  |____|
              |__| W I R E L E S S   F R E E D O M
          BARRIER BREAKER (Bleeding Edge, r39638)
      ***  	   MiOS LTD. ( www.mios.com )        ***
      ***				             ***
      ***               WARNING :  	             ***
      *** Any changes made to the system without ***
      *** guidance from MiOS support will VOID   ***
      *** your future Support requests  	     ***
    root@MiOS_XXXXXXXX:~# grep Arduino /var/log/cmh/LuaUPnP.log 
    50	04/11/15 9:06:57.719	luup_log:4: Arduino plugin: loading library L_Arduino ... <0x7713c520>
    50	04/11/15 9:06:57.744	luup_log:4: Arduino plugin: library L_Arduino loaded <0x7713c520>
    50	04/11/15 9:06:57.744	luup_log:4: Arduino: urn:upnp-arduino-cc:serviceId:arduino1,PluginVersion, 1.4, 4 <0x7713c520>
    50	04/11/15 9:06:57.745	luup_log:4: Arduino: urn:upnp-arduino-cc:serviceId:arduino1,GWAddress, -, 4 <0x7713c520>
    50	04/11/15 9:06:57.746	luup_log:4: Arduino: Using network connection: IP address is <0x7713c520>
    50	04/11/15 9:06:57.846	luup_log:4: Arduino: urn:upnp-arduino-cc:serviceId:arduino1,GWAddress,, 4 <0x7713c520>
    50	04/11/15 9:06:57.848	luup_log:4: Arduino: Sending: 0;0;3;0;2;Get Version <0x7713c520>
    50	04/11/15 9:06:57.852	luup_log:4: Arduino: Log: Gateway startup complete. <0x7533c520>
    50	04/11/15 9:06:57.867	luup_log:4: Arduino: urn:upnp-arduino-cc:serviceId:arduino1,ArduinoLibVersion, 1.4.1, 4 <0x7533c520>
    50	04/11/15 9:07:53.417	luup_log:4: Arduino: Set variable: 1;3;1;1;2;0 <0x7533c520>
    50	04/11/15 9:07:53.496	luup_log:4: Arduino: Set variable: 1;1;1;0;24;0 <0x7533c520>
    50	04/11/15 9:07:53.496	luup_log:4: Arduino: Setting variable 'Variable1' to value '0' <0x7533c520>
    50	04/11/15 9:07:53.497	luup_log:4: Arduino: urn:upnp-org:serviceId:VContainer1,Variable1, 0, 6 <0x7533c520>
    50	04/11/15 9:07:53.497	luup_log:4: Arduino: urn:micasaverde-com:serviceId:HaDevice1,LastUpdate, 1428768473, 6 <0x7533c520>
    50	04/11/15 9:07:53.498	luup_log:4: Arduino: urn:micasaverde-com:serviceId:HaDevice1,LastUpdate, 1428768473, 5 <0x7533c520>
    50	04/11/15 9:07:53.499	luup_log:4: Arduino: urn:micasaverde-com:serviceId:HaDevice1,LastUpdateHR, 09:07 AM, 5 <0x7533c520>

    Good luck.

  • @blacey

    For the gateway I'm using an Uno and W5100 Ethernet Shield. I preformed all the test you both suggested. After cracking my head for couple of hours, I found out that the W5100 Ethernet port wasn't making a good connection with the RJ45 connector from the router. Very wired but it happened. Cleaning the W5100 connector with rubbing alcohol fixed it. But'm stilling getting 0% - 20% packet loss. I'm going to try a different Ethernet Shield to see if the problem carries on or not.

    @blacey Other Vera questions
    In Devices, I have a few Unnamed devices and Arduino Relay Nodes. Should it stay or can I delete it. I notice you did't have that on your example to me.

    Secondly, when you turn ON / OFF a device, is it normal for the green wheel to spin a couple seconds or more?

    Third, What is "Commands" used for in My Sensor Advance Plugin. It gives me a options control via ...

    Forth, Any idea how to get Program Logic App working. I have installed it but don't know where to make rules for it.

    Thanks folks! your reply has been a great help to me!!!

  • @jeylites
    Great, packet loss could have lots of reasons and are not necessarily related to your arduino / ethernet shield.
    For example if the computer you are pinging via WiFi with lots of interference (so hard to judge / see as your signal indicator on the computer can still be indicating a good signal.

    So preferably you do all your tests connected via cable and on the same network device (your router), and as a reference you should try also to ping the router or another network device to check the connection from your computer to the network.
    If these all show no packet loss, and a ping to your arduino does, than I agree with you the problem is caused by the ethershield.

    But make sure you use good network cables, they are not that expensive and easy to replace.

  • Admin


    In Devices, I have a few Unnamed devices and Arduino Relay Nodes. Should it stay or can I delete it. I notice you did't have that on your example to me.

    You can delete them.

    Secondly, when you turn ON / OFF a device, is it normal for the green wheel to spin a couple seconds or more?

    Yes. The delay seems a little longer on the VeraEdge running UI7 with an Ethernet gateway than on a Vera3 running UI5 with a serial gateway. Unfortunately, with three differences between my two configs, it is hard to tell which causes the delay.

    Third, What is "Commands" used for in My Sensor Advance Plugin. It gives me a options control via ...

    That is standard across all Vera/MIOS devices - nothing specific to MySensors.

    Forth, Any idea how to get Program Logic App working. I have installed it but don't know where to make rules for it.

    You should visit the micasaverde forums for PLEG information and assistance...


  • @blacey

    Thanks for the explanation guys. Very much appreciated!!! Just an update on what I have done. I swapped my old Ethernet Shield with a new one and everything started working. Did a ping test on all four attempts, packet lost came in 0%. Lesson learned, never assume that the since its a new hardware it would not fail. Well, mine failed despite being 2 weeks old. LOL

  • Hello,

    I had the same issue and the root cause was my powersupply, it was not enought powerfull. I power my arduino with 12V and everything goes well.


Log in to reply

Suggested Topics

  • 4
  • 1
  • 2
  • 3
  • 1
  • 6
  • 10
  • 2