• I have just unboxed my new vera edge manage to upgrade so that it recognize the usb uno gateway.

    I can not get the sensor to be recognized. I press the button on the side and reset the sensor I know that it send sucessfully to the gateway having tested it on a computer.

    So the question now is what am i doing wrong. Should I creat a new device with the D_arduinoRelay1.xml file?

    Can someone tell me what I am doing wrong and point me in the right direction


  • @legaultf

    The first step is to test your sensors and see if they are communicating via Serial monitor, then do the same with serial gateway. If its good you will get a "complete".

  • Thank you for your reply.

    Here is what I get when I connect my gateway to my computer monitor and I reset my relay

    0;0;3;0;14;Gateway startup complete.
    0;0;3;0;9;read: 19-19-0 s=255,c=0,t=17,pt=0,l=5:1.4.1
    0;0;3;0;9;read: 19-19-0 s=255,c=3,t=6,pt=1,l=1:0
    0;0;3;0;9;read: 19-19-0 s=255,c=3,t=11,pt=0,l=12:Relay Outlet
    19;255;3;0;11;Relay Outlet
    0;0;3;0;9;read: 19-19-0 s=255,c=3,t=12,pt=0,l=3:1.0
    0;0;3;0;9;read: 19-19-0 s=0,c=0,t=3,pt=0,l=5:1.4.1

    I concluded that my sensor / gateway pair is working correctly.

    Should it be dectected by the veraedge when I press pairing and reset the Relay Outlet ?

    I try creating a new device and associate the D_ArduinoRelay1.xml file to it but I never get an on/off button associated with the device I created.


  • @legaultf

    Please give me a break down of what you have done and I will help with the next step.

  • I have tested the hardware succesfully connecting the serial gateway on com5 and having a remote relay not connected to the computer with a led. I can turn the led wirelessly on and off wiht MYSController.

    I have then connected the serial USB to the VeraEdge and with some help from Vera managed to activate and configure the serial port.

    Here is the vera config for the serial port

    Serial Port configuration
    If you connected the USB/serial device and it's not displayed here, reload Luup.Reload Luup
    Name: ftdi_sio Path: /dev/ttyUSB0
    Device number: usb-101c1000.ohci-1
    IP address: Port: 3481
    Baud: 115200 Parity: none
    Data bits: 8 Stop bits: 1
    Used by device: MySensors Plugin [Living Room]

    At that stage I tried paring by pressing the pairing button on the Vera edge and resetting my sensor without succes.

    I the proceeded on creating a new device in the vera develop apps/Create device.

    this one I created a standard d_arduinoRelay1.xml as a child of the MySensors Plugin

    I then tried to discover my sensor without success.

    My next step maybe to add an ethernet gateway and see if the issue come from the serial interface on the vera.

    Hopefully you will see something I am doing wrong.

    Thank you


  • @legaultf

    Did you "Reset the Lupp"

    A trick I learned right after creating devises is to click on " Reload Luup". Then give it a couple of minutes and you should see the created devices on DEVICES on VERA.

    " Reload Luup". could be access from Apps -> Develop apps -> Serial Port configuration -> Reload Luup

  • I see all the devices but none have any controls. Does that mean they are not properly configured ?

  • @legaultf

    If your gateway is connected, it should look something like this.. See below. On my setup I have it connected via Serial. Initially I had it connected via Ethernet, but felt there was a delay. The serial route seem to be working great for me.

    Are you using the latest Vera version: 1.7.1089

    Screen Shot 2015-04-26 at 11.01.41 AM.png

  • Please find below the config screen for my device.

    Could you either copy paste your configuration screens or tell me what is not set properly ?

    Your help is greatly appreciated


    ScreenHunter_65 Apr. 26 15.08.jpg ScreenHunter_64 Apr. 26 15.07.jpg

  • @legaultf

    Essentially, you don't have to do anything on this page unless you are using an Ethernet Gateway. If so you will have to copy the IP address with port No. into the ip column in Vera.

  • any idea why I can not pair any device or have a screen similar to yours showing the gateway ?

  • @legaultf

    Can you take a screen shot of your devices on Vera. Try doing a power off / on reset. Or there could be something you didn't create after uploading the Lupp...

  • I just made some progress

    I now have the start stop control. I did not initially uploaded the .json file. Now I made sure I have the following d_arduino1.xml, d_arduino1.json, d_arduinorelay1.xml & json

    ScreenHunter_67 Apr. 26 15.34.jpg

    ScreenHunter_66 Apr. 26 15.33.jpg

  • @legaultf

    The Error message is a normal because the vera need time to reload the new setting. I suggest to go to serial devices and reload the lupp. Hope it work after. I still fill you mist a couple of steps. I suggest doing through all steps again just to make sure.

  • @legaultf

    Also make sure you are using UI7 files as linked

  • An uno as serial gateway?.
    I think that is not supported and you should use a nano for that:

  • Major improvement with the latest version for the ui7 ! I now have the gateway being recognized.

    When I press the start button it does work once after 10 tries and then I get the following ScreenHunter_69 Apr. 26 16.01.jpg

    your help as got me this far thank you again I feel that I am making progress

  • Ok so I made a new gateway with an Arduino Nano and do not have any error anymore but I can not add any devices.

    I contacted the people from Vera because my serial port option is gone.

    They were able to reactive it but they told me "Arduino seems to be a replica (it should use FTDI) " which probably mean I have to order new one. Are you aware of this issue ? is this a show stopper as they seem to imply.

    I will probably order what I need now and in the mean time I thank you all for your help.

    Kindest regards,


  • Thuis non-FTDI problem has been mentioned before:

Log in to reply

Suggested Topics

  • 5
  • 1
  • 2
  • 10
  • 2
  • 6
  • 1
  • 3