st=fail???



  • I am using library 1.4 with a MQTTGateway and testing my first sensor, a humidity/temperature sensor with the default sketch. The sensor serial monitor shows the following:

    send: 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    sensor started, id 255
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    T: 25.10
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    send: 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    H: 75.00
    

    Not really sure what is wrong. Seems like it does get a sensor id=255. The sketch has the humidity sensor on child id=0 and temperature on child id =1, but it doesn't look like that is being sent.

    I do see this in the gateway serial monitor:

    <<C0 00 
    >>D0 00 
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=4,pt=1,l=1,st=fail:20
    <<C0 00 
    >>D0 00 
    <<C0 00 
    >>D0 00 
    <<C0 00 
    >>D0 00 
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=4,pt=1,l=1,st=fail:20
    <<C0 00 
    >>D0 00 
    <<C0 00 
    >>D0 00 
    

    I am connected to the openHAB controller 1.7

    Any comments are greatly appreciated. I feel like i am so close to actually having this working!


  • Hero Member

    @bpair 255 is the default node ID before the real node ID gets assigned. Looks like you are getting a lot of packet failures. How are you powering your nodes? Do you have the recommended capacitors installed on the radios? If not, I would try that first. How far apart is your gateway from your sensor?

    Cheers
    Al



  • The radio and gateway are about 25 feet apart, although 1 is upstairs and 1 downstairs. I do have 4.7 uF capactors on both. I was using the power from the computer on the radio and gateway when I captured the serial output however originally the gateway was powered with the power supply that came with arduino and had similar results.


  • Hero Member

    @bpair I would try movies ng them closer first to see if they start working. If it does, then you have narrowed it down to a range issue and you can start troubleshooting that. If it still doesn't work, it may be power related.

    Cheers
    Al



  • I will try that tonight. My other concern is I do not have openHAB working correctly so it is not handing out sensor IDs. The output seems OK. It connects to the mysensor broker but possibly the item file must be perfect for the sensor IDs to be assigned?


  • Hero Member

    @bpair The fails indicate a communication problem at the radio level. I know nothing about OpenHAB/MQTT so can't help you with that aspect of it. I would focus on resolving the fails first.

    Cheers
    Al



  • I saw this in a different thread:

    @rickmontana83 said:

    If you're using the cheaper low-power variants of the nrf24l01+ on the gateway then make sure that your MyConfig.h file has RF24_PA_MAX for RF24_PA_LEVEL_GW.

    I noticed the other day that the default value from GitHub is RF24_PA_LOW, which gave me only a couple of feet of comms. Changing the default made everything work much better. Seems like the default repos is set up for the high-power radio variants.


  • Hero Member

    @bpair Yes, that may fix it if you have a range issue. As a note, I'm using the cheap low-power variants as well, and the defaults work fine for me throughout my house.

    Cheers
    Al



  • Definitely check out the power level -- MIN for the low power radios equates to incredibly short ranges (like tens of inches 🙂 ).

    In my very nonscientific experiments at MAX power the low-power variants of the rf24 radios have pretty solid comms up to about 40 feet (direct line of sight) and then communication drops precipitously. So 25 feet through a floor might be pushing it. I second the recommendation to move them closer together. If that fixes it then it's time to spring for a big radio (I found them on AliExpress for ~$6 ea.) or a repeater node.

    (As an aside, I found that a USB battery pack I had for my phone was a quick solution to powering my sensor board while carrying it around the house to check radio range.)



  • Thanks for all the comments but it looks like the issue was actually my Asus RT-N66U router which has LAN-WAN firewall. When enabled it was doing wan traffic to my gateway but not allowing a response from my gateway out.


Log in to reply
 

Suggested Topics

  • 16
  • 4
  • 15
  • 7
  • 1
  • 3
  • 4
  • 2

123
Online

10.6k
Users

10.8k
Topics

111.0k
Posts