openHAB 2.0 binding

  • @Francois ok, this is the normal output. What happens if you send the I_VERSION message (just copy, paste and send one of them: 0;0;3;0;2; or 0;255;3;0;2; )?

    UPDATE: Issue posted on tracker here

  • Hero Member

    @Francois : I've updated my serial gw to the most recent development version and checked it against the binding. It is working for me. The response to I_VERSION does not belong to the RF, I've checked the current implementation of the MySensors library, so it should make not difference if you use RFM69, NRF or no RF at all.

    Maybe the gateway is too busy to answer the request? Maybe we could an option for the binding to omit the check for I_VERSION? I'm out of ideas at the moment.

  • @TimO I have this gateway working on Domoticz without any problem. Put on OH2 I am getting this error and i don't know why it is happing

  • @TimO said:

    Maybe we could an option for the binding to omit the check for I_VERSION?

    I could do it without any problem.

  • @TimO I just download the last version of the beta version and recompile my gateway and I still am getting the same error code. There is not something that I missed in the MyConfig.h file or any other file that I need to change in openHAB2?

  • Hero Member

    @Francois : No, I don't think so. I can't explain this behaviour and I'm sure the binding will just work fine after the initial check of I_VERSION.

    @andreacioni : Would you be so kind to prepare a PR? I suggest to leave the check on by default.

  • @TimO simple update, tonight I'll push it 👍

  • Hero Member

    New version of the binding available!

    • A requestTime from a node is now answered by the controller. Is anyone able to test it? (@undee )
    • The controller will answer a request for "imperial or metric" like temperature sensors might ask. We need to test that too.

    Big thanks @andreacioni for the implementation and @Francois for testing/reporting!

    I've added an example page in the wiki:
    These are the type of things I'm currently using. (SensebenderMicro, Humidity, Temperature, Cover, Motion, Light ...)

    Has anyone additional examples yet?

  • @TimO

    Thanks for your work! It's really nice to see the progress!

    I have tried the TimeAwareSensor and the MockMySensors examples. The I_TIME message is sent by the node, obviously received by the gateway, but there the gateway is not sending anything in response. Are you sure your code for sending a time response is already active?

  • @TimO mysensor is now working 🙂 The only problem I have and I also had the same problem with OpenHab 1.8.2 as well in that I don't get my relay sensor to switch on or off. If if look at the log openhab it is sending the commands to the RelayActuator what am I doing wrong with this sensor? All my other sensor are reporting back to the dashboard.

    11:59:32.760 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'teststudy' received command ON
    11:59:32.769 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:32.782 [INFO ] [marthome.event.ItemStateChangedEvent] - teststudy changed from NULL to ON
    11:59:32.789 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleUpdate called
    11:59:32.873 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:32.977 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:33.478 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:34.479 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:35.209 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;1;1;0;16;0
    11:59:35.221 [INFO ] [marthome.event.ItemStateChangedEvent] - studymotion changed from OPEN to CLOSED
    11:59:35.243 [INFO ] [marthome.event.ItemStateChangedEvent] - studymotionlastup changed from 2016-04-23T11:59:31.084+0200 to 2016-04-23T11:59:35.229+0200
    11:59:35.269 [INFO ] [marthome.event.ItemStateChangedEvent] - studymotionlastup changed from 2016-04-23T11:59:35.229+0200 to 2016-04-23T11:59:35.248+0200
    11:59:36.480 [WARN ] [g.mysensors.protocol.MySensorsWriter] - NO ACK from nodeId: 101
    11:59:36.483 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - No old status know to revert to!

  • Hi @undee

    Can you post your node firmware version and log of OH2? It's very important for us to troubleshoot your problem.

  • Hero Member

    Hi all,

    After battling with some radio issues with my sensors (in the RFM69 library) I am again ready to get things working using OH2. I downloaded the latest copy of the binding, but sadly things are not working for me. I believe the problem is still related to collecting to the serial port. I have lots of zwave stuff going on in my log, but i have included it anyhow in case someone feels the urge to take a look :-).
    0_1461437647445_temporary log

  • @kolaf Same thing as @Francois, in the binding configuration try add this: skipStartupCheck=true.

  • Hero Member

    Thanks for the suggestion. I updated the configuration like this:

    Bridge mysensors:bridge-ser:gateway [ serialPort="/dev/mysensorsUSB", sendDelay=200, skipStartupCheck=true ] {
    	baro	stableBarometer	[ nodeId="6", childId="3" ]
    	power	mainPower	[ nodeId="3", childId="1" ]
    	temperature		basementTemperature		[ nodeId="10", childId="1"]

    It did not work as expected. The resulting log is like this:

        22:34:35.570 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'mysensors.things'
        22:34:35.606 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
        22:34:35.606 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Stopping Writer thread
        22:34:35.606 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread
        22:34:35.606 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
        22:34:35.607 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/mysensorsUSB [baudRate:115200]
        22:34:35.614 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
        22:34:35.614 [DEBUG] [col.serial.MySensorsSerialConnection] - Waiting 5 seconds to allow correct reset trigger on serial connection opening
        22:34:40.608 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occured while calling thing updated at ThingHandler 'org.openhab.binding.mysensors.handler.MySensorsBridgeHandler@534c4d92: null
                at java.util.concurrent.FutureTask.get([:1.8.0_66]
                at org.eclipse.smarthome.core.common.SafeMethodCaller.callAsynchronous([88:org.eclipse.smarthome.core:]
                at org.eclipse.smarthome.core.thing.internal.ThingManager.thingUpdated([94:org.eclipse.smarthome.core.thing:]
                at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.notifyTrackers([94:org.eclipse.smarthome.core.thing:]
                at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.notifyListenersAboutUpdatedElement([94:org.eclipse.smarthome.core.thing:]
                at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.notifyListenersAboutUpdatedElement([94:org.eclipse.smarthome.core.thing:]
                at org.eclipse.smarthome.core.common.registry.AbstractRegistry.updated([88:org.eclipse.smarthome.core:]
                at org.eclipse.smarthome.core.common.registry.AbstractProvider.notifyListeners([88:org.eclipse.smarthome.core:]
                at org.eclipse.smarthome.core.common.registry.AbstractProvider.notifyListenersAboutUpdatedElement([88:org.eclipse.smarthome.core:]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider.access$3([118:org.eclipse.smarthome.model.thing:]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider$18.apply([118:org.eclipse.smarthome.model.thing:]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider$18.apply([118:org.eclipse.smarthome.model.thing:]
                at org.eclipse.xtext.xbase.lib.IterableExtensions.forEach([129:org.eclipse.xtext.xbase.lib:2.6.2.v201407030533]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider.modelChanged([118:org.eclipse.smarthome.model.thing:]
                at org.eclipse.smarthome.model.core.internal.ModelRepositoryImpl.notifyListeners([107:org.eclipse.smarthome.model.core:]
                at org.eclipse.smarthome.model.core.internal.ModelRepositoryImpl.addOrRefreshModel([107:org.eclipse.smarthome.model.core:]
                at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.checkFile([107:org.eclipse.smarthome.model.core:]
                at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.access$1([107:org.eclipse.smarthome.model.core:]
                at org.eclipse.smarthome.model.core.internal.folder.FolderObserver$WatchQueueReader.processWatchEvent([107:org.eclipse.smarthome.model.core:]
        22:34:40.612 [INFO ] [smarthome.event.ThingUpdatedEvent   ] - Thing 'mysensors:bridge-ser:gateway' has been updated.
        22:34:40.620 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'mysensors.things'
        22:34:40.815 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
        22:34:45.619 [ERROR] [s.internal.MySensorsBridgeConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received
        22:34:45.619 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
        22:34:45.619 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Stopping Writer thread
        22:34:45.621 [WARN ] [g.mysensors.protocol.MySensorsWriter] - Writer thread interrupted
        22:34:45.621 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread

  • Hero Member

    I restarted OH2 after changing the configuration, and this time I get no exceptions, but I see no more messages from the binding after the one included below.

    @kolaf said:

    22:34:40.815 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;

    Edit: after a while I finally received a few packets in the debug console:

    2016-04-23 23:10:49.020 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;d0;6t,
    2016-04-23 23:10:49.021 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;4;1012.9

    Both of the packets seem quite mangled, they are missing pieces, and some of the pieces present do not make sense. I have verified that the baud rate is correct, and when I correct directly to the Gateway using a serial console the output looks normal.

  • @kolaf that's my output, check if there's something different.

    Have you tried rebooting the entire board/system?

    23:08:55.305 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
    23:08:55.379 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/ttyS80 [baudRate:115200]
    23:08:56.542 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
    23:08:56.558 [DEBUG] [col.serial.MySensorsSerialConnection] - Waiting 5 seconds to allow correct reset trigger on serial connection opening
    23:09:00.220 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:gateway' changed from INITIALIZING to UNINITIALIZED (HANDLER_INITIALIZING_ERROR)
    23:09:00.232 [WARN ] [ome.core.thing.internal.ThingManager] - Registering handler for thing 'mysensors:bridge-ser:gateway' takes more than 5000ms.
    23:09:00.403 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'logging.persist'
    23:09:00.623 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
    23:09:01.380 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.rules'
    23:09:01.615 [WARN ] [s.internal.MySensorsBridgeConnection] - Skipping I_VERSION connection test, not recommended...
    23:09:01.641 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:gateway' changed from UNINITIALIZED (HANDLER_INITIALIZING_ERROR) to ONLINE
    23:09:01.733 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    23:09:01.737 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:bridge-ser,,, service.bundleid=181, service.scope=singleton} - org.openhab.binding.mysensors
    23:09:01.768 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;2;1.5
    23:09:01.785 [DEBUG] [s.internal.MySensorsBridgeConnection] - Good,Gateway is up and running! (Ver:1.5)
    23:09:04.490 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.script'
    23:09:05.262 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.items'

    EDIT: Do you see Skipping I_VERSION connection test, not recommended...?

  • Hero Member

    @andreacioni The difference is that I never get a response from the board for some reason. Connecting using screen works without issues. I think the still might be an issue with the serial lock, but given that we actually receive some data at all this might not be the case after all.

    Edit: I have rebooted the board by unplugging it and reconnecting it.

  • @kolaf Could you try link the serial port to another name (ln -s /dev/mysensorsUSB /dev/ttyS80)

  • Hero Member

    I just tried disconnecting and reconnecting the board and restarting OH2 again, and this time it seems to have initialised correctly :-). I'm not sure why it didn't work the first two times, though.

  • @kolaf Perfect! 😉

  • Hero Member

    Now that things seem to be working on all levels, I have a very small request. Could someone please update the "baro" thing definition to include "V_PRESSURE" as well as "V_FORECAST"? My arduino is not big enough to calculate the forecast without running out of memory, so I can only send the actual barometric pressure.

    Edit: Perhaps it is better to replace forecast with pressure for baro and create a new channel for the forecast?

    What would also have been great, but this is a longer shot, would be to have some standardised way of getting received signal strength for the (at least directly connected) sensors. At least the RFM69 has an easy way of reporting RSSI, so just need a standard way of reporting this to the binding. Currently I'm reporting it as a generic debug message like this: 0;255;3;0;9;Received RSSI: -32

    The reason I want to keep track of this is to keep an eye on the RF environments around my sensors. Things may change for many reasons (appliances, foliage, et cetera) and this will allow me to pre-emptively correct any problems in the future 🙂

  • @andreacioni

    Here is the output generated after restarting the TimeAwareSensor sketch from the MySensors examples.

    You can see that the I_TIME (3;0;1) message is received by the gateway several times, but it never sends a response to the node.

    Do you need anything else?

    12:20:59.677 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0-beta)
    12:20:59.683 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Radio init successful.
    12:20:59.683 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;14;Gateway startup complete.
    12:20:59.683 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    12:20:59.683 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:2dc775c4' changed from INITIALIZING to ONLINE
    12:20:59.776 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    12:20:59.782 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;2;2.0.0-beta
    12:20:59.782 [DEBUG] [s.internal.MySensorsBridgeConnection] - Good,Gateway is up and running! (Ver:2.0.0-beta)
    12:21:01.067 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:
    12:21:01.071 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;1;
    12:21:01.076 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=15,pt=0,l=2,sg=0:
    12:21:01.119 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;send: 0-0-167-167 s=255,c=3,t=15,pt=0,l=2,sg=0,st=fail:
    12:21:01.125 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=0,t=17,pt=0,l=10,sg=0:2.0.0-beta
    12:21:01.128 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;0;0;17;2.0.0-beta
    12:21:01.131 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    12:21:01.134 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;6;0
    12:21:03.135 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=11,pt=0,l=5,sg=0:Clock
    12:21:03.138 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;11;Clock
    12:21:03.144 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    12:21:03.146 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;12;1.0
    12:21:11.059 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:
    12:21:11.061 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;1;
    12:21:21.061 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:
    12:21:21.063 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;1;
    12:21:31.063 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:

  • Hi @TimO, me and @undee have tested everything (thanks again!). I'll push a little PR on github to fix a problem found in I_TIME response.

  • Hero Member

    Hey @andreacioni & @undee , thanks for the test & fix!
    I've merged the PR.

  • Hi @TimO ! I want to tell you an idea for the OH2 binding. What do you think about adding a date time channel to every thing that hold the last communication of the thing with the gateway? For example, it will be useful if you want to notify user that some sensors have become unavailable. Tell me what do you think! 🙂

  • Hero Member

    @andreacioni This can be easily done with a periodic rule that checks the latest update of the value assuming you have some persistence like rrd configured.

  • Hi @kolaf, yes this is how to do it. But my idea is to integrate the datetime channel into the binding in order to automatically update that value when updates are received. I think is better than have to do rules into OH config for each devices. What do you think?

  • Hero Member

    @andreacioni Sure, getting automatically configured alerts both for silent sensors and low battery for free would be great ☺️.

  • Hardware Contributor

    @andreacioni i support your idea to implementing this in the bindning.

  • Hero Member

    Hi @andreacioni !

    I can't decide if I like the idea or not. 🙂
    For sure, the result is needed. I currently have a rule that does store the last update from a sensor. In fact, I have a few rules, for all my battery powered sensors, so a reduction in the number of rules would be great.
    BUT I suppose implementing this in the binding is not the OpenHAB-way, because the binding is only the interface to the hardware and should be lightweight.

  • Hardware Contributor

    Open query.
    I think it is a bit boring that when you give the sensor a new adress that you have to power cycle the device to get it added. I can see that the sensor is starting to transmitt with the new address but The binding is not finding it as a new device. I can see that this happens becouse the sonsor dont present it self to the binding. how ever what about implementing a feature that asks the sensor for data when it just gave out a new address. I have also asked for mySensor to add the feature that when the node gets a new adress that it should present it self.

    Which way do you see as best? Or is it nothing that can be one?

  • Admin

  • Hardware Contributor

    @hek SO if i understood it correctly from reading info from this link. My question below is answered by that it is beeing implemented as we sspeak?

  • Admin


  • Hardware Contributor

    Does the ack signaling work in the binding? I have a sensor that will request an ack from the gateway. Does anyone know if this is working?

  • @Denke yes acknowledge is actually implemented in binding 🙂

  • Hardware Contributor

    Hi I have trouble finding out how to get my node to request ack, do you know how. I think i have figured out how to handle incoming message to check that the ack is received ant that is through message.isAck().

    But how do i get the node to send a request for ack?

  • Hardware Contributor

    You look and you look, then you ask someone how to do.

    Then you look again and you find it:)
    , true after the set message in send did the trick.

  • @TimO


    Ive been trying for ages to get a stable OpenHab + MySensors setup going. Your new binding is exactly what I've been hoping for and I'm so close to having it working, but can't see what I am doing wrong???

    I've installed OpenHab2 plus your MySensors binding. I tried to follow your setup guide / otes, but I suspect a lot has changed since you wrote it.

    What Works

    • OpenHab runs without any errors in the log file {Yay!}

    • My sensor data appears in the OpenHab log - ok.

    • In OpenHab, my individual sensors are there and 'linked' to sensor channel.

    • The date/time in browser from the NTP binding updates as expected.

    Whats Wrong

    • The items (in demo.items) appear in the browser, but no data values?

    • I can see data from sensor changes in OpenHab log, but still NOT displayed?

    Can anybody post an items, things and sitemap example file, or spot an error in mine?

    My demo.items:

    Number mywatts2 "Watts 2 [%.1f W]" <temperature> {channel="mysensors:power:503a021b:Power_21_6:watt"}
    Number  mywatts1 "Watts 1 [%.1f W]" <temperature> {channel="mysensors:power:503a021b:Power_21_2:watt"
    Number myhum01 "hum 1 [%.1f %RH]" <temperature> {channel="mysensors:humidity:7fbda972:hum"}
    Number mytemp01 "Temp [%.1f C]" <temperature> {channel="mysensors:temperature:503a021b:Temperature_22_3:temp"

    My demo.things:

    yahooweather:weather:Dawesville [ location=28584781 ]
    astro:sun:home  [ geolocation="-32.634619,115.638888", interval=60 ]
    ntp:ntp:demo [ hostname="", refreshInterval=60, refreshNtp=30 ]

    Extract from my demo.sitemap:

      sitemap demo label="Main Menu" { 
        Frame { 
            Text item=mywatts1
            Text item=mywatts2 
            Text item=myhum01
            Text item=mytemp01 

    Initial startup from my openhab.log (apologies for the length)

    2016-05-14 09:49:21.749 [DEBUG] [org.openhab.binding.mysensors       ] - BundleEvent STARTING - org.openhab.binding.mysensors
    2016-05-14 09:49:21.760 [DEBUG] [org.openhab.binding.mysensors       ] - BundleEvent STARTED - org.openhab.binding.mysensors
    2016-05-14 09:49:21.770 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={,,, service.bundleid=10, service.scope=bundle} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.367 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'ipp:printer:Brother_MFC_8510DN' has been added.
    2016-05-14 09:49:32.383 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.DiscoveryService}={, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.398 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:bridge-eth:503a021b' has been added.
    2016-05-14 09:49:32.410 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:humidity:503a021b:Humidity_22_2' has been added.
    2016-05-14 09:49:32.411 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:bridge-eth,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.436 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:humidity,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.438 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:humidity:7fbda972' has been added.
    2016-05-14 09:49:32.441 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:40868d6c' has been added.
    2016-05-14 09:49:32.444 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:503a021b:Power_21_1' has been added.
    2016-05-14 09:49:32.447 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:503a021b:Power_21_2' has been added.
    2016-05-14 09:49:32.448 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:503a021b:Power_21_3' has been added.
    2016-05-14 09:49:32.452 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:503a021b:Power_21_4' has been added.
    2016-05-14 09:49:32.455 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:503a021b:Power_21_5' has been added.
    2016-05-14 09:49:32.456 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:power:503a021b:Power_21_6' has been added.
    2016-05-14 09:49:32.458 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:temperature:503a021b:Temperature_22_3' has been added.
    2016-05-14 09:49:32.459 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:temperature:522d430d' has been added.
    2016-05-14 09:49:32.460 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'ntp:ntp:local' has been added.
    2016-05-14 09:49:32.477 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:humidity,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.497 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.500 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.502 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.505 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.511 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.514 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.520 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:power,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.523 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:temperature,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.525 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:temperature,,, service.bundleid=10, service.scope=singleton} - org.openhab.binding.mysensors
    2016-05-14 09:49:32.673 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:503a021b' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:32.699 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:humidity:503a021b:Humidity_22_2' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:32.712 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
    2016-05-14 09:49:32.714 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:humidity:7fbda972' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:32.756 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - Connecting to bridge ...
    2016-05-14 09:49:32.899 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:40868d6c' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:32.901 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - Connection to ethernet gateway successful!
    2016-05-14 09:49:33.053 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:humidity:503a021b:Humidity_22_2' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:33.081 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:humidity:7fbda972' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:33.121 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:503a021b' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:33.123 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_2' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:33.178 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:temperature:503a021b:Temperature_22_3' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:33.106 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 0;0;3;0;14;Gateway startup complete.
    2016-05-14 09:49:33.200 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 0;0;3;0;2;1.5.1
    2016-05-14 09:49:33.203 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_1' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.205 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_2' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.213 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_3' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.217 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_4' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.235 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_5' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.237 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_6' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.239 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:temperature:503a021b:Temperature_22_3' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.240 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:temperature:522d430d' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:33.242 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'CurrentDate-ntp:ntp:local:dateTime' has been added.
    2016-05-14 09:49:33.254 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'hum01-mysensors:humidity:503a021b:Humidity_22_2:hum' has been added.
    2016-05-14 09:49:33.255 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'mywatts1-mysensors:power:503a021b:Power_21_2:watt' has been added.
    2016-05-14 09:49:33.256 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'mywatts1-mysensors:power:503a021b:Power_21_4:watt' has been added.
    2016-05-14 09:49:33.263 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'mywatts2-mysensors:power:503a021b:Power_21_5:watt' has been added.
    2016-05-14 09:49:33.264 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'temp01-mysensors:power:503a021b:Power_21_5:watt' has been added.
    2016-05-14 09:49:33.268 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'watts1-mysensors:power:503a021b:Power_21_5:watt' has been added.
    2016-05-14 09:49:33.304 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'watts1-mysensors:power:503a021b:Power_21_6:watt' has been added.
    2016-05-14 09:49:33.305 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'watts2-mysensors:power:503a021b:Power_21_2:watt' has been added.
    2016-05-14 09:49:33.534 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'ipp_printer_Brother_MFC_8510DN-ipp:printer:Brother_MFC_8510DN' has been added.
    2016-05-14 09:49:33.593 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:49:33.884 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:49:34.272 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_1' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:34.274 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_bridge_eth_503a021b-mysensors:bridge-eth:503a021b' has been added.
    2016-05-14 09:49:34.275 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_humidity_503a021b_Humidity_22_2-mysensors:humidity:503a021b:Humidity_22_2' has been added.
    2016-05-14 09:49:34.277 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_humidity_7fbda972-mysensors:humidity:7fbda972' has been added.
    2016-05-14 09:49:34.278 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_40868d6c-mysensors:power:40868d6c' has been added.
    2016-05-14 09:49:34.278 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_503a021b_Power_21_1-mysensors:power:503a021b:Power_21_1' has been added.
    2016-05-14 09:49:34.279 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_503a021b_Power_21_2-mysensors:power:503a021b:Power_21_2' has been added.
    2016-05-14 09:49:34.279 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_503a021b_Power_21_3-mysensors:power:503a021b:Power_21_3' has been added.
    2016-05-14 09:49:34.280 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_503a021b_Power_21_4-mysensors:power:503a021b:Power_21_4' has been added.
    2016-05-14 09:49:34.280 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_503a021b_Power_21_5-mysensors:power:503a021b:Power_21_5' has been added.
    2016-05-14 09:49:34.281 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_power_503a021b_Power_21_6-mysensors:power:503a021b:Power_21_6' has been added.
    2016-05-14 09:49:34.284 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_temperature_503a021b_Temperature_22_3-mysensors:temperature:503a021b:Temperature_22_3' has been added.
    2016-05-14 09:49:34.295 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_temperature_522d430d-mysensors:temperature:522d430d' has been added.
    2016-05-14 09:49:34.347 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'ntp_ntp_local-ntp:ntp:local' has been added.
    2016-05-14 09:49:34.557 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'ipp_printer_Brother_MFC_8510DN' has been added.
    2016-05-14 09:49:34.560 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_bridge_eth_503a021b' has been added.
    2016-05-14 09:49:34.576 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_4' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:34.581 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_humidity_503a021b_Humidity_22_2' has been added.
    2016-05-14 09:49:34.584 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_humidity_7fbda972' has been added.
    2016-05-14 09:49:34.589 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_40868d6c' has been added.
    2016-05-14 09:49:34.589 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_503a021b_Power_21_1' has been added.
    2016-05-14 09:49:34.591 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_503a021b_Power_21_2' has been added.
    2016-05-14 09:49:34.592 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_503a021b_Power_21_3' has been added.
    2016-05-14 09:49:34.593 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_503a021b_Power_21_4' has been added.
    2016-05-14 09:49:34.594 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_503a021b_Power_21_5' has been added.
    2016-05-14 09:49:34.596 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:temperature:522d430d' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:34.597 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_power_503a021b_Power_21_6' has been added.
    2016-05-14 09:49:34.597 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_temperature_503a021b_Temperature_22_3' has been added.
    2016-05-14 09:49:34.599 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:40868d6c' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:34.880 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_temperature_522d430d' has been added.
    2016-05-14 09:49:35.059 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'ntp_ntp_local' has been added.
    2016-05-14 09:49:35.093 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_5' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:35.099 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_6' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:35.190 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:power:503a021b:Power_21_3' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:42.498 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:49:43.626 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;174
    2016-05-14 09:49:43.972 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2076
    2016-05-14 09:49:44.806 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /ui
    2016-05-14 09:49:45.008 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
    2016-05-14 09:49:45.503 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ntp:ntp:local' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:45.976 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ntp:ntp:local' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:46.283 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ipp:printer:Brother_MFC_8510DN' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:46.285 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ipp:printer:Brother_MFC_8510DN' changed from INITIALIZING to OFFLINE
    2016-05-14 09:49:46.979 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
    2016-05-14 09:49:47.057 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
    2016-05-14 09:49:47.812 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.sitemap'
    2016-05-14 09:49:48.239 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.things'
    2016-05-14 09:49:48.414 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'logging.persist'
    2016-05-14 09:49:48.425 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'yahooweather:weather:Dawesville' has been added.
    2016-05-14 09:49:48.726 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
    2016-05-14 09:49:48.749 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.script'
    2016-05-14 09:49:48.983 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'yahooweather:weather:Dawesville' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:48.984 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'yahooweather:weather:Dawesville' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:48.985 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'astro:sun:home' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:49.390 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'astro:sun:home' has been added.
    2016-05-14 09:49:49.473 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.items'
    2016-05-14 09:49:49.566 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ntp:ntp:demo' changed from UNINITIALIZED to INITIALIZING
    2016-05-14 09:49:49.737 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'ntp:ntp:demo' has been added.
    2016-05-14 09:49:49.742 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'mywatts2-mysensors:power:503a021b:Power_21_6:watt' has been added.
    2016-05-14 09:49:49.743 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'mywatts1-mysensors:power:503a021b:Power_21_2:watt' has been added.
    2016-05-14 09:49:49.743 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'myhum01-mysensors:humidity:7fbda972:hum' has been added.
    2016-05-14 09:49:49.744 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'mytemp01-mysensors:temperature:503a021b:Temperature_22_3:temp' has been added.
    2016-05-14 09:49:50.090 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'astro:sun:home' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:50.608 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ntp:ntp:demo' changed from INITIALIZING to ONLINE
    2016-05-14 09:49:53.619 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;70
    2016-05-14 09:49:53.853 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1737
    2016-05-14 09:49:54.166 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'ipp:printer:Brother_MFC_8510DN' changed from OFFLINE to ONLINE
    2016-05-14 09:50:02.663 [WARN ] [stence.jpa.internal.JpaConfiguration] - Connection url is required in openhab.cfg!
    2016-05-14 09:50:02.663 [WARN ] [stence.jpa.internal.JpaConfiguration] - Empty connection url in openhab.cfg!
    2016-05-14 09:50:02.663 [WARN ] [stence.jpa.internal.JpaConfiguration] - Driver class is required in openhab.cfg!
    2016-05-14 09:50:02.666 [WARN ] [stence.jpa.internal.JpaConfiguration] - Empty driver class in openhab.cfg!
    2016-05-14 09:50:02.666 [INFO ] [stence.jpa.internal.JpaConfiguration] - user was not specified!
    2016-05-14 09:50:02.673 [INFO ] [stence.jpa.internal.JpaConfiguration] - password was not specified!
    2016-05-14 09:50:02.673 [INFO ] [stence.jpa.internal.JpaConfiguration] - syncmappings was not specified!
    2016-05-14 09:50:02.724 [INFO ] [core.karaf.internal.FeatureInstaller] - Installed 'openhab-persistence-jpa'
    2016-05-14 09:50:03.283 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;0;1;0;37;0
    2016-05-14 09:50:03.591 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:50:03.856 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:50:08.636 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:50:13.592 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;167
    2016-05-14 09:50:13.859 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2095
    2016-05-14 09:50:23.600 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;71
    2016-05-14 09:50:23.861 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1744
    2016-05-14 09:50:33.595 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:50:33.855 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:50:34.786 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:50:43.593 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;170
    2016-05-14 09:50:43.862 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2113
    2016-05-14 09:50:53.596 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;69
    2016-05-14 09:50:53.860 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1751
    2016-05-14 09:51:00.926 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;12
    2016-05-14 09:51:03.595 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:51:03.860 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:51:09.380 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;1;1;0;37;17
    2016-05-14 09:51:13.594 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;170
    2016-05-14 09:51:13.855 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2131
    2016-05-14 09:51:23.597 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;71
    2016-05-14 09:51:23.862 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1758
    2016-05-14 09:51:29.115 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:51:31.920 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;255;0;0;17;1.5.1
    2016-05-14 09:51:32.131 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;255;3;0;6;0
    2016-05-14 09:51:32.520 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;255;0;0;17;1.5.1
    2016-05-14 09:51:32.732 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;255;3;0;6;0
    2016-05-14 09:51:33.958 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;255;3;0;11;Lounge Environs
    2016-05-14 09:51:34.219 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;255;3;0;12;1.1
    2016-05-14 09:51:34.478 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;2;0;0;7;
    2016-05-14 09:51:34.739 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;3;0;0;6;
    2016-05-14 09:51:35.000 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;1;1;0;43;2.5 ppm
    2016-05-14 09:51:35.264 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;255;3;0;11;Energy Meter
    2016-05-14 09:51:35.525 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;0;0;13;
    2016-05-14 09:51:35.787 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;0;0;13;
    2016-05-14 09:51:36.049 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;43;KwHours
    2016-05-14 09:51:36.313 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;43;KwHours
    2016-05-14 09:51:36.570 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;43;Watts
    2016-05-14 09:51:36.831 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;3;1;0;0;24.1
    2016-05-14 09:51:55.263 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:51:55.833 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;69
    2016-05-14 09:51:56.094 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1698
    2016-05-14 09:52:05.837 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:52:06.104 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:52:15.832 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;171
    2016-05-14 09:52:16.093 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.1998
    2016-05-14 09:52:21.403 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:52:25.833 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;68
    2016-05-14 09:52:26.099 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1704
    2016-05-14 09:52:35.837 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:52:36.102 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:52:37.110 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;0;1;0;37;0
    2016-05-14 09:52:45.833 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;167
    2016-05-14 09:52:46.095 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2016
    2016-05-14 09:52:47.542 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:52:55.838 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;70
    2016-05-14 09:52:56.108 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1711
    2016-05-14 09:53:05.835 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:53:06.105 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:53:13.694 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:53:15.836 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;174
    2016-05-14 09:53:16.097 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2034
    2016-05-14 09:53:25.839 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;70
    2016-05-14 09:53:26.099 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1718
    2016-05-14 09:53:35.835 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:53:36.096 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:53:39.845 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:53:45.835 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;172
    2016-05-14 09:53:46.095 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2053
    2016-05-14 09:53:55.836 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;68
    2016-05-14 09:53:56.098 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1724
    2016-05-14 09:54:05.837 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:54:06.100 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:54:08.040 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:54:14.044 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;0;1;0;37;0
    2016-05-14 09:54:15.840 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;174
    2016-05-14 09:54:16.102 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2071
    2016-05-14 09:54:25.839 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;68
    2016-05-14 09:54:26.100 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1729
    2016-05-14 09:54:34.176 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:54:35.836 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:54:36.096 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:54:45.843 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;173
    2016-05-14 09:54:46.105 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2089
    2016-05-14 09:54:49.812 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;2;1;0;1;55.3
    2016-05-14 09:54:55.837 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;68
    2016-05-14 09:54:56.102 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1734
    2016-05-14 09:55:00.313 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:55:05.851 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:55:06.117 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:55:15.837 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;166
    2016-05-14 09:55:16.107 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2108
    2016-05-14 09:55:25.836 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;68
    2016-05-14 09:55:26.108 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1739
    2016-05-14 09:55:26.463 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:55:35.838 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:55:36.098 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:55:45.838 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;170
    2016-05-14 09:55:46.106 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2126
    2016-05-14 09:55:50.716 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 22;0;1;0;37;0
    2016-05-14 09:55:52.609 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 50;0;1;0;37;11
    2016-05-14 09:55:55.839 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;1;1;0;17;67
    2016-05-14 09:55:56.101 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;4;1;0;18;93.1743
    2016-05-14 09:56:05.838 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;2;1;0;17;0
    2016-05-14 09:56:06.098 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;5;1;0;18;32.4534
    2016-05-14 09:56:15.839 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;3;1;0;17;168
    2016-05-14 09:56:16.099 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - 21;6;1;0;18;345.2144

    All suggestions appreciated...



  • Hero Member

    The things are not linked to items, therefore the items do not update. You have configured the bridge via PaperUi, correct? This should work, but I haven't tested it. Could you try to configure the gateway in the things file instead?
    Have you seen the examples in the github wiki?
    I'm currently on my mobile, so I can't say more at the moment.

  • @TimO

    Hi Tim,
    Thanks for replying so promptly 😀 , trying to get this going over the weekend.

    From what I can see, the fields are linked. I base this on the fact that the log file shows 'link added' and 'link removed' as I play with the 'demo.things' file.
    Also, I get the same messages in the log etc, whether I create the links via the things file or with the paper-ui. I've also noticed that when I do make a typing mistake with an items or things entry, OpenHab is usually quick to spit out an error[s], implying that the corrected text is passing the syntax check.

    I have stripped my demo to the bare minimum and have included my current set here. The first two (MySensors) 'items' do not update but the log file shows no error. The third item is linked to a non MySensors binding and it works regardless of whether I use to paper.ui or create the links manually (which helps me believe I am creating the link to the binding correctly.

    My sitemap.demo

      sitemap demo label="Test Menu" { 
        Frame { 
            Text item=myhum01
            Text item=mytemp01 
            Text item=mytemp99 

    My items.demo

    Number myhum01 "Humidity Test (22:2) [%.1f RH]" { channel="mysensors:humidity:gateway:myhum01:hum" }
    Number mytemp01 "Temperature Test (22:3) [%.1f] °C" { channel="mysensors:temperature:gateway:mytemp01:temp" }
    Number mytemp99 "Printer queue [%.0f jobs]" {channel="ipp:printer:Brother_MFC_8510DN:waitingJobs"}

    In the following things entry, should the first line start with "Bridge" or without? The binding setup notes appear to show both with and without?

    My things.demo

    Bridge mysensors:bridge-eth:gateway [ ipAddress="",   tcpPort=5003, sendDelay=200 ] {
        /** define things connected to that bridge here */
        humidity        myhum01   [ nodeId="22", childId="2" ]
        temperature     mytemp01  [ nodeId="22", childId="3" ]

    I always look for 'what I am doing wrong', but I have been on this for days with no joy, I've reached the point where I am really starting to suspect there may be a bug.

    Once again, I would appreciate suggestions from anybody...



  • Hardware Contributor

    Hi all
    Im having major difficulties getting openhab to discover my serial gateway. I have had it working and i have got input from my sensors. But every know and then when i have restarted the computer the serial gateway is offline. The COM port is active and working according to Windows.
    I have tried to restart the computer, unplug and plug the usb several times. Doing this i have at some occasions got everything to work again.

    Any suggestions what it can be that is being the problem.

    I also think i have found a bug.

    If i for example take the gateway or an sensor that has been added which is marked off line. Then if i press edit on that one and just press the "save" button then it shows that it is on line even though i seriously doubt it is. As i dont get data from my sensors.

    Also how do i get the debug window (console view) to show for openhab?

  • Hero Member

    @AffordableTech Hmmm, your configuration looks good. Please show me the debug output.

    According the use of Bridge: I suppose using the word Bridge at the beginning is the right way!

    @Denke: I haven't used OH2 on Windows yet, but I suppose you see the karaf console?

    If so, you should be able to use: log:set DEBUG org.openhab.binding.mysensors and log:tail.

    The online/offline status of a thing in OH2 only shows if the bridge is connected and if the thing could be initialized. There is no dependence to wether a thing has received data or not.

  • Hardware Contributor

    @TimO said:

    log:set DEBUG org.openhab.binding.mysensors

    I tried this. From what i can see after doing some attempts to connect.
    First & second attempt
    This is what i get after just opening the serial gateway thing and edit and sav, seems as openhab then tries to reconnect with the gateway.
    third attempt
    It seems like it gets connected, bu some error occurs which closes the connection again
    Forth attempt actually seemed to get things going

    Now to the next step.
    I have a device that was just given a new address from the my sensor binding. I restarted the sensor and waited to see it in the inbox (this is something that i have seen working occasionally( sometimes it gets in there sometimes it don't. I added the device manually and it seems to work. How ever my links dont work

  • Hero Member

    @Denke: At the first and the second attempt the library is not able to establish a connection to the COM port. As "getPortIdentifier()" is mentioned it is possible that there is a correlation with the bug mentioned earlier in this thread. The OH developers need to update this library soon!

    At the third attempt the binding does not get an answer on the I_VERSION check and therefore stops its initialization. Try skipStartupCheck=true Wiki to avoid this.

    According to the discovery with PaperUI:

    I must admit I have not worked with it for a long time. The OH core team has announced some big changes/improvements in the PaperUI and I've postponed my tests for after the release of this changes.

  • Is any bodoy having high CPU load with this binding? My setup is: Openhab 2.0, running on a Pi3, with Java SDK Oracle. Openhab is running +100% CPU all the time. Here is the output of top command:

    top - 19:54:33 up  9:19,  1 user,  load average: 0.98, 1.01, 1.03
    Tasks: 153 total,   1 running, 152 sleeping,   0 stopped,   0 zombie
    %Cpu(s): 21.4 us,  4.2 sy,  0.0 ni, 74.4 id,  0.0 wa,  0.0 hi,  0.1 si,  0.0 st
    KiB Mem :   948056 total,   112832 free,   325232 used,   509992 buff/cache
    KiB Swap:        0 total,        0 free,        0 used.   573692 avail Mem
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
     3919 root      20   0  455068 180668  14280 S 101.3 19.1 547:33.46 java
    28144 root      20   0    8436   2840   2280 R   0.7  0.3   0:06.30 top
      368 root      20   0    1448     88     16 S   0.3  0.0   0:31.75 rngd

    If I look all the threats with command

    ps -Lp 3919

    I can see one that is eating too much CPU:

     3919  4226 ?        08:25:13 java

    and looking at this one in the output of a thread dump: (4226 DEC = 1082 HEX)

    Jun  1 19:30:31 avinaz-pi3[3822]: "pool-41-thread-1" #273 prio=5 os_prio=0 tid=0x62addc00 **nid=0x1082** runnable [0x5d6be000]
    Jun  1 19:30:31 avinaz-pi3[3822]:    java.lang.Thread.State: RUNNABLE
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at Method)
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at$SerialInputStream.available(
    Jun  1 19:30:31 avinaz-pi3[3822]: #011- locked <0x6afb81f8> (a$SerialInputStream)
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at sun.nio.cs.StreamDecoder.inReady(
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at sun.nio.cs.StreamDecoder.implReady(
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at sun.nio.cs.StreamDecoder.ready(
    Jun  1 19:30:31 avinaz-pi3[3822]: #011- locked <0x6b2a41e8> (a
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at
    Jun  1 19:30:31 avinaz-pi3[3822]: #011- locked <0x6b2a41e8> (a
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at java.util.concurrent.Executors$
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at java.util.concurrent.ThreadPoolExecutor.runWorker(
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at java.util.concurrent.ThreadPoolExecutor$
    Jun  1 19:30:31 avinaz-pi3[3822]: #011at

    You can see that is related to

    Any ideas?

  • Hero Member

    @avinaz : After a second thought I now have an idea! 😄

    With the last commit I changed line 50 in due to an exception I got after upgrading ubuntu/java and OH2.
    The binding (old version) was still unchanged.

    I need to look into this. Maybe @andreacioni has an idea?

  • @TimO I would say at a glance, that the thread is continuously reading the Serial port, with out a break, so this must be very CPU consuming?

  • I think i need some help. I am not shure, if my problem lies on the openHab2 side or if there is a problem with the mysensors addon.

    This is what i I have:
    A working mysensors addon. I receive updates in OpenHab:

    2016-06-06 07:12:08.483 [DEBUG] [org.openhab.binding.mysensors       ] - BundleEvent STARTING - org.openhab.binding.mysensors
    2016-06-06 07:12:08.550 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={,,, service.bundleid=11, service.scope=bundle} - org.openhab.binding.mysensors
    2016-06-06 07:12:09.070 [DEBUG] [org.openhab.binding.mysensors       ] - BundleEvent STARTED - org.openhab.binding.mysensors
    2016-06-06 07:12:12.062 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
    2016-06-06 07:12:18.694 [ERROR] [org.openhab.ui.habmin               ] - [org.openhab.ui.habmin.designer(3)] bind method [setItemRegistry] not found; Component will fail
    2016-06-06 07:12:18.702 [ERROR] [org.openhab.ui.habmin               ] - [org.openhab.ui.habmin.designer(3)] bind method [setItemRegistry] not found
    2016-06-06 07:12:25.252 [ERROR] [org.eclipse.smarthome.core.transform] - [org.eclipse.smarthome.action.transformation.action(51)] Circular reference detected, getService returning null
    2016-06-06 07:12:39.288 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_light_gateway_Light_1_0-mysensors:light:gateway:Light_1_0' has been added.
    2016-06-06 07:12:39.315 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'home_group_88a3d2a1' has been added.
    2016-06-06 07:12:42.030 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /ui
    2016-06-06 07:12:42.261 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
    2016-06-06 07:12:42.825 [WARN ] [sql.internal.MysqlPersistenceService] - The SQL user is missing - please configure the sql:user parameter in openhab.cfg
    2016-06-06 07:12:43.071 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
    2016-06-06 07:12:43.114 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
    2016-06-06 07:12:43.470 [INFO ] [.openhab.core.internal.CoreActivator] - openHAB runtime has been started (v2.0.0, build b2).
    2016-06-06 07:12:43.479 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'home.sitemap'
    2016-06-06 07:12:44.159 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'home.things'
    2016-06-06 07:12:44.397 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:bridge-eth:gateway' has been added.
    2016-06-06 07:12:44.468 [INFO ] [nsors.handler.MySensorsBridgeHandler] - Using Metric measure unit
    2016-06-06 07:12:44.470 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Set skip check on startup to: false
    2016-06-06 07:12:44.489 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.DiscoveryService}={, service.bundleid=11, service.scope=singleton} - org.openhab.binding.mysensors
    2016-06-06 07:12:44.527 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
    2016-06-06 07:12:44.531 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:gateway' changed from UNINITIALIZED to INITIALIZING
    2016-06-06 07:12:44.540 [DEBUG] [rs.protocol.ip.MySensorsIpConnection] - Connecting to bridge ...
    2016-06-06 07:12:44.762 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-06-06 07:12:44.770 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;14;Gateway startup complete.
    2016-06-06 07:12:44.776 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;11;EthernetGateway
    2016-06-06 07:12:44.778 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;12;1.0
    2016-06-06 07:12:44.849 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;2;2.0.0-beta
    2016-06-06 07:12:44.852 [DEBUG] [s.internal.MySensorsBridgeConnection] - Good,Gateway is up and running! (Ver:2.0.0-beta)
    2016-06-06 07:12:44.858 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:bridge-eth,,, service.bundleid=11, service.scope=singleton} - org.openhab.binding.mysensors
    2016-06-06 07:12:44.859 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:gateway' changed from INITIALIZING to ONLINE
    2016-06-06 07:12:44.900 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'logging.persist'
    2016-06-06 07:12:44.990 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
    2016-06-06 07:12:45.047 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'home.items'
    2016-06-06 07:12:45.168 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'n1c0-mysensors:light:gateway:n1c0:status' has been added.
    2016-06-06 07:12:45.171 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'n1c1-mysensors:light:gateway:n1c1:status' has been added.
    2016-06-06 07:12:45.174 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'n1c2-mysensors:humidity:gateway:n1c2:hum' has been added.
    2016-06-06 07:12:45.178 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'n1c3-mysensors:humidity:gateway:n1c3:hum' has been added.
    2016-06-06 07:12:45.182 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'n1c4-mysensors:humidity:gateway:n1c4:hum' has been added.
    2016-06-06 07:14:50.818 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;3;1;1;1;1
    2016-06-06 07:14:50.820 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - ACK received!
    2016-06-06 07:14:55.831 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;3;1;1;1;0
    2016-06-06 07:14:55.832 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - ACK received!
    2016-06-06 07:28:01.373 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;3;1;1;1;1
    2016-06-06 07:28:01.375 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - ACK received!
    2016-06-06 07:28:06.385 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;3;1;1;1;0
    2016-06-06 07:28:06.387 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - ACK received!
    2016-06-06 07:32:21.567 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;3;1;1;1;1
    2016-06-06 07:32:21.568 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - ACK received!
    2016-06-06 07:32:26.578 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;3;1;1;1;0
    2016-06-06 07:32:26.582 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - ACK received!

    Seems ok.

    But I am not able to see the result in Openhab


    mysensors:bridge-eth:gateway [ ipAddress="", tcpPort=5003, sendDelay=200 ] {
            /** define things connected to that bridge here */
            light           n1c0   [ nodeId="1", childId="0", requestAck=true ]
            light           n1c1   [ nodeId="1", childId="1", requestAck=true ]
            humidity        n1c2   [ nodeId="1", childId="2" ]
            humidity        n1c3   [ nodeId="1", childId="3" ]
            humidity        n1c4   [ nodeId="1", childId="4" ]


    Switch n1c0    "PFLANZENNAME1 Pumpe"                    <water> (gGF_irrigation01) { channel="mysensors:light:gateway:n1c0:status" }
    Switch n1c1    "PFLANZENNAME1 Pumpe Automatikmodus"     <water> (gGF_irrigation01) { channel="mysensors:light:gateway:n1c1:status" }
    Number n1c2    "PFLANZENNAME1 Bodenfeuchtigkeit max"    <water> (gGF_irrigation01) { channel="mysensors:humidity:gateway:n1c2:hum" }
    Number n1c3    "PFLANZENNAME1 Bodenfeuchtigkeit min"    <water> (gGF_irrigation01) { channel="mysensors:humidity:gateway:n1c3:hum" }
    Number n1c4    "PFLANZENNAME1 Bodenfeuchtigkeit"        <water> (gGF_irrigation01,gGF_eating) { channel="mysensors:humidity:gateway:n1c4:hum" }

    There are simply no values in openhab although I see the debug messages in the openhab log.
    Any idea how to fix it? I did not use the autodicovery of openhab paper UI. what confuses me is the name of the link used by openhab:

    2016-06-06 07:12:45.168 [INFO ] [home.event.ItemChannelLinkAddedEvent] - Link 'n1c0-mysensors:light:gateway:n1c0:status' has been added.

    That does not match the channel. is that ok?


    EDIT: updated openhab log to complete startup process and added question

  • Hey man,
    This is awesome!
    You should add support for Relays.

  • Hi @TimO
    I am having the exact same simtoms. Huge CPU usage with latest binding version.
    Let me know if you need me to run some test to get this solved.

  • @dakky said:

    I think i need some help. I am not shure, if my problem lies on the openHab2 side or if there is a problem with the mysensors addon.

    No idea anyone? i'm stucked here and I'd really like to continue 😞

    EDIT: MAybe this helps debugging: it seem there is no "link" between things and items. The rest endpoints reveals, that the thing has no item:

        "statusInfo": {
          "status": "ONLINE",
          "statusDetail": "NONE"
        "link": "http://autohome:8080/rest/things/mysensors:bridge-eth:gateway",
        "configuration": {
          "tcpPort": 5003,
          "ipAddress": "",
          "skipStartupCheck": false,
          "imperial": false,
          "sendDelay": 200
        "properties": {},
        "UID": "mysensors:bridge-eth:gateway",
        "channels": [
            "linkedItems": [],
            "id": "n1c0",
            "itemType": "light",
            "properties": {}
            "linkedItems": [],
            "id": "n1c1",
            "itemType": "light",
            "properties": {}
            "linkedItems": [],
            "id": "n1c2",
            "itemType": "humidity",
            "properties": {}
            "linkedItems": [],
            "id": "n1c3",
            "itemType": "humidity",
            "properties": {}
            "linkedItems": [],
            "id": "n1c4",
            "itemType": "humidity",
            "properties": {}


  • Dammit ... found the error 😉

    created a pull request:


  • Hero Member

    Glad you found it! 👍

    I'm a little low in time at the moment, I will look at the PRs next weekend. Thank you for the contributions! 🙂

  • Hero Member

    There is a new jar available that fixes the bug with the high CPU usage.

    Additionally @meju25 added support for customSensor and an option to adjust the behavior in case no ACK could be received (see wiki). Thanks a lot!

  • Thanks @TimO , seems is working fine. I updated my installation with the new jar and now CPU is around 4-6%. Thanks a lot. By the way, I did not see a commit in the code repository.

  • Hero Member

    @avinaz: I'm glad, thanks for testing!
    Did you look into the right branch? I've committed all changes to github.

  • Hardware Contributor

    Hi all

    Implemented a barometric sensor "pressure meter" that i sample in the sensor. Then i send the value Through "BARO". I can see in both the sensor output and the openhab debug that i receive a value for example "1.2".

    I try to display this in the openhab and i dont get the Text item to update.

    Anyone know how this can be as i have other values that i am able to display.

    line in .items
    String Pool_Pressure "Pressure (bar) [%s]" <pressure> (gPool)

    line in .sitemap
    Text item=Pool_Pressure

    any help is appriciated as i have tried different options with Number and so on

  • Hardware Contributor

    Merging sensor to one

    I have been thinking and i think it would be nice if there is a way to merge sensor data to one in the mysensors binding.

    I am trying to build a pool control based on mysensors and i have a lot of options that i wan it to handle. For example:

    • on/off of my pool pumps (S_LIGHT)
    • on/off of lights around the pool (S_LIGHT)
    • thermostat function for heaters (S_HVAC)
    • measuring pressure on pump (S_BARO)
    • measuring consumed power on pump (S_POWER)

    All this are using the same sensor ID and getting own child IDs. When they now are brought in to openhab they appear as single sensors

    Is there a possibility to get an automatic merge for thes combined sensors?

    And what do you think about the idea.
    Or is there already a solution that exist that I am not aware about

    example from paper UI

    with openhab poolcontrol view

  • @Denke
    If I understand correctly, you are suggesting to combine different sensor types in one thing.
    IMHO this would jeopardize the concept of the binding. The binding provides one thing per message type (see the thing has one channel per supported sub type.
    I also do not see the advantage of combining different sensor/message types in one thing as you need one item per channel anyhow.
    => this would not reduce the number of items needed.

    Grouping the items in the site map - as you already did - is the best way here.

    Does anybody see this differently?

  • Hardware Contributor

    @meju25 I saw this from a management perspective.
    I have one device, my pool controller, that has multiple sensors and also channels per sensor just as HVAC that has a sum of channels. In my case i implemented a number of sensors in different types of channels "S_HVAC, S_LIGHT,...." what i see that it gets messy when you try to see if the channels are active or the pool control is active it has multiple sensors.

    So maybe a suggestion is to maybe implement this in the mysensors instead of in the openhab binding.
    In that case i would like to add something that allows me to tell what channels are in a "sensor" by combining differnt channels and sensor types.

    I don't know if i got my message through.

    But all this is mainly for management of my devices so that this gets less messy

  • @TimO do you plan to implement the reconnect thing? I often have to struggle with that and the only solution is the restart the openhab service :S Is there a problem with the reconnect or is it just "another task on the todo list"?


  • Hardware Contributor

    Is there anybody that have had a problem with the S_BARO and the V_PRESSURE channel?

    I try to send a value on this channel as 1.2 I can see that the serial gateway receives it

    23:10:51.808 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;9;read: 163-163-0 s=10,c=1,t=4,pt=7,l=5,sg=0:1.2

    I set up the channel as i have done for alot of other channels through the paper ui. where i link the channel to an item.

    The item file looks like this
    String Pool_Pressure "Pressure [%s]" <pressure> (gPool)

    the sitemap file looks like this
    Text item=Pool_Pressure

    result is this

    The field never gets updated.
    any suggestions?

  • Hardware Contributor

    I cant find V_PRESSURE connected to CHANNEL_BARO below, can that be the reason?


  • Hero Member

    @Denke : You're right, the pressure channel was missing in the thing definition. This is fixed in the current version!

    @dakky : Which gateway type keeps disconnecting and why? I've a serial and ethernet gateway running side by side in OH2 and both didn't get disconnected so far. The hardest part is to recognize if the connection gets down.

  • Hi @TimO . Are you having both gateways connected to same the OH simultaneously?
    Any troubles with that? I imagine you should have different radio channels for each gateway, right? like two separate sensors networks.

  • Hero Member

    Hi @gonzalonal !

    Only the ethernet gateway has an attached radio.

    Here is my current (MySensors) setup:

    Bridge mysensors:bridge-eth:MySGW [ ipAddress="", tcpPort=5003, sendDelay=100, skipStartupCheck=true  ] {
    	humidity        bathHum01   			[ nodeId="101", childId="0" ]
        temperature     bathTemp01  			[ nodeId="101", childId="1" ]
        humidity		bathBat01				[ nodeId="101", childId="255" ]
        humidity        bedHum01   				[ nodeId="103", childId="2" ]
        temperature     bedTemp01  				[ nodeId="103", childId="1" ]
        humidity		bedBat01				[ nodeId="103", childId="255" ]
        humidity        workHum01  				[ nodeId="104", childId="2" ]
        temperature     workTemp01 				[ nodeId="104", childId="1" ]
        humidity		workBat01				[ nodeId="104", childId="255" ]
        humidity        kitchenHum01			[ nodeId="105", childId="2" ]
        temperature     kitchenTemp01			[ nodeId="105", childId="1" ]
    	humidity		kitchenBat01			[ nodeId="105", childId="255" ]
        humidity        childHum01 				[ nodeId="107", childId="3" ]
        temperature     childTemp01				[ nodeId="107", childId="4" ]
        light			childLight01			[ nodeId="107", childId="0" ]
        light			childLight02			[ nodeId="107", childId="1" ]
        light			childLight03			[ nodeId="107", childId="2" ]
        humidity        guestHum01				[ nodeId="106", childId="0" ]
        temperature     guestTemp01				[ nodeId="106", childId="1" ]
    	light			guestPresence01			[ nodeId="106", childId="3" ]
        light			livingLight01			[ nodeId="106", childId="4" ]
        light			livingLight02			[ nodeId="106", childId="5" ]
        light			livingLight03			[ nodeId="106", childId="6" ]
        light			livingLight04			[ nodeId="106", childId="7" ]
        light			corridorLight03			[ nodeId="106", childId="8" ]
        light			livingLight06			[ nodeId="106", childId="9" ]
        humidity        livingHum01				[ nodeId="108", childId="2" ]
        temperature     livingTemp01			[ nodeId="108", childId="1" ]
    	humidity		livingBat01				[ nodeId="108", childId="255" ]
    	humidity        gardenHum01				[ nodeId="110", childId="2" ]
        temperature     gardenTemp01			[ nodeId="110", childId="1" ]
    	humidity		gardenBat01				[ nodeId="110", childId="255" ]
    	motion			gardenMotion01			[ nodeId="110", childId="3" ]
    Bridge mysensors:bridge-ser:MySGWKeller [ serialPort="/dev/ttyUSB0", sendDelay=100, skipStartupCheck=true ] {
        cover			kitchenShutter02 	[ nodeId="0", childId="0" ]
        cover			kitchenShutter03	[ nodeId="0", childId="1" ]
        cover			livingShutter01 	[ nodeId="0", childId="2" ]
        cover			livingShutter02 	[ nodeId="0", childId="3" ]
        cover			kitchenShutter01 	[ nodeId="0", childId="4" ]
        light			corridorLight01		[ nodeId="0", childId="5" ]
        light			corridorLight02		[ nodeId="0", childId="6" ]
        power			corridorLight01watt	[ nodeId="0", childId="7" ]

  • @TimO

    I'm using a ethernet gateway.
    the problem is: if the sensors gateway gets restarted/disconnected/updated/whatever the binding does not reconnect. The only way to fix that, is to restart openhab in order to force the binding to connect again.
    Detecting an disconnect is really that hard? in the worst case, what about simply reconnecting timebased? not as cute as only reconnect when nessecary but a dirty quickfix.

  • Thanks @TimO. Now I get it.
    What do you think about having two gateways, one with NRF radio and the other one with RFM69 radio?

    Will the binding support both gateways simultaneusly with no issues?

    Another question..Will you support HearbeatRequest for the development branch?

    Thanks, regards.

  • Hello againg.

    I have updated my OH2 to latest nightbuild from cloudbees, and also updated to lastest realease of OH2 MyS Binding.

    Now, I am facing an issue, that everytime that OH2 starts, it sends out all the items status to its respective node. This is causing, for example, to open my gates, or lowering my rollershutters, even disabling/enabling my alarm system. So I have shutdown OH2 for time being.

    Have anyone faced this behavior before?

    This is some of the log:

    15:41:40.241 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing 'mysensors:bridge-ser:gateway' takes more than 5000ms.
    15:41:40.272 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.295 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.322 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.335 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.348 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.362 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.375 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.388 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.402 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.545 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'Home.items'
    15:41:40.671 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.685 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.697 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.710 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.724 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.738 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.755 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.768 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.783 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.806 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;14;Gateway startup complete.
    15:41:40.811 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.856 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.871 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.885 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.898 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.914 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.928 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:40.941 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:41.029 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 2;3;1;0;0;
    15:41:41.110 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleCommand called
    15:41:41.288 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 3;253;1;0;2;
    15:41:41.546 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 1;6;1;0;2;
    15:41:41.799 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 3;252;1;0;24;REFRESH
    15:41:42.052 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 3;254;1;0;2;
    15:41:42.307 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 1;254;1;0;2;
    15:41:42.562 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 3;3;1;0;2;
    15:41:42.817 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 1;253;1;0;2;
    15:41:43.073 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 2;252;1;0;24;REFRESH

    I would really appreciate your help.

  • Hero Member

    @gonzalonal I have no idea why this should happen. The binding isn't that smart to do something like that. I've done a complete fresh installation on 21.06. with the nightly build from cloudbees and don't see this issue.

    @dakky Do you see disconnection messages in the log? The binding already tries to detect a disconnect and tries to reestablish the connection when an ethernet gateway is used. Currently the time within a reconnect would be successful is very small due to sleep limitations of threads in OH2 bindings.

  • Thanks @TimO . I will try to make a progressive installation and try to figure out what is causing this behavior.

    I'll let you know if I find out.
    Have you read my previous message?

    @gonzalonal said:

    Thanks @TimO. Now I get it.
    What do you think about having two gateways, one with NRF radio and the other one with RFM69 radio?

    Will the binding support both gateways simultaneusly with no issues?

    Another question..Will you support HearbeatRequest for the development branch?

    Thanks, regards.

  • Hero Member

    @gonzalonal : I just downloaded the recent version of the binding again and I don't see this behaviour.

    I hope both gateways will work together! This is was the idea. I've not tested it in combination with RFM69 but I don't see a reason why this should not work! 🙂

  • @TimO I have solved my probles using OH2 Beta3 and the last release of the MyS binding.

    It seems that the problem is only reproduced with the last release of OH2 from Cloudbees. At least withe the release 372.

    Have you tryed it?

  • Hero Member

    After a full computer crash (overheated CPU, CPU fan stopped working) I'm trying to set everything up on a new computer. Using the latest openhab2 beta 3 I'm having issues with using this binding. Specifically, whenever I add my standard thing configuration I get a buffer overflow in openhab which results in a core dump.

    I have downloaded latest binding from the link at github, but that did not affect it. In addition to this binding I am using the zwave binding and rfxcom binding. All three connect to devices through serial ports, although I I'm not sure if they do it in the same way.

    You may recall that I have had trouble using these three bindings together earlier, but for some reason things worked out and it has worked quite reliably since then.

    I'm not sure which information from the system crash is useful, but if there is anything I can send you to help you figure out what happens, let me know. Also, I realise that this problem might not be related directly with mysensors, but maybe with the serial library used (I saw a reference to NVJavaSeria in the stack trace after the crash.

  • Hero Member

    Hello again.

    As a temporary fix I found a simple TCP/serial Gateway Python snippet that handles the connection to the serial mysensors device and provides a TCP interface to openhab. Switching the binding of aggression from serial to socket and having it connected to this software gateway removes the core dump issue. This confirms my suspicions that the issues are with the serial port library.

    It works okay as a workaround until someone figure something out 🙂

    If anyone else is having issues with the serial connection, this is the by then snippet I found and used:

  • Hero Member

    @kolaf I'm only using one serial gw and that is running rock stable within OH2. My last update was 22 days ago, so maybe it is time for an update again. 🙂

    I recently changed my job, so I'm a little low in time at the moment. 😞

  • From what i can see this binding is not part of the official bindings for openHAB. Are there any plans to try to get this as a official binding for openhab?


  • Hero Member

    @Fredrik-Jönsson : Yes, this is on my to do list with high priority. I've done some preparations but need to contact the OH2 developers before creating a PR.

  • Hero Member

    @gonzalonal :

    I've found the time to sync my repository with upstream master OH2. Now I do see the behaviour you described above. The status of every item is send out at startup.

    Using the current package of the MySensors binding from today with an older version of OH2 does work fine. But my development environment now throws out the status of all things.

    Are you using any other bindings? Are they working fine?At first I need to find out if this problem only occures with the MySensors binding or if there is a bug. 😉

  • Hi @TimO.
    I am using several bindings in my OH2 setup.
    As I am using MyS and OH2 in a productive and sensible environement I could try out how the other bindings behaved. As soon as I detect the error I had to rollback my setup. So I can't really tell is there is a bug with the latest snapshot of OH2 or if it is something more specific of MyS binding.

    I am currently using OH2 Beta 3 with no issues.

  • @TimO That sounds great, i will start trying this out. By reading this thread it sounds like it works quite well..

    Thanks for all you time you put into this binding.


  • Hero Member

    @gonzalonal : I've found the reason for this beaviour and fixed the bug.

    @andreacioni contributed a PR to the code that includes a channel for the last update of a thing. If you want to know at which time there was a message from a node you may subscribe to the "lastupdate" channel.


    DateTime   lastUpdate01 "Last Update" { channel="mysensors:baro:gateway:baro01:lastupdate" }

    Thanks @andreacioni !

  • Hi @TimO .
    I have tried the binding and the issue is fixed as you have said.
    I have been looking at the logs, and found the following regarding last update feature:

    15:52:11.580 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;253;1;0;2;1
    15:52:11.583 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.581-0300
    15:52:11.585 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.584-0300
    15:52:11.590 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.588-0300
    15:52:11.594 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.592-0300
    15:52:11.598 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.597-0300
    15:52:11.602 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.601-0300
    15:52:11.606 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.604-0300
    15:52:11.609 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.608-0300
    15:52:11.613 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.611-0300
    15:52:11.618 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.616-0300
    15:52:11.624 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.622-0300
    15:52:11.628 [DEBUG] [g.mysensors.handler.MySensorsHandler] - Setting last update for node 1 to 2016-08-08T15:52:11.626-0300

    Is this the expected behavior? It seems to me that we should have only one "Setting last.." for value updated.
    Maybe is my setup. Can someone check this.

  • Hi @gonzalonal

    The implementation of the binding create a thing for every channel of a single node. So the solution result is what you can see in the log. We can do a little bit more to prevent a single message to fire every 'lastupdate' channel of every thing that have the same node ID. But I think it is not a good idea.

  • Got it!
    Thanks for your quick reply @andreacioni

  • Hi guys,

    I've tried to add my ethernet gateway to openhab2 through but I just cant get the Online-status on, it. Do I have to do anything else than just adding it into the things file?

  • Hi @Gustafsson,

    Have you read the readme? Readme . Probably you have not configured things? See the readme on how to do that 🙂

  • @andreacioni That's exactly what I did.


    Bridge mysensors:bridge-eth:gateway [ ipAddress="", tcpPort=5003, sendDelay=200 ]
            door    frontDoor       [ nodeId="102", childId="4" ]


    Text    frontDoor       "Door"  { channel="mysensors:door:gateway:frontDoor:tripped" }


    sitemap MySitemap label="Main Menu" {
            Frame {
                    Text item=frontDoor

    This is how everything looks like now. I get the door item green in habmin but still the red cross on the gateway. The door item dosn't show me if it's open or closed.

  • @Gustafsson

    You are missing the opening brackets

    Bridge mysensors:bridge-eth:gateway [ ipAddress="", tcpPort=5003, sendDelay=200 ] {
    door frontDoor [ nodeId="102", childId="4" ]

  • @gonzalonal sorry, I missed it when I pasted in my code here, so there is in fact a { in my code. Any other ideas?

  • I have a problem with adding one of my nodes.
    My temp en hum nodes are working perfectly, but i try to add a Light Level node. The sensor is sending the amount of Lux and not the percentage:

    18:14:59.572 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 1-1-0 s=0,c=1,t=23,pt=3,l=2,sg=0:3
    18:14:59.572 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;0;1;0;23;3
    18:14:59.574 [ERROR] [g.mysensors.protocol.MySensorsReader] - (java.lang.IllegalStateException: Could not update state, because callback is missing) on reading from serial port, message: class org.openhab.binding.mysensors.protocol.serial.MySensorsSerialReader

    It is using CHILD_ID_LIGHT inside the skechts. Is this light level node supported?

  • Hero Member

    @FutureCow said:

    18:14:59.572 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 1;0;1;0;23;3

    According to this:

    V_LIGHT_LEVEL	23	Uncalibrated light level. 0-100%. Use V_LEVEL for light level in lux.	S_LIGHT_LEVEL
    V_LEVEL	37	Used for sending level-value	S_DUST, S_AIR_QUALITY, S_SOUND (dB), S_VIBRATION (hz), S_LIGHT_LEVEL (lux)

    Your node should send "1;0;1;0;37;3 if I'm not mistaken.

    The light level message is supported by the binding.

  • Hero Member

    Small update to the progress:

    1. Expert mode: I've added a special thing that will allow rule based parsing and sending of MySensors messages. If the binding is limiting your creativity you are now free to go. 😉 You are now able to combine/adapt rules like in this Thread with the easy process of thing/item/sensor configuration. I've added a description to the Wiki. This may solve some problems mentioned above with sensors requesting information like pulse count.

    2. Last week the OH2 core team has released beta4 of OH2. I've tested the binding against the current beta and it is working fine.

    3. I've created a PR against the official openhab2-addons repository. I'm now awaiting feedback and hope to introduce the MySensors binding as part of OH2.

  • Admin

    Great job @Timo!

  • Great news to hear @TimO .
    I will be testing the binding in a couple of hours. It's really usefull the new RAW messenger things.

  • Hi all, i am new in mysensors, but i have problem with install this plugin to OpenHab2.0 i tried versions 2.0 and 2.0b4 but i couldn't see this plugin in OpenHab2, i tried with RPi B, RPi3 with Raspian Jessie, and with Windows 10. But all with the same result.

    I placed org.openhab.binding.mysensors-2.0.0.SNAPSHOT.jar into addons directory, but i can't se it in OpenHab.

    Can anyone help me?

  • Hero Member

    @xlibor Did you follow the instructions on the wiki and installed serial transport first? Is there a log file entry? How did you install OH2? Debian Package or Zip File?

  • This post is deleted!

  • @TimO Yes, i follow instruction on wiki and install serial transport sucesfully. I tried both types, first zip file and next package, but both with the same result 😞

    In log file is nothing about mysensors or any error.

    Now i downloaded again from github and now all works without any problem. But i don't know where was problem.

Log in to reply

Suggested Topics

  • 5
  • 1
  • 5
  • 5
  • 1
  • 3
  • 1
  • 10