Error compiling serial gateway. Please help.



  • Have anyone problem with compiling serial gateway? Everything works fine before I try to update my serial gw to 1.5 with codebender. So I try to use Arduino Uno, and Arduino nano (witch works on 1.4) It could compiling something like "clear eeprom" or "blink" but when I try to compile gw in shows:

    Looks like your project uses header files or libraries that do not exist in our system, in your personal libraries or in your sketch. More info
    
    In file included from  SerialGateway.ino:26:
    libraries/28475_cb_personal_lib_MySensors/MyGateway.h:39:28: error: use of undeclared identifier 'DEFAULT_CE_PIN'
                    MyGateway(uint8_t _cepin=DEFAULT_CE_PIN, uint8_t _cspin=DEFAULT_CS_PIN, uint8_t _inclusion_time = 1, uint8_t _inclusion_pin = 3, uint8_t _rx=6, uint8_t _tx=5, uint8_t _er=4);
                                             ^
    libraries/28475_cb_personal_lib_MySensors/MyGateway.h:39:59: error: use of undeclared identifier 'DEFAULT_CS_PIN'
                    MyGateway(uint8_t _cepin=DEFAULT_CE_PIN, uint8_t _cspin=DEFAULT_CS_PIN, uint8_t _inclusion_time = 1, uint8_t _inclusion_pin = 3, uint8_t _rx=6, uint8_t _tx=5, uint8_t _er=4);
                                                                            ^
     SerialGateway.ino:33:14: error: use of undeclared identifier 'DEFAULT_CE_PIN'
    MyGateway gw(DEFAULT_CE_PIN, DEFAULT_CS_PIN, INCLUSION_MODE_TIME, INCLUSION_MODE_PIN,  6, 5, 4);
                 ^
    3 errors generated.
    

    And with 1.5 i have:
    2015-08-08 17-53-34 Скриншот экрана.png

    So, what i doing wrong?


  • Hero Member

    Did you delete the 1.4 libraries?

    Cheers
    Al



  • It all started with the setting up of separate Arduino Uno as a serial gateway but now I've managed to reinstall Chrome, restarted "Getstarted" on codebender.cc when connected to the computer working 1.4 serial arduino nano. Now my ex-serial gateway 1.4 only Blinking. 🙂 And Vera is hanging without a controller. And I cant compile old or new serial gw!
    Alsow I try to install IDE from arduino site but it has the same problem even before installing from codebender.
    How to install Mysensor libraries to codebender? Or it more easy to make a new accaunt?



  • Ha! It's solved by deliting Mysensors from Personal Libraries on codebender.cc and Cloning Sketch&Libraries.
    Thaks Sparkman for Idea!


Log in to reply
 

Suggested Topics

  • 4
  • 21
  • 2
  • 10
  • 10
  • 3
  • 7
  • 9

48
Online

11.1k
Users

11.1k
Topics

112.5k
Posts