id request fails



  • I have a strange problem with the id requests. My sensor (analog humidity sensor) is able to send data to the gateway (i can see data coming in on that side), but says the request for a node id failed. Tried adding a capacitor, worked on the power-supply, tried a different RF-module, erased EPROM, behavior remains the same.
    Any idea what might be going wrong here? What else can i try/check?

    My serial output on the sensor side looks like this:

    €x00x00send: 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    sensor started, id 255
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    0
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:```

  • Admin

    When you say that you capacitor, it means you added it to the gateway right?

    As you might see, the ack sent from gateway isn't received by your node.



  • How can i see this? At the moment the gateway is only 1m away from the sensor and i even exchanged the RF module with the enhanced one from Sparkfun (http://www.exp-tech.de/shields-module/wireless/funk/transceiver-nrf24l01-module-with-rp-sma-wrl-00705). But indeed i soldered the Cap onto the sensor, not the gateway...
    Do you think i should put it on the gateway anyway, even with the new tranceiver?



  • As you can see here I had a similar problem. In my case the problem was that the RF module of the gateway did not work properly. I changed it (without adding any caps etc) and after that the nodes got their IDs immediately.

    You may add a capacitor to the gateway too. However, in my opinion the capacitor treatment for everything is a little bit overrated.



  • I had a similar problem which was solved after I added a capacitor to the gateway.



  • ditto 👍



  • Hi, don't know if @Stephan-Noller found a solution, but I had a similar issue with a serial gateway running on a 8MHz arduino : it could not handled serial input at 155200 baud, setting it to 57600 solved my gateway behaviour. What gateway sketch are you using ? What hardware is it running on ?


Log in to reply
 

Suggested Topics

  • 2
  • 1
  • 20
  • 4
  • 15
  • 10
  • 8
  • 3

2
Online

10.2k
Users

10.7k
Topics

109.5k
Posts