My Slim 2AA Battery Node

  • Update : Day 3 and still all PIR nodes are working 😉
    I´m using the given sketch here.

  • Still up and running stable.
    8Mhz Bootloader did the trick for me 🙂


  • Hardware Contributor

    @Komaandy Nice! Thumbs up for 8MHz (and your "dark-style Fhem" - same as I use) 👍

  • @m26872
    thanks again for this great idea and that you developed these fine boards !
    And by the way...
    As you are using fhem as well...
    How do you manage to reset the tripped "1" in Fhem ?
    I just added a delay and a gw.send"0" to your sketch :), but using fhem would be more sophisticated actually ...

  • Hardware Contributor

    @Komaandy said in My Slim 2AA Battery Node:

    How do you manage to reset the tripped "1" in Fhem ?

    I don't. I just use the last trip time as it's state and then notify (e.g. light or push message) on trip. I think it should be very simple to make a notify with a timer "at" to reset it after a while, if you wish.

  • just want to mention that I am using successfully the same Bootloader @Komaandy is using for about 2 weeks now. So it seems like my problems with freezing nodes are depending on a bad or too slow bootloader...

  • All of the ducting near me is a bit too slim to fit sensors based on this, so I decided to design and print a case instead.

    Does the trick nicely, and I also chose to use proper AA battery clips to retain a good connection, as the cable-tie battery assembly wasn't holding well for me!

    On the Thingiverse page I have a link to the original OnShape doc.

    Thoughts, suggestions, etc will be much appreciated!

  • Hi

    Did anyone make DHT 22 slim node with MySensors 2.0? I created one Node from modified MySenors 2 example...But I get a feeling that it is freezing sometimes (but then again comes back to life).

  • Mod

    @Oliviakrk the dht22 needs at least 3.3V to function properly. See the datasheet.

  • Hardware Contributor

    @Oliviakrk - I did a test (which works pretty ok) with a DC/DC step up booster attached to D3 -> Vin. This way I could turn the booster on/off with HIGH/LOW from the sketch. This provided 3.3v to my sensors just fine and has been working for a while now. I dont know what will happen when the voltage drops though.

  • @sundberg84 Thanks. Will try.

  • Hi,
    Thank you for all the hard work put into this project. I have built a few door sensor nodes and have some issues. At first I had pull-ups connected as shown in previous pictures but at a logic 1, when there should have been 3.3V there was only roughly half, 1.7V. I am no expert but I take it there has to be a current leak through the D3 pin for this to happen. I have this on all my nodes. I have tried different code but still the same. When I remove the external pull-up the node works properly but instead the batteries run out in a week or so. Have I made a mistake soldering these and maybe shorted something? I have looked at them closely but can't see anything wrong.

    Does anyone else have this problem? Any tips?

  • Mod

    Did you actually check if there is continuity between the pins you said? Do you have a photo of your nodes?

  • If I disconnect the battery, there is continuity between D3 and VCC with a resistance of around 20 kOhm. So when the door sensor is shut (no resistance), I connect GND through 20 kOhm to VCC. The current should be 0,165 mA. Too high by reading previous posts but still much less than what I get if I measure. Then I get roughly 18 mA! (Far from a Fluke though but has proven reliable before). Am I misunderstanding things?

    I have tried different nodes and sketches with pull-ups both enabled and disabled but I doesn't seem to matter. I have tried different radio modules but still the same, unless I use the bigger! antenna-version. Then the current goes up to 24-25 mA.

    I have done/am doing something really wrong although they seem to work just fine. Tomorrow I will try more radio modules to see if I can find any difference.

    3_1504391407612_IMG_4745.jpeg 2_1504391407612_IMG_4748.jpeg 1_1504391407612_IMG_4747.jpeg 0_1504391407611_IMG_4746.jpeg

  • Hardware Contributor

    @masfak97 It's not clear to me whether you've tried to run it a as pure Arduino, without radio module and without MySensors library in your sketch? (I see that you haven't the serial/FTDI pins soldered - do you use ICSP, pogo-pins or whatever to upload and debug?)

  • I have thought about running it as a pure arduino and to use the debug function, but can't quite get the FTDI to work. I have used this before to upload code to arduino pros. I have a previous node that has all the pins soldered but simply won't be recognized with the USB FTDI. I have also tried switching USB-FTDI but still no luck. Is the FTDI supposed to work if all the pins are there?

    I have also bought a USBtinyISP but haven't read up on how to use it.

    Currently I install a first boot loader with Nick Gammons sketch running on a UNO connected to a breadboard and the 328. After that has been installed, I install the 8 MHz boot loader by Gert Sanders (thank you of it) and finally upload the code using "Upload using programmer". I currently have no way of reading the serial debug from the node.

    I checked the node without the nrf but still power-hungry in the mA.

  • Hardware Contributor

    I think you should focus on getting these basic Arduino functions working so you're in control of what's going on. Note that I recently added a few updates to the first post of this thread (under The uC - Software). Read the tutorials and use 8MHz internal clock.
    When you get everything running, test your door switch again with a simple Arduino sketch.

  • @m26872
    UPDATE 2: There have been reported issues with MySensors 2.x freezing on SlimNodes running at 1MHz, which I've confirmed. Recommended solution when using MyS 2.x, is to use 8MHz (internal) instead.

    This I can confirm - running at 1 MHz introduced some real oddities with latest MySensors library. Not sure what changed but my nodes definitely freaked out. Will try switching to 8 MHz - hopefully before Irma whacks us here.

  • @wergeld
    Same confirmation from my side; 1mhz boot loader doesn't work; dht22 with step up connected does always give NAN. Switching to 8mhz boot loader did the trick.

  • Hardware Contributor

    @kotzer Thanks for sharing. But (AFAIK) the Arduino DHT22 library has never worked at all at 1MHz. And since dht22 doesn't support <3V there's no need for 1MHz anyway.

  • @m26872
    Maybe offtopic, sry, but:
    I have Step up at dht22, so it has 3,3v to operate..

    But I am in wrong topic, it should be your first 2aa sensor ( )

    This is what I built, and with 1mhz it doesn't work (tried with step up 3,3v and without) this wasted me many hours, because I wanted to save energy as much possible 😉 with 8mhz its operating well.
    Greets from Germany

  • Hardware Contributor

    @kotzer Infact I'm actually making a few of my first model too rigth now. I had components left over and despite everyones criticism against the dht22, I find it working very well as long as you deal with the failed readings in the sketch. And, the battery life time was pretty good too. Greets. 👍

  • @m26872 I finally got to try your suggestions and loaded the Blink-sketch to my nodes. The power consumtion is then cut to ~4mA. Scrolling back through the forum, I copied the sketch from a user with low power consumption and - Finally - I get an idle comsumtion of 1,9 uA! Connecting the FTDI I can also debug and check for proper function.

    I do have another problem I haven't managed to solve; With an UNO and a breadboard I can easily load the bootloader using Nick Gammons sketch and then the sketch with the UNO as ISP. Using the FTDI I can read the serial stream without any problem but I can't seem to load any bootloader or sketches! I keep getting a sync error. I understand the principle of DTR going low and that the capacitor between DTR and reset and the resistor between +5 and reset will make the LOW into a low-pulse and then back to high. With the FTDI I can program a Pro Mini without any problems but it fails constantly with the nodes.

    I have no scope so I can't visualize the signal but with the meter I can see that the voltage on the reset is ~3,3v, the resistance between +5 and reset is 10 kOhm and the capacitor reads 83 uF although branded 100uF.

    I use Gert Sanders versions of Optiboot at 8Mhz and the one with 38400 NO LED (Thank you for that). I have tried several FTDIs and nodes, checked all connetions, tried to control the reset manually using a breadboard but can't get it to work. I have tried the FTDI at 5v instead (no nRF connected) and tried different boards and speeds. I have tried 1 MHz, 16Mhz.

    Is it possible that 83 uF is too small? Any other tips? When building more nodes it would be great to be able to program them without dismantling.

  • Hardware Contributor

    @masfak97 Have you selected the right board in Arduino IDE? (Installed MiniCore in Board Manager?) Have you tried to use baud 9600 (with corresponding bootloader of course) ?
    I doubt that 83uF is too small.

  • @m26872 Thank you for your suggestions. I have now tried them (and many more) but still can't it to work. It's really not a big problem since I can program them using an Uno as ISP instead but it's really annoying that I can't get it to work.

    I have checked my chips, they are all at mega328P-PU and I have tried many of them with the same result. I have soldered many nodes, thinking that I didn't make the solder connect through the holes but without any luck. I have tried different sockets to make the connections better and I have traced the entire node without finding any broken connections.

    To get the sketch loaded I use Nick Gammons board_programmer with an Uno and use the LilyPad boot loader which enables the internal 8 MHz (Using pin 9 as clock instead of an external crystal). After that I program the Uno with ArduinoISP, set the programmer to Arduino as ISP and upload the sketch with "Burn with programmer" command.

    I have switched USB-cable, USB outlet on the mac, breadboards, dupont cables, capacitors (different ceramic but all show too little capacitance), Atmegas and FTDI programmers. I have tried all combinations with 3.3 and 5 v without any luck. Programming Arduino Pros with the FTDI works fine.

    I have tried the Mincore and Gert Sanders OptiBoot. I have tried to manually reset the chip connecting the reset pin to ground briefly when programming. I have tried lowering the baud rate to 9600. I have tried to load the Uno bootloader together with a 16 MHz crystal and 2 x 22pf capacitors and then the FTDI. I have tried larger electrolytic capacitors.

    Last week, when mimicking the slim node on a breadboard, I managed to get the FTDI to work a few times but can't really say exactly what I did. Now I can't get it to work anymore.

    All in all I have spent many hours trying to figure this out but without any luck. My nodes look just like the ones I see in your pictures.

    Could it be that the internal 8 Mhz is too unstable to work?
    Capacitors being too small? I've seen some reporting that they succeeded with larger...
    Bad connection somewhere > momentary voltage drop?
    Cheap FTDIs?
    Mac USB-power maxing out?
    Bad atmegas?

    Please help me solve this annoying problem.

  • Hardware Contributor

    @masfak97 Wow. You work hard. Of course we must help you. I'm not familiar with your programming method. So that would be my quick wild first guess. I can't read that you've verified the fuse settings? Have tried different startup times e.g?
    Do I understand correctly if you're able to send and recieve commands to the Atmega with your FTDI after it is programmed ?

  • Hi. I have a problem with my slim node with the sketch "temperature"
    with the slim pcb node and a DS18B20 in domoticz it does well the node presentation but neither the S_TEMP child arrives nor does it get any temperature afterwards of course.
    but if I mount the same sketch in an arduino nano and with power to 5v it works perfectly.
    please help

  • Hardware Contributor

    @Mikepara Please elaborate and post your code. Tell us also about power supply, fuse settings (clock speed) and your troubleshooting steps. See debug-faq-and-how-ask-for-help.

  • sorry. the sketch is the "temperature" of library and the bootloader configuration is:
    arduino ide 1.8.5 and usbasp, record the minicore bootloader on atmega328P, clock 8mhz internal, compiler LTO disabled, variant 328P, BOD disabled.

  • Hi All,

    This Topic is a little old but hopefully still active. I am using the battery Duracell CR123 because it is small and fits in my case. Would this be an ok choice or does someone has other recommendations?

    Thanks for feedback.


  • Mod

    Look also at AAA/AA size LiFePO4 as it will need just one cell instead of 2 as the normal alkaline/nimh ones

  • Hi,

    Maybe a silly question, but where did you get the library for the Vcc.h ?

     #include <Vcc.h>
    compilation terminated.
    exit status 1
    Error compiling for board ATmega328.

    I couldn't find any VCC in the MySensors library set and also doing a search for vcc in the Arduino Library Manager I can't find it either...

    [EDIT] : Found it in other thread. Leaving here for reference:


  • @gohan said in My Slim 2AA Battery Node:



  • I have 29 panels of the latest version of the PCB. It's more than I can use. Please PM me if you are interested in them.

  • As information for everyone, I suggest that if you get sockets for the ATMEGA, that you get
    these: alt text
    rather than these: alt text

    The reason being that the former have a much wider gap in the middle than the later. Because of that, the .1 puff #104 monolithic multilayer 5.08mm pitch capacitors called for in the BOM fit nicely. If you use the later ones, you will need to remove material from the socket to fit them.

  • I just made a new case for a LiFePO4 magnetic sensor implementation of this. Thanks for the excellent work on this handy node design!!

    a picture

  • Mod

    With 2 mini solar panels on the sides and an harvesting circuit, you could run it indefinitely 😁

  • Good evening!

    I had a bit of a break from this forum (approx 3-4 years...) And just got back into it . I managed to put a bootloader into my 328p-pu chip

    can anyone just confirm if it is OK to use this bootloader with the version 2.0 board here.

    I understand that it should run at 8Mhz to be stable . so I assumed I could use the bootloader that comes with Arduino IDE ?

    I flashed this one onto the chip at the moment and will start to solder some of my boards soon. but would like to be sure that it is correct before I go too far 😃

    ############################################################## on a breadboard (8 MHz internal clock)



  • Hero Member

    @badmannen Welcome back. The good news is that there's now a mysensors bootloader, which is even better because it allows over-the-air firmware updates for the atmega328p:

  • Daaaaang ... it is a good time to be alive and come back to this I see 😃 ... thanks a million to you guys that made that one .. that certainly makes changes a whole lot less painful!

  • @neverdie Alright , that took me a couple of days of fighting with Arduino/Linux/windows/drivers/bootloaders etc etc etc but I got it all running with my updated gateway+repeater-node + mailbox-node. did not try the update function yet but surely it should work. just need one or two more repeater-nodes since I have way to thick cement walls here for this signal.

  • OK I had some fun the last couple of days and actually got something done =D !

    Managed to update my gateway and repeater-nodes to latest version and boot-loaded all nodes and future nodes so they are FOTA enabled .

    So far I managed to assemble 3 nodes and after a bit of swearing and soldering and de-soldering and re-soldering I got:
    1 - DHT11 TEMP / HUM node, on Battery (Slim 2AA) - surprisingly accurate actually

    2 - DOOR-SWITCH - on Battery (Slim 2AA) - to be used in my mailbox, got the idea from someone here in the forums, so thank you, I don´t remember who it was since I probably read a million posts by now =D

    3 - a 220V Relay switch, with the PA LN radio, and works as repeater ( runs on a NANO )

    just wanted to say a huge thanks to the MySensors group and all people here on the forum for helping me get started (Had a little break for a couple of years 😃



  • Hero Member

    Let us know when you get it to FOTA update.

  • @neverdie
    Just tried it by mounting an "empty" 328P in the node just with the
    fuses set to:

    and with the MYSBootloader .

    Amazing ! . worked at the first try! (this time around =D )

    ( tried and failed a couple of times earlier, but I know I burned 0xFD instead of 0xFE so set the BOD to the wrong value, and that does not work )

  • @neverdie Actually... I run into another problem ..

    After I make a FOTA and upload a sketch . it runs as it should, no problem.

    But if I try to update it again , it never tries to upload the sketch to the node.

    The only thing I could find that was clever to do to make it work ok with a battery node was to use smartSleep();
    which I do ... is there anything else in the code that needs to be present ?

  • Hero Member

    Hopefully someone who knows can chime in.

  • @neverdie OK, that person who knows something is now ME ! =D ... RTFM ... as always , it worked strangely enough to update ONCE with some slightly wrong Fuses set... reloaded the bootloader with soem correct fuses agian .. ( hopefully alst time .. and VOILA! now it works to update the node multiple times .. yeaa.

  • Hero Member

    What were the winning fuse settings that you finally settled on using? Trust me, a year from now you won't remember, and you'll be glad you posted it.

  • OK MY solution was actually the fuses that I said earlier . but confused myself by changing them back and forth a couple of times and downgraded Arduino to the previous version etc.

    So the fuses for my barebone 328P are:


    the biggest issue I had was probably with ARduino IDE .. that one I enver manged to set the fuses ( I read somewhere it should.. but maybe I´m wrong) . Anyway it works when I set the fuses and upload it with AVRDUDESS.

    (note: hello me 1 year into the future, just do what I say ! )

  • I just add another note to myself ( And anyone else that lost their hair wondering why the bootloader was lost....)

    DO NOT UPLOAD SKETCH ONLY WITH USBASP ... it deletes the bootloader .
    yes I know it is mentioned on the foru m.. just found it .. but I mention it again...

  • @badmannen

    and here is a good simple explanation of the fuses

  • Hero Member

    FYI: If you run the ceramic resonator at 8mhz, with the zero wake up fuse setting, you can wake the atmega328p up in less than 4usec. This is a huge power savings compared to all other options.

  • @neverdie aa thanks for the info. Might be useful for some other nodes I will do.

  • Hero Member

    @badmannen You're welcome. I even measured it on an oscope just to be sure, so I'm certain it is true.

  • This style?
    € 1,09 8%OFF | 20pcs Ceramic Resonators ZTT 4M 6M 8M 10M 12M 16M 4/6/8/10/12/16MHZ DIP-3 Crystal Frequency Element

  • Hero Member

    @badmannen no. It's built in. You already have it.

  • @neverdie aa ok sorry got confused there for a second. I'm running the internal, so I guess I will pop them off again now then and burn that fuse for a quicker startup 👍🏻

  • Hero Member

    @badmannen yes, it must be the internal resonator.

  • Hello, will there be a good soul that will help improve the program? I know what the error is but I have no idea how to correct it.


    when i change


    the interruptReturn = 1, but when i change


    the interruptReturn = 0.
    My question is how can i chane it to send 1 and 1 by both contactrons.

    Full code:

    //#define MY_DEBUG
    #define MY_RADIO_NRF24
    #define MY_NODE_ID 100
    #define MY_PARENT_NODE_ID 0
    #include <MySensors.h>
    #include "Vcc.h"
    #define SKETCH_NAME "WindowSlimSensor2pcs_smallR"
    #define PRIMARY_CHILD_ID 1
    #define PRIMARY_BUTTON_PIN 2
    #define SECONDARY_CHILD_ID 2
    #define BATTERY_REPORT_DAY 2   // Desired heartbeat interval when inactive. Maximum heartbeat/report interval is equal to this due to the dayCounter.
    #define BATTERY_REPORT_BY_IRT_CYCLE 10  // Adjust this according to usage frequency.
    #define ONE_DAY_SLEEP_TIME 86400000
    //#define BATTERY 3
    //MyMessage msg3(BATTERY, V_CUSTOM);
    int dayCounter = 0;
    int irtCounter = 0;
    bool interruptReturn=false;
    const float VccMin   = 1.7;           // Minimum expected Vcc level, in Volts.
    const float VccMax   = 3.3;           // Maximum expected Vcc level, in Volts.
    const float VccCorrection = 3.43 / 3.455;  // Measured Vcc by multimeter divided by reported Vcc
    const int32_t report_interval = 8640000; // 1day -> h * m * s * ms NOTICE: milliseconds, not microseconds!
    Vcc vcc(VccCorrection);
    //Vcc vcc;
    #ifdef MY_DEBUG
    void before(){
    void setup()
          //EXTERNAL pull-ups
        digitalWrite(PRIMARY_BUTTON_PIN, LOW);
        digitalWrite(SECONDARY_BUTTON_PIN, LOW);  
    void presentation()
        sendSketchInfo(SKETCH_NAME, __DATE__);
        present(PRIMARY_CHILD_ID, S_DOOR, "Lewe Okno");
        present(SECONDARY_CHILD_ID, S_DOOR, "Prawe Okno");
      //  present(BATTERY, S_CUSTOM);
    void loop()
        uint8_t reedState;
        uint8_t reedState2;
        static uint8_t lastReedState = 2;
        static uint8_t lastReedState2 = 2;
        sleep(5); // Short delay to allow buttons to properly settle
        reedState = digitalRead(PRIMARY_BUTTON_PIN);
        sleep(5); // Short delay to allow buttons to properly settle
        reedState2 = digitalRead(SECONDARY_BUTTON_PIN);
      if (!interruptReturn) { // Woke up by timer (or first run)
        if (dayCounter >= BATTERY_REPORT_DAY) {
              dayCounter = 0;
      else {    // Woke up by pin change
          // Woke up by pin change
          if (reedState != lastReedState) {
            send(msg.set(reedState==HIGH ? 1 : 0));
            lastReedState = reedState;
          if (reedState2 != lastReedState2) {
            send(msg2.set(reedState2==HIGH ? 1 : 0));
            lastReedState2 = reedState2;
          if (irtCounter>=BATTERY_REPORT_BY_IRT_CYCLE) {
      // Sleep until something happens with the sensor,   or one sleep_time has passed since last awake.
    void sendBatteryReport() {
              uint8_t batteryPercent = (uint8_t)vcc.Read_Perc(VccMin, VccMax);

  • Mod

    Welcome to the forum @Grzegorz-B


    bool interruptReturn=false;


    uint8_t interruptReturn= INTERRUPT_NOT_DEFINED;


    if (!interruptReturn) { // Woke up by timer (or first run)


    if (interruptReturn== MY_WAKE_UP_BY_TIMER) { // Woke up by timer (or first run)

    Documentation for the sleep function is available at

  • @mfalkvidd Thanks! now its works like a charm 😄

  • Hi,

    Has anybody succeeded Inn creating an rfm69 version of this?

  • I built a Temp/Hum sensor using Slim Node few years back on Mys 1.5x and it was working for so long without any issues. Now I am trying to upgrade it to Mys 2.2x. I successfully loaded the bootloader on a new ATMEGA 328P-PU. Bootloader I used is minicore as recommended by @m26872 in his original post. I used the "Arduino as ISP" method to load the bootloader as explained in this tutorial How to burn 1Mhz & 8Mhz bootloader using Arduino IDE 1.6.5-r5.


    Here are the settings I used in my Arduino IDE when loading the bootloader,

    • internal clock 8 Mhz ( again based on the recommendation from the original post)
    • BOD disabled
    • Compiler LTO disabled
    • Variant "328P/328PA"

    Bootloader Settings

    Now I am trying to upload the temperature/Hum Sketch using FTDI cable with the jumper set at 3.3v, I am getting the "stk500_recv(): programmer is not responding" error. Here is how I am connecting from FTDI to Slimnode and the same configuration has worked originally when I built the node but now it is failing.


    Could some experts in this forum please help me to bring my node back to work?

    Sorry about the long post. Appreciate your help.

  • @kiesel do you mean a copy of the same project or something that does a similar job using an RFM69?

  • Hi,

    this is an awesome project and after waiting for weeks to get all parts, I finally started building.

    The problem I am facing is that it seems that I cannot get the board working if I use such a 8-pin connector socket. I am generally OK with NOT using such a socket for sensors that "go into production" but for some sensors where space is not an issue or for boards which I want to use for testing different NRF24s etc, I would like to make the socket work.

    Does anybody have any tipps on how to make the radio reliably work with a socket? That would be awesome!

Log in to reply

Suggested Topics