intermittent connection between nodes and the ethernet gateway

  • Hello,

    This is a difficult one to debug. I have three nodes (temp+hum, pulse count meter and air quality nodes) reporting data to the ethernet gateway. The problem is that sometimes, it works like a charm, but very often it does not and one of the nodes "disappear" /not reporting data to the gateway for 5-6 hours, but then comes back. The energy meter pulse counts and consumption are reporting to Domoticz via the ethernet gateway every 20 seconds, but I can see the gaps between reports being from 1 min to several hours.

    I am running MY1.5 on all nodes/gateway. I have used standard sketches form

    This is what I have tried:

    1. changing the channel in MyConfig.h to 28, which is the most clear one at my property
    2. changing RF_#define RF24_PA_LEVEL and #define RF24_PA_LEVEL_GW with no much joy.
      Currently, I have all nodes set to MAX and the gateway to HIGH. I have rf24l01+ PA+LNA in my gateway. I have just ordered 3.3V voltage regulator and see if this helps. Currently, it is powered from Arduino Uno 3.3V pin, which may not be enough I understand
    3. All nodes have capacitors soldered to VCC and GND

    I could not notice any particular pattern - sometimes it is one node silent for several hours and sometimes it is the other one.

    Any help would be appreciated.


  • Hardware Contributor

    Does any if the act like a repeter? I had that issue with a node acting as a repeter which had power issues... i used a charger with to low mA i think because when i changed the power source it went better.

  • No, I do not have any repeaters. The problem is, for example, the Air Quality node is powered by 12V and using Itead Studio Nano shield (nrf24l01+ and Arduino Nano + MQ135 on one board). Another node (Sensebender Micro) is using batteries. They both disappear from time to time and I cannot find if there is a particular pattern.

    I'll try to feed nrf24l01+ PA+LNA from a different power source (5V pin) through LD111733. The regulator has a limit of 800mA (USB power has a limit of 450mA anyway), which is plenty of juice of the transceiver.

    By the way, I tried to change transceivers in nodes - no effect. I'll change the transceiver in the gateway and see if it helps. By the way, anyone if recommending a cap on PA+LNA transceivers?
    This is the only one I do not have a cap.

    Other ideas welcome!

    @sundberg84 said:

    Does any if the act like a repeter?

  • Hm, that is very interesting. Because I observe the same thing. I have one gateway attached to raspberry pi2 with arduino nano. It has a rf24l01+ PA+LNA. My node, it has a DHT22 and an optocoupler (which is off usually, hence not drawing power) has a arduino pro mini 3.3V and a rf24l01+. Usually it works very well, but sometimes, for example like this week for about 2 days the system was distorted. Only about 20% of the messages got through from the node to the gateway. I saw that 100% of the messages from the gateway came through to the node, but in the other direction it was very bad.
    Now, without me having touched anything (I am not even there, nobody at home) Things a back to normal and it seems everything is transmitted well.

    What does it mean? How to debug?

  • Is it always for 2 hours ? We had it at one Installation, Ethernet Gateway sending to FHEM
    But between the FHEM Server and the Gateway was a Powerline unit
    FHEM log showed some Problems reaching the network, i think caused by noise in the power line
    all attached other Network Units showed Errors for a few seconds, but the mysensors Gateway then always wasn´t reachable for about 2 hours
    I don´t know this is because of a fault in mysensors or the fhem Software part for it

Log in to reply

Suggested Topics

  • 5
  • 14
  • 6
  • 4
  • 3
  • 21
  • 2
  • 5