Compile error with v1.5 library using #define SOFTSPI



  • Situation: I downloaded the v1.5 library and installed it over the top of the Arduino IDE 1.7.8 version. I'm using the AtmelStudio IDE mostly. But in either case both IDE's give me the following errors. I don't want to rearrange the Mysensor library so can you tell me what the fix is, what am I missing? Thanks.

    Compiling 'RGT_SerialGatewayLCDmega' for 'Arduino Mega w/ ATmega2560 (Mega 2560)'
    MyTransportNRF24.h:In file included from
    MySensor.h:from
    MySensor.cpp:from
    RF24.h:20:23: fatal error: DigitalIO.h: No such file or directory
    :#include <DigitalIO.h>
    :compilation terminated
    MyTransportNRF24.h:In file included from
    MyTransportNRF24.cpp:from
    RF24.h:20:23: fatal error: DigitalIO.h: No such file or directory
    :#include <DigitalIO.h>
    :compilation terminated
    RF24.cpp:In file included from
    RF24.h:20:23: fatal error: DigitalIO.h: No such file or directory
    :#include <DigitalIO.h>
    :compilation terminated
    Error compiling libraries



  • seems u don't have extracted the mysensors lib correctly.
    DigitalIO.h is included in the bundle. have a look, if u have ./MySensors/drivers/AVR/DigitalIO/DigitalIO.h



  • The directories look correct. I will attempt to put the structure in this message. I simply downloaded from the MySensor site "Arduino-master.zip". Expanded in my download directory. copy and paste over the Arduino IDE directory replacing any existing files with the MySensor files.
    removed the comment on the #define SOFTSPI and received those errors above.

    Arduino>libraries>MySensors>examples> (lots of directories with samples directories)
    Arduino>libraries>MySensors>utility>RF24...
    Arduino>libraries>MySensors>utility>RFM69...
    Arduino>libraries>MySensors>utility>SPIFlash...
    Arduino>libraries>MySensors>utility>sha256...
    Arduino>libraries>MySensors>utility>RF24...
    Arduino>libraries>MySensors>utility>(many other MySensor files)

    I don't seen the ./MySensors/drivers/AVR/DigitalIO/DigitalIO.h in the download package... yet.
    Although it did come with a DigitalIO directory in the package.



  • uh my fault. The DigitalIO lib is in located in the AVR folder in the development branch only. In the master (1.5 release) its located in the libraries folder: libraries/DigitalIO/DigitalIO.h



  • Yes it is right on the libraries branch. I was a bit wrong in that the Arduino IDE compiled with the following errors ... similar to the other IDE.

    In file included from C:\Users\Scotts\arduino\libraries\MySensors/MyTransportNRF24.h:26:0,
    from RGT_SerialGatewayLCDmega.ino:26:
    C:\Users\Scotts\arduino\libraries\MySensors/utility/RF24.h:20:23: fatal error: DigitalIO.h: No such file or directory
    #include <DigitalIO.h>
    ^
    compilation terminated.
    Error compiling.

    Oddly the DigitalIO directory is contained on the libraries branch.


Log in to reply
 

Suggested Topics

  • 5
  • 5
  • 10
  • 6
  • 1
  • 11
  • 1
  • 13

199
Online

9.6k
Users

10.2k
Topics

106.1k
Posts