💬 Sensebender Micro

  • This module looks very good. Where can I buy these? Does it sells as soldered module or (can I buy) only PCB?

  • Admin


    See this page for more info.. It's the official mysensors pcb 🙂

  • How stupid of me. But of course it would be on the official mysensors site 😀😂😂😂

  • Let me know if you manage to order them. The IMALL website won't let me actually place an order due to it sending the wrong address to Paypal. I'm curious if it is just me...

  • I had no problems two weeks ago. Just got them last week.

  • Hero Member

    I had that same problem, but then I carefully checked my address entry on the site and found I had made an error. Once corrected it processed OK.

  • @Dan-S.

    Crazy but there was a space after my city name that was preventing it from working. I would have never thought it was that picky. Ordered 5 and I cannot wait to see how well they work!

  • cool .. Any idea how long it last on battery?

  • Mod

    The history thread mentioned in forum.mysensors.org/topic/1345/sensebender-micro/1 has a lot of information. I think the conclusion was 1-2 years.

  • Hardware Contributor

    A version with the SMD NRF24L01+ would be cool !

  • Hero Member

    Is it possible to add an ds18b20 to the Sensebender?

  • Hardware Contributor

    That certainly is possble, but there is already an excellent SI7021 on board (temperature AND humidity), so why would you need it?
    In any case you can connect it via de exposed pins.

  • Hero Member

    @GertSanders Thanks, It would be used for remote temp. sensing in a Ref/freezer/aquarium.. etc.

  • Hardware Contributor

    Certainly possible, check the examples.

  • Hello,
    is it possible, that the Sketch posted here, does not work with the MySensors libraray V2.0? There have been removed many libs, (SI7021, sha204, RunningAverage), which are used in the Sketch "SensebenderMicro.ino" V01.4.
    I had a little bit trouble last weekend, to get it run.
    I switched back to Mysensors lib 1.56 and used the expamle Sketch "SensebenderMicro" which was included in this lib. Then it worked.
    But thanks for this Great Projekt, and this great Board Sensenbender Micro


  • Admin


    External libraries (and examples depending on them) have been moved to a separate repository https://github.com/mysensors/MySensorsArduinoExamples.

    This was done because we can not have the external libraries in the main repository now that we are in the arduino library manager.

  • @tbowmo Thank you very much for your response and explaining.

  • Anyone managed to get this working with PlatformIO (through Atom) yet? I'm struggling.

  • @tbowmo

    I upgrade my sensebender firmware with the new one (V1.4), and i have a question.

    In the sketch (https://www.mysensors.org/hardware/micro) the line

    //#include <avr/power.h>

    is commented.

    Is it "normal" or is it a mistake ?

  • Admin


    I think it's a leftover from a cleanup at some point in time. Not used anymore.. The MySensors core library is handling the sleep mechanism now.

  • To reprogram the sketch in a sensbender micro, wich board must be selected in the arduino prg?
    I have problem with inclusion in jeedom, the command are not loaded.

  • Mod

    @fearoffish did you manage to get this working?
    And, if so, what was the issue?

    I am looking into changing to PlatformIO on Atom or even CLion...

  • Hi, I'm getting this error message when compiling the sketch with the 2.1.1 MySensors library:
    SensebenderMicro:168: error: 'getConfig' was not declared in this scope
    isMetric = getConfig().isMetric;

    I just commented out the line as workaround, but not sure that its correct.

  • Admin

    Hmm.. The api was recently changed to getControllerConfig().isMetric;

    I'll update the example.

  • Thank you.

  • How difficult is to replace 0402 components with 0603 or 0804 components in Eagle? I am too old for 0402 soldering :-)))

  • Admin


    Not that hard, but you'll probably need to redesign the board, to get room for the larger components.

    Another option is to order the board pre-assembled from our partner, itead studio

  • Plugin Developer

    I've tested to upload a sketch to the Sensebender Micro using platformio.

    Put the following JSON into a json file in a folder named boards either in the MySensors library folder (your project in platformio), or somewhere else on the search path. Use the name of the json file in platformio.ini in the board setting. See for more info:

    • Create a folder named boards in MySensors project folder.
    • Create a file in boards named sensebendermicro8MHz.json.
      "build": {
        "core": "arduino",
        "extra_flags": "-DARDUINO_ARCH_AVR -DARDUINO_AVR_PRO",
        "f_cpu": "8000000L",
        "mcu": "atmega328p",
        "variant": "standard"
      "frameworks": [
      "fuses": {
        "efuse": "0x06",
        "hfuse": "0xD2",
        "lfuse": "0xE2",
        "lock": "0x3F"
      "name": "Sensebender Micro (3.3V, 8 MHz)",
      "upload": {
        "maximum_ram_size": 2048,
        "maximum_size": 30720,
        "protocol": "arduino",
        "require_upload_port": true,
        "speed": 57600
      "url": "https://github.com/mysensors/SensebenderMicro",
      "vendor": "MySensors"
    • Add an env in platformio.ini.
    platform = atmelavr
    framework = arduino
    board = sensebendermicro8MHz
    lib_deps = MySensors
    • Compile sketch.
    • Upload sketch.

    I think I've got the settings correct, but it was the first time I did this. But it's tested and works as far as I can see.

    Should we add a JSON file to one of the mysensors repos on github?

  • Mod

    I have a bunch of W25X40CLSNIG-ND lying around.
    They have the same size and same layout as far as I can see.

    Is my thinking correct that I should be able to simply replace the AT25DF512C-SSHN-B, change the sketch and use it?

  • Admin


    If it's a jedec compatible flash, then you should be able to swap.. But what is the usecase of a larger flash? You can't execute code in the external flash.. So for OTA you still only have a bit under 32Kbyte usefull space..

  • Mod

    @tbowmo no case at all, just that I have them and otherwise probably won't use them..

  • To reprogram the sketch in a sensbender micro, wich processor frequency do I choose?

    After choosing Board "Sensebender Micro", the menu in Arduino 1.6.12 has choice Processor "Atmega328 8MHz" and "Atmega328 1MHz".
    My code seems to be executed equally fine with both settings.
    But the Arduino Serial Monitor not:

    If I choose the 1MHz version, the Serial monitor only produces garbage, whatever setting I choose for baud (in the sketch and in the serial monitor UI).

    If I choose the 8MHz version, the serial monitor works fine.

    I am confused. The Sensebender is a 1MHz device, isn't it? Is it able to run on 8MHz too?

  • Admin


    No, it runs at 8Mhz. It is asleep most of the time, so running at 8Mhz is actually more battery conserving, than running at 1Mhz (in theory), as shown in calculations over in this post. This is due to the shorter time powered on, when running at 8Mhz, compared to running at 1Mhz.

  • OK, I understand.
    My confusion was caused by the second sentence at https://www.mysensors.org/hardware/micro : "... it operates at 1Mhz ..."
    That's a mistake then?

  • Admin


    Yes, sorry that was a false statement. I have modified the description, so that it now states that the Micro is running at 8Mhz.

  • Mod

    I am thinking of expanding the Sensebender Micro and learn Kicad in the process.

    Unfortunately every attempt to convert from Eagle to Kicad failed.

    Is there a Kicad version available or did any of you manage to convert the project?

  • Admin


    There is no kicad project available for the Sensebender Micro, I tried to convert it myself, but didn't succeed with it either.

  • Admin

    @tbowmo said in 💬 Sensebender Micro:


    There is no kicad project available for the Sensebender Micro, I tried to convert it myself, but didn't succeed with it either.

    I haven't tried this Eagle->KiCAD convertor myself but it might do the trick or at least reduce a lot of the manual labor to convert...

    There's even a tutorial video.

  • Admin


    thanks for finding that tutorial.. Might give it a spin, and see if I can convert the sensebender micro to kicad

  • Mod

    @blacey I tried that one but for some reason a dialog pops up that I can not click away anymore 😞
    Complaining about files in a wrong place without giving more info.

  • Admin

    @marceltrapman The author updated his repo within the past few days so you could open an issue on his GitHub repo to see if he can help...

  • Admin


    Just tried the scripts from the url that @blacey mentioned above on the sensebender micro eagle files.. And got a semi working thing in kicad..

    And it seems that at least the forward annotation from schematics to pcb is working like it should..

  • Mod

    @tbowmo Nice, I will try again (probably sunday or so)...

  • Hey together,
    i have a question, because i have some capacity troubles. I used the example sketch from sensebender micro that meassures the temperature and humidity but i have additional activated the signing and encryption and now i got over the availible space 109%.
    use anybody from you all the features? what i have to do?
    thank you

  • Re: 💬 Sensebender Micro
    I'm trying to flash the sketch to the sensebender micro using the Arduio IDE.

    I bought the sensebender micro with the suggested FTDI programmer.

    I connected the programmer to the sensebender and plugged in the USB cable.

    My windows 7 installation finds the device and installs the driver as USB Serial Port (COM3). The driver is from FTDI. The hardware device id is: FTDIBUS\COMPORT&VID_0403&PID_6001

    In the Arduino IDE, i've selected Board: Sensebender Micro, Processor: Atmega 328 8Mhz, Port: COM3.

    I tried using USBasp, made a clone with the right hardware id's and tried that. I tried AVRIsp Mk II.

    Whatever i try, avrdude.exe tells me it can't find the device:

    C:\Program Files (x86)\arduino-1.8.1\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\arduino-1.8.1\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -cRF232RL -Pusb -Uflash:w:C:\Users\rob\AppData\Local\Temp\arduino_build_955073/SensebenderMicro.ino.hex:i 
    avrdude: Version 6.3, compiled on Dec 16 2016 at 13:33:19
             Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
             Copyright (c) 2007-2014 Joerg Wunsch
             System wide configuration file is "C:\Program Files (x86)\arduino-1.8.1\hardware\tools\avr/etc/avrdude.conf"
             Using Port                    : usb
             Using Programmer              : RF232RL
    avrdude: Warning: cannot open USB device: Function not implemented
    avrdude: error: could not find USB device with vid=0x403 pid=0x6001
    avrdude done.  Thank you.
    the selected serial port 
     does not exist or your board is not connected

    Anyone knows what's wrong?

  • Hey together,

    i have an problem, i had some troubles with the space on the sb micro, i have removed the #define my_debug that solved my space problem, but now i have observed that the node is starting and sends few times the temp and humidity but after the few times nothing happens anymore.
    i observed, when i hold the sensor in the fingers so that it will be worm, and start the node then it sends all minute the temp, but when the temp goes down to the room temperature then the node should send only when the humidity or temp changes over the threshhold, so in the room i dont have much changes and i think that when the node does not send about a longer time, that the the problem comes up.
    I tested it in some different distances, on another floor but in very short distance too. I dont think that is a radio problem.
    What do you think about?
    The Problem is, that i cant debug the node because i disabled it because of space problems.
    Thank you

  • i have just tried it again, it worked for 20 minutes. After them i get this output:

    Sensebender Micro FW 1.4 - Online!
    isMetric: 1
    TempDiff :122.28
    HumDiff  :154.00
    T: 22.28
    H: 54
    TempDiff :0.00
    HumDiff  :0.00
    TempDiff :0.10
    HumDiff  :0.50
    TempDiff :0.11
    HumDiff  :0.50
    TempDiff :0.12
    HumDiff  :0.00

    ok one more thing i found, when i close the serial monitor and start it again, i get the correctly output again, and i see in fhem the new readings.

    but i cant understand what happens why stop the node to transmit the correct readings

  • @meddie, do you use the default sketch for sensebender ?
    If this is the case, please notice that after 5 measures, the clock speed is lowered to 1 Mhz. It means that the serial output won't work anymore using the default baud speed.
    And, when you restart the serial monitor, it starts all over again from measure number 1.
    Hope this helps.


  • @qqlapraline
    oh yes it does! It explains why i get the € signs in the serial monitor. But why does the node not send to my FHEM Controller? Depends it also on it, that the node switch to 1 Mhz and cant send anymore?
    Thank you very much for your answer, its very helpfull.
    Greets Eddie

  • Admin

    Hmm I actually thought that this feature with switching to 1mhz was removed, as my calculations show that it (in theory) will use more current, than running at 8mhz (due to the fact that it sleeps most of the time)

  • @tbowmo : The code to switch the frequency back to 1MHz is still there at https://www.mysensors.org/view/1/Sensebender-Micro.
    Should it be removed?

  • Is it possible to directly connect a RFM69* module to the Sensebender Micro? Or do I need the (rather costly) NRF2RFM69 to do that?

  • Mod

    @Wavemaker welcome to the community!
    You can spend your time instead of your money to do exactly what the adapter does, no need to buy it.

  • Admin


    What is costly? If you grab the gerbers for the nrf2rfm69, send them to dirtypcbs (or use the link provided in the thread and order the pre uploaded gerbers at dirtypcbs) you'll get around 30 modules for 12$..

  • @tbowmo Aha, yes, well I was looking at the cost of just one adapter to test. But you're right, in larger quantities it's not costly.

  • @Michiel-van-der-Wulp
    Can you tell me where in the code is the switch to 1 MHz? I still have the problems that my node dosnt send anymore. It works for several hours but after then it dont send anything.

    In programming i am not good, and so i cant find the switch.
    Thank you very much.
    Greets Eddie

  • @meddie : Sure, I can:

    The following is an extract from the code shown at https://www.mysensors.org/view/1/Sensebender-Micro, from the "loop()" function:

      if ((measureCount == 5) && highfreq) 
        clock_prescale_set(clock_div_8); // Switch to 1Mhz for the reminder of the sketch, save power.
        highfreq = false;

    If you remove these lines, it will stay on 8MHz.
    (I did not test this but I am quite sure)

  • @Michiel-van-der-Wulp
    thank you i will test it the next few days

  • I assume there is no exposure to the SPI bus on this board?

  • Hardware Contributor

    @Dominic-Amann from the hardware site:

    MYSx 2.6 with
    Dedicated UART
    Dedicated SPI
    Dedicated Interrupts
    I2C bus (shared with onboard eeprom)

  • Ah - right, the radio connector uses SPI.

  • Admin


    There are multiple SPI ports in use, one of them is dedicated to the expansion header (which follows MYSx 2.6 standard)

  • Can somebody please post what this boards current draw is at 8Mz w/wo a radio. Because it will live in a crawl space It's going to be plugged in. I've also added a very simple water detector.

  • Admin


    normal operating frequency is 48Mhz (if I remember right).. If I remember right, then there is no options in arduino to switch the frequency to 8Mhz..

  • Beware that the Si7021 can return a RH value < 0 or > 100, and Domoticz will not store it. Clamp the humidity to a valid range to avoid losing values.

    Lately, my Sensebender reported values of 101-104 during the night. Took me some time to understand why Domoticz complained it didnt receive any values.
    It received these values, but didnt like them.

    See section 5.1.1 of the Si7021 datasheet says:
    Due to normal variations in RH accuracy of the device as described in Table 4, it is possible for the measured value of %RH to be slightly less than 0 when the actual RH level is close to or equal to 0. Similarly, the measured value of %RH may be slightly greater than 100 when the actual RH level is close to or equal to 100. This is expected behavior, and it is acceptable to limit the range of RH results to 0 to 100%RH in the host software by truncating values that are slightly outside of this range.

  • So cool that the micro as a node reports its battery level to the UI (I'm still on the FTDI power, hence > 100%)


  • Is there a board definition for sensebender micro for PlatformIO available ?

  • Plugin Developer

  • Am I able to remote reboot the sensebender micro? I can send an OTA firmware if i manually press the reset button.
    but can i use the reboot command in MYScontroller? it doesn't seem to do anything when issued.

  • Admin


    Is it the default dualoptiboot bootloader? Then the bootloader itself does not support OTA FW. You need to put a sketch on it, that supports OTA. (Default sensebender micro sketches doesn't)

  • @tbowmo said in 💬 Sensebender Micro:


    Is it the default dualoptiboot bootloader? Then the bootloader itself does not support OTA FW. You need to put a sketch on it, that supports OTA. (Default sensebender micro sketches doesn't)

    yes it's the default bootloader. yes i have OTA added to the sketch. it works if i reset the device via manual reset. but what i'd like to do is send the reboot command from myscontroller. but it seems to do nothing ever. does the bootloader support reboot? or is that something i also have to add to the sketch?

    situation: i have about 15 sensors all over the house. if i update, i'd like to be able to assign the firmware, and then issue the reboot command. so upon reboot, they take the assigned firmware. what i don't want to do is have to go to each one and manually press the reset button to get it to take the firmware. i'm sure it's healthier to run up and down 3 flights of stairs. but i'm lazy 🙂

  • Admin


    The sketch should support reboot, try sending I_REBOOT to one of your nodes (info can be found here, look under internal messages)

    I haven't tried it myself yet, as I haven't touched my sensebender micros for ages..

  • Hi,
    Three questions regarding SenseBender Micro:

    • What board should I configure in Arduino IDE in order to upload sketches? Would it be equivalent to Arduino mini pro, or is there any "board library" to load ?(Didn't find it, Woudn't it make sense to be included in the examples/Libraries pack?)...
      (Found it: https://github.com/mysensors/ArduinoBoards . If you look between the photos above there is a simple link lost in the between)
      MySensors Admins: Just a small suggestion: As it is now, - a simple link between photos is easily overlooked. Can't you place it near the specs where it should be more visible?

    • It has an I2C bus for the SI7021, but it seems the ATSHA204A (which I believe its I2C also) is connected to another pin (a3). Does this mean it has two I2C buses?

    • Can anyone confirm that the port that measures the battery voltage is A0?


  • Contest Winner

    @joaoabs we do not support I2C variant of atsha204a. Only single wire variant.

  • Admin


    It uses the internal vref to measure the battery voltage. Some of the theory is described here https://www.sciencetronics.com/greenphotons/?p=1521

  • For the battery powering voltage measuring do you mean that this is not needed after all? (https://www.mysensors.org/build/battery#measuring-and-reporting-battery-level)
    It would be just a matter of enabling the flag "#define BATT_SENSOR 199 " and no resistors needed?

  • Admin


    Yes, when you power it directly of f.ex. two AA batteries, then you can use the secret trick mentioned in that article that I linked to, for measuring battery voltage without external resistors.

  • Sorry for the dummy question, but my SenseBender Micros came with a small white sticker on top of the Si7021 sensor (like in the pictures above). Is it supposed to be removed or to stay like that?

  • Contest Winner

    @joaoabs the datasheet for the device clarifies that I believe

  • Admin


    Just leave it on..

  • Hello!

    Help me understand why the sketches are not loaded in Sensebender Micro - there is a synchronization error:
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x82
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x82
    avrdude: stk500_recv(): programmer is not responding

    • FTDI connected via 3.3V jumper

    • Another device built on the SB Micro with SB bootloader is also not flashed with the same error, but on the PC of my friend, sketches successfully loaded into the device and on my PC are given the correct data when working sketch

    • device and serial port are selected correctly

    • mySensors Lib and device packs(AVR, SAMD) installed with standard lib and device managers(and also added path https://raw.githubusercontent.com/mysensors/ArduinoBoards/master/package_mysensors.org_index.json in the settings menu)

    • at the same time if I take a pure Pro Mini and load into it any sample sketch of mySensors package - it will successfully do it and will work.

    What am I doing wrong and how do I get the Sensebender Micro to take sketches?

  • Admin


    Did you select the sensebender micro as target in Arduino? Is it the same FTDI device that is used on both computers?

  • @tbowmo
    Yes, of course, I chose the target device "Sensebender Micro -> "Atmega328p, 1mhz" and "Atmega328p, 8mhz"(for device (RGBW controller) based on SB Micro with 8Mhz quartz resonator).

    I tried three different FTDIs.

    With any other Arduino (with native loaders) there are no problems with these FTDI adapters.

  • @nailman At what Mhz does your RGBW Controller is running now?
    It seems to be the problem is in identifying the correct board.

    If I have a board running at 1Mhz and try to program it at 8Mhz, similar to your error would come up, i.e. not in sync

  • Admin

    Unless the bootloader is reprogrammed, then it defaults to 8mhz, and you have to actively set registers to run at 1mhz in your sketch.

    Do you have a ISP programmer? If yes, could you make a memory dump, and send it to me?

  • Hello,
    Coming back to the battery powering topic: I was checking some SlimNode code and it uses #include <Vcc.h> library to report battery level. I can see in that the example code above doesn't use it. Does anyone know what is the difference? Which is better?

  • Admin


    Could you post a link to the code from slimnode?

  • Hi,

    The slimnode original thread has a few (not sure anymore which example I'm using now because the thread is huge and I've lost track of it)
    Here is one example:

    and other:

  • Admin


    The library use the exact same method to read VCC, as the Sensebender Micro example. It's just the functions that is extracted into a library (which I think have been done by @Yveaux )

  • @tbowmo
    I apologize for the delay in replying, I was very busy with work.

    It turned out to be some mystical incompatibility of the FTDI and Sensbender Micro or a device based on its loader. Three versions of my FTDI refused to work with Sensbender Micro, but they worked with regular Arduino, and the fourth one, bought on AliExpress, works perfectly normal. Externally, all the same, only those that do not work with Sensbender Micro, the labeling of the chip differs slightly in the quality of engraving on the plastic.

    Maybe it's fake or some kind of non-standard chips.

  • @nailman There are a lot of fake FTDI modules. Some are labelled FTDI other claim to be FTDI but are CH340. Some have DTR others RST and good ones like Adafruit Friend it is selectable.

    My recommendation is do not try to save a few bucks here. Spend money on a good quality FTDI adapter like Adafruit Friend.

  • Hi,
    I'm using the mysensor lib for a while but I recently run into problems. I've some arduino pro minis running with dht22 sensors which send their data over nrf24 to an mqtt ethernet gateway.
    But maybe someone can help me with this one: I have build my own sensebender-micro modules. First of all I programmed the fuses of the mega328p as follows: lfuse: 0xE2, hfuse: 0xD2, efuse: 0xFE. Then I've programmed the DualOptiBoot Bootloader to them, everything worked fine so far, I can upoload sketches from the Arduino IDE via FTDI Programmer. The Problem: When I upload the official example sketch and watch the serial monitor I just see the MySensors splash screen. It seems, that the sketch does not even run into the setup routine. This starts to make me crazy, since I do not even know where to search. If I upload other sketches (basic blinking led, serial port examples or the passive node example from mysensors) it shows that my hardware in general seems to work. When I enable debug this is the output:

     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.3.0
    26 TSM:INIT
    28 TSF:WUR:MS=0
    38 TSF:SID:OK,ID=100
    40 TSM:FPAR
    75 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2086 TSM:FPAR
    2121 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4132 TSM:FPAR
    4167 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6178 TSM:FPAR
    6213 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8222 !TSM:FPAR:FAIL
    8224 TSM:FAIL:CNT=1
    8226 TSM:FAIL:DIS
    8228 TSF:TDI:TSL
    18229 TSM:FAIL:RE-INIT
    18231 TSM:INIT
    18239 TSM:INIT:TSP OK
    18241 TSF:SID:OK,ID=100
    18243 TSM:FPAR
    18280 TSF:MSG:SEND,100-100-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20289 !TSM:FPAR:NO REPLY

    Even the NRF24 connection seems to work. This is the output of my mosquitto broker when running the passive node example:

    home/OpenMQTTGateway/LWT Online
    home/OpenMQTTGateway/version 0.7
    mygateway1-out/100/255/0/0/17 2.3.0
    mygateway1-out/100/255/3/0/6 255
    mygateway1-out/100/255/3/0/11 Passive node
    mygateway1-out/100/255/3/0/12 1.0
    mygateway1-out/100/0/0/0/6 (null)
    mygateway1-out/100/0/1/0/0 25.70
    mygateway1-out/100/0/1/0/0 26.90
    mygateway1-out/100/0/1/0/0 27.30
    mygateway1-out/100/0/1/0/0 25.80
    mygateway1-out/100/0/1/0/0 26.00

    I appreciate any help, thanks in advance!


  • Mod

    Hi @flybysun, welcome to the forum!


    means that the sensor node does not get a response from the gateway. What type of gateway are you using? Could you post the debug log from it?

    If you haven't already, check https://forum.mysensors.org/topic/666/debug-faq-and-how-ask-for-help/ for the most common problems and how to troubleshoot them. (Hint: Power supply is the most common problem, the nrf24 is extremely picky)

  • Hi @mfalkvidd, thanks for the warm welcome!
    So, tonight I'll give it another try. I soldered 1000uF above VCC and GND on both the sender and the gateway RF Links (that's all I could find here for now). Still got issues. Here are the logs from my gateway, when it starts up and receives values from my working sensor I had before:

    3 TSM:INIT
    4 TSF:WUR:MS=0
    14 TSM:READY:ID=0,PAR=0,DIS=0
    580 GWT:TPC:IP=
    1583 MCO:BGN:STP
    1584 MCO:BGN:INIT OK,TSP=1
    1587 GWT:TPC:IP=
    2800 GWT:TPS:TOPIC=mygateway1-out/0/255/0/0/18,MSG SENT
    20587 TSF:MSG:READ,1-1-0,s=0,c=1,t=1,pt=7,l=5,sg=0:32.5
    20592 GWT:TPS:TOPIC=mygateway1-out/1/0/1/0/1,MSG SENT
    55353 TSF:MSG:READ,1-1-0,s=1,c=1,t=0,pt=7,l=5,sg=0:27.3
    55358 GWT:TPS:TOPIC=mygateway1-out/1/1/1/0/0,MSG SENT
    55364 TSF:MSG:READ,1-1-0,s=0,c=1,t=1,pt=7,l=5,sg=0:32.6
    55369 GWT:TPS:TOPIC=mygateway1-out/1/0/1/0/1,MSG SENT

    This looks okay I guess, now this happens when I activate my SenseBender Micro:

    139854 TSF:MSG:READ,3-3-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    139859 TSF:MSG:BC
    139860 TSF:MSG:FPAR REQ,ID=3
    139864 TSF:PNG:SEND,TO=0
    139866 TSF:CKU:OK
    139868 TSF:MSG:GWL OK
    140512 !TSF:MSG:SEND,0-0-3-3,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    141940 TSF:MSG:READ,3-3-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    141945 TSF:MSG:BC
    141947 TSF:MSG:FPAR REQ,ID=3
    141949 TSF:CKU:OK,FCTRL
    141952 TSF:MSG:GWL OK
    142632 !TSF:MSG:SEND,0-0-3-3,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    144021 TSF:MSG:READ,3-3-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    144026 TSF:MSG:BC
    144028 TSF:MSG:FPAR REQ,ID=3
    144030 TSF:CKU:OK,FCTRL
    144033 TSF:MSG:GWL OK
    144746 !TSF:MSG:SEND,0-0-3-3,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    146101 TSF:MSG:READ,3-3-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    146106 TSF:MSG:BC
    146108 TSF:MSG:FPAR REQ,ID=3
    146111 TSF:CKU:OK,FCTRL
    146113 TSF:MSG:GWL OK
    146857 !TSF:MSG:SEND,0-0-3-3,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0

    I filled this logs into the Log Parser and found out that the Gateway receives informations on the sensor node, but when it responses it does not get the ACK from the sensor node.

    May I have a faulty NRF24? I just received a new batch from AliExpress and this my first try with them.

    My gateway is an Arduino Uno Board with the Arduino Ethernet shield and on top of that equipped with the long range version of the NRF24 Board (the one with the antenna).
    The SenseBender is equipped with the "normal" smt version as suggested. The sensor nodes which are working right now were equipped with the smd version of the nrf-board.

    I also found out that the initialization of the sensor and the gateway has a different Core initialization, different capabilities (CP). I looked through the API, but didn't find what CP=RNNGA or CP=RNONA stands for.

    Any suggestions or ideas?

  • Mod

  • Admin


    what is the "official" firmware that you upload to the atmega? If it's the sensebender micro fw, then please observe that this is meant to run with a Si7021 sensor, and not DHT22, so unless you modify things, it won't run without that sensor onboard..

  • @tbowmo
    I have a 1:1 build of the sensebender micro, including the Si7021. Something I definetly will try tonight is to change the the radio modules with one of these I had before (and are working). I've just discovered this here:

    With "official" firmware I mean the Arduino Sketch which is included on the hardware webpage:

  • @mfalkvidd @tbowmo
    So folks, I finally got it to work. It really seems to be a problem with my radio modules. When I change my PA module on the gateway against one of these I ordered for the SenseBender Micro, everything works fine. But I still don't understand why my pro mini with the smd radio was able to send the data to the pa module, while the sensebender connected to a smd version still didn't work.
    Is there anything special on the PA Version, that I've missed? I wonder if I can live with that now, I thought the PA Version has a bit more sensitivity and gain and would be better as the central gateway unit.

  • Mod

    @flybysun the PA version draws much more power than the non-PA version (5x more if I remember correctly). If the power supply can't deliver clean power (without ripples or sudden dips), the radio will malfunction.

Suggested Topics