MySensor Gateway restarts continuously



  • Hello,
    I have recently built mysensor network using Synology NAS with Domoticz as controller and the sensors plus gateway are based on arduino nanos plus nrf24l01+ radio modules. Everything has been working fine until today, when I added RfLink gateway (original arduino mega) to Synology. RFLink works fine, but now the mysensor gateway is restarting every 30sec or so. I have tried different usb ports in Synology without any luck. I also tried the capacitor trick in mega (only had 220 and 2.2uF capacitors to test with), but it did not make any difference. Any ideas what to try next, maybe usb hub?

    Jyrki


  • Hero Member

    Hi!
    Sounds like a problem with the power supply. An active USB hub may help. You could also power the nano via Vin with up to 12V and test if that will solve the problem.

    Greetings!



  • Some more testing done... connected 5V power source (thanks to SonyEricsson for old mobile charger 😉 ) to 5V pin in arduino nano, but it did not make any difference. Then I realised that maybe the there is similar reset issue with Nano than already reported with Mega, so I connected a capacitor between reset pin and ground in Nano and the restarts stopped! Weird enough, then I removed the capacitor again to see if restarts reoccur, but now mysensor GW works also without capacitor. 😲

    Let's see if thing keep working now... I'm little skeptic when things just magically get fixed. 😉

    Few more "facts" about my system: Synology DS212, Domoticz version 2.4623, GW fake Nano 3.0 with CH340G serial chip


Log in to reply
 

Suggested Topics

  • 5
  • 12
  • 2
  • 22
  • 15
  • 5
  • 14
  • 4

160
Online

9.5k
Users

10.1k
Topics

105.0k
Posts