Find parent

  • Hardware Contributor

    I am currently using domoticz + Raspberry pi + serial Gateway via Arduino uno as a controller and a small sensor node from this thread. I have a working rgbw node, so this can't really be the problem but with my sensor node I only get "find parent" in the serial output and it doesn't show up at the controller.
    Both are using the 1.5 Version of mysensors.
    The sensor node uses the bootloader and fuse settings from the 2AA Battery Sensor Thread.

    Any ideas?

  • I had this problem the other day.

    I noticed when I put my thumb on the radio the communication reached the gateway.

    I ended up extending the radio antenna with a piece of wire. It's documented I believe in the latest video. MySenors Troublshooting. I'd link but on mobile/a plane.

    Not entirely sure why this wasn't working but this fixed it for me. I assumed as it was sending a signal the radio wires/power was okay, I suspect it wasn't recieveing okay.

  • Hardware Contributor


    Find parent means the node is trying to find its way to the gateway - and if this repeats it cant.
    Its either a range issue or a power issue. You can start by checking the gateway serial log and see if there is any info.
    Also, have you added a capacitor on the radios? This is very important since the radio is sensitive to power spikes.

    It this doesnt work start with changing the power source and check your wirings / ground connection on the node.
    Also you can try to move the node closer to the gateway - if this works and you have some distance between node and gateway you should consider a repeater.

  • Hardware Contributor

    Thanks for the advice but nothing seems to help 😞 It's running of of 2 AA batteries and there is a capacitor right beside the radio so power should be no problem. I even measured the values and tried an external usb power source.
    Whatever I do there is no reaction at all in the serial log of the gateway and the sensor only says "find parent". Only once though and without any other info. The distance is less than 10cm so that can't be a problem either.
    I also tried different radios: 2x find parent 1x cant init radio.

    The strange thing is that it worked some months ago (see my linked thread above) and the only thing that I changed (at least I think so) is the bootloader. The one I am now using is the one from the Slim 2AA node and that has been tested too. Do I have to change any other settings when changing the bootloader (done via arduino IDE so the fuses are changed too)?

    I will try to build another node to test tomorrow but if you guys have and other ideas how to fix this... feel free to tell me 😉

  • Mod

    I actually had a problem with only one "find parent" earlier today. Normally, when the node is unable to reach the gateway, it keeps repeating "find parent". In this case the node died after writing "find parent" once. I switched the radio and the problem went away. I haven't spent any time troubleshooting that radio so I don't know what is wrong with it but the new one works.

    Also, I've seen some forum users having trouble with too short distance. You could try moving the node 1-2m away from the gateway.

  • Hardware Contributor

    It seems like I have found the problem. As I said I am using the 1MHz bootloader/settings from the other thread. That seems to require slower baudrates. I already used 9600 for uploading but it seems like you also have to use it internally for the mysensors library. I changed the baudrate setting in the MyConfig.h to

    #define BAUD_RATE 9600

    and now its working. Can you somehow overwrite that in the sketch direclty (so that I don't have to change the library I am using for other sketches too)? Perhaps just include that define statement there?

  • Mod

    Unfortunately not. MyConfig.h will always override whatever you set in the sketch.

    But if you change

    #define BAUD_RATE 115200


    #ifndef BAUD_RATE
    #define BAUD_RATE 115200

    in MyConfig.h you should be able to define it in your sketch before #include <MySensor.h>

    This change has already been done in the MySensors dev version so in the future you'll be able to override in your sketch without modifying the library.

  • Admin

    @mfalkvidd said:

    in MyConfig.h you should be able to define it in your sketch before #include <MySensor.h>

    Overriding defines from sketch only work in the development branch.
    It requires a source code inclusion "hack" that's not in place for 1.5.x.

Log in to reply

Suggested Topics