Node are not receiving messages from domoticz

  • Hi,
    I'm a beginner with MySensors and Domoticz. I did configure some nodes last days and I'm able to monitor temperature, humidity, pressure, air quality, distance... and until now I was happy with it !
    But, I'm actually trying to control an RGB strip LED and I discovered that although my nodes were sending their data, they cannot receive messages from Domoticz. So I did some simple tests with relayActuator node, and no way to control it...

    My config

    • Arduino IDE 1.6.9 on Linux Mint
    • Arduino mini pro 3.3V 8MHz
    • CH340G USB to TTL
    • 1.5A power supply
    • NRF24L01+ Radios close to each-other with 47uF capacitors (maybe RFM73?)
    • Try with both stable (1.5.4) and development branch (2.0 beta from github) of MySensors libraries
    • Try with Domoticz 3.4834, 3.5143 and master from github

    What happens
    Almost nothing... that's the problem. Message is not received by node, however the gateway serial led blink a bit when I turn off and on the relay switch on Domoticz interface. But nothing appears when monitoring serial communication with arduino IDE.
    Logs of domoticz :

    User: Admin initiated a switch command
    (mysensor) Lighting 2 (Light)

    Is there a way to debug it better ? Like some commands to put on gateway sketch to know if it receives something...
    Could it be related to ack (I didn't really understand what it is...) and some supposed RFM73 radios ?
    Could someone give me its working combination of version of MySensor and Domoticz ?
    Any other suggestions ?

    Thanks for your help.

  • Mod

    The serial debug output from the gateway and the node is usually helpful when troubleshooting.

  • Thanks for your answer.
    In my case, there is nothing on serial monitoring for both node (relayActuator) and gateway when switching the relay from domoticz.
    However the gateway RX led is blinking, so I guess it is receiving something from Domoticz. That's why I was wandering if there is some code to add to the gateway for it to be more talkative.

    I just tried to give you some logs from the initialisation sequence (from arduino IDE) and I found that some times lines are not complete. Is that some common artefacts of arduino IDE or should I be worried about it ? Maybe have I a problem of serial transmission reliability ?

    NGA-, 2.0.0-beta)
    0;255;3;0;9;Radio init successful.
    0;255;3;0;14;Gateway startup complete.
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    0;255;3;0;9;read: 0-0-0 s=255,c=3,t=15,pt=0,l=2,sg=0:
    0;255;3;0;9;read: 0-0-0 s=255,c=0,t=18,pt=0,l=10,sg=0:2.0.0-beta
    0;255;3;0;9;read: 0-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    0;255;3;0;9;read: 0-0-0 s=255,c=3,t=11,pt=0,l=5,sg=0:Relay
    0;255;3;0;9;read: 0-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    0;255;3;0;9;read: 0-0-0 s=1,c=0,t=3,pt=0,l=0,sg=0:
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0

  • Mod

    You might meed to edit MyConfig.h to enable debug output. Details are available at

  • You're right, that the deal while moving between different libraries versions, I forgot to put back the debug mode on development version...
    Anyway, I had a drop in my voltage regulator last night, I guess that explains that my serial reads were not complete...
    So now I'm back with with MySensor 1.5.4, debug active, and Domoticz 3.5143, but with no more luck.

    Here is an entire sequence :

    • I run Domoticz, go to hardware and configure a Mysensors Gateway USB, Domoticz report :
    MySensors: Using serial port: /dev/ttyUSB3
    • I reset the gateway, Domoticz report :
    MySensors: Gateway Ready...

    And here is serial output of the gateway :

    0;0;3;0;9;gateway started, id=0, parent=0, distance=0
    0;0;3;0;14;Gateway startup complete.
    • I reset the relay node.

    Domoticz :

    MySensors: Node: 1, Sketch Name: Relay
    MySensors: Node: 1, Sketch Version: 1.0
    (Mysensors) Lighting 2 (Light)

    Gateway :

    0;0;3;0;9;read: 1-1-0 s=255,c=0,t=18,pt=0,l=5,sg=0:1.5.4
    0;0;3;0;9;read: 1-1-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    0;0;3;0;9;read: 1-1-0 s=255,c=3,t=11,pt=0,l=5,sg=0:Relay
    0;0;3;0;9;read: 1-1-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    0;0;3;0;9;read: 1-1-0 s=1,c=0,t=3,pt=0,l=0,sg=0:

    Relay node :

    send: 1-1-0-0 s=255,c=3,t=15,pt=2,l=2,sg=0,st=ok:0
    send: 1-1-0-0 s=255,c=0,t=18,pt=0,l=5,sg=0,st=ok:1.5.4
    send: 1-1-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,st=ok:0
    repeater started, id=1, parent=0, distance=0
    send: 1-1-0-0 s=255,c=3,t=11,pt=0,l=5,sg=0,st=ok:Relay
    send: 1-1-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0,st=ok:1.0
    send: 1-1-0-0 s=1,c=0,t=3,pt=0,l=0,sg=0,st=ok:
    • Then, the switch appears in domoticz devices so I add it to the panel and try to switch on/off

    Domoticz :

    Admin initiated a switch command
    (Mysensors) Lighting 2 (Light)

    Gateway and Node : nothing but the gateway serial led is shortly blinking...

    What wrong did I do ?

  • Hero Member

    @davy39 What should happen is that your Relay node "reads" something. Are you using the 'example' sketch?

  • @AWI Yes, I'm using examples "Serial Gateway" and "relayActuator". I've just changed gw.begin(incomingMessage, AUTO, true); to gw.begin(incomingMessage, 1, true); otherwise my node was not detected.

    So, to answer to your first question, I guess I should read "Incoming change for sensor: ... , New status: ...." and state of pin 3 should change...

  • Hero Member

    @davy39 That should pretty much bet true.. If you have "ack" set in Domoticz (default) then Domoticz will complain if the node did not receive the message.

  • @AWI I did get error messages (Error sending switch command, check device/hardware !) in the past and did played with the ack option in domoticz hardware menu.
    In fact, I've just checked and ack was enabled without getting error messages... So I've disabled and re-enabled it, and I got error message back... How to know what happens in the gateway while receiving messages from Domoticz ?

  • Hero Member

    @davy39 The best way to move forward is detach the gateway from Domoticz and try to send the message manualy to the node. You can use MYSController to do this and see what is going on. I doubt if Domoticz is the cause..

  • Great idea. I'll dig in that way.
    Is there same kind of tool for linux ?
    If not, maybe could I send some serial messages through arduino IDE's serial monitor ?
    That probably means I'll need to learn a bit more about mysensor API...

  • With my node-id=1, my child-sensor-id would be 1 as well, I should send 1;1;1;0;2;1(without ack) or 1;1;1;1;2;1(with ack). Am I right ?
    I've tried to send it through arduino IDE with a new line at the end, but the gateway is still not responding...
    Am I missing something ?

  • Finally I got it !
    In the stable version, baud-rate is at 115200, I changed it to 38400 in MyConfig.h and now it is working !
    A question still need to be solved : why it is not working with the development libraries since 38400 is default baud-rate ?

  • Hero Member

    @davy39 I'm not sure. All my nodes and gateways are running on 115200..

  • 8 MHz Arduinos absolutely need to use lower baud rate than 115200. The baud rate is generated from the internal clock, and at 8 MHz 38400 bps is the highest baud rate close enough to the standard.

  • Good to know, indeed my setup is working now with stable libraries thanks to this helpful community.
    I'll go back later to development libraries to see if I'm able to work with it as well.

Suggested Topics