Issues Converting to Ethernet Gateway (Uno)

  • I have had my serial gateway set up for a few months now and I wanted to convert over to Ethernet because of issues with USB locations switching (I am running Altsteon on my Vera).

    Because I was changing gateways (my serial was a nano), I removed all MySensors devices from Vera. I set up and verified that the Ethernet gateway is working (I can ping it and the library version shows up in the interface). I took my sensors and cleared their EEPROM and reloaded the programs via IDE. I have two temperature/motion and a humidity sensor.

    When I include the devices it is hit or miss if the Ethernet gateway sees it (they are in the same room). Sometimes Vera will add a new device to the interface (sometimes just a node, sometimes just a temperature device) other times nothing. When I look at the serial output on the gateway, it sees the humidity sensor and is receiving data from it, but the Vera interface does not add new devices.

    One time when I was including the humidity sensor, it added all of the devices to the interface, however, none of them updated.

    I wasn't having issue with the serial interface, but now I cannot get them to work. Every time I start over I remove all devices from Vera, clear EEPROM on the sensors and start again.

    My sensors are Mini Pro 3.3v (Clones) and my Gateway is a Uno with the W5100 ethernet shield.

    I will try to add some outputs from my gateway when I get home.

    Thanks for the help!

  • Admin

    There is really no reason to remove anything from vera (or clear/rebuild sensors) unless you also upgraded to a newer MySensors library version.

    Hard-restart Vera after removing devices.

    You could also check sensor-communication by watching debug output while connected to your computer to rule out this kind of problems.

  • @hek Thanks for taking a look. I will leave the sensors on the Vera interface from now on. When you say hard reset, do you mean pull power or factory reset. Sorry, when I hear hard reset, I start to feel queasy.

    EDIT: Now I reread and I see hard restart, so I am assuming that is pull the plug.

  • Admin

    @RyanAHolland said:

    pull the plug.


  • So I hard powered off the Vera and re-added my humidity sensor. It was detected by Vera, but only added two devices (temp and humidity) no node. I am getting values, but without the node, I don't know when it last updated.


    Also, when I tried to add another device (temp / motion), Vera doesn't find any devices. I am going to double check my wiring, but this device worked on my serial gateway (I have cleared the EEPROM),

  • I'm struggling to get my Ethernet Gateway working - trying with a Nano, but having problems - and thought that we couldn't use a Uno with the Ethernet Shield. Uno works with Vera? Thanks.

  • @karenbobiv I believe that the restriction on using an Uno is only for the serial gateway. You can use any arduino for the ethernet gateway.

  • Hero Member

  • Hero Member

    I'm using an Uno with Ethernet shield with no problems (after overcoming some initial startup problems).

Log in to reply

Suggested Topics