Can't connect to radio on raspPi with latest stable 2.1.1 build, but works with 2.2.beta but with beta mqtt gateway very unstable...

  • Hi, just wondering if I simple do something wrong.

    I try to setup a mysensors gateway on raspPi. What I did:

    git clone --branch master

    ./configure --my-gateway=mqtt --my-controller-ip-address= --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-rf24-ce-pin=22 --my-rf24-cs-pin=24 --my-rf24-irq-pin=15

    Build seems ok, but when I tried to start the gw, it seems radio can not be initialized. I got

    i@pi:~/msg_stable/MySensors $ sudo bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG--Q,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT

    When I use same kind of install with the development branch 2.2.beta it all starts up, however the gateway seems very unstable (not surprisingly, as its dev build), it cashes a lot.

    So - how to get the stable 2.1.1 connecting to the radio (NRF24L01+ )? I guess the gateway on 2.1.1 is stable...


  • @alterfritz any update? Release 2.1.1 does not work for. Current dev branch 2.2 works.

    Any hint?

  • I am experiencing the same behavior. 2.1.1. radio is not detected. 2.2.0 beta detected ok.

  • I also have problems with NRF24L01+ on both 2.1.1 and 2.2.0 Beta

    I have installed a fresh RPI with all new libraries and trying to make a RPI Serial GW

    In 2.1.1 it doesn't start at all but in 2.2.0 it starts but in the log I constantly receive the following in the Domoticz log where I have added the GW

    2017-10-09 19:25:12.306 MySensors: Gateway Version: 2.2.0-beta
    2017-10-09 19:25:12.306 Error: Serial Port closed!... Error: End of file
    2017-10-09 19:25:13.306 MySensors: retrying in 30 seconds...

    After a while I get the following in the console

    mysgw: TSF:MSG:READ,0-0-0,s=0,c=3,t=2,pt=0,l=11,sg=0:Get Version
    mysgw: !TSF:MSG:LEN,0!=18 

    The above points at something wrong with the radio connection

    I have tried 3 different radios but still no luck

    So I guess it all boils down to that there is some problems with these libraries and the NRF24L01

    Any guesses?

  • Same by me - combination of Rapberry 3 + mosquitto + OpenHab2. 2.1.1. doesn't start at all (TSM:INIT:TSP FAIL), 2.2.0 beta starts without troubles but after a few minutes the communication is lost (!TSF:MSG:LEN,0!=32). Have capacitors on the node and gateway.

  • I have submitted a bug report on this

Log in to reply

Suggested Topics

  • 3
  • 1
  • 24
  • 15
  • 3
  • 2