Where to find working MySensors Binding for OpenHAB 2 beta 5?



  • I started from scratch one's again. Now I am running OpenHAB2 beta5. It can control Philips HUE lamps without problems, but not the MySensors nodes. I am using the MySensors Ethernet Gateway and listed from Karaf console:184 | Active | 80 | 2.0.0.201612221259 | MySensors Binding.
    I get following listing:

    17:20:44.890 [ERROR] [rs.internal.protocol.MySensorsReader] - (java.lang.InterruptedException: sleep interrupted) on reading from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorIpReader
    17:20:44.913 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:5c0d1e86' changed from ONLINE to OFFLINE
    17:20:44.912 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Connecting to IP bridge [192.168.1.201:5003]
    17:20:45.096 [WARN ] [al.protocol.ip.MySensorsIpConnection] - Skipping I_VERSION connection test, not recommended...
    17:20:45.119 [INFO ] [al.protocol.ip.MySensorsIpConnection] - Successfully connected to MySensors Bridge.
    17:20:45.121 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:5c0d1e86' changed from OFFLINE to ONLINE
    17:20:55.125 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped
    17:21:05.128 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped

    So there are still something wrong in the MySensors binding, because i cannot read actual values from sensor node.


  • Hero Member

    @pentti12 said:

    on reading from serial port, message

    What's the output, if you don't skip the startup check? I've a NRF24L01 and RFM69 gateway working fine with skipStartupCheck=false.

    The ERROR you see at the beginning may happen due to restarts of the threads. Not nice, but should not hurt.

    DON'T upgrade your binding to the latest commits!!! The current binding is not compatible to beta5 because of this change in OH2: https://github.com/openhab/openhab-core/pull/104



  • When I enable the startup connection check of the MySensors Ethernet Gateway, I get the following listing:
    16:36:08.633 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Connecting to IP bridge [192.168.1.201:5003]
    16:36:08.838 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    16:36:09.657 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    16:36:10.657 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    16:36:11.658 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    16:36:12.658 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    16:36:13.658 [ERROR] [al.protocol.ip.MySensorsIpConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received. Try set skipStartupCheck to true
    16:36:13.664 [ERROR] [al.protocol.ip.MySensorsIpConnection] - Failed connecting to bridge...next retry in 10 seconds (Retry No.:8)
    16:36:13.666 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Disconnecting from IP bridge ...
    16:36:13.668 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Stopping Writer thread
    16:36:13.672 [ERROR] [rs.internal.protocol.MySensorsWriter] - (java.lang.InterruptedException) on writing from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorsIpWriter
    16:36:13.694 [DEBUG] [rs.internal.protocol.MySensorsReader] - Stopping Reader thread
    16:36:13.700 [ERROR] [rs.internal.protocol.MySensorsReader] - (java.lang.InterruptedException: sleep interrupted) on reading from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorIpReader

    But my question still is, when I will get the working MySensors binding for OH2 beta 5?



  • Hello,
    I've installed OpenHAB 2 beta 5 on raspberry pi 3. I'm using MySensors ESP8266 Gateway. The gateway are online the Sensor (dht22) are connect to the gateway but I can not read the actual values from the sensor node too.
    Is there a little chance to get a working MySensors binding for OH2 beta 5 in the next weeks?
    Thanks


  • Hero Member

    @fishermans There was an important change in the OpenHAB2 core only a few days after the release of the beta 5, which prevents backwards compatibilty of the binding. My development sticks to the snapshot releases at the moment and therefore the current versions of the binding will not work with beta5 (not tested myself, but pretty sure).

    If you really want to give it at try with beta 5, try this version of the binding:

    https://github.com/tobof/openhab2-addons/tree/9cc95d38cf9d137f3e8e02218fc5847671b9796d/addons/binding/org.openhab.binding.mysensors/target

    I'm using a snapshot release of OpenHAB2 for my production environment and I'm happy with it. It is pretty stable but of course there are a few glitches. ;-) At the moment I have to restart OpenHAB2 after changing the *.things file. I can live with that for a while ...



  • @TimO So I have try this version of binding but I get no values. The telnet connect works well, I see the data from the sensor.
    In the Karaf console log ther are no warnings or errors. The ethernet gateway are online. But I can not see any values in the
    openHAB UI.
    Should I try to install manually the openHAB 2 beta 4 version?


  • Hero Member

    @fishermans Yesterday there was an Announcement of the 2.0.0 Release Candidate, better try this one:

    https://community.openhab.org/t/openhab-2-0-0-release-candidate/20462

    I have not tested it myself, so I'm interested in the results. :)



  • @TimO So, with apt-get install I could install two versions of openHAB 2:

    1. deb http://dl.bintray.com/openhab/apt-repo2 testing main (this is the beta 5)
    2. deb http://dl.bintray.com/openhab/apt-repo2 unstable main
      I don't know how I could install the OH2RC1 Release with apt-get.
      Both versions work with the binding -> 'mysensors:bridge-eth:gateway' changed from OFFLINE to ONLINE message. Then the message "Successfully connect to MySensors Bridge." are shown.
      The things:
      Bridge mysensors:bridge-eth:gateway [ ipAddress="192.168.178.81", tcpPort=5003, sendDelay=200, skipStartupCheck=true ] {
      /** define things connected to that bridge here */
      humidity hum01 [ nodeId="1", childId="0" ]
      temperature temp01 [ nodeId="1", childId="1" ]
      humidity bat01 [ nodeId="1", childId="255" ]
      }
      I install the humidy things with the UI:

    message: add new thing mysensor:humidity:gateway:Humidity_2_0' to INBOX
    message: Thing mysensor:humidity:gateway:Humidity_2_0' has been added
    message: mysensor:humidity:gateway:Humidity_2_0' changed from INITIALIZING to ONLINE

    but no values are shown.

    How could I install the OH2RC1 Release with apt-get ?



  • Now I habe good news, with the OH2RC1 works it fine.
    First I clean my openhab2 installation

    1. sudo apt-get purge openhab2-offline
    2. echo 'deb http://dl.bintray.com/openhab/apt-repo2 testing main' | sudo tee /etc/apt/sources.list.d/openhab2.list
    3. sudo apt-get install openhab2
    4. sudo systemctl daemon-reload
    5. sudo systemctl enable openhab2.service
    6. sudo systemctl start openhab2.service

    Then under addon I have installed the serial-binding

    My standard.things:

    Bridge mysensors:bridge-eth:gateway [ ipAddress="192.168.178.81", tcpPort=5003, sendDelay=200, skipStartupCheck=true ] {
    /** define things connected to that bridge here */
    humidity humi01 [ nodeId="2", childId="0" ]
    temperature temp01 [ nodeId="2", childId="1" ]
    humidity batt01 [ nodeId="2", childId="255" ]
    }

    the standard.items:

    Number temp01 "Temp. Bath [%.1f °C]" <temperature> { channel="mysensors:temperature:gateway:temp01:temp" }

    Number humi01 "Hum. Bath [%.1f %%]" <humidity> { channel="mysensors:humidity:gateway:humi01:hum

    I was a little bit confuse about the nodeid, first I set it to the value 1, but I should use nodeid 2 then it works fine for me.

    Thank you very much @TimO !!!


  • Hero Member

    @fishermans I'm glad to hear that! I'll upgrade to RC1 soon, thanks for reporting back!


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.