Car Presence Modul / Passiv node but delay at bootup



  • Hello,
    I build up a "car presence modul" with a rfnano to switch on/off light at the garage.
    I have also a repeater node in the garage, which is connected to the gateway and also a relais for the light.

    When i unlock the car, there is power on the usb port for ~5 seconds before it wil lbe powered off again until i openm the door.

    The presence modul is build as a passive node without registration need to the gw. It will only send a "probe" to the repeater node in the garage, which will switch on the light and swith off after a delay of 60 seconds after the last received probe.

    But sometimes the 5 seconds are to short to send out the first ping and light will not be switched on.
    There is a delay starting at ms 75 and ends with the first needed send at ms 4249. Is it possible to disable this?

    0 MCO:BGN:INIT NODE,CP=RNNPA---,VER=2.2.0
    7 MCO:BGN:BFR
    9 TSM:INIT
    11 TSF:WUR:MS=5
    19 TSM:INIT:TSP OK
    22 TSM:INIT:TSP PSM
    26 TSM:INIT:STATID=226
    30 TSF:SID:OK,ID=226
    33 TSM:FPAR
    35 TSM:FPAR:STATP=102
    39 MCO:BGN:STP
    43 MCO:BGN:INIT OK,TSP=0
    47 TSM:ID
    49 TSM:ID:OK
    51 TSM:UPL:DISABLED
    55 TSM:READY:ID=226,PAR=102,DIS=1
    97 ?TSF:MSG:SEND,226-226-102-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    2147 ?TSF:MSG:SEND,226-226-102-0,s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=OK:2.2.0
    2196 ?TSF:MSG:SEND,226-226-102-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:102
    4209 MCO:REG:NOT NEEDED
    Probe:
    4249 ?TSF:MSG:SEND,226-226-102-102,s=4,c=1,t=2,pt=1,l=1,sg=0,ft=0,st=OK:1
    Reset:
    Probe:
    6296 ?TSF:MSG:SEND,226-226-102-102,s=4,c=1,t=2,pt=1,l=1,sg=0,ft=0,st=OK:1
    

    The Script header is, i have no presentation function.

    #define MY_SPLASH_SCREEN_DISABLED
    #define MY_DEBUG
    #define MY_BAUD_RATE 57600
    #define MY_RF24_CHANNEL 124
    #define MY_RF24_DATARATE RF24_250KBPS
    #define MY_PARENT_NODE_IS_STATIC
    #define MY_PARENT_NODE_ID 102
    #define MY_NODE_ID 226
    //#define MY_REGISTRATION_FEATURE
    #define MY_TRANSPORT_UPLINK_CHECK_DISABLED
    #define MY_RF24_CE_PIN 10
    #define MY_RF24_CS_PIN 9
    #define MY_PASSIVE_NODE
    #define MY_RADIO_RF24
    #define MY_TRANSPORT_WAIT_READY_MS  5  
    

    Any idea or hint?


Log in to reply
 

Suggested Topics

  • 4
  • 6
  • 1847
  • 59
  • 2
  • 81
  • 3
  • 1

178
Online

9.8k
Users

10.3k
Topics

106.7k
Posts