openHAB 2.0 binding



  • Hi everyone. Just to let you know OpenHAB 2.0.0 first BETA release is available. Unfortunatelly Tim0's binding is throwing some errors while OpenHAB tryes to install it.

    2016-01-13 13:46:25.314 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/home/pi/OpenHAB2/Downloads/OpenHAB-Beta/addons/org.openhab.binding.mysensors-2.0.0-SNAPSHOT.jar
    org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.mysensors [166]
      Unresolved requirement: Import-Package: gnu.io
    
            at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
            at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:393)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
            at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1245)[8:org.apache.felix.fileinstall:3.5.0]
            at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1217)[8:org.apache.felix.fileinstall:3.5.0]
            at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:509)[8:org.apache.felix.fileinstall:3.5.0]
            at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:358)[8:org.apache.felix.fileinstall:3.5.0]
            at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:310)[8:org.apache.felix.fileinstall:3.5.0]
    

    Let me know Tim0 if I can help you fix this.
    Thanks, regards.
    Gonzalo.



  • kewl, thank 4 digging this up. I'm just evaluating openHab2 😄



  • Hi Timo,

    Regarding the errors in OH2beta, see this post for a possible solution.

    Some other questions:
    Is it possible to access sensors with different "V_types" for example V_VAR1 to a temperature sensor? I would like to send out numbers to my sensor nodes from rules.

    I was not able to get the battery level to work.
    my item looks like this:

    Number SHBat "Storehouse Node Battery Level [%f %%]"       (nSH,gBAT) { channel="mysensors:temperature:gateway:SHtemp_in:battery" }
    

    What is wrong?

    Thank you for a great work!

    /Tomas


  • Hero Member

    Hi Tomas!

    Thanks for the hint, I will take a closer look!

    @ofverstedt said:

    I would like to send out numbers to my sensor nodes from rules.

    This is currently not possible, but it will be. It is on my ToDo list. 🙂
    The current solution with the serial binding in OH 1.X is complicated, but leaves a lot of freedom for the user and I would like to preserve as much freedom as possible.

    I've implemented some new features a while ago, like resending of messages if no ACK is received. But the Repo is out of date. I will fix that.



  • Hi Tim0.
    Really nice work with this binding. Huge step forward into a official MySensors OpenHAB binding.

    It would be nice to have the repo updated so as to try the new features you have implemented.

    Have you had time to check why we are gewtting that error at OpenHAB 2 Beta while trying to install the binding?

    Let me know if there is any way in which I can help.
    Thanks, regards!

    Gonzalo.


  • Hero Member

    Hi @gonzalonal !

    I'm working on it. Due to the changes in the OH git repository my environment is all messed up. 😞



  • This kind of problem (as I've read online) in this release of OH seems to be not only related to this binding. One suggestion that I found is here: https://github.com/openhab/openhab-distro/issues/82 (last comment) or here: https://github.com/openhab/openhab-distro/issues/81

    I've tested it without success but I don't know if I've done it right. I've also try to build myself a rfxcom binding (this one use gnu.io) and it has the same issue

    hope this help

    EDIT: this work for me, run on OSGI console: feature:install openhab-transport-serial and restart OH



  • @andreacioni said:

    This kind of problem (as I've read online) in this release of OH seems to be not only related to this binding. One suggestion that I found is here: https://github.com/openhab/openhab-distro/issues/82 (last comment) or here: https://github.com/openhab/openhab-distro/issues/81

    I've tested it without success but I don't know if I've done it right. I've also try to build myself a rfxcom binding (this one use gnu.io) and it has the same issue

    hope this help

    EDIT: this work for me, run on OSGI console: feature:install openhab-transport-serial and restart OH

    Hi @andreacioni.

    You saved the day. It worked for me.
    Here the steps I did to make it work.

    1- Download latest snapshot from https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ (Download offline version)
    2- Unzip the file.
    3- Run start_debug.sh
    4- In console write "feature:install openhab-runtime-compat1x"
    5- Ctrl-D to exit/shutdown OpenHAB
    6- Once exited, copy MySensors binding to addons folder.
    7- Start againg OpenHAB-
    8- Thats it. It should work

    Remember to copy your serial thing to things folder.
    Regards!
    Gonzalo


  • Hero Member

    @andreacioni: Absolultly amazing! Thanks!

    I don't understand why this helps though because the changes in the code I have to do have nothing to do with OH1 (compability).

    I hope to provide an adjusted version today or tomorrow along with a clean and working repository.

    Thanks for your patience! 🙂



  • @TimO I'think the OH1 compatibility is not the problem. It seems that OH2 beta1 have not installed transport feature and so it has no definition for the gno.io pakage, so I'think there's nothing to do on your code 😄

    PS tell me when the new repo is OK that I download it and try to add the baudrate config 😉 Thanks!!


  • Hero Member

    So, I would like to show you my current status. I've tested it against my mini MySensors environment and it looks good so far. Feel free to test.

    1. Download latest snapshot from cloudbees: https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-offline/target/openhab-offline-2.0.0-SNAPSHOT.zip

    2. Unzip file (into a directory like oh2).

    3. Download the current binding from Binding and place it in the addons directory under oh2.

    4. Configure addons, things, items and sitemap. Example?! addons.cfg, demo.things , demo.items, demo.sitemap

    5. Start "start_debug.sh", "start_debug.bat" ...

    6. In the karaf console enter: "feature:install openhab-transport-serial".

    7. MySensors Plugin "should" start. 😉

    8: "log:set debug" + "log:tail" to see debug output.

    Github and documentation will follow, please refer to the "old" Readme and the examples.



  • @TimO Hi Tim, for debugging outupt of the binding I need to write: log:set DEBUG org.openhab.binding.mysensors, without this I cannot see anything about binding logs



  • @andreacioni Hi andreacioni. Same issue with debug mode with me. Thanks for the tip!

    @TimO: V_STOP for Rollershutter sensors, is a MySensors binding limitation, or it is not implemented in OH2 yet?

    Another thing I've noticed is that every item added, despite being a regular switch or a rollershutter, is is being added as:

    Battery Level
    mysensors:cover:gateway:Cover_1_0:battery
    MySensors Battery Channel

    Is this the intended behavior for every node of my sensor, despite having or not a battery?

    Regards.
    Gonzalo.


  • Hero Member

    @gonzalonal said:

    V_STOP for Rollershutter sensors, is a MySensors binding limitation, or it is not implemented in OH2 yet?

    It is a limitation of OH2 and I don't understand the limitation. It is very confusing, because with the "RollerShutter" widget in OH2 I get three buttons: UP, DOWN and STOP. UP and down calls the handler in which I generate the MySensors message. STOP don't call the handler and therefore I can't do anything. I need to dig deeper.

    Battery Level
    mysensors:cover:gateway:Cover_1_0:battery
    MySensors Battery Channel

    Is this the intended behavior for every node of my sensor, despite having or not a battery?

    This is intended behavior. The battery status is send via an internal message and there is no presentation if a sensor has a battery or not.
    I've therefore added the battery channel to every item. In Paper UI you are able to simply disable the channel by clicking the blue circle next to the battery channel or in the configuration file you have to specify the channel, if you want to use it. If the battery channel is not defined for a thing it won't receive the battery status.

    For the future: maybe there is a way to hide the channel as long as there was no battery status received and display it only when used. But currently I don't see an easy way to implement that.

    Greetings!
    Tim



  • @TimO
    Great TimO. Thanks for clarifying this topic.
    Regards.
    Gonzalo


  • Hero Member

    @gonzalonal : I found a solution for V_STOP! It will be available soon.

    But more important: @andreacioni is doing some great work improving the stability and performance of the binding!!

    I just wanted to let you know, that the binding is currently under heavy development. 👍



  • @TimO
    Great news TimO. Really nice to hear that.
    Regarding STOP functionality for the binding, I have read somewhere that the supported commands by OpenHAB, for RollerShutter items, are Up, Down and StopMove. Have yoy tried something like this?

    Regards
    Gonzalo.


  • Hero Member

    @gonzalonal said:

    Regarding STOP functionality for the binding, I have read somewhere that the supported commands by OpenHAB, for RollerShutter items, are Up, Down and StopMove. Have yoy tried something like this?

    Yeah, my problem till yesterday was, that I was not able to cast the given state to StopMoveType in case of Stop, while casting the state to UpDownType for Up and Down was no problem. 🙂

    I changed the way how the binding handles this type of message and it works now.



  • @TimO
    Can we clone the latest source code from this binding? I think that your github repository is outdated and I want to work this weekend with it, 'cause I would like to integrate the mysensors 2.0-beta "smartSleep" feature with your binding in my home sensors setup (ESP8266 Ethernet GW).

    Also, if there are any ISSUE y your TODO list in which I can help you, please tell me.

    Regards





  • @andreacioni said:

    @Sebastián-Zaffarano

    Hi Sebastián, what repository have you checked? Currently the development is not on the old https://github.com/wishmoooop/openhab2/tree/master/addons/binding/org.openhab.binding.mysensors but was moved here: https://github.com/tobof/openhab2-addons/tree/MySensors/addons/binding/org.openhab.binding.mysensors

    Hope this help 🙂

    Thanks @andreacioni
    I was working on the old repo! 🙂


  • Hero Member

    I've updated the first posting in this thread. You'll find the current repo there (also). 😉

    I've added a Wiki to the repo and made a brief description of the installation and configuration process.

    https://github.com/tobof/openhab2-addons/wiki

    The current binding (jar) is also in the repo now. You'll find the link in the wiki under "Installation".

    Modifications in the current version:

    • RollerShutter now supports STOP
    • Performance of the binding improved. Big thanks to @andreacioni !!
    • Stability improved. Also big thanks to @andreacioni
    • Error handling on connection loss improved
    • The baud rate of the serial gateway is now adjustable. (@andreacioni again!)
    • some code cleanup: removed not needed debug output etc.

    Please let me know if you found the time to test the binding and what the results are. 🙂



  • @TimO said:

    I've updated the first posting in this thread. You'll find the current repo there (also). 😉

    I've added a Wiki to the repo and made a brief description of the installation and configuration process.

    https://github.com/tobof/openhab2-addons/wiki

    The current binding (jar) is also in the repo now. You'll find the link in the wiki under "Installation".

    Modifications in the current version:

    • RollerShutter now supports STOP
    • Performance of the binding improved. Big thanks to @andreacioni !!
    • Stability improved. Also big thanks to @andreacioni
    • Error handling on connection loss improved
    • The baud rate of the serial gateway is now adjustable. (@andreacioni again!)
    • some code cleanup: removed not needed debug output etc.

    Please let me know if you found the time to test the binding and what the results are. 🙂

    Thank you @TimO !
    This weekend I started migrating from my OH1.8 + mqtt GW setup to OH 2 beta + your binding. At the moment all is working fine, I spent some time learning about OH2 / Eclipse smartHome and watching your code, because I want to implement the smartSleep feature (https://github.com/mysensors/Arduino/pull/271) in the mysensors binding.

    My idea is: when the handler don't receive an ACK from a message, it store the message for a while, waiting a heartbeat from a node, and, if the binding has some message stored for this node, then send it again. I don't know if this is correct, or if you thinks there is a better solution.

    Regards


  • Hero Member

    @Sebastián-Zaffarano said:

    This weekend I started migrating from my OH1.8 + mqtt GW setup to OH 2 beta + your binding. At the moment all is working fine, I spent some time learning about OH2 / Eclipse smartHome and watching your code, because I want to implement the smartSleep feature (https://github.com/mysensors/Arduino/pull/271) in the mysensors binding.

    My idea is: when the handler don't receive an ACK from a message, it store the message for a while, waiting a heartbeat from a node, and, if the binding has some message stored for this node, then send it again. I don't know if this is correct, or if you thinks there is a better solution.

    That sounds like a good plan. The binding already uses a queue where messages that should be send are buffered and you are able to specify how long a message is hold in the queue (when it is time to send again).

    I've already implemented a mechanism to request for an ACK message. This mechanism sends a message to the node, but holds this message in the queue and increments the number of retries (currently 4 retries, with different/longer delays). If the node responds with an ACK or the number of retries exceeds 4 the message is removed from queue. So you could indicate, with a configuration setting, that the node is an smartSleep node and thus only send the message once and if no ACK is received store the message for 10 minutes (for example) in the queue.

    Here is the implementation: https://github.com/tobof/openhab2-addons/blob/MySensors/addons/binding/org.openhab.binding.mysensors/src/main/java/org/openhab/binding/mysensors/protocol/MySensorsWriter.java

    BUT: The reader and the writer are working in different threads (asynchronus), so we have to sync the threads (the queue), if we receive an ACK and remove a message from the queue. I'm still struggling with that and that is the reason why the request for ACK should not be used at the moment and this will be a problem for smartSleep too.

    According to the ACK feature: if the binding don't receive an ACK after 4 timeouts it will revert the status of the thing to the last value. So if you for example try to switch on your light and the message is not acknowledged, the binding will revert the switch state to off. I've removed the code for this, because of the issue above, but will add it again in the future.



  • Hello everyone

    I'm testing MySensor Ethernet gateway with a relay code on it. My understanding that Gateway stores the current state of the relay (or GPIO port) in it's EPROM. Can the binding periodically check the state of the port or should I rely on OH persistence functionality? Please advise what is the right way to keep the states synced between the Gateway and OH.

    Thanks
    Andrew


  • Hero Member

    Hi Andrew!

    Good question. Polling is currently not supported by the binding itself, but what you could do is: send a message from the node to the gateway, when the node restarts (the moment after you read the EEPROM and set the output of the pin).

    Greetings
    Tim



  • @TimO , thanks for the idea.
    So I can probably take some code used for reporting button presses in the examples and use it in the 'message'.

    Thanks again
    Andrew



  • Hi Tim0.

    I have read all your instructions in the GitHub Repo.
    Is there any special reason why you suggest to add things in manual, text way, rather than with the PaperUI?

    I have done it with the PaperUI and manually restarting my nodes and everything works just fine.

    Let me know what you think.
    Regards



  • I wondered that but I'm quite new to OpenHab so did some looking in to how various things work..

    PaperUi uses something called MapDB which is basically a non-human readable configuration file. If you add "things" via PaperUi as far as I can tell you've still got to link the thing to an item for OpenHab to work with as far as I can tell..

    I opted to do everything manually like in the wiki, seems much simpler

    I get the impression PaperUi is still very new and not for production yet... its not compatible with sitemaps as they are waiting to implement a version of sitemaps in PaperUI or something.. I think it all boils down to the fact they want to keep V2 100% compatible with V1 configs and bindings etc so all the new stuff in V2 isn't quite ready yet...

    Anyway might have totally got the wrong impression but that's what I see as a new OpenHab user going straight to v2.

    On another note the work your doing TimO is awesome!


  • Hero Member

    @gonzalonal

    I totally agree with @Qu3Uk ! 🙂
    Both ways work and currently I like the configuration with the .items file more.

    In an early version of the PaperUI it was possible to change the status of items (switch lights on and off). Maybe something like this will return or habmin2 will fill the gap.


  • Hardware Contributor

    I need support for HVAC device, how much work is there to be done to get that included.

    I have made a thermostat controller for my Wirsbo floor project can be found under myprojects wirsbo uponor thermostat replacement


  • Hero Member

    @Denke What is it exactly what you need? Which types?
    How is the setpoint set (request/send)?

    Greetings
    Tim


  • Hardware Contributor

    @TimO
    Hi Tim
    I use gw.present(0, S_HVAC); to present the sensor to the controller

    I use the following messages to send information
    MyMessage msgTemp(0,V_TEMP); //temperature of thermostat
    MyMessage msgFlowState(0,V_HVAC_FLOW_STATE); //tells if the thermostat is active HeatOn or off
    MyMessage msgSetpointHeat(0,V_HVAC_SETPOINT_HEAT); //used for setting wanted temperature
    MyMessage msgKnobTemp(0,V_VAR1); //gives the wanted manual temperature set on the thermostat knob (used for fallback when home automation dont work
    MyMessage msgRunningMode(0,V_VAR2); //running mode internal or external internal = knob value used, external set by home automation
    MyMessage msgHystLow(0,V_VAR3); //used if hysteresis needs to be changed (low value)
    MyMessage msgHystHigh(0,V_VAR4); //used if hysteresis needs to be changed (high value)
    MyMessage msgUpdateTime(0,V_VAR5); //used to set system sampling/update time

    All of the above values are sent out from the thermostat at update sampling time interval.

    V_HVAC_SETPOINT_HEAT(msgSetpointHeat), V_VAR3(msgHystLow), V_VAR4(msgHystHigh), V_VAR5(msgUpdateTime) can be set from the controller to update the thermostat parameters



  • Hi TimO.

    I am trying to do a gw.request from one of my nodes that requires the value of a numeric item from OpenHAB.

    Have you tested this? I am unable to make it work.

    I have created a rule:

    rule "Heart Rate request"
    when
    	Item Heart_Rate received command
    then
    if (receivedCommand == "REQUEST")
    {
    	logInfo( "Heart Rate", "Heart rate request")
    	sendCommand(Heart_Rate, Heart_Rate.state);
    }
    end
    

    Please, let me know if I am doing it the wrong way.
    Regards.



  • I seem to be having some issues with the dimmer function and I'm not entirely sure if its OpenHab, the binding or MySensors... but I seem to be able to crash the gateway once OpenHab boots up... The node is basically running DimmerLED stretch

    20:31:13.030 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 7;1;1;0;0;33.8
    ...
    20:31:13.596 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Light_APT_Lounge_TV' received command ON
    20:31:13.598 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 8;0;1;0;2;1
    20:31:13.602 [INFO ] [marthome.event.ItemStateChangedEvent] - Light_APT_Lounge_TV changed from NULL to 100
    20:31:14.599 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;14;Gateway startup complete.
    20:31:27.963 [WARN ] [g.mysensors.protocol.MySensorsReader] - Connection to Gateway lost!
    20:31:27.964 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread
    20:31:27.965 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:gateway' changed from ONLINE to OFFLINE
    

    I notice the ItemState is null and that sort of makes sense why if OpenHab has been restarted but surely if it is null it shouldn't cause the gateway to go offline? Also it doesn't reconnect which is probably more of an issue.

    
    Bridge mysensors:bridge-eth:gateway [ ipAddress="192.168.1.150", tcpPort=5003, sendDelay=200 ] {
            	dimmer			light08	[ nodeId="8", childId="0" ]	
    }
    
    

    Items

    Dimmer	Light_APT_Lounge_TV	"TV Lights"	<light>	(Lights, APT_Lounge)	{ channel="mysensors:dimmer:gateway:light08:dimmer" }
    
    

  • Hero Member

    I finally found some time to develop on the binding.

    A new version is available with the following changes:

    • On startup the binding will request I_VERSION from gateway to ensure its proper startup. Thanks @andreacioni for the PR!!

    • HVAC (V_VAR1, V_VAR2 ...) are now available. Thanks @Denke for the PR!!

    • The request for ACK feature is now available for testing. It works for light/status for me. If a message is NOT acknowledged by a node the binding retries to send the message five times. If no ACK is received after that the binding will try to revert the item to its old state. This only works, if a state is known (not NULL, for example at startup).

    Additionally I've tested the binding with multiple gateways (one EthernetGW, one SerialGW), works fine.



  • Hi @TimO.
    I have just installed the new release and I believe I've found a little bug. I am using Serial Gateway with version 1.5.3

    At boot up time, I am getting the followinf error:

    03:07:52.644 [ERROR] [s.internal.MySensorsBridgeConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received
    

    I have read that this new release, request the gateway for its version so as to prove proper start up.

    What I have found is that the binding might be asking for the Gateway version al little too soon.

    03:07:50.895 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    03:07:50.912 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;14;Gateway startup complete.
    03:07:52.644 [ERROR] [s.internal.MySensorsBridgeConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received
    03:07:52.647 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
    03:07:52.659 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Stopping Writer thread
    03:07:52.661 [WARN ] [g.mysensors.protocol.MySensorsWriter] - Writer thread interrupted
    03:07:52.666 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread
    

    I have tested this manually and found that the gateway ONLY answers its version after its startup is finished and the message "0;0;3;0;14;Gateway startup complete." is sent.

    When the binding starts, It makes (somehow) the gateway to reboot. So, the gateway runs its setup() method and when it's done, it send the message "0;0;3;0;14;Gateway startup complete"

    Let me know if you can reproduce this error. Maybe it's just some problem with my setup, but with the previus version I was having no issues.

    Regards!



  • @gonzalonal I've implemented the check on startup. On serial gateway with the last version I'm not having any issue, so I would like to know: what hardware are you using? I think that probably is only a timing issue because, for exaple, Arduino UNO reset itself on opening connection and the message for request I_VERSION is sent immediately after connection is opened. I'll suggest you to try adding something like this:

    Thread.sleep(3000)
    

    After line 49 on MySensorsSerialConnection.java. Should become:

    serialConnection = new NRSerialPort(serialPort, baudRate);
            if (serialConnection.connect()) {
                logger.debug("Successfully connected to serial port.");
                Thread.sleep(3000); 
                mysConReader = new MySensorsSerialReader(serialConnection.getInputStream(), this);
                mysConWriter = new MySensorsSerialWriter(serialConnection.getOutputStream(), this, sendDelay);
    
                connected = startReaderWriterThread(mysConReader, mysConWriter);
            } else {
                logger.error("Can't connect to serial port. Wrong port?");
            }
    

    I can't do this test because I do not have an appropriate hardware, can you try the suggested code modification?

    Thanks!

    UPDATE: I've upload a temp build here: https://drive.google.com/file/d/0B11IarucpGdUdFJ2ZjVtZENsb2c/view?usp=sharing if you can't do the modification you can use this. Let me know!



  • Hi @andreacioni. Thanks for your answer.
    I have tested your custom build and it's working flawlessly.

    09:10:36.913 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;14;Gateway startup complete.
    09:10:37.161 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    
    09:10:37.172 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;2;1.5.3
    09:10:37.177 [DEBUG] [s.internal.MySensorsBridgeConnection] - Good,Gateway is up and running! (Ver:1.5.3)
    

    Let me tell you about my hardware configuration. I am running OH2 Beta2 in a Raspberry Pi 2 Model B with an Arduino Nano V3 working as Serial Gateway directly connected to one of Rpi USB ports.

    Please, let me know if you need me to some tests or maybe is just my config.
    Thanks, regards.



  • @gonzalonal I've done all of my test on a custom ATMEGA328p shield for BeagleBone Black, running OH2 (beta) so the environment is the same but I've not the reset circuit that gives the issue above. So now I'll push this little fix on the github repo, I think there's nothing to to in this sense. Thank for your time 🙂 !

    If you find some other strange behaviour also remember that github repo has it's own issue tracker available here: https://github.com/tobof/openhab2-addons/issues, it works very well and is the best place to keep track of every software-releated bug 👍

    Greetings!


  • Hero Member

    There is a new build of the jar available!

    Changes:

    • Added delay before checking the SerialGW (@andreacioni )
    • Requests are answered by the binding (The binding returns "0" if no value was set before)

    https://github.com/tobof/openhab2-addons/issues/8


  • Hero Member

    Are any of you having trouble with this binding together with other bindings that use serial ports? It looks as if the different bindings try to use the same serial port lock, so I get a conflict where things fail til initialize. Think it had something to do with the serial port library...


  • Hero Member

    @kolaf Is it zwave again? Last time I tried to fix the conflict I needed to change the zwave binding.


  • Hero Member

    It is both zwave and rfxcom. I played about it in the oh2 community some time ago, let me see if I can find a link.


  • Hero Member



  • Hello @TimO .

    Just tested the last build of the binding. Works great.
    I see you manage to answer the nodes requests without having to trigger a rule to respond.

    I though that wasn't possible due to the limitation of the API. Did they manage to solve this from the OH side?

    Does the binding itself keeps track of the items values, or does it querys OH (or its persistence service) for getting the right value?

    Thanks!
    Gonzalo


  • Hero Member

    Hi @gonzalonal !

    I'm glad it works, thanks for testing!
    Sadly the limitation of the API is still there, but for the implementation of the requestAck feature I needed to implement a memory and now reused this memory to answer requests.

    There is a really big BUT coming with this implementation: we currently can't use persistence out of the box. For this a rule is needed. After startup of OH we need to use "sendCommand(ITEMNAME, VALUE)", where VALUE Is the value stored in persistance. With that the memory of the binding is filled initially.
    Hopefully I will find an easier way in the future .



  • I get what you mean @TimO .

    Unfortunatelly, using the rule method you suggest would create a lot of traffic (depending on how many sensors you have) at boot up time. Maybe there are some sensors that wouldn't behave the intended way if receiving the "last value" repeteadly.

    An example. Lets supose I have an automatic gate, that everytime it receives a command, wether its a "1" or "0" it toggles its moving direction. Like the most common automatic gates remotes.

    Gate is closed.

    Press button > Gate opens
    Press button > (if gate moving) Gate stops
    Press button > (if gate open) Gate closes

    Now, suppose last command send to the gate made it close. Suddenly, OH restarts itself because of power failure or whatever. It runs the rule to load the memory of the binding, while at the same time it sends to the sensors the last status taken from the persistance service. This would make the gate to open without your notice.

    This may create dangerous escenarios.
    I hope you can understand what I mean.

    Maybe it would be a better idea to handle requests with rules in the way I suggested in the github issue, that is the same way as the OH-1 mysensors serial binding works.

    Let me know if I can help in any way.
    Regards.

    Gonzalo.


  • Hero Member

    @gonzalonal Good point! 😟

    If a request (or a message in general) is received there is no "commandReceived" in OH, so you can't trigger a rule based on a message received. So doing it with a rule is not possible.

    A workaround would be to use "postUpdate()" to update the value after restart. This isn't implemented yet, but is no big deal. This would be a workaround for the workaround, because we still need the rule. 😕

    In the OH1 binding the request is answered with the state of the item, as I would like to to do too.
    Line 277: https://github.com/bloft/openhab/blob/master/bundles/binding/org.openhab.binding.mysensors/src/main/java/org/openhab/binding/mysensors/internal/MySensorsBinding.java



  • Hi @TimO . Good we got in the same page.

    I think this topic needs some more thinking.

    I was reading OH wiki and found this about receivedCommand.

    
     Implicit Variables inside the Execution Block
    
    Besides the implicitly available variables for items and commands/states (see the script documentation), rules can have additional pre-defined variables, depending on their triggers:
    
    
    * Every rule that has at least one command event trigger, will have the variable 
    receivedCommand available, which can be used inside the execution block.
    
    * Every rule that has at least one status change event trigger, will have the variable
    previousState available, which can be used inside the execution block.
    

    https://github.com/openhab/openhab/wiki/Rules

    Maybe this is not available anymore, or at least on OH2.

    For now, I think it would be a better approach to use postUpdate at systemStart to populate the binding memory. With this, we'll avoid sending commands to the nodes.

    Regards!



  • Hi again @TimO .

    Just an idea.

    What do you think about solving this problematic in this way:

    We create a group whose members are all those items that later will populate the binding's memory. I have a group named mysqlpersisted where I put all the items whose data will be stored in my SQL DB. So I could use that group. For this example, let's call it "MemoryGroup"

    Then, we can create the following rule:

    rule "Populate MySensors binding memory"
    
    when 
    System started
    then
    
    (maybe add a delay to allow persistance services to load)
    
    MemoryGroup?.members.forEach[i |
            postUpdate(i.name, i.previousState(true))
    ]
    

    Using this method, memory would get populated everytime OH boots up, with data belonging to the persistance service that we use. And we use postUpdate, so no command is sent to the nodes.

    With this I think we solve both problems as data in the binding will be concurrent with the persistance service data.

    Let me know what you think about this.

    Regards!


  • Hero Member

    Hi @gonzalonal !

    I was thinking in the same direction and I have played a litte bit with different rules. I had no success in finding a rule that worked. Additionally I don't like the workaround. 😉

    A good solution would be, to trigger a rule, if a request is received, but there too I had no success till now.

    I'm still struggling with it ...



  • @TimO Do you think it would be hard to add MQTT support to the binding? I had a brief look to your code and it looks like the protocols are nicely isolated.


  • Hero Member

    I'm currently trying to migrate my production environment from OH1 to OH2. I'm now using two serial gateways.

    @kolaf : The problem you described occured to me too. In my case I use two serial gateways. I've added a little method that ensures that a connection to more than two serial ports via nrjavaserial is possible. It works within the OH2 binding. Could you test if it works with the RFXCOM binding you are using? A new jar is available on github. OH2 is currently using an old version of nrserialjava that has a bug. I don't know how to switch the version yet.

    @tomkxy : I will integrate MQTT in my OH2 Installation soon and will come back to your request after that.



  • The binding doesn't seem to handle the "requestTime" function yet. Time-aware sensors would be able to handle temporary OpenHAB outages by executing some scheduled actions autonomously, which I could use in the window cover controllers I'm developing.


  • Hero Member

    @TimO Thanks for the update. Unfortunately it did not seem to change anything for me, rfxcom still fails trying to use the wrong lock file. If it is helpful I can send you the log. Appreciate your input and effort.


  • Hero Member

    The weird thing is that it seems to work with an older version of OH2 (and an old version of your binding), but not with the more recent beta releases.


  • Hero Member

    @kolaf : My guess is, the implementation in the could be the problem. Please do a litte test: remove the mysensors.jar file from the addons folder. Start OH2. RFXCOM should start fine now. Copy the mysensors.jar in the addons folder. OH2 will try to load the binding. What is the result?

    I suppose this way both binding work fine together?!


  • Hero Member

    @TimO I tried this before, and removing the MySensors binding made the rfxcom binding work. However, this was not the case this time. I will try a bit later to also remove the zwave binding.

    20:56:34.098 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'zwave:serial_zstick:43b9314d' changed from UNINITIALIZED to INITIALIZING
    20:56:34.115 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
    20:56:34.115 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'zwave:serial_zstick:43b9314d' changed from INITIALIZING to ONLINE
    RXTX Warning:  Removing stale lock file. /var/lock/LCK..ttyACM0
    20:56:34.361 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is     initialized
    20:56:34.384 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave     controller
    20:56:34.385 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to     5000ms. Soft reset is false.
    20:56:34.419 [INFO ] [me.event.ThingStatusInfoChangedEvent] -     'zwave:serial_zstick:43b9314d' changed from ONLINE to     INITIALIZING
    20:56:34.444 [INFO ] [smarthome.event.InboxUpdatedEvent   ] - Discovery Result     with UID     'sonos:zoneplayer:RINCON_5CAAFD2BB4D801400' has been updated.
    20:56:34.578 [INFO ] [smarthome.event.InboxUpdatedEvent   ] - Discovery Result     with UID     'sonos:zoneplayer:RINCON_5CAAFD21C16201400' has been updated.
    20:56:34.756 [INFO ] [smarthome.event.InboxUpdatedEvent   ] - Discovery Result     with UID     'sonos:zoneplayer:RINCON_5CAAFD2BB4FE01400' has been updated.
    20:56:34.852 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
    20:56:34.866 [INFO ] [smarthome.event.InboxUpdatedEvent   ] - Discovery Result with UID 'hue:bridge:0017881c7280' has been     updated.
    20:56:34.869 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
    20:56:34.998 [INFO ] [.openhab.core.internal.CoreActivator] - openHAB runtime has been started (v2.0.0, build 201602200203).
    20:56:35.015 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.sitemap'
    20:56:35.444 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'mysensors.things'
    20:56:35.491 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:bridge-ser:gateway' has been added.
    20:56:35.500 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:gateway' changed from UNINITIALIZED to     INITIALIZING
    RXTX fhs_lock() Error: opening lock file: /var/lock/LCK..ttyACM0: File exists. It is mine
    
    �a�� testRead() Lock file failed
    RXTX Warning:  Removing stale lock file. /var/lock/LCK..mysensorsUSB
    20:56:37.420 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 37: Not initialized yet, ignoring message.
    20:56:37.426 [ERROR] [WaveSerialHandler$ZWaveReceiveThread] - Protocol error (CAN), resending
    20:56:37.427 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 37: Not initialized yet, ignoring message.
    20:56:37.429 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 37: Not initialized yet, ignoring message.
    20:56:38.773 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:gateway' changed from INITIALIZING to ONLINE
    20:56:38.774 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rfxcom.things'
    20:56:38.780 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'rfxcom:bridge:rfxtrx' has been added.
    20:56:38.790 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'rfxcom:bridge:rfxtrx' changed from UNINITIALIZED to INITIALIZING
    20:56:38.792 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'rfxcom:bridge:rfxtrx' changed from INITIALIZING to OFFLINE
    RXTX fhs_lock() Error: opening lock file: /var/lock/LCK..mysensorsUSB: File exists. It is mine
    
    �`�� testRead() Lock file failed
    20:56:38.805 [ERROR] [g.rfxcom.handler.RFXComBridgeHandler] - Connection to RFXCOM transceiver failed: null

  • Hero Member

    It appears that I get these errors even if I remove all the offending bindings. I think I need to start with a completely clean installation and see how it goes. I will let you know.


  • Hero Member

    Success, I think.

    I started a brand-new installation of the latest OH2 snapshot, and sequentially added the rfxcom, z-wave, and mysensors bindings. After fiddling a bit with getting serial ports recognised by OH2 and getting the permissions correct, it seems to work. I still get some weird error messages, but apparently the library is able to work through its issues :-). An example of what I mean is included.

    08:30:03.894 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'mysensors:bridge-ser:334037be' has been added.
    08:30:03.910 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:334037be' changed from UNINITIALIZED to INITIALIZING
    RXTX fhs_lock() Error: opening lock file: /var/lock/LCK..rfxtrxUSB: File exists. It is mine
    
    @�2� testRead() Lock file failed
    RXTX fhs_lock() Error: opening lock file: /var/lock/LCK..ttyACM0: File exists. It is mine
    
    @�2� testRead() Lock file failed
    08:30:04.043 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_bridge_ser_334037be' has been added.
    08:30:04.219 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_bridge_ser_334037be-mysensors:bridge-ser:334037be' has been added.
    08:30:07.060 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:334037be' changed from INITIALIZING to ONLINE

  • Hero Member

    Returns out that I am still seeing the problem sometimes. If I change the configuration so that the bindings are reloaded (especially the zwav binding) it fails to reconnect to the serial port. I found someone who had posted an updated serial binding which supposedly solved some related problem (I think), but I'm not sure. It does not appear to have had any effect on the problem.

    The modified version is available from one of the last posts here: https://github.com/openhab/openhab2-addons/issues/671


  • Hero Member

    I managed to get things working pretty well under Linux, but I have now switched to a Windows-based installation to see how that is.

    Currently I have all three bindings working at the same time using three different serial ports. This is finally allowed me to pay attention to what the mysensors binding is doing.

    The seems to be some kind of delay through the system for messages coming from the device. This is quite evident from the log included below. Device number three is a power sensor which transmits about once a minute. For some reason things are bunched together. I guess some of these could be Retransmissions, though. The sensor is located 4 m away from the gateway. Number 10 is a temperature sensor in the basement.

    For some reason I have had severe problems getting the sensor to talk to the Gateway today. It shouldn't be related to the binding, I know, but I'm loosing my mind trying to keep track of all the different factors here.

    2016-04-10 16:56:19.535 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 10;1;1;0;0;6.3
    2016-04-10 16:56:20.512 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 10;1;1;0;0;6.3
    2016-04-10 16:56:21.747 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 10;1;1;0;0;6.3
    2016-04-10 16:56:21.805 [INFO ] [marthome.event.ItemStateChangedEvent] - FirstFloorHallMotionSensor changed from ON to OFF
    2016-04-10 16:56:21.805 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_command changed from ON to OFF
    2016-04-10 16:56:21.806 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_dimmingLevel changed from 100 to 0
    2016-04-10 16:56:21.807 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_contact changed from OPEN to CLOSED
    2016-04-10 16:56:24.922 [INFO ] [marthome.event.ItemStateChangedEvent] - FirstFloorHallMotionSensor changed from OFF to ON
    2016-04-10 16:56:24.923 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_command changed from OFF to ON
    2016-04-10 16:56:24.924 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_dimmingLevel changed from 0 to 100
    2016-04-10 16:56:24.926 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_contact changed from CLOSED to OPEN
    2016-04-10 16:56:55.048 [INFO ] [marthome.event.ItemStateChangedEvent] - CurrentDate changed from 2016-04-10T16:55:55.046+0200 to 2016-04-10T16:56:55.045+0200
    2016-04-10 16:56:55.049 [INFO ] [ome.event.GroupItemStateChangedEvent] - ntp_ntp_local changed from 2016-04-10T16:55:55.046+0200 to 2016-04-10T16:56:55.045+0200 through ntp_ntp_local_dateTime
    2016-04-10 16:56:55.049 [INFO ] [marthome.event.ItemStateChangedEvent] - ntp_ntp_local_dateTime changed from 2016-04-10T16:55:55.046+0200 to 2016-04-10T16:56:55.045+0200
    2016-04-10 16:57:08.332 [INFO ] [marthome.event.ItemStateChangedEvent] - FirstFloorHallMotionSensor changed from ON to OFF
    2016-04-10 16:57:08.333 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_command changed from ON to OFF
    2016-04-10 16:57:08.334 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_dimmingLevel changed from 100 to 0
    2016-04-10 16:57:08.334 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15669958_10_contact changed from OPEN to CLOSED
    2016-04-10 16:57:13.444 [INFO ] [marthome.event.ItemStateChangedEvent] - MainHallMotionSensor changed from OFF to ON
    2016-04-10 16:57:13.445 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15663466_10_command changed from OFF to ON
    2016-04-10 16:57:13.450 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15663466_10_dimmingLevel changed from 0 to 100
    2016-04-10 16:57:13.451 [INFO ] [marthome.event.ItemStateChangedEvent] - rfxcom_lighting2_A1WJD2HB_15663466_10_contact changed from CLOSED to OPEN
    2016-04-10 16:57:23.053 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 10;1;1;0;0;6.3
    2016-04-10 16:57:24.511 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 3;1;1;0;17;9223
    2016-04-10 16:57:24.513 [INFO ] [marthome.event.ItemStateChangedEvent] - CurrentTotalPower changed from 6559 to 9223
    2016-04-10 16:57:24.519 [INFO ] [marthome.event.ItemStateChangedEvent] - AverageTotalPower changed from 6559 to 9223
    2016-04-10 16:57:24.798 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 3;1;1;0;17;9223
    2016-04-10 16:57:25.616 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 3;1;1;0;24;4597
    2016-04-10 16:57:27.075 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 3;1;1;0;24;4597
    2016-04-10 16:57:29.766 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 3;1;1;0;24;4597
    2016-04-10 16:57:31.128 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 3;1;1;0;18;4.6050

  • Hero Member

    @kolaf : I'm glad the bindings are now working together.

    The delay in the transmission is a bit strange. I've no idea where that could come from.
    I've ported my production environment to OH2 and this didn't occure to me yet. I've upgraded a lot of my sensors to 2.0-beta and therefore took a closer look at the debug output of the OH2 binding to check if the devices present themself correctly and send the messages. I'll will keep an eye on it!

    Currently I'm running OH2 with:

    • Astro1
    • Weather1
    • MySensors2
    • MySQL Persistence
    • Sonos2

    In the MySensors network I have a couple of Sensebender Micros, a shutter control with 12 SSR and two nodes to control LED lights plus selfmade DHT22 nodes connected to two gateways (one serial, one ethernet (iboard)).

    I'm glad it runs stable for days now, although it is obvious in some places that this is a beta release of OH2. There are icons missing and there are bugs in the basicui and the documentation could be much better.



  • @TimO I try openHab 2.0 binding today and I am getting this where the serial changes from Initializing to Offline. Even if I reboot I get the same error. Why is this happing?

    12:49:05.469 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
    12:49:05.543 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/ttyUSB0 [baudRate:115200]
    12:49:06.140 [INFO ] [smarthome.event.ItemAddedEvent      ] - Item 'mysensors_bridge_ser_bb7302f6' has been added.
    12:49:06.390 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
    12:49:06.446 [INFO ] [rthome.event.ItemThingLinkAddedEvent] - Link 'mysensors_bridge_ser_bb7302f6-mysensors:bridge-ser:bb7302f6' has been added.
    12:49:09.409 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Starting gateway (RRNGA-, 2.0.0-beta)
    12:49:09.426 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Radio init successful.
    12:49:09.434 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;14;Gateway startup complete.
    12:49:09.441 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    12:49:09.506 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    12:49:10.488 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing 'mysensors:bridge-ser:bb7302f6' takes more than 5000ms.
    12:49:10.763 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 40-40-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    12:49:10.767 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;1;1;0;16;1
    12:49:11.676 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 40-40-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    12:49:11.680 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;1;1;0;16;1
    12:49:11.778 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 40-40-0 s=0,c=1,t=23,pt=2,l=2,sg=0:72
    12:49:11.783 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;0;1;0;23;72
    12:49:11.792 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 40-40-0 s=5,c=1,t=38,pt=7,l=5,sg=0:3.07
    12:49:11.796 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;5;1;0;38;3.07
    12:49:11.838 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 40-40-0 s=5,c=1,t=38,pt=7,l=5,sg=0:3.07
    12:49:11.843 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;5;1;0;38;3.07
    12:49:11.861 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 40-40-0 s=255,c=3,t=0,pt=1,l=1,sg=0:100
    12:49:11.866 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;255;3;0;0;100
    12:49:12.079 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 66-66-0 s=1,c=1,t=24,pt=5,l=4,sg=0:3579898
    12:49:12.083 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 66;1;1;0;24;3579898
    12:49:14.409 [ERROR] [s.internal.MySensorsBridgeConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received
    12:49:14.410 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
    12:49:14.412 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Stopping Writer thread
    12:49:14.418 [WARN ] [g.mysensors.protocol.MySensorsWriter] - Writer thread interrupted
    12:49:14.428 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread
    12:49:14.528 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:bb7302f6' changed from INITIALIZING to OFFLINE
    Insert Code Here
    


  • Hi @Francois ,

    thanks for report. Seems that the you are using 2.0 version of MS Gateway. If you do not need it for particular task, try install the 1.5 version. I'll try to fix your problem as soon as possible!



  • @andreacioni Thanks for this all my sensor are running on version 2 so I don't know it my nodes will run on an 1.5 serial GW


  • Hero Member

    I have a serial and ethernet gateway with version 2.0 running without any problems.
    In your case there are a lot messages arriving within a short time, maybe that is the reason the gateway won't react on the I_VERSION message from the binding.

    Please disable debugging in the gateway and try again. The reliability of my gateway improved a lot after disabling debugging.



  • @TimO I still get the same error after I disable debugging in the gateway



  • @Francois could you please send manually the I_VERSION command to the gateway? By no this is done by binding to check if the startup of the gateway was completed without errors. In your case that check fail. The I_VERSION message is this: 0;0;3;0;2;, you could try also 0;255;3;0;2; and see if gateway answer. Let we know what you see!



  • @andreacioni sorry how do I do this I_VERSION command to the gateway?



  • @Francois is a simple serial text message, just open the serial monitor of Arduino IDE and send it from there.



  • @andreacioni Here is is the info:

    0;255;3;0;9;Starting gateway (RRNGA-, 2.0.0-beta)
    0;255;3;0;9;Radio init successful.
    0;255;3;0;14;Gateway startup complete.
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    0;255;3;0;9;read: 40-40-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    40;1;1;0;16;1
    0;255;3;0;9;read: 40-40-0 s=255,c=3,t=0,pt=1,l=1,sg=0:100
    40;255;3;0;0;100
    0;255;3;0;9;read: 40-40-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    40;1;1;0;16;1
    0;255;3;0;9;read: 2-2-0 s=0,c=1,t=1,pt=7,l=5,sg=0:34.0
    2;0;1;0;1;34.0
    0;255;3;0;9;read: 40-40-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    40;1;1;0;16;0
    0;255;3;0;9;read: 40-40-0 s=0,c=1,t=23,pt=2,l=2,sg=0:80
    40;0;1;0;23;80
    0;255;3;0;9;read: 40-40-0 s=255,c=3,t=0,pt=1,l=1,sg=0:100
    40;255;3;0;0;100
    0;255;3;0;9;read: 40-40-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    40;1;1;0;16;1
    0;255;3;0;9;read: 101-101-0 s=255,c=3,t=15,pt=0,l=2,sg=0:
    0;255;3;0;9;send: 0-0-101-101 s=255,c=3,t=15,pt=0,l=2,sg=0,st=fail:
    0;255;3;0;9;read: 101-101-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    101;255;3;0;6;0
    0;255;3;0;9;read: 101-101-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    101;255;3;0;6;0
    0;255;3;0;9;read: 101-101-0 s=255,c=3,t=12,pt=0,l=3,sg=0:2.0
    101;255;3;0;12;2.0
    


  • @Francois ok, this is the normal output. What happens if you send the I_VERSION message (just copy, paste and send one of them: 0;0;3;0;2; or 0;255;3;0;2; )?

    UPDATE: Issue posted on tracker here


  • Hero Member

    @Francois : I've updated my serial gw to the most recent development version and checked it against the binding. It is working for me. The response to I_VERSION does not belong to the RF, I've checked the current implementation of the MySensors library, so it should make not difference if you use RFM69, NRF or no RF at all.

    Maybe the gateway is too busy to answer the request? Maybe we could an option for the binding to omit the check for I_VERSION? I'm out of ideas at the moment.



  • @TimO I have this gateway working on Domoticz without any problem. Put on OH2 I am getting this error and i don't know why it is happing



  • @TimO said:

    Maybe we could an option for the binding to omit the check for I_VERSION?

    I could do it without any problem.



  • @TimO I just download the last version of the beta version and recompile my gateway and I still am getting the same error code. There is not something that I missed in the MyConfig.h file or any other file that I need to change in openHAB2?


  • Hero Member

    @Francois : No, I don't think so. I can't explain this behaviour and I'm sure the binding will just work fine after the initial check of I_VERSION.

    @andreacioni : Would you be so kind to prepare a PR? I suggest to leave the check on by default.



  • @TimO simple update, tonight I'll push it 👍


  • Hero Member

    New version of the binding available!

    • A requestTime from a node is now answered by the controller. Is anyone able to test it? (@undee )
    • The controller will answer a request for "imperial or metric" like temperature sensors might ask. We need to test that too.

    Big thanks @andreacioni for the implementation and @Francois for testing/reporting!

    I've added an example page in the wiki: https://github.com/tobof/openhab2-addons/wiki/Examples
    These are the type of things I'm currently using. (SensebenderMicro, Humidity, Temperature, Cover, Motion, Light ...)

    Has anyone additional examples yet?



  • @TimO

    Thanks for your work! It's really nice to see the progress!

    I have tried the TimeAwareSensor and the MockMySensors examples. The I_TIME message is sent by the node, obviously received by the gateway, but there the gateway is not sending anything in response. Are you sure your code for sending a time response is already active?



  • @TimO mysensor is now working 🙂 The only problem I have and I also had the same problem with OpenHab 1.8.2 as well in that I don't get my relay sensor to switch on or off. If if look at the log openhab it is sending the commands to the RelayActuator what am I doing wrong with this sensor? All my other sensor are reporting back to the dashboard.

    11:59:32.760 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'teststudy' received command ON
    11:59:32.769 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:32.782 [INFO ] [marthome.event.ItemStateChangedEvent] - teststudy changed from NULL to ON
    11:59:32.789 [DEBUG] [g.mysensors.handler.MySensorsHandler] - handleUpdate called
    11:59:32.873 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:32.977 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:33.478 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:34.479 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 101;1;1;1;2;1
    11:59:35.209 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 40;1;1;0;16;0
    11:59:35.221 [INFO ] [marthome.event.ItemStateChangedEvent] - studymotion changed from OPEN to CLOSED
    11:59:35.243 [INFO ] [marthome.event.ItemStateChangedEvent] - studymotionlastup changed from 2016-04-23T11:59:31.084+0200 to 2016-04-23T11:59:35.229+0200
    11:59:35.269 [INFO ] [marthome.event.ItemStateChangedEvent] - studymotionlastup changed from 2016-04-23T11:59:35.229+0200 to 2016-04-23T11:59:35.248+0200
    11:59:36.480 [WARN ] [g.mysensors.protocol.MySensorsWriter] - NO ACK from nodeId: 101
    11:59:36.483 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - No old status know to revert to!
    


  • Hi @undee

    Can you post your node firmware version and log of OH2? It's very important for us to troubleshoot your problem.
    Thanks!


  • Hero Member

    Hi all,

    After battling with some radio issues with my sensors (in the RFM69 library) I am again ready to get things working using OH2. I downloaded the latest copy of the binding, but sadly things are not working for me. I believe the problem is still related to collecting to the serial port. I have lots of zwave stuff going on in my log, but i have included it anyhow in case someone feels the urge to take a look :-).
    0_1461437647445_temporary log



  • @kolaf Same thing as @Francois, in the binding configuration try add this: skipStartupCheck=true.


  • Hero Member

    Thanks for the suggestion. I updated the configuration like this:

    Bridge mysensors:bridge-ser:gateway [ serialPort="/dev/mysensorsUSB", sendDelay=200, skipStartupCheck=true ] {
    	baro	stableBarometer	[ nodeId="6", childId="3" ]
    	power	mainPower	[ nodeId="3", childId="1" ]
    	temperature		basementTemperature		[ nodeId="10", childId="1"]
        }
    

    It did not work as expected. The resulting log is like this:

        22:34:35.570 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'mysensors.things'
        22:34:35.606 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
        22:34:35.606 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Stopping Writer thread
        22:34:35.606 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread
        22:34:35.606 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
        22:34:35.607 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/mysensorsUSB [baudRate:115200]
        22:34:35.614 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
        22:34:35.614 [DEBUG] [col.serial.MySensorsSerialConnection] - Waiting 5 seconds to allow correct reset trigger on serial connection opening
        22:34:40.608 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occured while calling thing updated at ThingHandler 'org.openhab.binding.mysensors.handler.MySensorsBridgeHandler@534c4d92: null
        java.util.concurrent.TimeoutException
                at java.util.concurrent.FutureTask.get(FutureTask.java:205)[:1.8.0_66]
                at org.eclipse.smarthome.core.common.SafeMethodCaller.callAsynchronous(SafeMethodCaller.java:179)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at org.eclipse.smarthome.core.common.SafeMethodCaller.call(SafeMethodCaller.java:72)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at org.eclipse.smarthome.core.common.SafeMethodCaller.call(SafeMethodCaller.java:56)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at org.eclipse.smarthome.core.thing.internal.ThingManager.thingUpdated(ThingManager.java:515)[94:org.eclipse.smarthome.core.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.notifyTrackers(ThingRegistryImpl.java:218)[94:org.eclipse.smarthome.core.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.notifyListenersAboutUpdatedElement(ThingRegistryImpl.java:141)[94:org.eclipse.smarthome.core.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.notifyListenersAboutUpdatedElement(ThingRegistryImpl.java:1)[94:org.eclipse.smarthome.core.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.core.common.registry.AbstractRegistry.updated(AbstractRegistry.java:102)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at org.eclipse.smarthome.core.common.registry.AbstractProvider.notifyListeners(AbstractProvider.java:57)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at org.eclipse.smarthome.core.common.registry.AbstractProvider.notifyListenersAboutUpdatedElement(AbstractProvider.java:82)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider.access$3(GenericThingProvider.java:1)[118:org.eclipse.smarthome.model.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider$18.apply(GenericThingProvider.java:700)[118:org.eclipse.smarthome.model.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider$18.apply(GenericThingProvider.java:1)[118:org.eclipse.smarthome.model.thing:0.8.0.201604051458]
                at org.eclipse.xtext.xbase.lib.IterableExtensions.forEach(IterableExtensions.java:399)[129:org.eclipse.xtext.xbase.lib:2.6.2.v201407030533]
                at org.eclipse.smarthome.model.thing.internal.GenericThingProvider.modelChanged(GenericThingProvider.java:705)[118:org.eclipse.smarthome.model.thing:0.8.0.201604051458]
                at org.eclipse.smarthome.model.core.internal.ModelRepositoryImpl.notifyListeners(ModelRepositoryImpl.java:200)[107:org.eclipse.smarthome.model.core:0.8.0.201604051458]
                at org.eclipse.smarthome.model.core.internal.ModelRepositoryImpl.addOrRefreshModel(ModelRepositoryImpl.java:116)[107:org.eclipse.smarthome.model.core:0.8.0.201604051458]
                at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.checkFile(FolderObserver.java:240)[107:org.eclipse.smarthome.model.core:0.8.0.201604051458]
                at org.eclipse.smarthome.model.core.internal.folder.FolderObserver.access$1(FolderObserver.java:235)[107:org.eclipse.smarthome.model.core:0.8.0.201604051458]
                at org.eclipse.smarthome.model.core.internal.folder.FolderObserver$WatchQueueReader.processWatchEvent(FolderObserver.java:117)[107:org.eclipse.smarthome.model.core:0.8.0.201604051458]
                at org.eclipse.smarthome.core.service.AbstractWatchQueueReader.run(AbstractWatchQueueReader.java:95)[88:org.eclipse.smarthome.core:0.8.0.201604051458]
                at java.lang.Thread.run(Thread.java:745)[:1.8.0_66]
        22:34:40.612 [INFO ] [smarthome.event.ThingUpdatedEvent   ] - Thing 'mysensors:bridge-ser:gateway' has been updated.
        22:34:40.620 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'mysensors.things'
        22:34:40.815 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
        22:34:45.619 [ERROR] [s.internal.MySensorsBridgeConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received
        22:34:45.619 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
        22:34:45.619 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Stopping Writer thread
        22:34:45.621 [WARN ] [g.mysensors.protocol.MySensorsWriter] - Writer thread interrupted
        22:34:45.621 [DEBUG] [g.mysensors.protocol.MySensorsReader] - Stopping Reader thread

  • Hero Member

    I restarted OH2 after changing the configuration, and this time I get no exceptions, but I see no more messages from the binding after the one included below.

    @kolaf said:

    22:34:40.815 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    

    Edit: after a while I finally received a few packets in the debug console:

    2016-04-23 23:10:49.020 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;d0;6t,
    2016-04-23 23:10:49.021 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;4;1012.9
    

    Both of the packets seem quite mangled, they are missing pieces, and some of the pieces present do not make sense. I have verified that the baud rate is correct, and when I correct directly to the Gateway using a serial console the output looks normal.



  • @kolaf that's my output, check if there's something different.

    Have you tried rebooting the entire board/system?

    23:08:55.305 [DEBUG] [nsors.handler.MySensorsBridgeHandler] - Initialization of the MySensors Bridge
    23:08:55.379 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/ttyS80 [baudRate:115200]
    23:08:56.542 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
    23:08:56.558 [DEBUG] [col.serial.MySensorsSerialConnection] - Waiting 5 seconds to allow correct reset trigger on serial connection opening
    23:09:00.220 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:gateway' changed from INITIALIZING to UNINITIALIZED (HANDLER_INITIALIZING_ERROR)
    23:09:00.232 [WARN ] [ome.core.thing.internal.ThingManager] - Registering handler for thing 'mysensors:bridge-ser:gateway' takes more than 5000ms.
    23:09:00.403 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'logging.persist'
    23:09:00.623 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
    23:09:01.380 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.rules'
    23:09:01.615 [WARN ] [s.internal.MySensorsBridgeConnection] - Skipping I_VERSION connection test, not recommended...
    23:09:01.641 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:gateway' changed from UNINITIALIZED (HANDLER_INITIALIZING_ERROR) to ONLINE
    23:09:01.733 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    23:09:01.737 [DEBUG] [org.openhab.binding.mysensors       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandler}={thing.type=mysensors:bridge-ser, thing.id=mysensors:bridge-ser:gateway, service.id=319, service.bundleid=181, service.scope=singleton} - org.openhab.binding.mysensors
    23:09:01.768 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;0;3;0;2;1.5
    23:09:01.785 [DEBUG] [s.internal.MySensorsBridgeConnection] - Good,Gateway is up and running! (Ver:1.5)
    23:09:04.490 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.script'
    23:09:05.262 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.items'
    

    EDIT: Do you see Skipping I_VERSION connection test, not recommended...?


  • Hero Member

    @andreacioni The difference is that I never get a response from the board for some reason. Connecting using screen works without issues. I think the still might be an issue with the serial lock, but given that we actually receive some data at all this might not be the case after all.

    Edit: I have rebooted the board by unplugging it and reconnecting it.



  • @kolaf Could you try link the serial port to another name (ln -s /dev/mysensorsUSB /dev/ttyS80)


  • Hero Member

    I just tried disconnecting and reconnecting the board and restarting OH2 again, and this time it seems to have initialised correctly :-). I'm not sure why it didn't work the first two times, though.



  • @kolaf Perfect! 😉


  • Hero Member

    Now that things seem to be working on all levels, I have a very small request. Could someone please update the "baro" thing definition to include "V_PRESSURE" as well as "V_FORECAST"? My arduino is not big enough to calculate the forecast without running out of memory, so I can only send the actual barometric pressure.

    Edit: Perhaps it is better to replace forecast with pressure for baro and create a new channel for the forecast?

    What would also have been great, but this is a longer shot, would be to have some standardised way of getting received signal strength for the (at least directly connected) sensors. At least the RFM69 has an easy way of reporting RSSI, so just need a standard way of reporting this to the binding. Currently I'm reporting it as a generic debug message like this: 0;255;3;0;9;Received RSSI: -32

    The reason I want to keep track of this is to keep an eye on the RF environments around my sensors. Things may change for many reasons (appliances, foliage, et cetera) and this will allow me to pre-emptively correct any problems in the future 🙂



  • @andreacioni

    Here is the output generated after restarting the TimeAwareSensor sketch from the MySensors examples.

    You can see that the I_TIME (3;0;1) message is received by the gateway several times, but it never sends a response to the node.

    Do you need anything else?

    12:20:59.677 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0-beta)
    12:20:59.683 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Radio init successful.
    12:20:59.683 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;14;Gateway startup complete.
    12:20:59.683 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    12:20:59.683 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-ser:2dc775c4' changed from INITIALIZING to ONLINE
    12:20:59.776 [DEBUG] [g.mysensors.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    12:20:59.782 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;2;2.0.0-beta
    12:20:59.782 [DEBUG] [s.internal.MySensorsBridgeConnection] - Good,Gateway is up and running! (Ver:2.0.0-beta)
    12:21:01.067 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:
    12:21:01.071 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;1;
    12:21:01.076 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=15,pt=0,l=2,sg=0:
    12:21:01.119 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;send: 0-0-167-167 s=255,c=3,t=15,pt=0,l=2,sg=0,st=fail:
    12:21:01.125 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=0,t=17,pt=0,l=10,sg=0:2.0.0-beta
    12:21:01.128 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;0;0;17;2.0.0-beta
    12:21:01.131 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    12:21:01.134 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;6;0
    12:21:03.135 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=11,pt=0,l=5,sg=0:Clock
    12:21:03.138 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;11;Clock
    12:21:03.144 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    12:21:03.146 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;12;1.0
    12:21:11.059 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:
    12:21:11.061 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;1;
    12:21:21.061 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:
    12:21:21.063 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 167;255;3;0;1;
    12:21:31.063 [DEBUG] [g.mysensors.protocol.MySensorsReader] - 0;255;3;0;9;read: 167-167-0 s=255,c=3,t=1,pt=0,l=0,sg=0:


  • Hi @TimO, me and @undee have tested everything (thanks again!). I'll push a little PR on github to fix a problem found in I_TIME response.


  • Hero Member

    Hey @andreacioni & @undee , thanks for the test & fix!
    I've merged the PR.



  • Hi @TimO ! I want to tell you an idea for the OH2 binding. What do you think about adding a date time channel to every thing that hold the last communication of the thing with the gateway? For example, it will be useful if you want to notify user that some sensors have become unavailable. Tell me what do you think! 🙂


  • Hero Member

    @andreacioni This can be easily done with a periodic rule that checks the latest update of the value assuming you have some persistence like rrd configured.



  • Hi @kolaf, yes this is how to do it. But my idea is to integrate the datetime channel into the binding in order to automatically update that value when updates are received. I think is better than have to do rules into OH config for each devices. What do you think?


 

233
Online

8.4k
Users

9.3k
Topics

97.9k
Posts