Where does the fail in the debug output come from ?



  • Recently started with mysensors with Domoticz as controller. It's great stuf, I use a serial gateway connected to a USB port on the raspberry pi running domotics. It works, the gateway is registered in domotics, i have build a simple input sensor on an Arduino UNO that toggles every 5 seconds. Status is shown correctly in domoticz so all looks good. Until I look at the the serial debug output on the sensor, I see frequent fails, like this -
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=fail:1
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:0
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:1
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:0
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:1
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:0
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:1
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=fail:0
    send: 10-10-0-0 s=1,c=1,t=2,pt=2,l=2,sg=0,st=ok:1

    My question is where does this fail come from ? Is it from the controller ? the gateway ? or the sensor itself ?
    I have caps on the radio, tried getting closer to the gateway but no change.

    Thanks !


  • Hardware Contributor

    Hi @Rolo6442u - welcome!

    st=fail means the radiotraffic between the node and gateway fails in some way.
    Sometimes it can reach the gw, but some more skilled in the code need to present you with the details.

    If you use a nrf radio and you dont use a 4.7uF cap on VCC-GND thats a good advice.


Log in to reply
 

Suggested Topics

  • 10
  • 4
  • 3
  • 4
  • 5
  • 1
  • 1026
  • 3

263
Online

9.9k
Users

10.4k
Topics

107.4k
Posts