[SOLVED] Nodes not receviving ACK from Pi3 gateway



  • Hi everyone,

    I have been running a sensor node with a nrf52832 talking to an Arduino Uno and a NRF24L01+ for the mqtt Gateway without trouble. Recently I wanted to run the Gateway on my Raspberry Pi that is already running Openhab with the Embedded MQTT Broker. I followed the installations and setup guidelines, installing the latest development rep. The test does make a connection to the NRF24L01+ chip as the logs here:

    
    Mar 03 23:48:09 INFO  Starting gateway...
    Mar 03 23:48:09 INFO  Protocol version - 2.3.1
    Mar 03 23:48:09 DEBUG MCO:BGN:INIT GW,CP=RNNGL---,REL=255,VER=2.3.1
    Mar 03 23:48:09 DEBUG TSF:LRT:OK
    Mar 03 23:48:09 DEBUG TSM:INIT
    Mar 03 23:48:09 DEBUG TSF:WUR:MS=0
    Mar 03 23:48:09 DEBUG TSM:INIT:TSP OK
    Mar 03 23:48:09 DEBUG TSM:INIT:GW MODE
    Mar 03 23:48:09 DEBUG TSM:READY:ID=0,PAR=0,DIS=0
    Mar 03 23:48:09 DEBUG MCO:REG:NOT NEEDED
    Mar 03 23:48:09 DEBUG MCO:BGN:STP
    Mar 03 23:48:09 DEBUG MCO:BGN:INIT OK,TSP=1
    Mar 03 23:48:09 DEBUG GWT:RMQ:MQTT RECONNECT
    Mar 03 23:48:09 DEBUG connected to 127.0.0.1
    Mar 03 23:48:09 DEBUG GWT:RMQ:MQTT CONNECTED
    Mar 03 23:48:09 DEBUG GWT:TPS:TOPIC=mygateway1-out/0/255/0/0/18,MSG SENT
    Mar 03 23:48:09 DEBUG TSM:READY:NWD REQ
    Mar 03 23:48:11 DEBUG TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0                                                                                     ,st=OK:
    

    But on the other side, on the debug from my node I have:

     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.3.1
    
    284 MCO:BGN:INIT NODE,CP=RNNNN---,REL=255,VER=2.3.1
    338 TSM:INIT
    352 TSF:WUR:MS=0
    369 TSM:INIT:TSP OK
    390 TSM:INIT:STATID=5
    413 TSF:SID:OK,ID=5
    434 TSM:FPAR
    454 TSF:MSG:SEND,5-5-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2527 !TSM:FPAR:NO REPLY
    2551 TSM:FPAR
    2572 TSF:MSG:SEND,5-5-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4646 !TSM:FPAR:NO REPLY
    4670 TSM:FPAR
    4691 TSF:MSG:SEND,5-5-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6765 !TSM:FPAR:NO REPLY
    6789 TSM:FPAR
    6810 TSF:MSG:SEND,5-5-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8884 !TSM:FPAR:FAIL
    8904 TSM:FAIL:CNT=1
    8925 TSM:FAIL:DIS
    8944 TSF:TDI:TPD
    

    I used the configuration line :

    ./configure --my-transport=rf24 --my-rf24-pa-level=RF24_PA_MAX --my-rf24-ce-pin=26 --my-rf24-cs-pin=24 --my-gateway=mqtt --my-controller-ip-address=127.0.0.1  --my-port=1883  --my-mqtt-publish-topic-prefix=mygateway1-out --my-mqtt-subscribe-topic-prefix=mygateway1-in --my-mqtt-client-id=Gateway
    

    Which is most alike than what I had on my Arduino Uno Gateway.

    Did I miss anything to make it works?

    Thanks for your help on that matter!


  • Mod

    @olision actually, the nodes do receive ack, as indicated by st=OK.

    Does the gateway log cover the time when the node sent its messages? In that case, maybe there is another gateway (or a repeater node) that send the acks?

    What capacitor(s) are you using for the power on the gateway radio? How is the gateway radio powered?



  • Thanks for your fast reply,

    In my case, there is only one Gateway running on the Pi3 and only one NRF52832 node. I have a 10uf capacitor soldered on the NRF24L01+ and it is powered using the 3.3V form the Raspberry Pi. To make sure it wasn't a faulty radio, it is the same I used on my working Arduino gateway.
    I saw in the configure help that there is a --my-rf24-channel=<0-125> option set to 76 by default. Could it be the cause of this communication error?

    I'm all ears if you have any recommendation to my setup to make it works!



  • Finally got some time to work on it. I started back from scratch, installing the openhabian image and configuring it all over. I problably made a mistake somewhere because now it does works well!


 

293
Online

8.9k
Users

9.6k
Topics

100.9k
Posts