pH Sensor probe (board PH-4502C)



  • Hello forum,
    I recently bought a pH sensor probe and board from ebay, along with pH buffer powders 4.0, 6.86 and 9.18 so I could calibrate it.
    I've spent the last couple of days calibrating and testing the probe, and initially I was happy with the results. I can repeatedly get results within 0.05pH when retesting the 6.86 and 9.18 solutions (I don't really care about the 4.0, I'm trying to test my salt water pool).
    My issue started when I attempted to test my pool water... it was returning a pH around 7.15 which I knew was way off the mark by manually testing it.
    I took a sample of the water to the pool shop for testing, and they said the pH was 8.2, so my probe is returning crazy values for my pool water, but is accurate when checking against the buffer solutions which I trust...
    Does anyone have any ideas why the pool water readings would be off the mark? The chlorine is pretty high (8.63ppm according to the pool shop) and they also said the phosphate level is too high. Would either of these things cause an errant reading?
    Thanks in advance for any advice.



  • I think this question is best answered by a chemist, not an electronics expert. I do not claim to know much about water chemistry other than it is very complex. Probably pool water does not have the buffering capacity as the buffer solutions do so the measurements are affected by all other chemicals, gases and stuff in the water. But again, this is just what i learned from my father who indeed was a chemist.


 

209
Online

8.9k
Users

9.6k
Topics

100.8k
Posts