Your suggestions to choose naming for "sensor" and "variable"


  • Plugin Developer

    Hello,
    MyController 2.0 is in the development stage. I hope we can do a pre-release soon.
    I do not want to limit MyController usage not only to the sensors world. can be used for another use case too.

    Example:

    • monitor stock market and act based on that
    • monitor GitHub issues, JIRA issues act based on that
    • Monitor an application on a computer
    • We have many use cases...

    The names should be generic and can be adaptable for all use cases.
    So we need a better common name for the sensor and variable.

    Current approach (In Version 1.x): Gateway >> Node >> Sensor >> Variable

    Sensor:

    • The sensor will be renamed as element
    • I need better naming here if this is not looking good

    Variable:

    • We cannot use the name variable, it is more confusing.
    • The Variable will be renamed as field (inputs are welcome)

    Please respond back with your suggestions

    between, Current work of MyController 2.0 deployed at https://demo-v2.mycontroller.org (Username:admin Password: admin)



  • Hello @jkandasa
    This is looking very good. Nomenclarture wise - I am of the opnion that users adapt but if you ask me I like sensor over element (but I can live with element as well).

    In future will it be possible port this to mobile apps for iOS and Android?

    One integration I would request is for HomeKit.

    Thank you


  • Plugin Developer

    @Puneit-Thukral Thanks for your suggestions

    In future will it be possible port this to mobile apps for iOS and Android?

    Mobile app is a long pending work for MyContorller. Yes, in future we have to develop.

    One integration I would request is for HomeKit.

    Sure, I add it in the note. Thanks!



  • Gateway >> Node >> Device >> Metrics

    Nodes have devices attached and each device has metrics.



Suggested Topics

121
Online

10.2k
Users

10.7k
Topics

109.5k
Posts