Scrambled UI - not reading sensors



  • Hi all,
    I've installed MyController on Intel Edison (x86 system). This worked successfully few months back when I tested but with 0.0.2-Alpha5 I get scrambled UI and the controller is not showing any activity towards the sensors. The log looks fine, serial port is discovered and serial gateway attached ...
    Please see screenshots & status page readout.

    Screenshot from 2016-01-02 22:11:47.png

    Operating System Linux
    Architecture i386
    Version/Kernel 3.10.17-yocto-standard-r2
    Available Process 2
    System Load Average 29.00 %
    System Cpu Load 0.00 %
    Process Cpu Load: 0.00 %, Time: 47710 milliseconds
    Physical Memory (RAM) Free: 790 MB, Total: 960 MB
    Swap Space Free: 0 MB, Total: 0 MB
    Committed Virtual Memory Size 132 MB
    User working directory /home/edison/mycontroller/bin
    Java Virtual Machine Specification:
    Java Home /bin/java/jre1.8.0_66
    Java Vendor Url http://java.oracle.com/
    VM Name Java HotSpot(TM) Client VM
    VM Vendor Oracle Corporation
    VM Version 25.66-b17
    Specification Vendor Oracle Corporation
    Specification Version 1.8
    Management Specification Version 1.2
    Up Time 17 minutes 47 seconds
    Heap Memory Used: 15 MB, Committed: 20 MB, Init: 8 MB, Max: 38 MB
    Non Heap Memory Used: 19 MB, Committed: 19 MB, Init: 0 MB, Max: n/a
    Threads Count Current: 33, Peak: 33, Total started: 42, Daemon: 13
    Class Loading Details Loaded: 4586, Unloaded: 28, Total loaded: 4614
    Garbage Collector - Copy Collection time: 579, Collection count: 28, Last GC duration: 35
    Garbage Collector - MarkSweepCompact Collection time: 554, Collection count: 4, Last GC duration: 213


  • Plugin Developer

    @Kurt

    If you try with old database it will not work. Database upgrade will not support on latest releases. You should start from fresh database.

    It looks like browser cash issue. Kindly try with 0.0.2-alpha6. If you still face the issue, refresh (press F5 from your keyboard) your browser. If no success clear your browser cache.



  • Thx!
    Turned out to be a combination of cached data and a power delivery problem at my gateway. All working fine now.
    Any hints at how to test the (guess alpha) MQTT broker?
    Kurt


  • Plugin Developer

    @Kurt said:

    Thx!
    Turned out to be a combination of cached data and a power delivery problem at my gateway. All working fine now.
    Any hints at how to test the (guess alpha) MQTT broker?
    Kurt

    @Kurt To use MySensors.org 1.6 dev branch MQTT gateway we should(I guess) have a MQTT broker. So I have added inbuilt MQTT broker to provide easy setup for users. Two options available for MQTT broker.

    • Use MyController.org MQTT broker (by default will be enabled, configuration will be available in mycontroller/conf/mycontroller.properties). You can modify or use default port number(1883)
    • Use external MQTT broker. In this case if you use external MQTT broker on the same machine, you should disable MQTT broker of MyController.org.

    You have to configure MQTT client details here mycontroller/conf/mycontroller.properties

    you have to change the following lines based on MySensors.org MQTT gateway configuration

    mcc.gateway.mqtt.topic.publish=mygateway-in
    mcc.gateway.mqtt.topic.subscribe=mygateway-out
    

 

178
Online

8.6k
Users

9.4k
Topics

99.1k
Posts