๐Ÿ’ฌ Building a Raspberry Pi Gateway



  • @Luc3as Thanks for your response. No, in fact it was not enabled. Please read my reply to gohan. As you see, I've cheated my way out of this problem. In the process, I've lost track of the SD card on which I encountered this problem. Nonetheless, I will circle back to test your suggestion.


  • Mod

    Try to enable the SPI first. Then you could also try different linux distributions and see which one you like better ( I personally like dietpi more than the others ). You may also want to try to use Mysensors library from development branch that is now 2.2.0.
    I now have a dietpi + mysensors 2.2.0 + nrf24 and all running fine



  • @marceloaqno said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    @Roberto-Mo-Ca If you are using the nrf24 PA/LNA version you need to use a 5V->3.3V regulator otherwise you can connect to the 3.3v pin.

    But why do we need to convert down from 5v to 3.3v? The pi does supply 3.3 on some pins.. Is this because the PA/LNA uses more mA?


  • Mod

    yes, the 3.3v can't supply enough current. I am using some small adapters that have the AMS1117 and some capacitors that allow for a quick swap of radio modules when you need test them



  • @gohan said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    yes, the 3.3v can't supply enough current. I am using some small adapters that have the AMS1117 and some capacitors that allow for a quick swap of radio modules when you need test them

    Ok. Maybe this should be mentioned in the documentation page.


  • Mod

    @subutux could you explain where you would expect to find that note?


  • Mod

    (obviously not here)
    0_1496838882911_image.png


  • Mod

    @subutux it is mentioned as stated above that you need it, it is just skipping all the info that are in datasheets and are not stricly necessary to make the gateway



  • @gohan said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    @subutux it is mentioned as stated above that you need it, it is just skipping all the info that are in datasheets and are not stricly necessary to make the gateway

    Well, I for one would like to know why we need to step-down from 5v to 3.3v. Just a simple statement that the LNA version requires more power that only the 5v can deliver on the pi.
    @mfalkvidd Yeah I would mention it there. It mentions to use a regulator but not why.. I've read that line & was like, why? That's when I've started a search in the forums here.


  • Mod

    @subutux I've updated the text. Do you think it is ok?



  • @mfalkvidd said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    @subutux I've updated the text. Do you think it is ok?

    yup! thanks!



  • Hi,
    I'm having trouble setting up mysensor with this configuration.
    Controler : Home assistant on a debian server. ip : 192.168.0.50
    Gateway : rpi3, connected to the server trought ethernet. ip : 192.168.0.21
    Sensor : simple door switch from the example scripts.

    On both sensor and gateway the transport is a nrf24l01+ module. I bought 4 of them and they all worked in simpler projects (on both arduino and rpi).

    The main problem is I can't get the rf24l01+ to work with mysensor. I checked the wiring multiple times a changed the module. Nothing changes.
    I also tried to change the configuration settings but it has no effect :

    I configured as :
    ./configure --my-transport=nrf24 --my-gateway=ethernet --my-controller-ip-address=192.168.0.50 --my-port=5003

    Here is what I got every time i launch mysgw :

    /MySensors $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.1.1
    mysgw: MCO:BGN:INIT GW,CP=RNNG---,VER=2.1.1
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: !TSM:INIT:TSP FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:PDT
    mysgw: TSM:FAIL:RE-INIT

    I used the wiring described in the script but without a voltage regulator. so I also checked the voltage received by the nrf24l01+ and it's a steady 3.3v.

    What's wrong here ? Any help would be greatly appreciated.

    --

    On another topic, home assistant doesn't seem to provide support for mysensor 2.1 protocol. Should I downgrade to 2.0 ?
    Obviously the controler can't connect to the gateway presently since the gateway isn't launching properly.
    Home assistant is constantly whining about it :

    Here is what I get from home automation console :

    Error (Thread-13) [mysensors.gateway_tcp] Failed to connect to socket at ('192.168.0.21', 5003).

    and here is my configuration.yaml extract :

    mysensors:
    gateways:
    - device: '192.168.0.21'
    optimistic: false
    persistence: true
    retain: true
    version: 2.0,



  • I just checked the wiring again and tested it with a voltage shifter I used for a grove RGB LCD and I got the same results


  • Mod

    @qkzk said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    --my-controller-ip-address=192.168.0.50

    I think you can ignore that parameter. Did you try making a USB gateway or ethernet gateway with an arduino? Why the voltage shifter? Did you add a capacitor on the 3.3v supply of the nrf24? You could also try with the 2.2.0 version from development branch that has some fixes



  • I tried the voltage shifter since I read : (*): If you are using the nrf24 PA/LNA version you need to use a 5V->3.3V regulator because the Raspberry Pi 3.3V can't supply enough power.
    Since I don't know the version...

    I had no success with an arduino USB gateway but I'll try again.

    I thought the controller-ip-adress=192.168.0.50 parameter was usefull otherwise the gateway would have to look guess where the controler is. I may have got everything wrong about who is initiating the dialogue. From what I read in home automation logs it's the controller who is looking for the gateway...

    I'll try the 2.2.0 version.



  • I managed to connect everything but not the way I would have prefered.
    Controler : Home assistant on debian server
    Gateway : arduino Uno connected to debian server trough usb serial
    Sensor : binary sensor (reed switch) on arduino mini.

    I'm still trying to figure what's wrong with what I posted earlier.



  • WOW ! It works ๐Ÿ™‚ thanks @gohan ๐Ÿ™‚
    I removed the voltage shifter, added an 1ยตF capacitor and downloaded developpement libraries.
    Also, I cleaned the configuration parameters : ./configure --my-transport=nrf24 --my-gateway=ethernet
    It finally works as expected (sensor, gw on rpi3, controler on debian server) and I can ditch the uno (well, I'll find him another use).
    Thanks again for the wonderfull work, it's been fun ๐Ÿ™‚


  • Mod

    Voltage regulator is strongly suggested when you are going to have the gw sending out messages and also a bigger capacitor will help



  • I'm trying to understand the need for a separate Gateway if the Ras Pi is the host of the controller. Is it possible to use OpenHab on the Pi AND have the RF transceiver connected to that same Pi and skip the ethernet adapter w/ Arduinos? Or, if you have to use ethernet, could you use localhost as the IP? Or is there a technical reason why that wouldn't work (or would work, but in a totally different way)? Thank you.


  • Mod

    Did you read the article?



  • @Andy-Pethan there is no need, where You read that ? I have a raspi with openhab and mqtt gw on single board. works very well.



  • @gohan @rozpruwacz After reading a couple times it still wasn't clear that everything could run on one device (single Ras Pi), though that seemed like the intuitive answer. Thank you for confirming as I buy up parts.



  • I figured out my problem -- I had the image and concept of this tutorial (http://www.instructables.com/id/Uber-Home-Automation-w-Arduino-Pi/) one tab over and never noticed at 3am that I mentally blended the articles. Sorry, everyone.


  • Mod

    In fact I was wondering what in the article wasn't clear.


  • Hardware Contributor

    Going crazy here.
    I did get success with MySensors and first Arduino node on a fresh Raspbian (last image) and branch development. All ok!

    Now I want re-do on other SD (same Pi, same WIring, same Radio). I did put "old" sd on a secure location and re-start from scratch.

    I did compile with:

    ./configure --my-transport=nrf24 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    and answer is:

    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=BCM2835, Type=rpi1, CPU=armv6l.
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
      [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    

    Make ends with no error.

    The debug

    sudo ./bin/mysgw โ€“d
    

    locks here:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    

    And no other lines.

    I Repeat, same PI, same Radio, same wiring. If I try other SD, all goes ok and I can use it on domoticz.

    Thank you


  • Hardware Contributor

    @sineverba

    @sineverba said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    Going crazy here.
    I did get success with MySensors and first Arduino node on a fresh Raspbian (last image) and branch development. All ok!

    Now I want re-do on other SD (same Pi, same WIring, same Radio). I did put "old" sd on a secure location and re-start from scratch.

    I did compile with:

    ./configure --my-transport=nrf24 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    and answer is:

    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=BCM2835, Type=rpi1, CPU=armv6l.
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
      [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    

    Make ends with no error.

    The debug

    sudo ./bin/mysgw โ€“d
    

    locks here:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
    

    And no other lines.

    I Repeat, same PI, same Radio, same wiring. If I try other SD, all goes ok and I can use it on domoticz.

    Thank you

    OK, re-re-done on fresh install and all went ok.

    I think that problem was when I deleted the PI default user and created another one.

    I did follow the gordon guide: https://gordonlesti.com/change-default-users-on-raspberry-pi/

    Probably a permission issues changing or not changing root?

    Thank you



  • Hi all

    Hope someone can help MySensors noob ๐Ÿ™‚ I try to do Raspberry pi 3 gateway with nrf24 module.

    Hardware:
    Raspberry pi 3
    nrf24 module
    3.3v 0.5A regulator.
    status leds (3pcs)
    Domoticz Beta

    I start with this instructions:
    https://www.mysensors.org/build/raspberry#improving-throughput-for-nrf24

    commands what i use:
    git clone https://github.com/mysensors/MySensors.git --branch master
    cd MySensors
    ./configure --my-transport=nrf24
    ./configure --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyMySensorsGateway (try ttyUSBMySensorsGateway too, but now help)
    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15
    ./configure --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18

    make
    sudo ./bin/mysgw -d

    After that i get error what is same to that instruction site:
    http://i.imgur.com/jpiaMdC.png

    I douple check wiring that seems to be all right. I think Linux console tell wrong wiring, if wiring is problem? But anyway i douple checked that wiring.

    Hope someone can help me with this problem.

    I try many times different settings, dont know do i need delete some old files or can i try again and again do configure and give "make" command.


  • Mod

    @lassivv please don't post the same question in multiple places. Posting in multiple places will result in people trying to help you in one place, even after the problem has been solved in the other place. That is a waste of people's time.

    Anyone trying to help @lassivv please post in https://forum.mysensors.org/topic/7050/multi-node-project-mysensors-noob-raspberry-gateway-problem



  • Sorry see this topic after i post my own topic, thinks this is better topic to my problems. But i continue my own topic.


  • Hardware Contributor

    I have a couple of nodes + PI working without issues from a couple of days.
    Now, I would add encryption / signing / security etc to protect traffic between Arduinos and PI.
    Could you please help me posting right configuration to add to the

    ./configure

    command?

    Thank you very much!



  • Why do Tx and Rx Leds blink every 5 to 6 seconds?

    Is it about communication between RPi and Gateway?

    Is there a way to disable it and keep blinks only with nodes communication?


  • Hardware Contributor

    @sineverba said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    I have a couple of nodes + PI working without issues from a couple of days.
    Now, I would add encryption / signing / security etc to protect traffic between Arduinos and PI.
    Could you please help me posting right configuration to add to the

    ./configure

    command?

    Thank you very much!

    Sorry..... I would UP! this ๐Ÿ™‚


  • Contest Winner

    @sineverba is there not a --help argument to get a list of settings?


  • Hardware Contributor

    @Anticimex sure... Bit I did read also the guide and .... I did noto understand very well whats I need to activate (if need) on gateway and on Arduinos to block, for example, the persone that live on third floor to play with my heater ..... ๐Ÿ™‚ thank you in advance

    PS security only software, no other hardware implied / want use

    Thank you!


  • Contest Winner

    @sineverba I am not sure I understand what you want. You want to enable signing? There is extensive documentation on how to enable that. As for what to pass to the configure command on a rPi I am unsure of the exact naming but I am pretty sure the names are very similar to the #define:s the signing documentation describes.


  • Hardware Contributor

    @Anticimex Yes, the doc is ... maybe ... too extensive ๐Ÿ™‚

    By the way, I would signing. So I need to do on both? Gateway/Raspberry and Arduino?

    Thank you


  • Contest Winner

    @sineverba I am not sure I understand how it can be too excessive? It sounds like it is inadequate since you still have questions. ๐Ÿ™‚
    Of course you have to enable signing on both node and gateway. You also need to personalize the services with a hmac key. This is described. Please read the docs carefully. And if they are unclear, please provide a link to the documentation you have read, so I can verify you read the correct one.


  • Hardware Contributor

    @Anticimex
    I'm talking about this: https://www.mysensors.org/about/signing

    Seems to me that probably need to be more clear your hint: you have to enable signing on both node and gateway.

    I hope that soon I will can test on my network ๐Ÿ™‚

    Thank you for the moment ๐Ÿ™‚


  • Contest Winner

    @sineverba yes, well that is for the official release so so far so good. I assume you also run the official version of the library and not the beta version, right?
    For details on rPi configuration, perhaps @marceloaqno can provide some assistance but you will find all information needed on that page for configuring signing on your nodes.


  • Hardware Contributor

    @Anticimex On Raspberry PI V1 I can work only with branch development. With master the radio / serial doesn't work


  • Contest Winner

    @sineverba then please use this documentation instead.


  • Hardware Contributor

    @Anticimex thank you but... it is not the same?


  • Contest Winner

    @sineverba no, it isn't. There are newer features on beta branch. A third simplified option for signing exist (and if you have a hard time figuring out signing I highly recommend you use it).


  • Hardware Contributor

    Raspberry PI V1 Model B (2 USB ports, no wifi, 26 GPIO).

    RASPBIAN JESSIE LITE v 2017-04-10-raspbian-jessie-lite.

    Some day ago I did compile the gateway only with development branch, using this:

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    And all works fantastic.

    Today I did try a new fresh installation for a friend, same PI, and same commands and routine from zero:

    1. Logged with PI
    2. Changed Password
    3. Activate SSH
    4. Activate SPI
    5. Expand Filesystem
    6. Changed timezone

    launched

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    No error on output, rebooted many times, gateways locked. See the screen:

    alt text

    With current setup (that works perfect), if I reconfigure to use Led TX/RX/Err, I get same lock.

    I have SD and a copy of it, but I would setup another one from zero.... and I cannot.

    Thank you


  • Hardware Contributor

    I don't want give up!

    I did download last RASPBIAN version (2017-06-21).
    Gitted from development branch...

    alt text

    My question is.... is it a problem of my PI? Too old? Need to buy the V3?

    I don't understand why some time ./configure works (and entire system with domoticz works without problem!!!) and other time no!

    @sineverba said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    Raspberry PI V1 Model B (2 USB ports, no wifi, 26 GPIO).

    RASPBIAN JESSIE LITE v 2017-04-10-raspbian-jessie-lite.

    Some day ago I did compile the gateway only with development branch, using this:

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    And all works fantastic.

    Today I did try a new fresh installation for a friend, same PI, and same commands and routine from zero:

    1. Logged with PI
    2. Changed Password
    3. Activate SSH
    4. Activate SPI
    5. Expand Filesystem
    6. Changed timezone

    launched

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    No error on output, rebooted many times, gateways locked. See the screen:

    alt text

    With current setup (that works perfect), if I reconfigure to use Led TX/RX/Err, I get same lock.

    I have SD and a copy of it, but I would setup another one from zero.... and I cannot.

    Thank you


  • Hardware Contributor

    Hi to all!
    I did another test, on a new SD with Raspbian Lite 2017-06-21.

    It doesn't work. Hangs on protocol version.

    But... I did note this, after ./configure

    Master branch

    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=unknown, Type=unknown, CPU=armv6l.
    [SECTION] Checking GPIO Sysfs.
      [OK] /sys/class/gpio/export found
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:SPIDEV.
    [SECTION] Detecting init system.
      [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    

    Development branch

    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=BCM2835, Type=rpi1, CPU=armv6l.
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
      [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    

    I'm going crazy ๐Ÿ˜ž

    @sineverba said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    I don't want give up!

    I did download last RASPBIAN version (2017-06-21).
    Gitted from development branch...

    alt text

    My question is.... is it a problem of my PI? Too old? Need to buy the V3?

    I don't understand why some time ./configure works (and entire system with domoticz works without problem!!!) and other time no!

    @sineverba said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    Raspberry PI V1 Model B (2 USB ports, no wifi, 26 GPIO).

    RASPBIAN JESSIE LITE v 2017-04-10-raspbian-jessie-lite.

    Some day ago I did compile the gateway only with development branch, using this:

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    And all works fantastic.

    Today I did try a new fresh installation for a friend, same PI, and same commands and routine from zero:

    1. Logged with PI
    2. Changed Password
    3. Activate SSH
    4. Activate SPI
    5. Expand Filesystem
    6. Changed timezone

    launched

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    

    No error on output, rebooted many times, gateways locked. See the screen:

    alt text

    With current setup (that works perfect), if I reconfigure to use Led TX/RX/Err, I get same lock.

    I have SD and a copy of it, but I would setup another one from zero.... and I cannot.

    Thank you


  • Mod

    Try DIETPI instead of raspian and see if it changes


  • Hardware Contributor

    @gohan
    I can and I will try, of sure. But, why do you think that something will change? My hardware is too old?



  • Can you look and see what power supply you are using and also tell us what you have connected to the pi?
    Do you have a volt meter and know how to use it?


  • Hardware Contributor

    @skywatch
    For a moment, I did hope that your was final solution.

    By the way, I have HDMI attached (but TV is off) and a hub usb (with nothing attached).

    I did try 7 sd cards.

    I did try also Samsung charger (ETA U90EWE) and a powerbank, both 5v/2a

    I have a cheap multimeter and I have basic knolewdge. What do you want I measure?

    The radio is firmed soldered on an header array and linked with jumpers:

    alt text

    No caps 'cause the nodes and gw can transmit without problem on over 15 meters on my home ๐Ÿ™‚

    Exact configuration with a 7-days-old installation works very well. If I try to replicate, with every combination (last raspi/previous raspi/master/development) sometimes works, I re-flash and doesn't work anymore.

    I'm not crazy, I would to be sure that in every moment I can replicate totally the configuration from scratch and... I want understand whats the problem!

    PS The config that works very well, If I try to reconfigure to use the LEDS, after configure hangs on same, same step of debug. Luckily, I use rpi-clone before every single edit on my so-precious configuration.

    PPS If someone wants, I could torrent my SD configured.... ๐Ÿ˜ž



  • OK! - Now I am not saying I have the solution to your problem, but I think it is worth ruling out a few things.

    If nothing is attached to the USB hub, disconnect it.
    With your voltmeter set to DC Volts, measure between TP1 and TP2 on the pi. You should see 5V DC. Up to about 5.5V is OK, but less than 4.8V can affect some things. Many time I have seen power issues be the problem.

    Why not wire the NRF24L01 direct to the pi?

    If all is well, then seems it is software problem after all ๐Ÿ˜‰


  • Hardware Contributor

    @skywatch

    Thank you for your support.
    So, I did disconnect everything.
    I did try and I have 4.95 - 4.98v on every moment, also during the "make" of ./configure.

    alt text

    A bit low, but I think no so low. The mysgw -d lock / hangs with every power supply...

    PS Radio between headers because I want learn skill solders and more easy swap to test others radio, and, last but not last, with headers dupont/wires are more firmly than directly on the radio.



  • That all seems to be OK - Always worth checking though if you ever get issues.
    That means that I am lost for any ideas on why you have problems with ./configure>make>make install. It seems odd. Do you have another pi to try it on? That's the only thing I can think of now....even a cheap pi zero would be OK for a test.

    I would still disconnect the USB hub and all the gpio wiring at the pi and see how it goes.

    Good Luck! ๐Ÿ™‚


  • Hardware Contributor

    @skywatch Unfortuntately not, it's only pi that I have.
    No problem, better to check everything. I don't know if open in github, leave here, pass to arduino connected via USB.....

    And.. for Arduino connected via USB, I need to abilitate something with raspi-config or the only thing to do is to connect and domoticz will read it? (of course with sketch gateway loaded on arduino!)



  • @OliverDog said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    Why do Tx and Rx Leds blink every 5 to 6 seconds?
    Is it about communication between RPi and Gateway?
    Is there a way to disable it and keep blinks only with nodes communication?

    Is there an answer for that?
    Thanks again



  • Hi and sorry for the question..
    I have been trying to build a gateway with a raspberry pi 1 and a radio module nrf24 + for several days without success. .I am analyzing step by step what I can be wrong..
    You can kindly indicate the exact command syntax ./configure I have to give?
    thank you so much


  • Mod

    Welcome to the MySensors community @pandy

    ./configure --my-transport=nrf24
    

    should be sufficient. What results did you get from the make and sudo ./bin/mysgw -d commands?



  • @mfalkvidd said in ๐Ÿ’ฌ Building a Raspberry Pi Gateway:

    ./configure --my-transport=nrf24

    Hi and thanks for the quick answer..
    This is the result of the command:

    [SECTION] Detecting target machine.
    [OK] machine detected: SoC=BCM2835, Type=rpi1, CPU=armv6l.
    [SECTION] Detecting SPI driver.
    [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
    [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.



  • The result of the "make" command is very long ..


  • Hardware Contributor

    @pandy

    On pi1 I cannot get a stable and re-doable configuration. See some post before.

    I finally swith to Arduino connected via USB. WOrks like a charme. Probably an issue with PI1.



  • the result of sudo ./bin/mysgw -d is :

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta

    and it blocks..


  • Mod

    @pandy that's definitely a problem. What linux are you using?


  • Hardware Contributor

    @pandy Same my problem.
    @gohan I did try also the DIETPI, how you did suggest to me some days ago. Only to say to @pandy let down the idea to use PI1. Use arduino usb/serial with your PI1.
    I did use several nights.... ๐Ÿ˜ž



  • Thanks to everyone for the answers and suggestions...
    At this point I think the problem is the raspberry type..
    I will try the suggested solution above otherwise I will be forced to change raspberry ..
    Thanks to everyone for help



  • @sineverba thank you for your suggestion..Do you have a link where I can find a tutorial for this system?
    thank you so much


  • Mod

    @pandy go for a new rpi3 that works very well.



  • Hello everyone!

    I am trying to use a NRF24 module on the SPI1 of a Raspberry2 (so that I can also use a touch tft on SPI0).

    I enabled it in the config.txt so that is lists under /dev/spidev1.0 - for conveniency I configured the CS0 to be at GPIO16=Pin36 (by using dtoverlay=spi1-1cs,cs0_pin=16).

    I use the dev branch of MySensors.git as the master branch does not recognize my Pi. I used this configure line:

    ./configure --my-rf24-channel=124 --my-rf24-irq-pin=29 --my-rf24-ce-pin=31 --my-rf24-cs-pin=36 --spi-driver=SPIDEV --spi-spidev-device=/dev/spidev1.0
    

    successful make
    but when I run the gateway in the shell with sudo ./bin/mysgw -d, I get the following:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.2.0-beta
    
    mysgw: MCO:BGN:INIT CP=RNNG--Q-
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: pinMode: invalid pin: 29
    mysgw: pinMode: invalid pin: 31
    mysgw: pinMode: invalid pin: 36
    mysgw: digitalWrite: invalid pin: 31
    mysgw: digitalWrite: invalid pin: 36
    mysgw: digitalPinToInterrupt: invalid pin: 29
    mysgw: digitalPinToInterrupt: invalid pin: 29
    mysgw: digitalWrite: invalid pin: 36
    

    Any ideas what I can do to make it work?



  • I think I might have found the root of the problem. The ./configure detects my Rpi2 as such (rpi2) but in the RPi.cpp in line 26 there is the pin to GPIO translation array and it is lacking translations for the high pin numbers - which is obviously wrong as on the RPi2 you have the extended GPIO connector with 40 pins...

    const static int pin_to_gpio_rev1[41] = {-1, -1, -1, 0, -1, 1, -1, 4, 14, -1, 15, 17, 18, 21, -1, 22, 23, -1, 24, 10, -1, 9, 25, 11, 8, -1, 7, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1 };
    const static int pin_to_gpio_rev2[41] = {-1, -1, -1, 2, -1, 3, -1, 4, 14, -1, 15, 17, 18, 27, -1, 22, 23, -1, 24, 10, -1, 9, 25, 11, 8, -1, 7, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1 };
    const static int pin_to_gpio_rev3[41] = {-1, -1, -1, 2, -1, 3, -1, 4, 14, -1, 15, 17, 18, 27, -1, 22, 23, -1, 24, 10, -1, 9, 25, 11, 8, -1, 7, -1, -1, 5, -1, 6, 12, 13, -1, 19, 16, 26, 20, -1, 21 };
    

    I copied the rev3 array to the rev2 array and compiled this and it seems to work in my case!



  • @Velo17 Thank you! I had been pulling my hair out over this issue on installing a new RPi2 setup.


  • Mod

    Adding link to the github issue (thanks for creating!) for future reference
    https://github.com/mysensors/MySensors/issues/895



  • I just noticed that mysgw is constantly consuming 95-100% CPU here. This even happens when I unplug the NRF24 module so that after starting mysgw basically nothing happens. Running development branch. Hmmmm. Any idea what to check?


  • Mod

    @Velo17 strace might be able to help:

    sudo strace ./bin/mysgw -d
    

    Could you post your configure command? I'd like to try to reproduce the problem. I have a gateway with development from git as of about 2 weeks ago (a9418271) but I'm not using the nrf24. That gateway uses about 2% cpu on my Raspberry Pi 1. There have only been 6 commits since I built my gateway but I can update it and see if it starts acting up.

    On my gateway, strace outputs loads and loads of these:

    gettimeofday({1501098316, 668956}, NULL) = 0
    ioctl(6, FIONREAD, [0])                 = 0
    gettimeofday({1501098316, 671383}, NULL) = 0
    gettimeofday({1501098316, 672447}, NULL) = 0
    gettimeofday({1501098316, 673818}, NULL) = 0
    nanosleep({0, 10000000}, NULL)          = 0
    gettimeofday({1501098316, 685602}, NULL) = 0
    getsockopt(6, SOL_TCP, TCP_INFO, "\1\0\0\0\0\7g\1P4\3\0@\234\0\0\250\5\0\0\30\2\0\0\0\0\0\0\0\0\0\0"..., [104]) = 0
    getsockopt(6, SOL_TCP, TCP_INFO, "\1\0\0\0\0\7g\1P4\3\0@\234\0\0\250\5\0\0\30\2\0\0\0\0\0\0\0\0\0\0"..., [104]) = 0
    gettimeofday({1501098316, 689179}, NULL) = 0
    ioctl(6, FIONREAD, [0])                 = 0
    

    Also, which git hash are you using? (git log -1)

    Another thing to try could be to enable all the debug flags in MyConfig.h and see if they give you something interesting.


  • Mod

    I updated my gateway to 10ef623 (latest from git). Still works ok.



  • @mfalkvidd I make / make install a couple of times and maybe did a git pull inbetween as well - now everything is back to normal again. Thank you for giving me some dbug tips for the next issue ๐Ÿ™‚

    My strace output looks similiar.

    My configure line is

    ./configure --my-rf24-channel=124 --my-rf24-irq-pin=29 --my-rf24-ce-pin=31 --my-rf24-cs-pin=36 --spi-driver=SPIDEV --spi-spidev-device=/dev/spidev1.0 --my-debug=disable
    


  • Should be possible to connect two radio modules and run two instances at the same time?
    It could be interesting to have a hat with nrf+rfm, all in one.


  • Mod

    @Sergio-Rius it would be great if you could contribute to making that a reality.
    An earlier discussion on the same topic: https://forum.mysensors.org/topic/4151/nrf24l01-and-rfm69-on-one-gw/

    So far, people have found it easier to add a separate gateway for each transport.



  • @mfalkvidd thanks for guiding me on the starting point. Perhaps the raspberry can break the doble transport limitation.
    I'll investigate in how to install two services at once. But it'll would be nice any advice on the device virtualization part.


  • Mod


  • Mod

    Maybe it could be as simple as running two instances of mysgw, using different pins for the nrf and the rfm?



  • @mfalkvidd Maybe. I'm programmer, but not for Linux. My concern is the part of the service that creates the virtual device colliding between the instances.
    I'll do a test in a virtual machine as soon as I have some time.
    It should be something easy to test.


  • Mod

    @Sergio-Rius by "virtual device", do you mean the com port? If that's the caee, it can be specified with --my-serial-pty=

    Ot let one gateway be serial and the other ethernet.



  • @mfalkvidd yes. Should work. I admit I've not taken a look at the code nor I don't know how to install the service two times.
    I'm used to having problems with programs that use static resources allocation. But I don't know if that's the case.


  • Mod

    maybe you could also consider making 2 ethernet gateway one on port 5003 and the other on port 5004 so that you can use myscontroller to debug from remote.



  • Hi guys couple of questions, apologies if they have been covered elsewhere.
    I am running latest dev branches of domoticz and MYS on a pi2.
    At random times it seems the NRF24L01+ LNA/PA goes down, or MYS goes down and domotics stops receiving signals from all of the nodes at the same time. I have the interrupt feature enabled.
    I have set the option under domoticz/hardware/data timeout to restart if no data received in five minutes but I dont think this is an ideal solution, and have yet to find out if this domoticz feature actually works in my scenario.
    Any idea what causes this? I found an old thread over on the domoticz/mysensors forum but no answers there. I am using a new sd card class 10.
    What I want to do is try out the different MYS builds on domoticz ie MQTT and SERIAL as well as ethernet which I am currently running. However I'm not sure how to stop the current MYS service and completely clean up the current build to start from scratch... I have tried just re entering the ./configure commands then 'make' but this does not seem to work.
    Many thanks,
    Matt


  • Mod

    @Matt log files for the time where the problem occurred will be essential for troubleshooting.

    make uninstall will stop the service and uninstall
    make cleanconfig will remove previous ./configure settings
    make clean will remove compiled code



  • @ccy that correction to the detect_machine function was necessary on my Rpi 3 too (I took the latest version from master). I got it working with that addition.
    Soooo I guess that would be worth adding to the code / opening an issue on github, wouldn't it?



  • I'm just now testing the two instances installation. I was going to just alter the flag --prefix but now I see in options that there's also the install dir:

    Installation options:
        --prefix=<PREFIX>           Installation prefix path. [/usr/local]
        --gateway-dir=<DIR>         Gateway files installation directory. [PREFIX/bin]
    

    What do you think should be the preferred way for installing two instances, only changing --gateway-dir?



  • @mfalkvidd OK thanks for your reply.
    Have set up the -d parameter in mysgw.servie and am waiting for it to fall over again.
    If I catch it I will post syslog.
    Thanks,
    Matt



  • Seems that I'll need some help for getting this properly done.
    I can't launch two instances of the service.

    What I've done is following the guide instructions with the following configuration:

    ./configure \
     --my-transport=nrf24 \
     --my-rf24-irq-pin=18 \
     --my-gateway=ethernet --my-port=5003 \
     --prefix=/opt/mysgw-nrf
    

    Then manually executed it, and it run ok and get one test node connected and Domoticz saw it all.

    Then I duplicated the MySensors folder and in there made the build with the following configuration:

    ./configure \
     --my-transport=nrf24 \
     --my-rf24-channel=82 \
     --my-rf24-ce-pin=37 \
     --my-rf24-cs-pin=36 \
     --my-rf24-irq-pin=33 \
     --my-gateway=ethernet --my-port=5004 \
     --prefix=/opt/mysgw-rfm
    

    Even when it says rfm, i connected a second NRF with the following pinout (blue=first NRF, green=second):
    0_1501511919817_Pinouts.png
    *IRQ on pin 33 as config says, and power from 1.

    Then I tried to make and run and I get this output:

    pi@domo_testing:~/MySGW_RFM $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.2.0-beta
    
    mysgw: MCO:BGN:INIT CP=RNNG--Q-
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: pinMode: invalid pin: 33
    mysgw: pinMode: invalid pin: 37
    mysgw: pinMode: invalid pin: 36
    mysgw: digitalWrite: invalid pin: 37
    mysgw: digitalWrite: invalid pin: 36
    mysgw: You need root privilege to use SPI.
    

    Is that I have to connect MOSI and MISO to the same pins that the first NRF?


  • Mod



  • @mfalkvidd That was the culprit. Thanks.
    But now... seems that the radio that is using channel 76 also get connections from nodes on channel 83, and the second radio, the 83 one doesn't pick anything.

    Is there a way to confirm that gw and nodes are using one channel or other during the bootup?


  • Mod

    @Sergio-Rius try increasing the distance between channels to at least 10 or more



  • @gohan Done. I've just burnt the node with channel 125 and it seems to have no effect. It registers on the 76 radio.

    Does the #define MY_RF24_CHANNEL 125 has to be before or after the include of mysensors.h? I have it before.



  • Well, I've changed the channel for the 1st radio to 83 and left the second at 125.
    If I burn the testing node for ch125 it doesn't receives reply from the gw. If I then burn it on ch83, it registers and comunicates with the first radio.

    So I think the second radio does not work on the Raspberry Pi. The service communicates with the controller but does nothing for the network side.
    Also on the second radio:

    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: !TSF:SAN:FAIL
    mysgw: TSM:FAIL:CNT=1
    mysgw: TSM:FAIL:DIS
    mysgw: TSF:TDI:TSL
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: TSM:FAIL:RE-INIT
    mysgw: TSM:INIT
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    

  • Mod

    @Sergio-Rius if you shut down mysgw for the first radio and restart mysgw for the second radio, does the second radio start to work?
    And do you get the same debug output? The SPI message looks bad. Maybe the two gateways are conflicting.



  • @mfalkvidd Nope, the service seems to have stopped the SAN errors but still no communication:

    pi@domo_testing:~/MySGW_RFM $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-beta
     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.2.0-beta
    
    mysgw: MCO:BGN:INIT CP=RNNG--Q-
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: Listening for connections on 0.0.0.0:5004
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    mysgw: New connection from 127.0.0.1
    mysgw: Client 0 connected
    mysgw: Client 0: 0;0;3;0;2;
    mysgw: Client 0: 0;0;3;0;2;Get Version
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: Client 0: 0;0;3;0;18;PING
    
    0 MCO:BGN:INIT NODE,CP=RNNNA--,VER=2.1.1
    4 TSM:INIT
    4 TSF:WUR:MS=0
    12 TSM:INIT:TSP OK
    14 TSF:SID:OK,ID=1
    16 TSM:FPAR
    51 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2060 !TSM:FPAR:NO REPLY
    2062 TSM:FPAR
    2099 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4106 !TSM:FPAR:NO REPLY
    4108 TSM:FPAR
    4145 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6152 !TSM:FPAR:NO REPLY
    6154 TSM:FPAR
    6191 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8198 !TSM:FPAR:FAIL
    8200 TSM:FAIL:CNT=1
    8202 TSM:FAIL:PDT
    18206 TSM:FAIL:RE-INIT
    18208 TSM:INIT
    18214 TSM:INIT:TSP OK
    18219 TSF:SID:OK,ID=1
    18221 TSM:FPAR
    18257 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20267 !TSM:FPAR:NO REPLY
    20269 TSM:FPAR
    20305 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    22315 !TSM:FPAR:NO REPLY
    22317 TSM:FPAR
    22353 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24363 !TSM:FPAR:NO REPLY
    24365 TSM:FPAR
    24401 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    26411 !TSM:FPAR:FAIL
    26413 TSM:FAIL:CNT=2
    26415 TSM:FAIL:PDT
    36419 TSM:FAIL:RE-INIT
    36421 TSM:INIT
    36427 TSM:INIT:TSP OK
    36431 TSF:SID:OK,ID=1
    36433 TSM:FPAR
    36470 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    38479 !TSM:FPAR:NO REPLY
    38481 TSM:FPAR
    38518 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    40527 !TSM:FPAR:NO REPLY
    40529 TSM:FPAR
    40566 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    42575 !TSM:FPAR:NO REPLY
    42577 TSM:FPAR
    42614 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    44623 !TSM:FPAR:FAIL
    44625 TSM:FAIL:CNT=3
    

    You find the pinouts I send before are right to you?


  • Mod

    MY_* defines need to be before #include MySensors.h so you're doing the right thing.
    I don't know about the pins, have never used anything but the default wiring myself. But if the pins were wrong you should get TSM:INIT:TSP FAIL instead of TSM:INIT:TSP OK.

    If you reconfigure the first mysgw (the one with the default pins) to use channel 83, does communication with the node on channel 83 work?



  • @mfalkvidd yeah, look three posts before.
    I'll try to get mosi and miso from the default pin out sharing with the first radio. Now I'm using the ones marked as 1, when the default ones are marked 0.


  • Mod

    @Sergio-Rius I see. Sorry. Then we know the channel parameter works. Good testing.
    Strange problem. It looks from the threads I linked earlier that using the second SPI does indeed work (if the pin definition fix is applied). When the first mysgw is stopped, your second mysgw should behave just as it did for Velo17 and wergeld. Can you think of any difference in your setup?



  • @mfalkvidd I have the impression that if I stop the first service, the second picks the first radio.
    I disconnected the power from the first radio and left the second all connected and I only got TSM errors and fails. As soon as I attached power to the first NRF it worked.
    Perhaps the other users only used the configurable pins (CS/CE/IRQ) on the extended bank...


 

305
Online

8.9k
Users

9.7k
Topics

101.3k
Posts