MySensors Ethernet Gateway goes to OFFLINE state



  • Event log:
    2016-11-22 18:57:07.915 [hingStatusInfoChangedEvent] - 'mysensors:humidity:dd0f7b9e' changed from UNINITIALIZED to INITIALIZING
    2016-11-22 18:57:07.928 [hingStatusInfoChangedEvent] - 'mysensors:humidity:dd0f7b9e' changed from INITIALIZING to UNINITIALIZED (HANDLER_INITIALIZING_ERROR): org.eclipse.smarthome.core.thing.Bridge.getHandler()Lorg/eclipse/smarthome/core/thing/binding/BridgeHandler;

    And Openhba log:

    2016-11-22 18:57:07.924 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occured while initializing handler of thing 'mysensors:humidity:dd0f7b9e': java.lang.NoSuchMethodError: org.eclipse.smarthome.core.thing.Bridge.getHandler()Lorg/eclipse/smarthome/core/thing/binding/BridgeHandler;
    java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: org.eclipse.smarthome.core.thing.Bridge.getHandler()Lorg/eclipse/smarthome/core/thing/binding/BridgeHandler;
    at java.util.concurrent.FutureTask.report(FutureTask.java:122)[:1.8.0_101]
    at java.util.concurrent.FutureTask.get(FutureTask.java:206)[:1.8.0_101]
    at org.eclipse.smarthome.core.common.SafeMethodCaller.callAsynchronous(SafeMethodCaller.java:186)[96:org.eclipse.smarthome.core:0.9.0.201611102032]
    at org.eclipse.smarthome.core.common.SafeMethodCaller.call(SafeMethodCaller.java:79)[96:org.eclipse.smarthome.core:0.9.0.201611102032]
    at org.eclipse.smarthome.core.common.SafeMethodCaller.call(SafeMethodCaller.java:63)[96:org.eclipse.smarthome.core:0.9.0.201611102032]
    at org.eclipse.smarthome.core.thing.internal.ThingManager$9.run(ThingManager.java:761)[103:org.eclipse.smarthome.core.thing:0.9.0.201611102032]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_101]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_101]
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)[:1.8.0_101]
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)[:1.8.0_101]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101]
    at java.lang.Thread.run(Thread.java:745)[:1.8.0_101]
    Caused by: java.lang.NoSuchMethodError: org.eclipse.smarthome.core.thing.Bridge.getHandler()Lorg/eclipse/smarthome/core/thing/binding/BridgeHandler;
    at org.openhab.binding.mysensors.internal.handler.MySensorsThingHandler.getBridgeHandler(MySensorsThingHandler.java:284)
    at org.openhab.binding.mysensors.internal.handler.MySensorsThingHandler.initialize(MySensorsThingHandler.java:74)
    at org.eclipse.smarthome.core.thing.internal.ThingManager$9$1.call(ThingManager.java:764)
    at org.eclipse.smarthome.core.thing.internal.ThingManager$9$1.call(ThingManager.java:1)
    at org.eclipse.smarthome.core.common.SafeMethodCaller$CallableWrapper.call(SafeMethodCaller.java:177)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_101]
    ... 3 more



  • Update:

    I started from the scratch. I installed debian MATE and OH2-offline snapshot. I put the org.openhab.binding.mysensors-2.0.0-SNAPSHOT.jar into addons folder. I started openhab2 and after a while I got MySensors Ethernet Gateway and Temperature and Humidity Sensors ONLINE state.

    But still I cannot see any temperature nor humidity values from my sensors!

    Here is the Karaf Log after I pressed MySensorsGateway Reset button:

    08:35:40.194 [ERROR] [otocol.MySensorsNetworkSanityChecker] - Retry period expired, gateway is down. Disconneting bridge...
    08:35:40.196 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Request disconnection flag setted to: true
    08:35:44.213 [INFO ] [al.protocol.ip.MySensorsIpConnection] - Connection request disconnection...
    08:35:44.215 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Request disconnection flag setted to: false
    08:35:44.217 [INFO ] [otocol.MySensorsNetworkSanityChecker] - Network Sanity Checker thread stopped
    08:35:44.223 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Disconnecting from IP bridge ...
    08:35:44.227 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Stopping Writer thread
    08:35:44.241 [ERROR] [rs.internal.protocol.MySensorsWriter] - (java.lang.InterruptedException) on writing from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorsIpWriter
    08:35:44.244 [DEBUG] [rs.internal.protocol.MySensorsReader] - Stopping Reader thread
    08:35:44.246 [ERROR] [rs.internal.protocol.MySensorsReader] - (java.lang.InterruptedException: sleep interrupted) on reading from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorIpReader
    08:35:44.261 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to OFFLINE for device: mysensors:humidity:a825a6a7
    08:35:44.263 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Connecting to IP bridge [192.168.1.201:5003]
    08:35:44.267 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to OFFLINE for device: mysensors:temperature:43712fbc
    08:35:44.295 [WARN ] [al.protocol.ip.MySensorsIpConnection] - Skipping I_VERSION connection test, not recommended...
    08:35:44.305 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:temperature:43712fbc' changed from ONLINE to OFFLINE
    08:35:44.305 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:humidity:a825a6a7
    08:35:44.313 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:temperature:43712fbc
    08:35:44.325 [INFO ] [al.protocol.ip.MySensorsIpConnection] - Successfully connected to MySensors Bridge.
    08:35:44.349 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:d18f7f4c' changed from ONLINE to OFFLINE
    08:35:44.354 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:humidity:a825a6a7' changed from ONLINE to OFFLINE
    08:35:44.361 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:bridge-eth:d18f7f4c' changed from OFFLINE to ONLINE
    08:35:44.373 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:humidity:a825a6a7' changed from OFFLINE to ONLINE
    08:35:44.392 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'mysensors:temperature:43712fbc' changed from OFFLINE to ONLINE
    08:35:54.341 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped

    So what to do next?



  • I think that your sensor will be online also when your node are switched off. I am working with SerialGateway not with ethernet, so I am not sure.

    Can you send us your .things and your .items? Have you write or automatically discover them?

    And output from your node?
    Keep the sensor connected to your computer and enable the Serial Monitor in the Arduino IDE. Tools>Serial Monitor.



  • Openhab2 detected things automatically, I don't use my own. Here is the sensor node monitor listing:

    B´AÚXStarting sensor (RNNNA-, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=9)
    TSM:FPAR
    TSP:MSG:SEND 9-9-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 9-9-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 9-9-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSP:MSG:READ 0-0-9 s=255,c=3,t=8,pt=1,l=1,sg=0:0
    TSP:MSG:FPAR RES (ID=0, dist=0)
    TSP:MSG:PAR OK (ID=0, dist=1)
    TSM:FPAR:OK
    TSM:ID
    TSM:CHKID:OK (ID=9)
    TSM:UPL
    TSP:PING:SEND (dest=0)
    TSP:MSG:SEND 9-9-0-0 s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=ok:1
    TSP:MSG:READ 0-0-9 s=255,c=3,t=25,pt=1,l=1,sg=0:1
    TSP:MSG:PONG RECV (hops=1)
    TSP:CHKUPL:OK
    TSM:UPL:OK
    TSM:READY
    TSP:MSG:SEND 9-9-0-0 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=ok:0100
    !TSP:MSG:SEND 9-9-0-0 s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=fail:2.0.0
    TSP:MSG:SEND 9-9-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,ft=1,st=ok:0
    TSP:MSG:SEND 9-9-0-0 s=255,c=3,t=11,pt=0,l=10,sg=0,ft=0,st=ok:My Bedroom
    TSP:MSG:SEND 9-9-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=ok:1.0
    TSP:MSG:SEND 9-9-0-0 s=10,c=0,t=7,pt=0,l=0,sg=0,ft=0,st=ok:
    TSP:MSG:SEND 9-9-0-0 s=11,c=0,t=6,pt=0,l=0,sg=0,ft=0,st=ok:
    TSP:MSG:SEND 9-9-0-0 s=1,c=0,t=3,pt=0,l=0,sg=0,ft=0,st=ok:
    Request registration...
    TSP:MSG:SEND 9-9-0-0 s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=ok:2
    TSP:MSG:READ 0-0-9 s=255,c=3,t=27,pt=1,l=1,sg=0:1
    Node registration=1
    Init complete, id=9, parent=0, distance=1, registration=1
    !TSP:MSG:SEND 9-9-0-0 s=11,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=fail:21.8
    T: 21.80
    TSP:MSG:SEND 9-9-0-0 s=10,c=1,t=1,pt=7,l=5,sg=0,ft=1,st=ok:24.2
    H: 24.20
    TSP:MSG:SEND 9-9-0-0 s=10,c=1,t=1,pt=7,l=5,sg=0,ft=0,st=ok:24.6
    H: 24.60
    TSP:MSG:SEND 9-9-0-0 s=11,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=ok:21.9
    T: 21.90
    TSP:MSG:SEND 9-9-0-0 s=10,c=1,t=1,pt=7,l=5,sg=0,ft=0,st=ok:25.4
    H: 25.40
    TSP:MSG:SEND 9-9-0-0 s=11,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=ok:22.0
    T: 22.00
    !TSP:MSG:SEND 9-9-0-0 s=10,c=1,t=1,pt=7,l=5,sg=0,ft=0,st=fail:25.3
    H: 25.30

    It is operating normally and it send both temperature and humidity values.



  • @pentti12
    everytime you see a SEND message in the node debug log, you should also see a READ message in your gateway. And than you should also see a SEND message to the controller and a message coming in in your openhab binding.
    So would you mind start logging all three stages of the message at the same time as I showed several posts before? If you don't see incoming messages in the binding log there is something wrong with your ethernet connection. Otherwise it's only guessing whats wrong.



  • Before I set up full logging environment, I wonder why I cannot get connection when I enter following command on the terminal window of OH2 server (Pine64):

    telnet localhost 5003

    unable to connect to remote host



  • I didn't see in your node log an ip assignament. Are your sketch configured to Ethernet Gateway?

    I think you should use some parameters:

    // Enable MY_IP_ADDRESS here if you want a static ip address (no DHCP)
    #define MY_IP_ADDRESS 192,168,178,87

    // If using static ip you need to define Gateway and Subnet address as well
    #define MY_IP_GATEWAY_ADDRESS 192,168,178,1
    #define MY_IP_SUBNET_ADDRESS 255,255,255,0

    // MQTT broker ip address or url. Define one or the other.
    //#define MY_CONTROLLER_URL_ADDRESS "m20.cloudmqtt.com"
    #define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 68

    I am not sure how to use Ethernet Gateway, perhaps this example help you

    https://github.com/mysensors/MySensors/blob/development/examples/GatewayW5100MQTTClient/GatewayW5100MQTTClient.ino



  • I am not using the MQTT gateway, I am using standard GatewayW5100.ino, which has correct IP-settings:

    #define MY_IP_ADDRESS 192,168,1,201 // If this is disabled, DHCP is used to retrieve address
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003

    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    #define MY_CONTROLLER_IP_ADDRESS 192, 168, 1, 185

    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED

    And MySensors Ethernet Gateway is detected by Advanced IP Scanner and I can ping it and so on..



  • @pentti12

    the gateway is the server. You should succeed with telnet <ip_of_mysensors_gw> 5003



  • @pentti12

    Can you start manually your gateway with -d option to see the log?

    You should see there if your gateway its receiving messages. If you are receiving message then, the problem should be in the OH2



  • @Jic
    what do you mean with "start gateway manually -d option"? My gateway is a standalone device, ethernet connector on one side, nrf24 on the other, arduino in the middle connecting the other two parts.



  • Wait a minute! I think that from the original GatewayW5100 sketch there were missing the IP Gateway and subnet addresses!

    So I will recompile sketch and test again.



  • @pentti12

    slowly my image gets complete. Online/Offline status is resolved by OH2 binding via polling during initialization. Value updates are sent spontaneous by the gateway via callback, afair. So the gateway needs to know the address and mask of the controller to send values.



  • No help after new sketch loaded into GatewayW5100. OH2 log informs the same result:

    14:49:09.484 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped

    I will take a break - to be continued on next day...



  • @pentti12
    "connection skipped" message occurs frequently, usually every 10 seconds. That is normal and ok. But you should see messages from the gateway everytime the sensor nodes send updates, except the value is the same as before.



  • I connected my laptop into Ethernet Gateway. Here is a sample of monitoring listing:

    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.4
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=11,c=1,t=0,pt=7,l=5,sg=0:21.9
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.5
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=11,c=1,t=0,pt=7,l=5,sg=0:22.0
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=11,c=1,t=0,pt=7,l=5,sg=0:21.9
    0;255;3;0;9;TSP:SANCHK:OK
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.6
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.4
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.5
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.4
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.5
    0;255;3;0;9;TSP:SANCHK:OK
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.5
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.6
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.7
    0;255;3;0;9;TSP:SANCHK:OK
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.7
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=11,c=1,t=0,pt=7,l=5,sg=0:21.8
    0;255;3;0;9;TSP:MSG:READ 9-9-0 s=0,c=1,t=0,pt=7,l=5,sg=0:30.8

    So I think that this is OK, when I have only one sensor node alive.

    But still, how I shall modify my Arduino Gateway sketch in order to get OH2 server show temperature and humidity values?



  • @pentti12

    Could be permission problem?
    Can you connect your gateway on rpi and execute

    ls -l /dev/tty*
    

    I think you are using a ethernet gateway skecth, normaly it's should be mounted in /dev/ttyACM0

    Have you already execute

    sudo usermod -a -G dialout openhab
    

    Be sure that you have the las binding
    https://github.com/tobof/openhab2-addons/blob/MySensors/addons/binding/org.openhab.binding.mysensors/target/org.openhab.binding.mysensors-2.0.0-SNAPSHOT.jar
    and your openhab2 is updated.



  • I am running the Ethernet GatewayW5100 software on Arduino UNO. I don't have rpi, I have installed OH2 on Pine64. It is running debian Jessie and it is uptodate. Also the latest mysensors binding is in use. So what to next?



  • @pentti12 I am confused.

    Don't you need to connect your Ethernet GatewayW5100 by USB into your pine64?



  • OK, now Gateway is connected via USB into Pine64 and it is shown as /dev/ttyUSB0.



  • @pentti12 said:

    /dev/ttyUSB0

    Now, you need to configure your binding in your OH2?
    https://github.com/tobof/openhab2-addons/wiki/Configuration



  • I added into demo.things following line:

    Bridge mysensors:bridge-ser:gateway [ serialPort="dev/ttyUSB0", sendDelay=200 ] {

    In OH2 MySensor Serial Gateway stays OFFLINE state now. And also the Philips HUE things went OFFLINE state even if they have their own Bridge.

    Looks bad!



  • @pentti12 This configuration is for a Serial Gateway connected to GPIO, I think.

    You should use this one

    Bridge mysensors:bridge-eth:gateway [ ipAddress="127.0.0.1", tcpPort=5003, sendDelay=200 ] {
         /** define things connected to that bridge here */
      }
    

    But at this point I am really confused, I don't know how Ethernet Gateway works. I am not sure when I can help you.

    Do you need configure you ESSID and password of your WIFI in your sketch? or the ethernet Gateway geneate their own network?



  • Now I am confused, why I should bridge Ethernet Gateway, if I have USB-connection to MySensors Gateway only?

    I tried to use Ethernet Gateway connected into my local IP-network without success, so I think that I will end this work to this point. There seems no good instructions available what is missing or wrong on the MySensors openhab binding..



  • @pentti12

    Ok, sorry, I think I was wrong.
    Here has a similar example
    http://www.makeuseof.com/tag/diy-smart-home-sensors-arduino-mysensors-openhab/
    Could you try connecting it again separately, and configure in your OH2 and ethernet binding with the ip from your gatweay?



  • Can someone explain, why I cannot get real values from MySensors node, which has only temperature and humidity sensors?

    I can get the MySensors Ethernet Gateway into ONLINE STATE. I can get humidity and Temperature Sensors ONLINE STATE, but I cannot get real values from the node.

    What I see from OpenHAB2 log side is:

    09:31:45.356 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    09:31:45.375 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped
    09:31:48.356 [WARN ] [otocol.MySensorsNetworkSanityChecker] - I_VERSION message response is not arrived. Remained attempts before disconnection 1
    09:31:55.377 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped
    09:32:05.380 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped

    I think that there must be some error in MySensors Binding at the moment, because for example the Philips HUE bridge is working corretly via Openhab2 in the same Pine64 controller.



  • @pentti12

    This message is, following the information

    https://www.mysensors.org/download/serial_api_20

    node-id ; child-sensor-id ; message-type ; ack ; sub-type ; payload \n
    0; ;0 ;3 ;0 ;2 ;

    A message-type=3 means an internal message of the protocol
    Sub-type=2 means that it is ascking for the gateway version.

    You can find here how to disable it using skipStartupCheck=true
    https://github.com/tobof/openhab2-addons/wiki/Configuration

    Bridge mysensors:bridge-eth:gateway [ ipAddress="127.0.0.1", tcpPort=5003, sendDelay=200, skipStartupCheck=true ] {
         /** define things connected to that bridge here */
      }
    

    I hope this help you.


  • Hero Member

    Hey @pentti12!

    Which gateway are you using? Serial or Ethernet? You can't use the ethernet gateway via serial connection.

    Which sketch are you using?

    If you are using ethernet gateway sketch but used the serial connection this would explain why the binding could not get any response.



  • I am using Ethernet Gateway in my LAN. Gateway has static IP and it is accessible (ping works). Also port number 5003 is detected correctly.

    I am using standard GatewayW5100.ino sketch.

    How can I force OH2 to use only Ethernet-connection?


  • Hero Member

    Have you configured the gateway in the *.things file? How does it look?



  • Hello to all.

    I have similar problems as pentti12.
    Can not get values updated in OH2, there are always -NAN
    While with serial connection I get some reads in the log file, with eth connection I can't see any reads from gw.

    I've installed everything as per wiki several times without success.
    Radio connection between gw and nodes is running without problems.
    Previous testing gw with w5100MQTTClient sketch, was running perfectly

    My configuration:
    MySensors Binding: 2.0.0.201611221149
    OH2: 2.0.0-SNAPSHOT Build #629 running on debian
    gw: Arduino Uno with W5100 sketch
    Node: arduino nano with temp and humidity sensor.

    Could somebody help me in this.

    Regards!

    *** Debug for serial connection without skipping I-Version check
    2016-12-05 22:06:22.608 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/ttyUSB0 [baudRate:115200]
    2016-12-05 22:06:22.634 [DEBUG] [col.serial.MySensorsSerialConnection] - Final port list: /dev/ttyUSB0
    2016-12-05 22:06:22.664 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
    2016-12-05 22:06:22.664 [DEBUG] [col.serial.MySensorsSerialConnection] - Waiting 3 seconds to allow correct reset trigger on serial connection opening
    2016-12-05 22:06:25.665 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    2016-12-05 22:06:25.667 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:INIT
    2016-12-05 22:06:25.667 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:RADIO:OK
    2016-12-05 22:06:25.668 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:GW MODE
    2016-12-05 22:06:25.669 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:READY
    2016-12-05 22:06:25.669 [DEBUG] [rs.internal.protocol.MySensorsReader] - IP: 192.168.1.66
    2016-12-05 22:06:25.865 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:06:26.665 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:06:27.372 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;No registration required
    2016-12-05 22:06:27.372 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    2016-12-05 22:06:27.665 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:06:28.665 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:06:29.665 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:06:30.665 [ERROR] [col.serial.MySensorsSerialConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received. Try set skipStartupCheck to true
    2016-12-05 22:06:30.665 [ERROR] [col.serial.MySensorsSerialConnection] - Failed connecting to bridge...next retry in 10 seconds (Retry No.:27)
    2016-12-05 22:06:30.666 [DEBUG] [col.serial.MySensorsSerialConnection] - Shutting down serial connection!
    2016-12-05 22:06:30.666 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Stopping Writer thread
    2016-12-05 22:06:30.666 [ERROR] [rs.internal.protocol.MySensorsWriter] - (java.lang.InterruptedException) on writing from serial port, message: class org.openhab.binding.mysensors.internal.protocol.serial.MySensorsSerialWriter
    2016-12-05 22:06:30.669 [DEBUG] [rs.internal.protocol.MySensorsReader] - Stopping Reader thread
    2016-12-05 22:06:30.670 [ERROR] [rs.internal.protocol.MySensorsReader] - (java.lang.InterruptedException: sleep interrupted) on reading from serial port, message: class org.openhab.binding.mysensors.internal.protocol.serial.MySensorsSerialReader
    
    
    *** Debug for serial connection skipping I-Version check
    
    2016-12-05 22:16:52.785 [DEBUG] [ernal.handler.MySensorsBridgeHandler] - Initialization of the MySensors bridge
    2016-12-05 22:16:52.786 [DEBUG] [col.serial.MySensorsSerialConnection] - Set skip check on startup to: true
    2016-12-05 22:16:52.787 [DEBUG] [col.serial.MySensorsSerialConnection] - Enabling connection watchdog
    2016-12-05 22:16:52.789 [DEBUG] [ternal.factory.MySensorsCacheFactory] - Cache file: given_ids.cached exist.
    2016-12-05 22:16:52.789 [DEBUG] [ternal.factory.MySensorsCacheFactory] - Cache (given_ids) content: [4]
    2016-12-05 22:16:52.789 [DEBUG] [ernal.handler.MySensorsBridgeHandler] - Initialization of the MySensors bridge DONE!
    2016-12-05 22:16:52.793 [DEBUG] [col.serial.MySensorsSerialConnection] - Connecting to /dev/ttyUSB0 [baudRate:115200]
    2016-12-05 22:16:52.821 [DEBUG] [col.serial.MySensorsSerialConnection] - Final port list: /dev/ttyUSB0
    2016-12-05 22:16:52.851 [DEBUG] [col.serial.MySensorsSerialConnection] - Successfully connected to serial port.
    2016-12-05 22:16:52.851 [DEBUG] [col.serial.MySensorsSerialConnection] - Waiting 3 seconds to allow correct reset trigger on serial connection opening
    2016-12-05 22:16:55.852 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    2016-12-05 22:16:55.855 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:INIT
    2016-12-05 22:16:55.856 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:RADIO:OK
    2016-12-05 22:16:55.855 [WARN ] [col.serial.MySensorsSerialConnection] - Skipping I_VERSION connection test, not recommended...
    2016-12-05 22:16:55.860 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:power:9ba30e1b
    2016-12-05 22:16:55.862 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:humidity:gateway:hum01
    2016-12-05 22:16:55.863 [INFO ] [col.serial.MySensorsSerialConnection] - Successfully connected to MySensors Bridge.
    2016-12-05 22:16:55.863 [WARN ] [col.serial.MySensorsSerialConnection] - Network Sanity Checker thread disabled from bridge configuration
    2016-12-05 22:16:55.867 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-10 not registered yet, registering...
    2016-12-05 22:16:55.867 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-6 not registered yet, registering...
    2016-12-05 22:16:55.868 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:temperature:gateway:temp01
    2016-12-05 22:16:55.868 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-11 not registered yet, registering...
    2016-12-05 22:16:55.869 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:GW MODE
    2016-12-05 22:16:55.869 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSM:READY
    2016-12-05 22:16:55.869 [DEBUG] [rs.internal.protocol.MySensorsReader] - IP: 192.168.1.66
    2016-12-05 22:16:57.553 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;No registration required
    2016-12-05 22:16:57.558 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    2016-12-05 22:17:00.811 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    2016-12-05 22:17:00.811 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:BC
    2016-12-05 22:17:00.812 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:FPAR REQ (sender=4)
    2016-12-05 22:17:00.818 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:CHKUPL:OK (FLDCTRL)
    2016-12-05 22:17:00.818 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:GWL OK
    2016-12-05 22:17:01.091 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=ok:0
    2016-12-05 22:17:02.854 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=24,pt=1,l=1,sg=0:1
    2016-12-05 22:17:02.857 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:PINGED (ID=4, hops=1)
    2016-12-05 22:17:02.868 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=ok:1
    2016-12-05 22:17:02.881 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    2016-12-05 22:17:02.924 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;!TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=fail:0100
    2016-12-05 22:17:02.935 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    2016-12-05 22:17:04.940 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=11,pt=0,l=13,sg=0:Motion Sensor
    2016-12-05 22:17:05.863 [DEBUG] [col.serial.MySensorsSerialConnection] - Bridge is connected, connection skipped
    2016-12-05 22:17:06.765 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    2016-12-05 22:17:08.599 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=9,c=0,t=1,pt=0,l=0,sg=0:
    2016-12-05 22:17:10.422 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=10,c=0,t=7,pt=0,l=0,sg=0:
    2016-12-05 22:17:12.248 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    2016-12-05 22:17:12.258 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    2016-12-05 22:17:12.261 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    2016-12-05 22:17:12.304 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;!TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=fail:1
    2016-12-05 22:17:12.309 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    2016-12-05 22:17:12.320 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    2016-12-05 22:17:12.324 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=11,c=1,t=0,pt=7,l=5,sg=0:19.3
    2016-12-05 22:17:14.157 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=10,c=1,t=1,pt=7,l=5,sg=0:70.8
    2016-12-05 22:17:15.864 [DEBUG] [col.serial.MySensorsSerialConnection] - Bridge is connected, connection skipped
    2016-12-05 22:17:15.980 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=6,c=1,t=38,pt=7,l=5,sg=0:4.788
    2016-12-05 22:17:25.864 [DEBUG] [col.serial.MySensorsSerialConnection] - Bridge is connected, connection skipped
    2016-12-05 22:17:34.431 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=9,c=1,t=16,pt=0,l=1,sg=0:1
    2016-12-05 22:17:35.864 [DEBUG] [col.serial.MySensorsSerialConnection] - Bridge is connected, connection skipped
    2016-12-05 22:17:36.265 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=11,c=1,t=0,pt=7,l=5,sg=0:19.4
    2016-12-05 22:17:38.088 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=10,c=1,t=1,pt=7,l=5,sg=0:70.6
    2016-12-05 22:17:39.911 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=6,c=1,t=38,pt=7,l=5,sg=0:4.768
    2016-12-05 22:17:41.744 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;255;3;0;9;TSP:MSG:READ 4-4-0 s=9,c=1,t=16,pt=0,l=1,sg=0:0
    
    *** Debug for Ethernet connection without skipping I-Version check
    
    2016-12-05 22:23:12.927 [DEBUG] [ernal.handler.MySensorsBridgeHandler] - Initialization of the MySensors bridge
    2016-12-05 22:23:12.930 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Set skip check on startup to: false
    2016-12-05 22:23:12.931 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Enabling connection watchdog
    2016-12-05 22:23:12.934 [DEBUG] [ternal.factory.MySensorsCacheFactory] - Cache file: given_ids.cached exist.
    2016-12-05 22:23:12.935 [DEBUG] [ternal.factory.MySensorsCacheFactory] - Cache (given_ids) content: [4]
    2016-12-05 22:23:12.937 [DEBUG] [ernal.handler.MySensorsBridgeHandler] - Initialization of the MySensors bridge DONE!
    2016-12-05 22:23:12.938 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Connecting to IP bridge [192.168.1.66:5003]
    2016-12-05 22:23:13.148 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:23:13.963 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    
    2016-12-05 22:23:14.963 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:23:15.963 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:23:16.964 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Sending to MySensors: 0;0;3;0;2;
    2016-12-05 22:23:17.964 [ERROR] [al.protocol.ip.MySensorsIpConnection] - Cannot start reading/writing thread, probably sync message (I_VERSION) not received. Try set skipStartupCheck to true
    2016-12-05 22:23:17.967 [ERROR] [al.protocol.ip.MySensorsIpConnection] - Failed connecting to bridge...next retry in 10 seconds (Retry No.:0)
    2016-12-05 22:23:17.968 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Disconnecting from IP bridge ...
    2016-12-05 22:23:17.968 [DEBUG] [rs.internal.protocol.MySensorsWriter] - Stopping Writer thread
    2016-12-05 22:23:17.971 [ERROR] [rs.internal.protocol.MySensorsWriter] - (java.lang.InterruptedException) on writing from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorsIpWriter
    2016-12-05 22:23:17.975 [DEBUG] [ternal.handler.MySensorsThingHandler] - Configuration: node 4, chiledId: 10, revertState: false
    2016-12-05 22:23:17.976 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-10 not registered yet, registering...
    2016-12-05 22:23:17.977 [DEBUG] [ternal.handler.MySensorsThingHandler] - Configuration: node 4, chiledId: 11, revertState: false
    2016-12-05 22:23:17.977 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-11 not registered yet, registering...
    2016-12-05 22:23:17.990 [DEBUG] [rs.internal.protocol.MySensorsReader] - Stopping Reader thread
    2016-12-05 22:23:17.991 [ERROR] [rs.internal.protocol.MySensorsReader] - (java.lang.InterruptedException: sleep interrupted) on reading from serial port, message: class org.openhab.binding.mysensors.internal.protocol.ip.MySensorIpReader
    
    *** Debug for Ethernet connection skipping I-Version check
    
    2016-12-05 22:27:59.514 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Connecting to IP bridge [192.168.1.66:5003]
    2016-12-05 22:27:59.515 [DEBUG] [ternal.factory.MySensorsCacheFactory] - Cache (given_ids) content: [4]
    2016-12-05 22:27:59.515 [DEBUG] [ernal.handler.MySensorsBridgeHandler] - Initialization of the MySensors bridge DONE!
    2016-12-05 22:27:59.525 [WARN ] [al.protocol.ip.MySensorsIpConnection] - Skipping I_VERSION connection test, not recommended...
    2016-12-05 22:27:59.527 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:humidity:gateway:hum01
    2016-12-05 22:27:59.527 [INFO ] [al.protocol.ip.MySensorsIpConnection] - Successfully connected to MySensors Bridge.
    2016-12-05 22:27:59.528 [WARN ] [al.protocol.ip.MySensorsIpConnection] - Network Sanity Checker thread disabled from bridge configuration
    2016-12-05 22:27:59.528 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-10 not registered yet, registering...
    2016-12-05 22:27:59.528 [DEBUG] [ternal.handler.MySensorsThingHandler] - MySensors Bridge Status updated to ONLINE for device: mysensors:temperature:gateway:temp01
    2016-12-05 22:27:59.528 [DEBUG] [ternal.handler.MySensorsThingHandler] - Event listener for node 4-11 not registered yet, registering...
    
    2016-12-05 22:28:09.528 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped
    2016-12-05 22:28:19.528 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped
    
    

  • Hero Member

    @triceT you're trying to connect per serial to your ethernet gateway. Try connecting with the ethernet gateway configuration using the IP 192.168.1.66 and port 5003, like in the last output of your post. You only get the debug output of the serial gateway in OH2, the messages from the nodes are not forwarded to serial.

    The connection seems to be get established, but there is no answer to the I_VERSION message. Are you using RFM69? Did you try a "telnet 192.168.1.66 5003"? Do you see messages incoming?



  • @TimO Thanks for your help....

    I'm using nrf24 radio.
    When I telnet I receive only this:

    Trying 192.168.1.66...
    Connected to 192.168.1.66.
    Escape character is '^]'.

    No mesages are shown



  • This is what I'm getting on Arduino gw connecting over ethernet and setting skipstartupcheck to false. If I set skipstartupcheck to true, gw is not receiving anything from ethernet.

    0;255;3;0;9;Eth: connect
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth:
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth:
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: disconnect
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth:
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth:
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: disconnect


  • Hero Member

    @triceT Are you sure the gateway isn't in a boot loop? Could you please check serial debug if it gets started over and over again?



  • @TimO I guess it is not in a loop. Here is the serial debug...

    0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSM:RADIO:OK
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;9;TSM:READY
    IP: 192.168.1.66
    0;255;3;0;9;No registration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: 
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: 
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: disconnect
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;TSP:MSG:READ 4-4-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:BC
    0;255;3;0;9;TSP:MSG:FPAR REQ (sender=4)
    0;255;3;0;9;TSP:CHKUPL:OK
    0;255;3;0;9;TSP:MSG:GWL OK
    0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=ok:0
    0;255;3;0;9;Eth: 
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=24,pt=1,l=1,sg=0:1
    0;255;3;0;9;TSP:MSG:PINGED (ID=4, hops=1)
    0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;Eth: 
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=ok:0100
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=0,t=17,pt=0,l=5,sg=0:2.0.0
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=11,pt=0,l=13,sg=0:Motion Sensor
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    0;255;3;0;9;Eth: disconnect
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    0;255;3;0;9;TSP:MSG:SEND 0-0-4-4 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=11,c=1,t=0,pt=7,l=5,sg=0:19.4
    0;255;3;0;9;TSP:MSG:READ 4-4-0 s=10,c=1,t=1,pt=7,l=5,sg=0:61.7
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: disconnect
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: 
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: 
    0;255;3;0;9;Eth: 0;0;3;0;2;
    0;255;3;0;9;Eth: disconnect
    0;255;3;0;9;TSP:SANCHK:OK
    


  • @TimO brief setup: controller and serial gateway on raspberryPi running OH2, serial working OK. Trying to add ESP8266 Huzzah gateway with only local sensor, DHT22 - no radio. It seems I have a similar situation as others, but before I post all my setup and logs a question for you: when using both a serial gateway and ethernet gateway can they be named the same, "gateway", in things file? What bothers me is the "channel" in the items file ends up looking like it is from the same source or am I missing something?

    Things file:

    Bridge mysensors:bridge-ser:gateway [ serialPort="/dev/ttyMySensorsGateway", sendDelay=200 ]
    {
       /** define things connected to that bridge here */
       humidity         hum01   [ nodeId="1", childId="0" ]
       temperature      temp01  [ nodeId="1", childId="1" ]
       humidity         hum02   [ nodeId="1", childId="2" ]
       temperature      temp02  [ nodeId="1", childId="3" ]
       humidity         hum03   [ nodeId="1", childId="4" ]
       temperature      temp03  [ nodeId="1", childId="5" ]
       power            power01 [ nodeId="2", childId="0" ]
       mySensorsMessage mySMsg01    [ nodeId="999", childId="999" ]
    }
    Bridge mysensors:bridge-eth:gateway [ ipAddress="192.168.1.113", tcpPort=5003, sendDelay=200 ]
    {
       /** define things connected to that bridge here */
       humidity         hum04   [ nodeId="3", childId="0" ]
       temperature      temp04  [ nodeId="3", childId="1" ]
    }
    

    Items file snippet (hum02/temp02 on serial GW and hum04/temp04 on eth GW)

    Number mHum                 "Master Humidity [%.0f %%]"             <humidity>      (grpChart,grpTemperatures)  { channel="mysensors:humidity:gateway:hum02:hum" }
    Number mTemp                "Master Temperature"                    <temperature>                               { channel="mysensors:temperature:gateway:temp02:temp" }
    Number bHum                 "Bean's Humidity [%.0f %%]"             <humidity>      (grpChart,grpTemperatures)  { channel="mysensors:humidity:gateway:hum04:hum" }
    Number bTemp                "Bean's Temperature"                    <temperature>                               { channel="mysensors:temperature:gateway:temp04:temp" }
    
    

  • Hero Member

    @carlyler The name must be unique for each gateway. So please change that first and report back, if that solves the problem.


  • Hero Member

    @triceT Just to make sure it is still working with the current snapshot I made a clean install.

    I've used:

    • OH2 Snapshot #631
    • current Binding
    • MySensors 2.0.0
    • Ethernet Gateway (Arduino Uno + Ethernet Shield + NRF24L01+)

    Everything works just fine, so don't give up! 🙂



  • @TimO thanks for the reply. I changed mysensors:bridge-eth:gateway to mysensors:bridge-eth:ethGateway in things and items, restarted OH2, reset ESP8266, several times, but no luck. If I read this right the GW is not trying to do much, ie get node id, present sensor, send data, etc. Any idea?

    GW serial:

    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:SLP:MS=2000,SMS=0,I1=255,M1=255,I2=255,M2=255
    0;255;3;0;9;MCO:SLP:WUP=-2
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=NA
    Getting temperature
    T: 20.00
    H: 34.70
    Getting temperature
    T: 20.10
    H: 33.90
    

    I am trying to set node id in sketch:

    // Set this to the pin you connected the DHT's data pin to
    #define DHT_DATA_PIN 2
    
    // Enable debug prints to serial monitor
    #define MY_DEBUG
    #define MY_GATEWAY_ESP8266
    // ethernet settings
    #define MY_ESP8266_SSID "xxxxxx"
    #define MY_ESP8266_PASSWORD "xxxxxxxxxx"
    
    // Enable UDP communication
    //#define MY_USE_UDP
    
    // Set the hostname for the WiFi Client. This is the hostname
    // it will pass to the DHCP server if not static.
    #define MY_ESP8266_HOSTNAME "HuzzahGateway"
    
    // Enable MY_IP_ADDRESS here if you want a static ip address (no DHCP)
    //#define MY_IP_ADDRESS 192,168,213,113
    
    // If using static ip you need to define Gateway and Subnet address as well
    //#define MY_IP_GATEWAY_ADDRESS 192,168,213,1
    //#define MY_IP_SUBNET_ADDRESS 255,255,255,0
    
    // The port to keep open on node server mode
    #define MY_PORT 5003
    // How many clients should be able to connect to this gateway (default 1)
    #define MY_GATEWAY_MAX_CLIENTS 1
    
    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    //#define MY_CONTROLLER_IP_ADDRESS 192,168,213,116
    
    // Flash leds on rx/tx/err
    // Led pins used if blinking feature is enabled above
    #define MY_DEFAULT_ERR_LED_PIN 16  // Error led pin
    #define MY_DEFAULT_RX_LED_PIN  16  // Receive led pin
    #define MY_DEFAULT_TX_LED_PIN  16  // the PCB, on board LED
    #define MY_NODE_ID 3
    
    #include <SPI.h>
    #include <ESP8266WiFi.h>
    #include <MySensors.h>
    #include <DHT.h>
    
    

  • Hero Member

    @carlyler Serial log looks good. The gateway is receiving it's IP per DHCP, right? Is the IP you configured above still correct? I prefer a static IP for my gateway to prevent a changing of the IP.

    Is the gateway reachable by ping? Are you able to connect with "telnet IP 5003" to the gateway?



  • @TimO DHCP: yes, but it is actually static by way of reserved addresses via MAC in the router.
    IP: same
    ping: yes, works
    telnet, yes, all I see is:

    0;255;3;0;14;Gateway startup complete.
    

    Serial is OK? I do not see the send of the Temp and hum; it is printing it because there is code to do that, but I am expecting the MySensors send command; right? My thought was it is not transmitting them for some reason. This is an area I am not confident about and have yet to find a good explanation of it: how a GW handles local sensors. Thoughts?



  • @TimO I have the exact hardware (Mine is Chinese) and SW versions as you, but still can't connect via Ethernet gw. I will not give up till it is working 🙂 I've ordered another Ethernet shield and will try with the new one.

    Regards



  • @TimO Good news! I finally got it to work; I have been using the dev, 2.1.0, and decided to try master, 2.0.0 and it came right up! I did notice one thing though that you may be interested in: if I start the ethGateway after OH2 is up, or turn it off and back on, the binding does not reconnect. Not sure if there is anything you can do about that.
    One other change to mention (before changing to v2.0.0): I found a note from hek about the node id of gateway local sensors will always be 0; I changed that in my things file and in my sketch.

    16:34:59.286 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;1;1;0;0;12.5
    16:34:59.291 [DEBUG] [ternal.handler.MySensorsThingHandler] - Setting last update for node 0 to 2016-12-10T16:34:59.289-0500
    16:34:59.300 [DEBUG] [ternal.handler.MySensorsThingHandler] - Setting last update for node 0 to 2016-12-10T16:34:59.297-0500
    16:34:59.333 [INFO ] [marthome.event.ItemStateChangedEvent] - bTemp changed from 12.8 to 12.5
    16:34:59.354 [INFO ] [marthome.event.ItemStateChangedEvent] - bTempF changed from 55.04 to 54.50
    16:34:59.365 [INFO ] [marthome.event.ItemStateChangedEvent] - bTempC_F changed from 12.8 °C / 55.0 °F to 12.5 °C / 54.5 °F
    16:34:59.490 [DEBUG] [al.protocol.ip.MySensorsIpConnection] - Bridge is connected, connection skipped
    16:34:59.583 [DEBUG] [rs.internal.protocol.MySensorsReader] - 0;0;1;0;1;34.1
    16:34:59.593 [INFO ] [marthome.event.ItemStateChangedEvent] - bHum changed from 34.2 to 34.1
    

    @hek I could be wrong, or maybe something has changed configuration wise but as you can see from above posts, dev branch v2.1.0, the radioless ethernet (ESP8266) gateway with local temp & hum sensors was not sending local sensor data. When I switched back to master v2.0.0 it started sending.



  • @carlyler
    The issue with the oh2 binding is known. You have to restart oh2 or just the binding through oh console and binding:restart
    Maybe an update of the binding may help but I didn't try yet.



  • @jogant Thank you. I did not know about the binding restart so I will look into that.



  • @TimO
    yesterday I tried the new binding with OH2 b4 and I have exactly the faulty behavior as described before. The gateway goes in online state but none of the mysensor node items goes online. They remain uninitialized. I restored the older binding and everything works well again. As it is the same behavior that @pentti12 describes I think it has to with the binding itself.

    @pentti12 : please try attached binding as that works for me. 0_1482134888619_org.openhab.binding.mysensors-2.0.0-SNAPSHOT.jar
    it is an older snapshot from November, 7th.
    Good luck



  • @jogant I moved to different location here in Espoo, so it will take a couple of days before I can continue with proposed MySensors binding, but it is good to know that there is at least one working solution available.


  • Hero Member

    @jogant you're right, as stated in the wiki the current binding version is only working together with the current snapshot release. I had no luck while trying to create a binding that is backward compatible.



  • @TimO

    now I tried the new combination of a recent OH2 snapshot as of 2016-12-21 with the recent mysensors binding. I had to restart the gateway and every single node but then everything works well. The nodes were found in the inbox and could be acknowledged as new things. Values are transmitted regularly and my relay node follows the switch items as desired. So no glitch at the moment.
    Well done @TimO.


 

295
Online

8.9k
Users

9.6k
Topics

100.9k
Posts