Metric/Imperial selection


  • Hero Member

    My temp reporting on my temp/humidity sensor is in centigrade. Made sure that imperial was selected in Vera gateway plugin and rebooted sensor, but still get centigrade. From the code, it looks like the sensor is supposed to query whether metric is true from the controller on startup. Saw that this was an issue on previous thread and there was a correction made. Am running 4.1 plugin. Was correction before or after plugin was first created, i.e., do I need to load newer plugin?


  • Hero Member

    Just noted that when I included the temp/humidity sensor the sensors showed up with their readings, but I did not get a separate Arduino node for the temp/humidity sensor in Vera like I did for my light sensor. This may be related to the temp reading in centigrade problem. Is there a way to create the Arduino node without going through the include process all over again?


  • Hero Member

    It should do no harm starting inclusion mode again and then restarting your sensor a few times until you get the Arduino node device in Vera. You do not need to delete your sensor device and include it again.

    Regarding the Metric/Imperial issue maybe you should enable debug in your sensor sketch and try to see what it does. Maybe it has some communication issues so the setting or request is not going through.



  • Hi Dan, maybe this will help you. I run in the same problem but reverse and this post helped me to solve the problem.

    http://forum.mysensors.org/topic/334/issue-with-temperature-units/23

    I've downloaded the MySensors library from github and now everything works fine.


  • Hero Member

    @korttoma Took your advice about including to get node and it worked! Also when the node appeared in Vera I noted my termp sensor was now reporting in farhrenheit!

    Thank you!


 

222
Online

8.8k
Users

9.6k
Topics

100.3k
Posts