RPi gateway build - unknown init system & make: not found



  • Hi everyone,
    I am running hass.io on a RPi3 and currently have a few sonoff switches on lights. I am eager to incorporate sensors! However, I am stuck on getting a gateway off the ground (planning on usng nrfL01+ radios and nanos).

    I am following this sites guide (https://www.mysensors.org/build/raspberry) but am getting errors. Here is what I run into.

    core-ssh:~/MySensors# ./configure --my-gateway=mqtt --my-controller-ip-address=10.0.0.9 --my-mqtt-publish-topic-prefi
    x=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-transport=nrf24
    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=BCM2836, Type=unknown, CPU=armv7l.
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
      [FAILED] unknown init system.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    ./configure: line 611: make: command not found
    [OK] Finished.
    core-ssh:~/MySensors# make
    -ash: make: not found
    core-ssh:~/MySensors#
    

    So I noticed that the Detecting init system section has failed and also no make command found. What am I doing wrong? The guide makes it seem so easy!

    Thanks for any help you can offer.

    Ryan


  • Mod

    @hasemar which Linux distribution/flavor are you running on your raspberry pi?
    Seems like some tools (like make) is not installed by default on your Linux distribution.

    This command can usually be used to check if you don't know:

    cat /etc/*release
    


  • Thanks for the response!

    that command outputs this:

    core-ssh:~/MySensors# cat /etc/*release
    3.6.1
    NAME="Alpine Linux"
    ID=alpine
    VERSION_ID=3.6.1
    PRETTY_NAME="Alpine Linux v3.6"
    HOME_URL="http://alpinelinux.org"
    BUG_REPORT_URL="http://bugs.alpinelinux.org"
    core-ssh:~/MySensors#
    

    I downloaded the RPi image from the hass.io website ( https://home-assistant.io/getting-started/) under software requirements.

    I am not very happy with it as it also doesn't include the apt-get tool. Not very linux savy so I dont know how to get that.


  • Mod

    @hasemar cool. I haven't seen anyone using Alpine Linux before.

    It seems to use a tool called apk. More info: https://wiki.alpinelinux.org/wiki/Alpine_Linux_package_management

    There seems to be some sort of online search at https://pkgs.alpinelinux.org/packages?name=Vim&branch=&repo=&arch=&maintainer= but I don't get any search hits for common tools so I don't understand how to use it.

    Maybe ask in the hass forum?



  • Thanks. After I posted I found the same docs and search utility.
    I found make https://pkgs.alpinelinux.org/packages?name=make&branch=&repo=&arch=x86&maintainer=
    and tried it out but just got a warning about no such file or directory.

    I'll try the hass forum like you suggested.

    Thanks for your help, Im sure there will be loads more questions down the line!!

    Cheers,
    Ryan


  • Mod

    Stupid search. It was case sensitive.

    This should install the tools you need:

    apk add build-base
    

    Then re-start at the ./configure ... step

    The raspberry pi gateway has not been tested on Alpine Linux, so it might not work. But maybe it does. Only one way to find out 🙂


  • Mod

    @hasemar Raspberry Pi uses arch armhf (not x86 which was in your search command)

    This link should give the right settings https://pkgs.alpinelinux.org/packages?name=&branch=v3.6&repo=&arch=armhf&maintainer=



  • update:
    Thanks for the help @mfalkvidd
    I managed to get the make utility installed. Hopefully this will help anyone else running into this problem:
    had to update and upgrade before it would work

    apk update
    ...
    apk upgrade
    ...
    apk add build-base
    

    I am still experiencing the Failed init system

    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=BCM2836, Type=unknown, CPU=armv7l.
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
      [FAILED] unknown init system.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    

    Its like it doesn't know where my init files are. Digging around a little in the configure code, I see that the prefix is usr/local/

    Should I change that to where my MySensors directory is? Or do I need to move the init scrips out of the initscripts directory?



  • Doing a little digging I have realized that the last two lines of my last post were dumb questions.
    The init system is inherent to the linux distro, not the MySensors package. I have posted a plea for help on the HassIO forum (which seems to be down right now, otherwise i would include a link) .

    I will update this post once/if I get a reply so hopefully we can have a solution on record.


  • Mod

    @hasemar it seems like Alpine linix is focused on a read-only install. It might be a good idea to verify that the work you've done is still there after a reboot, so you don't need to redo the work.

    The read-onlyness could also be the reason the init scripts are stores in a special place.



  • Wow, you were right. All the packages that I installed are gone after reboot.

    This is unfortunate. I will now see if I can just install home assistant on a more common distro like rasbian or something.


 

267
Online

7.8k
Users

8.7k
Topics

93.0k
Posts