Ethernet Gateway (W5100) not working on an Ethernet Switch.

  • I needed some extra ethernet ports, so I bought a simple TP-Link Switch. When I connect the Gateway (Uno) on the Switch , it does not work. On the router I have no problems. I tried with a new good working Sensebender Gateway on the router. On the Switch it is not working. I noticed that with the Switch i do not see the Tx-signal coming through.

    Can this behaviour be explained? Have I setup something wrong? I tried different ethernet cables and interchanged them, but could not get it resolved. All my other devices are working correctly with the Switch, so it must be something with the Gateways!

  • Mod

    @ramwal could be that auto crossover doesn't work correctly. You could try with a cross ethernet cable and see if that makes a difference

  • Not that its much of a help, but I recently installed a TP-Link (non managed) router and my gateway (w/ W5100) works fine through it.

  • Mod

    @johnrob can you find any settings in your new switch related to auto crossover or auto link speed detection? Those might influence its behavior wrt the W5100.

  • @yveaux I toke your advise and made a small crossover network cable. Unfortunately with no success. I connected the crossover cable to my router and even with this cable, I was able to ping my both gateways. So, on the router and the gateways auto MDI-X is working, which means that Auto MDI-X automatically detects the required cable connection type and configures the connection appropriately, removing the need for crossover cables to interconnect switches. I tried two different brands of switches (not managed) with both the same problem:
    D-Link Model No: GO-SW-5E H/W Ver.: E1
    TP-Link: RE200 V 2.0
    I am really astonished (is it bad luck!!), because @johnrob is reporting normal working of his non-managed switch.

  • Mod

    @ramwal Very strange indeed. I don't recall any issues with W5100. Did you google for issues related to W5100?
    Do you have a spare W5100 to rule out issues with this specific board?

  • @yveaux I tried with two different gateways, one an Arduino Uno with Ethernet Shield and the other a Sensebender Gateway with the W5100 Ethernet module suitable for the gateway (I used two modules) So, two different hardware configurations, both with a W5100. Both gateways are working correctly directly on the router, but they refuse to work when a switch is connected between them. I will investigate if there exist issues with the W5100 and ethernet switches. At the moment I have no solution and I do not know if this is a hardware or software issue.
    Thank you for giving it attention

  • Mod

    there are some W5100 shields that have a wrong termination resistor, it could be your case.

  • @gohan You are correct. I came across this information on internet:

    There 3 "bugs" with the W5100 Ethernet module;
    Bug 1: the spi-bug: needs soldering on the board; I don't want to do that, cost to much time.
    Bug 2: the '510'-bug: needs soldering on the board; I am not going to destruct things!
    Bug 3: the funduino reset bug: put a delay(250) in setup; did not resolve the issue.
    So, I give up!! Spend the whole weekend on this and will think of doing things differently. At leats I know what caused the problem. That's positive, don't you think? May be someone comes up with a glamorous idea, that's is simple, cheap and easy to implement.

    Thanks for thinking with me.

  • @ramwal I think the best would be trying another switch. I have several GWs with W5100 connected to 8 ports switch and working without any issues.
    I think you have eliminated other possible issues.

  • Mod

    @ramwal I only soldered 2 100 Ohms resistors across the RJ45 pins and it has been working since without problems

  • @gohan Thanks, as per your advice, I soldered 2 100 Ohm resistors between pin 1 and 2 and between pin 3 and 6 on the backside of the boards. I did this for the Ethernet module of the Sensebender Gateway as well as for the Arduino Ethernet shield on the Uno. And indeed both gateways are now perfectly working on the Ethernet Switch. MySensors forum works!! Issue solved within 24 hours.

    I Am Very Grateful, @gohan

Log in to reply

Suggested Topics