Neighbor kicking me off my own mysensor network?



  • As I am still new to mysensors I'm still testing. And I have an mysensors mqtt gateway and 1 node that sends a counter every second. I let it run and after a few minutes it stopped. Looking at the serial log on the gateway I see nothing strange. So I reset the node and watched the node's output. After a few minutes I saw this:

    155152 SGN:SKP:MSG CMD=3,TYPE=16
    155221 TSF:MSG:SEND,8-8-0-0,s=1,c=3,t=16,pt=0,l=0,sg=1,ft=0,st=OK:
    155227 SGN:SGN:NCE REQ,TO=0
    155465 TSF:MSG:READ,209-71-52,s=165,c=2,t=50,pt=6,l=25,sg=1:9978A2FCDC377E7B58EE3EAE3CFE73C9691DF39531837A3FF0000000
    155475 !TSF:MSG:REL MSG,NREP
    155675 TSF:MSG:READ,0-0-8,s=255,c=3,t=17,pt=6,l=25,sg=1:<NONCE>
    155680 SGN:SKP:MSG CMD=3,TYPE=17
    155683 SGN:NCE:FROM=0
    155685 SGN:BND:NONCE=C9C51E6F68377E7B58EE3EAE3CFE73C9691DF39531837A3FF0AAAAAAAAAAAAAA
    155694 SGN:BND:HMAC=C4012E67EE6AF3CAB7FFA958EBA46DF1D2DEC47B2C75C489925A34683F4B8D00
    155701 SGN:SGN:SGN
    155769 TSF:MSG:SEND,8-8-0-0,s=1,c=1,t=16,pt=4,l=4,sg=1,ft=0,st=OK:92
    156775 !MCO:SND:NODE NOT REG
    157778 !MCO:SND:NODE NOT REG
    

    Putting that in the parser it looks like another node (not mine) sent a msg which caused it to disconnect from my gateway.

    So I changed my network id and then got a similar result:

    421032 SGN:SKP:MSG CMD=3,TYPE=16
    421101 TSF:MSG:SEND,8-8-0-0,s=2,c=3,t=16,pt=0,l=0,sg=1,ft=0,st=OK:
    421107 SGN:SGN:NCE REQ,TO=0
    421331 TSF:MSG:READ,156-176-216,s=108,c=1,t=29,pt=6,l=25,sg=1:75C28949816EF1D6D27FD99A4D5303D67DA46283A7DE8171F5000000
    421342 !TSF:MSG:PVER,3!=2
    421548 TSF:MSG:READ,0-0-8,s=255,c=3,t=17,pt=6,l=25,sg=1:<NONCE>
    421554 SGN:SKP:MSG CMD=3,TYPE=17
    421557 SGN:NCE:FROM=0
    421559 SGN:BND:NONCE=F3E9E79AB06EF1D6D27FD99A4D5303D67DA46283A7DE8171F5AAAAAAAAAAAAAA
    421567 SGN:BND:HMAC=6AC3B09CFFC889990700C30211E3B02F63CEE0B2D5B401CDB85E51FB055B985C
    421575 SGN:SGN:SGN
    421642 TSF:MSG:SEND,8-8-0-0,s=2,c=1,t=3,pt=4,l=4,sg=1,ft=0,st=OK:250
    422648 !MCO:SND:NODE NOT REG
    423651 !MCO:SND:NODE NOT REG
    

    So I guess my question is this a neighboring node that I'm picking up and can I force my node to only communicate with my gateway?

    For reference I did enable MY_SECURITY_SIMPLE_PASSWD so it should have been encrypted and signed.



  • Or if there is at least a way to check if there is no network connection to force a reconnect. (rfm69)



  • maybe try using the RF24 library's simple scanner example sketch to scan your rf channels to ensure there is no other source of interference on your selected nrf channels (defaulting to chan 76 [0x4C])
    (ok sorry, i see that you are using rfm69 😉



  • @les Perhaps your first guess is wrong and the Node is kicking itself off because something mismatches?
    I'm never used MQTT or encryption as never really saw the point with rfm69s, but it makes no sense that a neighbour would know your networkID and the Node number before and after you changed it?
    Did you establish communication worked on a simple serial gateway first with no encryption or is this your first attempt?


 

305
Online

8.7k
Users

9.5k
Topics

99.9k
Posts