MySensor Things - show up 'as active' when they are unplugged



  • I'm not sure if there is setting or option I need to set in my temp sensors or what's going on by I still have 'readings' in my 'Things' when the temp sensor is unplugged and not sending readings. I thought the 'Thing' would be greyed out or the reading gone when no data is received.


  • Mod

    @rmalbers I am not familiar with Mozilla WebThings, but for how long do you expect the device to be displayed as "active" after sending a message? 1 second? 10 minutes?



  • Not sure if there is config setting for that somewhere or not, for temp sensor I would say somewhere between an hour and 6 hours, I don't really care I just need to know that what I am seeing is fairly close or show no value. Like if the furnace quits and the temp drops, I need to know.


  • Mod

    @rmalbers Domoticz has a global setting called "sensor timeout". I have it set to 660 minutes. Domoticz doesn't seem to have support for per sensor timeouts. I checked https://iot.mozilla.org/docs/gateway-user-guide.html but can't find a similar setting unfortunately.



  • @mfalkvidd Thanks for researching this, that does explain why I didn't have the same issue with Domoticz. I like the 'look' of this gateway but I think I'll have to switch to Domoticz when I leave town, it just seems more feature rich for real life monitoring.


  • Plugin Developer

    There is a time-out related option in the MySensors settings, but it's focus is on setting the device to 'offline' when the Gateway boots up, and only setting it to 'online' when some data actually arrives.

    I don't know how Mozilla deals with timeouts.

    If it doesn't, then the add-on could manage this, since it can set things to 'available' or 'unavailable'.

    Ideally you'd want a different time-out setting for each device. It would be great if MySensors has a built-in "this is my prefered timeout" S_TYPE (perhaps it does?).


  • Mod

    My fear is that Mozilla (along with many other actors) assume that devices never sleep. They assume there is a constant mqtt connection (or similar), which makes it easy to determine if the device is online.



  • A timeout setting somewhere is needed for sure if you have battery powered sensors right?



  • @alowhum said in MySensor Things - show up 'as active' when they are unplugged:

    There is a time-out related option in the MySensors settings, but it's focus is on setting the device to 'offline' when the Gateway boots up, and only setting it to 'online' when some data actually arrives.

    I don't know how Mozilla deals with timeouts.

    If it doesn't, then the add-on could manage this, since it can set things to 'available' or 'unavailable'.

    Ideally you'd want a different time-out setting for each device. It would be great if MySensors has a built-in "this is my prefered timeout" S_TYPE (perhaps it does?).

    You know, I think I've seen that 'unavailable' happen a few times when I was playing with a battery powered sensor. The 'thing' was gray instead of bright white on the "Thing" page.


  • Plugin Developer

    I asked, and the add-on should handle the timeouts.

    Ideally I'd go the route where each device communicates the intended timeout. I've created a proposal on the MySensors Github to implement something like this.

    I think for now I will implement a universal timeout period, and then find a way for individual nodes to override that default if they communicate an individual period.



  • Wow that would be great, I think it's something that most people using the gateway would want, at least for some sensor types!


 

192
Online

8.8k
Users

9.6k
Topics

100.4k
Posts