RFM69/95 won't run



  • Hi all,

    I am trying to read the soil moisture and send it via radio. Therefore I bought a SX1278 radio chip but can't get it run.

    It is connected to my 3.3V arduino pro mini like described in the documentation:

    SX1278 ->  Arduino Pro Mini 3.3V
    
    GND    ->  GND
    VCC    ->  VCC
    MISO   ->  MISO (D11)
    MOSI   ->  MOSI (D12)
    SLCK   ->  SCK (D13)
    NSS    ->  SS (D10)
    DIO0   ->  INT0 (D2)
    

    Everytime I fire the arduino up, I see the following messages (debug activated):

    208 MCO:BGN:INIT NODE,CP=RRNNA---,FQ=8,REL=255,VER=2.3.2
    335 TSM:INIT
    350 TSF:WUR:MS=0
    419 !TSM:INIT:TSP FAIL
    442 TSM:FAIL:CNT=1
    462 TSM:FAIL:DIS
    481 TSF:TDI:TSL
    

    What does that mean and how can I fix it?

    Thanks and regards!


  • Mod

    Welcome to the MySensors community @cYnd !

    The log parser is useful for interpreting the logs.

    https://forum.mysensors.org/topic/666/debug-faq-and-how-ask-for-help/ shows them most common problems and how to troubleshoot them efficiently.

    For init failed, the most common cause is a problem with the wiring. Triple-check the wiring. If you can't find any problem, post photos here and we'll try to spot what is wrong.


  • Mod

    @cYnd said in RFM69/95 won't run:

    RRNNA---

    This indicates that you have configured a rfm69 radio. Rfm69 does not have a sx1278 chip. You probably want to configure it as rfm95.



  • Hi mfalkvidd,

    thanks for the welcome 🙃

    You're right, I should use RFM95 and I changed it. However the same error:

    208 MCO:BGN:INIT NODE,CP=RLNNA---,FQ=8,REL=255,VER=2.3.2
    335 TSM:INIT
    350 TSF:WUR:MS=0
    378 !TSM:INIT:TSP FAIL
    401 TSM:FAIL:CNT=1
    421 TSM:FAIL:DIS
    440 TSF:TDI:TSL
    

    Also I tried the log parser earlier but it just tells me "Transport device initialization failed". I need to figure out why it can't initialize that device. I quadrouple-checked the wires and can't see any issues 😒

    However here are some pcitures of it, maybe you find an issue? (Sorry, wiring is a bit messy 👽 )

    IMG_20200322_120517.jpg IMG_20200322_120440.jpg



  • So do you see anything odd in my wiring or do you have any idea why this isn't working?


  • Mod

    @cYnd my guess would be insuffcient contact, or shorts between two or more pins. Learning to solder well takes some practice. You could use a multimeter to check if there are any shorts. Measuring good connectivity is trickier.



  • @mfalkvidd I tested shorts with my multimeter and didn't find any shorts. However I should receive next week some new of these chips and I will try to solder them new. Let's hope that that's the issue!


Log in to reply
 

Suggested Topics

  • 5
  • 3
  • 1
  • 3
  • 22
  • 306
  • 5

200
Online

9.2k
Users

9.9k
Topics

103.2k
Posts