mysensors-adapter is receiving data but Things dashboard does not find devices



  • Hi all,

    I have installed the WebThings Gateway 0.12.0 and I've installed the MySensors (1.0.8) addon, the Candle Manager (1.0.8) addon, Web Thing (0.4.6) addon and (for testing purposes) the Weather (0.5.0) addon.

    I'm using a RF Nano, connected directly to the Raspberry Pi, as USB Serial Gateway device and have separately built a temperature-humidity sensor (BME280 based with RF Nano) and a CO2 sensor (MH-Z19 based with RF Nano).

    The problem

    The Things dashboard does not show the devices. When I scan for new devices, it shows "no new things found. Try adding some add-ons."

    In the logs I can see that the both RF Nano devices can wirelessly communicate with the USB Serial Gateway.

    2020-05-06 14:17:15.749 INFO   : mysensors-adapter: >> incoming message > internal > id: 0; child: 255; subtype: 22; payload: 3811525
    2020-05-06 14:17:15.750 INFO   : mysensors-adapter: 0 gets timestamp 1588767374
    2020-05-06 14:17:15.752 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.753 INFO   : mysensors-adapter: >> incoming message > internal > id: 3; child: 255; subtype: 22; payload: 4411583
    2020-05-06 14:17:15.754 INFO   : mysensors-adapter: 3 gets timestamp 1588767381
    2020-05-06 14:17:15.755 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.756 INFO   : mysensors-adapter: >> incoming message > set > id: 3; child: 0; subtype: 0; payload: 23.0
    2020-05-06 14:17:15.757 INFO   : mysensors-adapter: 3 gets timestamp 1588767381
    2020-05-06 14:17:15.758 INFO   : mysensors-adapter: property -> update: 23
    2020-05-06 14:17:15.762 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.763 INFO   : mysensors-adapter: >> incoming message > set > id: 3; child: 2; subtype: 4; payload: 1025.0
    2020-05-06 14:17:15.764 INFO   : mysensors-adapter: 3 gets timestamp 1588767383
    2020-05-06 14:17:15.765 INFO   : mysensors-adapter: property -> update: 1025
    2020-05-06 14:17:15.766 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.768 INFO   : mysensors-adapter: >> incoming message > set > id: 4; child: 2; subtype: 37; payload: 500
    2020-05-06 14:17:15.769 INFO   : mysensors-adapter: 4 gets timestamp 1588767396
    2020-05-06 14:17:15.770 INFO   : mysensors-adapter: property -> update: 500
    2020-05-06 14:17:15.771 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.772 INFO   : mysensors-adapter: >> incoming message > set > id: 4; child: 5; subtype: 47; payload: Good
    2020-05-06 14:17:15.773 INFO   : mysensors-adapter: 4 gets timestamp 1588767396
    2020-05-06 14:17:15.774 INFO   : mysensors-adapter: property -> update: Good
    2020-05-06 14:17:15.776 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.777 INFO   : mysensors-adapter: >> incoming message > internal > id: 3; child: 255; subtype: 22; payload: 4442583
    2020-05-06 14:17:15.778 INFO   : mysensors-adapter: 3 gets timestamp 1588767412
    2020-05-06 14:17:15.779 INFO   : mysensors-adapter: 
    2020-05-06 14:17:15.780 INFO   : mysensors-adapter: >> incoming message > set > id: 3; child: 2; subtype: 4; payload: 1025.0
    2020-05-06 14:17:15.781 INFO   : mysensors-adapter: 3 gets timestamp 1588767414
    
    • I've reinstalled everything from scratch, same result
    • I've installed the Weather addon just to see if that would show up when scanning for new devices (so I could rule out the USB Serial Gateway). I also get the "no new things found. Try adding some add-ons."
    • I've set loglevels to debug but that does not provide more information.

    Does anyone have suggestions what I can try or how I can find out what is wrong?



  • @Ray Have you rebooted the mysensor sensor after everything else has been running.



  • I've tried both ways: first the gateway online, adding the add-ons (Candle Manager , MySensors). Then use the Candle Manager to add the RF Nano devices and go to the Things Dashboard to add them.

    I've also tried to reboot the RF Nano devices while the gateway was running to see if that might trigger something.

    Unfortunately, "no new things found. Try adding some add-ons."



  • @Ray So the weather addon is not even working/being found?


Log in to reply
 

Suggested Topics

196
Online

9.7k
Users

10.3k
Topics

106.4k
Posts