notify.mysensors - powerful feature likely with a bug



  • Hi there! Recently I've been working on a new feature for my GoWired project, which is about configuring modules with text messages using notify.mysensors Home Assistant service. The whole idea seems pretty powerful to me, but I encountered problems with the notify service.

    Home Assistant documentation states 2 notations for setting the notification target:

    • “[Child description]”
    • “[Sketch name] [Node id] [Child id]”

    I started with the second one, because it gives an opportunity to precisely specify the target: node ID + child ID, while the first one leads to sending the notification to all nodes with a given child sensor description. But despite many attempts and trying many notation variants I only managed to make the first notation work. The second seems not to send anything at all. Is there anyone here who's encountered this issue?



  • Ok, I've made some digging on Home Assistant GH and found out it's not a bug but a feature, but they just haven't put any info about the change to their documentation:

    https://github.com/home-assistant/core/issues/62703

    Long story short, to use the notation “[Sketch name] [Node id] [Child id]”, there should be no sensor description in presentation().

    This is supposed to work with “[Child description]” notation:
    present(NOTIFY_SENSOR_ID, S_INFO, "Child description");

    And this with “[Sketch name] [Node id] [Child id]” notation:
    present(NOTIFY_SENSOR_ID, S_INFO);


Log in to reply
 

Suggested Topics

  • 1
  • 3
  • 1
  • 3
  • 5
  • 1
  • 6
  • 10

1
Online

10.7k
Users

10.9k
Topics

111.6k
Posts