FindParents on RFM69HW node



  • My set-up is as follows:

    Gateway:
    RPi 3B+ (64 bit debian)
    MySGW dev branch, master would not build because of know issue (not sure which one anymore)
    Compiled MySGW with:

    --my-transport='rfm69' --my-rfm69-frequency='433' --my-is-rfm69hw
    

    Node:
    Then I have 1 test node on an Arduino Pro mini 3.3V, with the same radio. Sketch has the following defined:

    #define MY_DEBUG 
    #define MY_RADIO_RFM69
    #define MY_RFM69_FREQUENCY RFM69_433MHZ 
    #define MY_IS_RFM69HW  
    #define MY_RFM69_NEW_DRIVER //Becasue RPi 3B+ as Gateway
    #define MY_NODE_ID 2
    

    Problem:
    The node only gets FPAR: No Reply all the time.
    Log for the node :

    MCO:BGN:INIT NODE,CP=RPNNA---,FQ=16,REL=255,VER=2.3.2
    TSM:INIT
    TSF:WUR:MS=0
    TSM:INIT:TSP OK
    TSM:INIT:STATID=2
    TSF:SID:OK,ID=2
    TSM:FPAR
    ?TSF:MSG:SEND,2-2-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    ?TSF:MSG:SEND,2-2-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,2-2-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    ?TSF:MSG:SEND,2-2-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:FAIL
    

    Although the gateway sees the message coming across:

    INFO  Starting gateway...
    INFO  Protocol version - 2.4.0-alpha
    DEBUG MCO:BGN:INIT GW,CP=RPNGL---,FQ=NA,REL=1,VER=2.4.0-alpha
    DEBUG TSF:LRT:OK
    DEBUG TSM:INIT
    DEBUG TSF:WUR:MS=0
    DEBUG TSM:INIT:TSP OK
    DEBUG TSM:INIT:GW MODE
    DEBUG TSM:READY:ID=0,PAR=0,DIS=0
    DEBUG MCO:REG:NOT NEEDED
    DEBUG MCO:BGN:STP
    DEBUG MCO:BGN:INIT OK,TSP=1
    DEBUG GWT:RMQ:CONNECTING...
    DEBUG connected to 192.168.1.24
    DEBUG GWT:RMQ:OK
    DEBUG GWT:TPS:TOPIC=mysensors-out/0/255/0/0/18,MSG SENT
    DEBUG TSM:READY:NWD REQ
    DEBUG ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    DEBUG TSF:MSG:READ,2-2-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    DEBUG TSF:MSG:BC
    DEBUG TSF:MSG:FPAR REQ,ID=2
    DEBUG TSF:CKU:OK,FCTRL
    DEBUG TSF:MSG:GWL OK
    DEBUG !TSF:MSG:SEND,0-0-2-2,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    DEBUG TSF:MSG:READ,2-2-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    DEBUG TSF:MSG:BC
    DEBUG TSF:MSG:FPAR REQ,ID=2
    DEBUG TSF:CKU:OK,FCTRL
    DEBUG TSF:MSG:GWL OK
    DEBUG !TSF:MSG:SEND,0-0-2-2,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    DEBUG TSF:MSG:READ,2-2-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    

    Tried so far

    • Disabling the HW flag (was pretty sure it is an HW, but seen examples of others that were mistaken). Leads to not initialising.
    • A different radio (I tried switching them, outcome is similar)
    • Different distances (1m, 4m, 10m with wooden floors between them)

    I followed the debugging flow, and came to the point were it says to add a capacitator to the radio. But everywhere i see a reference to that, it has to do with the nrf24 radios. Does the same go for the RFM69(HW) radio's? So is this the next step or should try something else (I currently have no capacitors at the ready).



  • Have you connected the interrupt pin on the node?
    And perhaps tried without the new driver? I don't know how that works with a RPI, does it have an old driver also?



  • OK that's embarrassing. It seems I connected interrupt / DIO0 to gnd. But i've reconnected the entire thing several times, including swapping... Anyway thanks for pointing it out. I still get some NACKs and the mqqt is not working anymore for some reason, but I'll figure that out, and do another post if necessary. Thanks for pointing it out!


Log in to reply
 

Suggested Topics

  • 1
  • 2
  • 5
  • 2
  • 9
  • 4
  • 3
  • 3

106
Online

10.8k
Users

11.0k
Topics

112.0k
Posts