- 0.0.3-alpha1 released

  • Plugin Developer

    I am happily announce that released it major milestone of 0.0.3-alpha1 release.

    Download page.
    Demo server.
    Document page.
    This page not completed fully. Still I am working on day by day I cover entire project in documents. Still I can help you. You can post your queries.

    If you face issues report to GitHub issues page.

    New Features

    • Backend refactored to support multiple gateways and to give support for other networks
    • GUI completely changed. moved to
    • Backup/restore via GUI
    • Migration support
    • Dashboard, can have more than one dashboard. customizable dashboard
    • Pushbullet note notification support
    • SMS vendor Twilio support
    • Role based authentication. can assign resources for role
    • Simple timer support
    • Resources groups(scene) support
    • Map resources to rooms
    • Sensors action board view list view and card view
    • Resources logs more friendly now
    • Can see server log on GUI
    • New language support added
    • customizable chart type and color for each sensor type
    • Metrics/Imperial units support
    • Nodes, sensors detailed view page
    • friendly sensors value change support
    • and many more

  • @jkandasa said:

    I am happily announce that released it major milestone of 0.0.3-alpha1 release.

    Nice work ­čĹŹ

  • Very nice work!!!!!!!!!

    I found this controller yesterday ( used Openhab before),
    downloaded it last night (before you released it a few hours later),
    compiled it and it worked almost out of the box on my Raspberry Pi,...

    I am loving it already....
    So easy to use with the mysensors,... only had to install the RF24 module on my raspberry pi and the Mycontroller hooked right into it,....

    Great work,... definitely will be using this and helping out where I can!!!


  • Hi!

    Everything is working fine, but how can i add firmware files? In the Add firmware section i have no type and version. How can i add this?


  • Plugin Developer


    on firmware page click on Types to add new type
    and click on Versions to add new version.

  • oooh really ­čśť

    thanks ­čĹŹ

  • Hello Jkandasa,

    First, thank you very much for all the work you have put in your controller, it's a nice product and simple to have working.
    I just have tried this last version, but I cannot get the dashboard to display a graph of sensor, like the details of the previous action board was doing.
    To be more precise, I cannot get it to display a linear graph without having to wait for several minutes.

    I can see all the numerical values from my sensors, but on the linear graph I only have a rotating "please wait" circle.
    They stay that way, I think, until (I think) every sensors have updated their values.
    I say that, but it's a feeling, not a certainty.
    The thing is, if the dashboard is displayed correctly, navigating to any other screen and getting back to the dashboard populates it again with the waiting symbols, for a few minutes.

    Is this something known?

  • Plugin Developer

    @tripy Thank you for using

    No, It is not a known issue. I need some details to understand more,

    • Is your sensor has data(linear graph)?
    • What type of sensor and variable type?
    • Did you upgrade from 0.0.3-alpha1-SNAPSHOT version?
    • Can you send the details of following? Open your MyController dashboard page in chrome browser, press CTRL+SHIFT+I , Once chrome developer screen opened, navigate to Networks wait few seconds(based on refresh time for graph, default: 30 seconds). You will see request something like https://host-ip:8443/mc/rest/metrics/metricsData?timestampFrom=1457120861793&variableId=1&withMinMax=false. Click that and navigate to Response. Can you post that data?

    Thank you!

  • @jkandasa In order:

    • Yes, they are linear
    • 3 nodes. 2 nodes have 3 sensors (humidity, temperature and luminosity). 1 node just have humidity and temperature.
      They implement respectively V_HUM, V_TEMP and V_LIGHT_LEVEL
      They all basically are the DHT sensor, and I've added a LDR to report a relative luminosity in rooms.
    • I didn't upgraded. I run the 0.2 version on 1 machine, and have tried on another the 0.3
      I downloaded the 0.3 that is available on the site. The file name is mycontroller-standalone-0.0.3-alpha1-bundle.tar.gz
      So no, it's not the snapshot and it was a clean install.
      They both use a MQTT broquer to get data (Latest version of mosquitto).
      I did not use the built in MQTT broker from the 0.3 version
    • I'm running on Linux, and usually run Firefox. I tried to access mycontroller with Chromium with the same results.
      This is the dashboard initially:
      0_1457220243058_mcontroller initial dashboard.png
      The strange thing is that I don't see a "metricsData" request in the initial display of the page.
      All the bootstrapping happens in a few ms, and then nothing for the next 6 minutes.
      0_1457220162934_mycontroller network trace after 6 minutes.png
      And then, suddenly at the 7th minute, several metricsData request are coming through:
      0_1457220302017_mycontroller network trace 7 minutes.png

    My dashboard is then ok, until I reload the page or naviate to another screen.
    0_1457220353693_mycontroller after metricData.png

    Hoping that this is relevant to you:
    Java version:

    openjdk version "1.8.0_72-internal"
    OpenJDK Runtime Environment (build 1.8.0_72-internal-b15)
    OpenJDK 64-Bit Server VM (build 25.72-b15, mixed mode)

    I tried to run it on a similar system (the one running the 0.2 version) with the same symptoms.
    I hope it's enough data to help you.

  • Hi,

    Ich like the mycontroller very much, the GUI is easy to use and work fine.

    One question: Is there a way to make an virtuell sensor with to crom Temperature aalculate the dewpoint fnd humidity with a formular.
    Or is it easiar to implement it in the Sensor.


  • Plugin Developer

    @midopple Thank you for your interest with For now we do not have any option to implement formula with

    But in future we should the one.

    closed Rules #151

  • Ok, I feel pretty dumb not to have thought of it before, but I've found the issue.

    For the sake of anyone running in the same issue, if you are running an ad blocker, try to disable it first.
    Looking at the request in Chromium, it said "ERR_BLOCKED_BY_CLIENT"
    0_1457283238242_mycontroler request blocked.png
    Turning off the ad blocker resulted in a dashboard as you would expect it.

    Sorry for bothering you for something I should have thought of, and thank you for your support.

Suggested Topics