2.0 beta, compatible with 1.5?



  • Hi!

    I wanted to try out Mysensors 2.0 beta (the Arduino library) since I have hit the bug that makes signing + relay nodes not work.

    How ready is 2.0 beta, can I expect it to work? :-) Any planned release date?

    What do I need to upgrade? All my nodes, or only the relay? Or the relay + the controller. Is the on-the-wire protocol the same so that multiple versions of mysensors library can cooperate on the same sensor network?

    Cheers!
    \EF



  • The sketches you have don't work. You have to modify some stuff.

    But the nodes that are already in your network and your gateway are working fine with 2.0 nodes.



  • @Erik-Forsberg

    I've been using beta and i'm very happy with it.

    If you do find problems, first update it again to get the newest builds and if the issue is still there report it.

    I'm sure folks will appreciate having another person testing.

    Cheers



  • I'm running beta2 for a month and haven't hit a real show stopper.

    The new syntax feels cleaner, I use it with a mqttclientgateway and it never went down since start. I upgraded gateway first and then ported my old 1.5 code to 2.0, OTU pushed via Mysloader 1.3 beta, living on the edge! :)

    Don't know about on-the-wire tho.



  • @cdr by using MyController 0.0.3-alpha, correct?



  • Btw, i'm testing with a sensor on 2.0 and its logging messages from other sensors like:

    read and drop: 1-1-0 s=1,c=1,t=16,pt=2,l=2,sg=0:1
    

    With repeater enabled:

    read and forward: 5-5-0 s=1,c=1,t=16,pt=2,l=2,sg=0
    

    In mysensors 1.5 I don't get this? It only repeats if the sensor asks for it or something like that. Now every repeater repeats the signal? Like a mesh netwerk or something?




Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.