Repeater Node, problems



  • RPi with Domoticz, MySensors 1.5.1

    I had an Ethernet GW(UNO) and a Repeater Node(NANO clone) working OK but sometimes the nodes couldn't send data, maybe 4 times per day, I could live with that but of course 100% data is much nicer :) my nodes sends data every 30/60 min.

    I changed to a Serial GW because my router sometimes stopped working so I had no connection to Ethernet GW.
    Since that time I lost lots of data, I have always though the problem was the Serial GW until yesterday. I checked my Logfile that write every time a node is not sending data for more than 70 minutes, it was always the nodes that was sending data through the Repeater Node, since the nodes are far away from Serial GW.

    Yesterday I changed to have NO DEBUG and from baud rate from 57600 to 9600 and since then I have data all the time.

    Can it be that critical to NOT have DEBUG?
    Could it be the baud rate that made my problems before?
    Maybe the sketch was not 100% complete and after I upload the new sketch it was 100% correct?


  • Mod

    Interesting case. Thanks for sharing.

    Writing to serial (which debug does) takes a lot of time (in a microprocessor world). It could be that the node was dropping incoming radio messages when it was busy writing to serial.



  • Ok, that can be the reason.

    I am soo happy that it works now.

    So far only 1 sensor has not sent data since I changed it, 22:00 yesterday, and I don't think that node send through Repeater



  • I also have PA on max

    #define RF24_PA_LEVEL 	   RF24_PA_MAX
    #define RF24_PA_LEVEL_GW   RF24_PA_MAX
    


  • I have now add DEBUG again, just to see if that was the problem, will update here later today



  • @flopp said:

    RPi with Domoticz, MySensors 1.5.1

    I had an Ethernet GW(UNO) and a Repeater Node(NANO clone) working OK but sometimes the nodes couldn't send data, maybe 4 times per day, I could live with that but of course 100% data is much nicer :) my nodes sends data every 30/60 min.

    I changed to a Serial GW because my router sometimes stopped working so I had no connection to Ethernet GW.
    Since that time I lost lots of data, I have always though the problem was the Serial GW until yesterday. I checked my Logfile that write every time a node is not sending data for more than 70 minutes, it was always the nodes that was sending data through the Repeater Node, since the nodes are far away from Serial GW.

    Yesterday I changed to have NO DEBUG and from baud rate from 57600 to 9600 and since then I have data all the time.

    Can it be that critical to NOT have DEBUG?
    Could it be the baud rate that made my problems before?
    Maybe the sketch was not 100% complete and after I upload the new sketch it was 100% correct?

    Hi floop, where You changed baud rate?
    this line in MyConfig ?
    I ask, because sometimes I have a problem with communication and my node are promini 3.3V 8MHz

    // Serial output baud rate (for debug prints and serial gateway)
    #define BAUD_RATE 115200```


  • @okos
    Hi, yes that is the place where I change the baud rate.
    OK, I read that if you use some bootloader you maybe need to have low baud rate, like 57600 and even low as 9600



  • I only had one single "not reporting node", so it seems to work good with DEBUG ON

    Just changed to baud rate 57600 and DEBUG ON, lets see whats happen now



  • Still OK just one node that had fail, same as last time, and only once.

    It is DEBUG ON and 57600, so it is same as before.

    I think the problem could be when I uploaded the sketch long time ago something went wrong or it can be my RPi which run Domoticz, I have not restarted DZ during this test so I don't think that is my problem.

    I noticed that DZ had problem with my scripts, "running more than 10 SEC..." This is also gone?!

    Can my internet router in some way have disturb MySensors? I had some problem with my Router but I restarted it and turn off OpenVPN so now my router seems to be working again. I am using Serial GW and Repeater so nothing else than RPi is connected to the Router.

    I am happy that it works now but it should be nice to know what the problem was.



  • Not solved.

    I still have some nodes that sometimes doesn't send data.

    23/8 22.00 I changed to DEBUG but still some Nodes that doesn't send correct.

    I just changed to NO DEBUG and 9600, i will let it run for a few days and see what happens



  • I seem to have the same issue. I just opened a topic about it.
    One or two nodes just stop sending and i am not sure if this is because there isn't a change in the reading or not.
    After rebooting the node it goes well for sometimes hours and sometimes just minutes.



  • I had a node that haven't sent any data for 3 days and suddenly it sent data without I touched it. This is a solar panel node.

    It must be something with range problem. If the battery is too low it cannot send even if the sun is shining it will not send because the solar panel is very small so it takes lots of hours to charge the battery to a high level.



  • I have two which are powered (nano) with USB and both in the same place (garage)
    They both are repeater nodes and i think they both have issues connecting to the nearest repeater node.



  • yesterday was the first day since I changed(27/8) to below setup, not even one error :grinning:
    this is my setup
    NO DEBUG, 9600, PA+LNA power taken from 5v on a Nano to an adapter http://www.ebay.com/itm/2pcs-Socket-Adapter-plate-Board-for-10Pin-NRF24L01-Wireless-Transceive-module-/191674251825



  • I will give up soon

    Today it start do NOT send again. It is raining if that can make problem. I reprogram Repeater with DEBUG ON and could see that the repeater didn't have connection to GW.

    I changed RF on Serial GW, didn't help.
    I change to have external power for RF on GW, didn't help.

    I changed RF on Repeater, didn't help.
    I change to have external power for RF on Repeater, didn't help.
    Reprogram Repeater, didn't help.

    Finally I restarted my RPi, that helped.

    I have 6-8 meters from GW to Repeater, there is 2 inner walls, 1 brick wall, 1 wood wall and the GW is inside my drawer so some woods there as well.
    It is a Serial GW with nRF24L01+ PA + LNA with shield. I take 5 volt from UNO to an adapter that step-down to 3.3V I have Cap on GW
    Repeater is Arduino Nano with nRF24L01+ PA + LNA no shield and Cap, power from 5v Nano to an adapter step-down to 3,3V

    What is next step?:flushed:



  • @flopp said:

    I will give up soon

    Today it start do NOT send again. It is raining if that can make problem. I reprogram Repeater with DEBUG ON and could see that the repeater didn't have connection to GW.

    I changed RF on Serial GW, didn't help.
    I change to have external power for RF on GW, didn't help.

    I changed RF on Repeater, didn't help.
    I change to have external power for RF on Repeater, didn't help.
    Reprogram Repeater, didn't help.

    Finally I restarted my RPi, that helped.

    I have 6-8 meters from GW to Repeater, there is 2 inner walls, 1 brick wall, 1 wood wall and the GW is inside my drawer so some woods there as well.
    It is a Serial GW with nRF24L01+ PA + LNA with shield. I take 5 volt from UNO to an adapter that step-down to 3.3V I have Cap on GW
    Repeater is Arduino Nano with nRF24L01+ PA + LNA no shield and Cap, power from 5v Nano to an adapter step-down to 3,3V

    What is next step?:flushed:

    Reposition and put it to the test in the vicinity of the goal.
    Exclude in this way the problem of the range.
    It's just a tip :smiley:


  • Hero Member

    @flopp

    If you live in a highly populated area the 2.4GHz part of the radio spectrum can get quite busy. There are a host of devices that could be sharing the same channel that you have setup your network on. These may include WiFi networks, cordless telephones, surveillance camera transmitters, bluetooth devices and a range of others that may be using the 2.4GHz ISM band. On top of this you may have to contend with noise being generated by other appliances, Microwave ovens for example operate at around 2.45GHz. See this page for an idea of what you are up against.

    When I first built my gateway I was very disappointed with the range I was getting but after spending a bit of time I now have my whole house covered by it and now only need repeater nodes for the outside area.

    I have found that intermittent nodes are usually caused by either power supply problems or range/channel crowding problems. If you take a logical approach to your fault finding you will soon have a reliable network.

    The first thing you should do is build a node that you can use to test the range of your gateway. You will need this so you can compare the results for changes that you make to improve the range. You will need a laptop and a small breadboard to complete the test unit.

    You can see my simple range tester node below

    0_1473028702681_tester.jpg

    You can then load this simple sketch, which just transmits dummy data every 5 seconds.

    /**
     * rangeTester
     */
    
    // Enable debug prints to serial monitor
    #define MY_DEBUG 
    
    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    //#define MY_RADIO_RFM69
    
    #include <SPI.h>
    #include <MySensors.h>  
    
    #define CHILD_ID_LIGHT 0
    
    
    unsigned long WAIT_TIME = 5000; //  time between reads (in milliseconds)
    
    MyMessage msg(CHILD_ID_LIGHT, V_LIGHT_LEVEL);
    
    
    
    void presentation()  {
      // Send the sketch version information to the gateway and Controller
      sendSketchInfo("Range Finder", "1.0");
    
      // Register all sensors to gateway (they will be created as child devices)
      present(CHILD_ID_LIGHT, S_LIGHT_LEVEL);
    }
    
    void loop()      
    {     
      
     for (int i=0; i<20; i++) {
       send(msg.set(i));
       Serial.println(i);
       wait(WAIT_TIME);
     }
      
    }
    
    
    
    
    

    plug the node into your laptop and walk around your house and watch the serial monitor to see when the node loses reliable contact with the gateway. Make sure you don't have any repeater nodes going at this time and always have the radio in the same position in relation to the gateway as this will make a difference too.

    you will see an output like this

    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:2
    2
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:3
    3
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:4
    4
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:5
    5
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:6
    6
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:7
    7
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:8
    8
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:9
    9
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:10
    10
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:11
    11
    TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=ok:12
    12
    !TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=0,st=fail:13
    13
    !TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=1,st=fail:14
    14
    !TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=2,st=fail:15
    15
    !TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=3,st=fail:16
    16
    !TSP:MSG:SEND 3-3-0-0 s=0,c=1,t=23,pt=2,l=2,sg=0,ft=4,st=fail:17
    
    

    When you see the fail your connection has been lost, move back closer to the gateway and you will see ok again. It may be a good idea to have a rough plan of your house as well so you can mark down the current range limits to compare with later results. Once you have this base data then we can talk about improving your range :)



  • @Boots33
    Thank you very much, this is something I really need to test.
    Since my restart yesterday all nodes has been working.

    I got answer about what frequencies nRF is using, see this post https://forum.mysensors.org/topic/4721/nrf-frequency-and-channels/4




Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.