Dallas Temperature Sensor on MySensors 2.0 - Temperature Value not showed in Vera Controller



  • Hi Guys,

    Congratulations for the great community maintained here. I am just a newbie and will appreciate your help with the following: I am using Mysensors V2, Arduino IDE 1.6.10, VeraPlus controller, Linux (Ubuntu 12.04) and Dallas Temperature Libraries and sketch example from Github (for sensors that uses other libraries). I am trying to setup a node that act as a Repeater, Light Sensor, Temperature, and doorbell (videophone) detector (this last one needs more work).

    While I was able to receive sensor data related to Lightlevel in Vera, and the Serial monitor don't show a problem in the Temperature Sensor (reporting as transmitted ok) I cannot watch the temperature value in Vera (just shows °C without value).

    Please, I was surfing the web since several weeks from now without success in troubleshooting the problem. Any help will be greatly appreciated.

    Here follows the Sensor log that report the temperature:

    ....

    TSP:MSG:SEND 1-1-0-0 s=1,c=1,t=16,pt=0,l=1,sg=0,ft=0,st=ok:1
    The ring has beeen pressed! pcb value:0.9863

    TSP:MSG:SEND 1-1-0-0 s=1,c=1,t=16,pt=0,l=1,sg=0,ft=0,st=ok:0
    Requesting Temperature info...Done.

    Temperature : 20.50

    TSP:MSG:SEND 1-1-0-0 s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=ok:20.5
    *** Lightlevel : 15

    .....

    And here the Gateway log

    ...
    =1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;1;0;0;20.5
    0;255;3;0;9;TSP:MSG1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    =0,c=1,t=0,pt=7,l=5,sg=0:20.5
    1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=0,c=1,t=0,pt=7,l=5,sg=0:20.5
    1;0;1;0;0;20.5
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=0,c=1,t=0,pt=7,l=5,sg=0:20.5
    1;0;1;0;0;20.5
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    1;1;1;0;16;1
    =1,c=1,t=16,pt=0,l=1,sg=0:0
    1;1;1;0;16;0



  • @pndgt0

    Post your sketch using the </> tool.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.