Serial Gateway not recognized

  • Hi,

    Domoticz is running on a NanoPi Linux. I just started with Domoticz. The gateway was recognized 2 days ago, but after i accidentally removed the sdcard while running it won't recognize the gateway any more. Made a fresh Domoticz installation. But no entry in the Hardware section 馃槥

    So my gateway is connected to ttyUSB0 according to dmesg. Correct?

    [  400.935722] ch341 6-1:1.0: device disconnected
    [  406.871835] ehci_irq: highspeed device connect
    [  407.080056] ehci_irq: highspeed device disconnect
    [  407.080087] ohci_irq: fullspeed or lowspeed device connect
    [  407.510120] usb 8-1: new full-speed USB device number 2 using sunxi-ohci
    [  407.731631] ch341 8-1:1.0: ch341-uart converter detected
    [  407.772934] usb 8-1: ch341-uart converter now attached to ttyUSB0

    This is the only thing that happens after starting Domoticz:

    2016-10-10 20:22:52.046 Domoticz V3.5744 (c)2012-2016 GizMoCuz
    2016-10-10 20:22:52.047 Build Hash: 289b09a, Date: 2016-10-09 15:14:57
    2016-10-10 20:22:52.047 Startup Path: /root/domoticz/
    2016-10-10 20:22:52.133 Sunrise: 07:12:00 SunSet:19:10:00
    2016-10-10 20:22:52.133 EventSystem: reset all events...
    2016-10-10 20:22:52.163 Active notification subsystems: (0/12)
    2016-10-10 20:22:52.195 WebServer(HTTP) started on address: :: with port 8080
    2016-10-10 20:22:52.220 WebServer(SSL) started on address: :: with port 443
    2016-10-10 20:22:52.222 Proxymanager started.
    2016-10-10 20:22:52.225 Starting shared server on: :::6144
    2016-10-10 20:22:52.225 TCPServer: shared server started...
    2016-10-10 20:22:52.226 RxQueue: queue worker started...
    2016-10-10 20:22:54.229 EventSystem: reset all events...
    2016-10-10 20:22:54.230 EventSystem: reset all device statuses...
    2016-10-10 20:22:54.232 EventSystem: Started
    2016-10-10 20:22:54.950 Incoming connection from:

    So. No gateway found. 馃槥
    This is my Gateway sketch from Arduini IDE examples:

    // Enable debug prints to serial monitor
    #define MY_DEBUG 
    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    //#define MY_RADIO_RFM69
    // Set LOW transmit power level as default, if you have an amplified NRF-module and
    // power your radio separately with a good regulator you can turn up PA level. 
    #define MY_RF24_PA_LEVEL RF24_PA_LOW
    // Enable serial gateway
    // Define a lower baud rate for Arduino's running on 8 MHz (Arduino Pro Mini 3.3V & SenseBender)
    #if F_CPU == 8000000L
    #define MY_BAUD_RATE 38400
    // Flash leds on rx/tx/err
    // Set blinking period
    // Inverses the behavior of leds
    // Enable inclusion mode
    // Enable Inclusion mode button on gateway
    // Inverses behavior of inclusion button (if using external pullup)
    // Set inclusion mode duration (in seconds)
    // Digital pin used for inclusion mode button
    // Uncomment to override default HW configurations
    //#define MY_DEFAULT_ERR_LED_PIN 4  // Error led pin
    //#define MY_DEFAULT_RX_LED_PIN  6  // Receive led pin
    //#define MY_DEFAULT_TX_LED_PIN  5  // the PCB, on board LED
    #include <SPI.h>
    #include <MySensors.h>  
    void setup() { 
      // Setup locally attached sensors
    void presentation() {
     // Present locally attached sensors 
    void loop() { 
      // Send locally attached sensor data here 

    When i connect the Gateway to my windows PC the serial monior shows this:

    0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;14;Gateway startup complete.
    0;255;3;0;9;No registration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1

    I don't see what can be wrong. What else can i check or change?

    Cheeers from Sumatra

  • What are your settings in Domoticz, hardware?

  • I am not sure what you mean by "settings"? Where can i do hardware settings?
    Here is how my Hardware section looks like:

  • Wow.
    Proof of beeing a real noob:

    I thought it will recognize the gateway automatically. But seems i must add it manual.
    Stupid me. Sorry wasting time and space.

  • Mod

    @edsteve no waste at all. Someone else might make the same mistake and now they'll be able to find the solution if they search. Thanks for reporting back 馃檪

Log in to reply

Suggested Topics