No new devices where found

  • Hi Erik,

    I've tried several methods/ways, but Homey keeps telling me that there are no devices found, restarted the gateway, restarted the node itself, it simply doesn't want to find the gateway. Any help?

    The output in the serial gateway looks fine by me:

    0_1477146904549_Schermafbeelding 2016-10-22 om 16.34.09.png

    Homey doesn't find any of the devices, hope you can help out.
    0_1477146922615_Schermafbeelding 2016-10-22 om 16.34.32.png


    Ps, always available for a debugging session if needed through teamviewer etc.

  • Hardware Contributor

    i dont know Homey, but you have to enable "Inclusion Mode" before add new Sensor?!

  • i have the same problem using the ethernet gateway. Sensor registers fine. Homey keeps telling no new sensors found.

    Mayby someone can post a working gateway sketch

    thanks evad

  • Got it working after running the app through the CLI, it suddenly wanted to find sensors.

    If we need to enable inclusion mode, does somebody has an example how that works with an ESP8266 Wifi gateway and a simple barometric sensor.


  • @Arjan-van-den-Eijnden

    Thanks wil try the cli method

    Can you tell me if i have to uncomment the line

    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254

  • Plugin Developer

    @Arjan-van-den-Eijnden, @evad
    Witch version of Homey and the app do you use?

    I know that someone got the same problem in the beginning, but after reboot the gateway and sensors it started to pop up in Homey.
    Have you tried it?

    I will post my sketch for my ESP8266 WIFI gateway when i get home.

  • @ErrK ,

    Homey V0.10.7. After installing the 0.17 through the CLI the sensors started working (very strange).

    Hope to see your sketch has some details i'm missing in mine.


  • Plugin Developer

    @Arjan-van-den-Eijnden ,

    Strange that it is working after installing it through the CLI.
    But good it's working now 🙂

    I will look in to it to find out if there is a bug in the app.

  • Homey V0.10.7. I did reboot homey, reboot the gateway, installed the app trough cli. Still no go. Hope to see something jn your sketch that i missed


  • this is the serial output from the gateway

    1�{�1�991�0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;9;No registration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=0,c=1,t=37,pt=4,l=4,sg=0:-19
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=0,c=1,t=37,pt=4,l=4,sg=0:-20
    0;255;3;0;9;TSP:MSG:READ 10-10-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:FPAR REQ (sender=10)
    0;255;3;0;9;TSP:MSG:GWL OK
    0;255;3;0;9;TSP:MSG:SEND 0-0-10-10 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=ok:0
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=255,c=3,t=24,pt=1,l=1,sg=0:1
    0;255;3;0;9;TSP:MSG:PINGED (ID=10, hops=1)
    0;255;3;0;9;TSP:MSG:SEND 0-0-10-10 s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    0;255;3;0;9;!TSP:MSG:SEND 0-0-10-10 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=fail:0100
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=255,c=3,t=11,pt=0,l=25,sg=0:Soil Moisture Sensor Reve
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=0,c=0,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    0;255;3;0;9;TSP:MSG:SEND 0-0-10-10 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=0,c=1,t=37,pt=4,l=4,sg=0:-11
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=0,c=1,t=37,pt=4,l=4,sg=0:-18
    0;255;3;0;9;TSP:MSG:READ 10-10-0 s=0,c=1,t=37,pt=4,l=4,sg=0:-16

    homey has ip
    #define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 18

  • Plugin Developer

    Thanks @evad,
    I will look in to it.

    I use the example sketch for my ESP8266 gateway.
    Have only change the MY_ESP8266_SSID and MY_ESP8266_PASSWORD.

  • its working. I installed the raspberry gateway/mqtt broker.
    the raspberry reports to the mqtt broker topic: mysensors-out.
    once i changed that in homey it started to work

Log in to reply

Suggested Topics

  • 5
  • 1

  • Homey  


  • Homey  

  • 15
  • 1