Upgrading to 2.0 with whitelisting: !TSP:MSG



  • I've a node in my split unit air conditioner to control my airco with Domoticz. The node communicates through a repeater.

    I want to use whitelisting, so upgraded from 1.5 to 2.0. Everything seems fine, I could send messages from the gateway to the node. But... I get a !TSP:MSG message in the log file.

    Two questions:

    1. Is this normal, see logs below
    2. Is the whitelisting working/active (including signing, when I change the serial, I'll get a signing error)?

    Configuration node:
    #define MY_SIGNING_SOFT
    #define MY_SIGNING_SOFT_RANDOMSEED_PIN 7
    #define MY_SIGNING_REQUEST_SIGNATURES
    #define MY_SIGNING_NODE_WHITELISTING {{.nodeId = GATEWAY_ADDRESS,.serial = {0x4D,0x8E,0x8F,0x89,0x60,0x34,0x8F,0xCC,0x43}}}

    #define MY_NODE_ID 40

    #define MY_PARENT_NODE_ID 10 //Repeater 1
    //#define MY_PARENT_NODE_ID 11 //Repeater 2

    Configuration gateway:
    #define MY_SIGNING_SOFT
    #define MY_SIGNING_SOFT_RANDOMSEED_PIN 7

    Used SecurityPersonalizer to set HMAC, AES and a new Serial on gateway and airco-node (HMAC and AES are the same).

    Log repeater:
    TSP:MSG:READ 0-0-40 s=0,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:REL MSG
    TSP:MSG:SEND 0-10-40-40 s=0,c=3,t=16,pt=0,l=0,sg=1,ft=0,st=ok:
    TSP:MSG:READ 40-40-0 s=255,c=3,t=17,pt=6,l=25,sg=0:61228E563AE82E62E583A693BE93AAAD49CFA30DBBDB661754
    TSP:MSG:REL MSG
    TSP:MSG:SEND 40-10-0-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:61228E563AE82E62E583A693BE93AAAD49CFA30DBBDB661754
    TSP:MSG:READ 0-0-40 s=0,c=1,t=2,pt=0,l=1,sg=1:1
    TSP:MSG:REL MSG
    TSP:MSG:SEND 0-10-40-40 s=0,c=1,t=2,pt=0,l=1,sg=1,ft=0,st=ok:1
    TSP:MSG:READ 40-40-0 s=0,c=1,t=2,pt=0,l=1,sg=0:1
    TSP:MSG:REL MSG
    !TSP:MSG:SEND 40-10-0-0 s=0,c=1,t=2,pt=0,l=1,sg=0,ft=0,st=fail:1
    TSP:MSG:READ 40-40-0 s=1,c=2,t=47,pt=0,l=0,sg=0:
    TSP:MSG:REL MSG
    TSP:MSG:SEND 40-10-0-0 s=1,c=2,t=47,pt=0,l=0,sg=0,ft=1,st=ok:
    TSP:MSG:READ 0-0-40 s=1,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:REL MSG
    TSP:MSG:SEND 0-10-40-40 s=1,c=3,t=16,pt=0,l=0,sg=1,ft=0,st=ok:
    TSP:MSG:READ 40-40-0 s=255,c=3,t=17,pt=6,l=25,sg=0:23EDB656448AE71910C5299C36845AFBE97173826B337A0436
    TSP:MSG:REL MSG
    TSP:MSG:SEND 40-10-0-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:23EDB656448AE71910C5299C36845AFBE97173826B337A0436
    TSP:MSG:READ 0-0-40 s=1,c=2,t=47,pt=0,l=8,sg=1:01202216
    TSP:MSG:REL MSG
    TSP:MSG:SEND 0-10-40-40 s=1,c=2,t=47,pt=0,l=8,sg=1,ft=0,st=ok:01202216
    TSP:MSG:READ 40-40-0 s=0,c=1,t=2,pt=2,l=2,sg=0:0
    TSP:MSG:REL MSG
    TSP:MSG:SEND 40-10-0-0 s=0,c=1,t=2,pt=2,l=2,sg=0,ft=0,st=ok:0

    Log node startup:
    Starting sensor (RNNNAS, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=40)
    TSM:FPAR
    TSP:MSG:SEND 40-40-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSP:MSG:READ 0-0-40 s=255,c=3,t=8,pt=1,l=1,sg=1:0
    TSP:MSG:FPAR RES (ID=0, dist=0)
    TSP:MSG:PAR OK (ID=0, dist=1)
    TSP:MSG:READ 10-10-40 s=255,c=3,t=8,pt=1,l=1,sg=0:1
    TSP:MSG:FPAR RES (ID=10, dist=1)
    TSP:MSG:FPAR (PPAR FOUND)
    TSP:MSG:PAR OK (ID=10, dist=2)
    TSM:FPAR:OK
    TSM:ID
    TSM:CHKID:OK (ID=40)
    TSM:UPL
    TSP:PING:SEND (dest=0)
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=ok:1
    TSP:MSG:READ 0-10-40 s=255,c=3,t=25,pt=1,l=1,sg=0:2
    TSP:MSG:PONG RECV (hops=2)
    TSP:CHKUPL:OK
    TSM:UPL:OK
    TSM:READY
    Air Conditioner node with DS18B20 sensor
    Found # DS18B20: 1
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=ok:0103
    TSP:MSG:READ 0-10-40 s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    TSP:MSG:SEND 40-40-10-0 s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=ok:2.0.0
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=ok:10
    TSP:MSG:READ 0-10-40 s=255,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:F5D9FF228C89C831ACCC92A03A72AF1404E61FCAB5713F0262
    TSP:MSG:READ 0-10-40 s=255,c=3,t=6,pt=0,l=1,sg=1:M
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=11,pt=0,l=5,sg=0,ft=0,st=ok:Airco
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=ok:2.0
    TSP:MSG:SEND 40-40-10-0 s=0,c=0,t=3,pt=0,l=10,sg=0,ft=0,st=ok:Airco Send
    TSP:MSG:SEND 40-40-10-0 s=1,c=0,t=36,pt=0,l=10,sg=0,ft=0,st=ok:Airco Data
    TSP:MSG:SEND 40-40-10-0 s=2,c=0,t=6,pt=0,l=11,sg=0,ft=0,st=ok:Temperature
    NODE:!REG
    Request registration...
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=ok:2
    TSP:MSG:READ 0-10-40 s=255,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:2AFF78F86CF7535A3809359EE8A3F0D7E2CBB46896EB7CE624
    TSP:MSG:READ 0-10-40 s=255,c=3,t=27,pt=1,l=1,sg=1:1
    Node registration=1
    Init complete, id=40, parent=10, distance=2, registration=1

    Log node message from gateway:
    TSP:MSG:READ 0-10-40 s=0,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:61228E563AE82E62E583A693BE93AAAD49CFA30DBBDB661754
    TSP:MSG:READ 0-10-40 s=0,c=1,t=2,pt=0,l=1,sg=1:1
    TSP:MSG:ACK msg
    TSP:MSG:SEND 40-40-10-0 s=0,c=1,t=2,pt=0,l=1,sg=0,ft=0,st=ok:1
    Requesting IR code from Domoticz...
    !TSP:MSG:SEND 40-40-10-0 s=1,c=2,t=47,pt=0,l=0,sg=0,ft=0,st=fail:
    TSP:MSG:READ 0-10-40 s=1,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=1,st=ok:23EDB656448AE71910C5299C36845AFBE97173826B337A0436
    TSP:MSG:READ 0-10-40 s=1,c=2,t=47,pt=0,l=8,sg=1:01202216
    Message: 1, Message: 01202216

    Update:
    The node doesn't react anymore... Strange...
    TSP:MSG:SEND 40-40-10-0 s=1,c=2,t=47,pt=0,l=0,sg=0,ft=0,st=ok:
    TSP:MSG:READ 0-10-40 s=1,c=3,t=16,pt=0,l=0,sg=1:
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:98ED811AA0F6BE824A89927D3172CF9656B281FB711BCE28C5
    TSP:MSG:READ 0-10-40 s=1,c=3,t=16,pt=0,l=0,sg=0:
    TSP:MSG:SEND 40-40-10-0 s=255,c=3,t=17,pt=6,l=25,sg=0,ft=0,st=ok:8C42A5C36CAC1CE1F8354F26294261A658C186EC414A74AB04
    TSP:MSG:READ 0-10-40 s=1,c=2,t=47,pt=0,l=8,sg=1:00202216
    !TSP:MSG:SIGN verify fail
    TSP:MSG:READ 0-10-40 s=1,c=2,t=47,pt=0,l=8,sg=1:00202216
    !TSP:MSG:SIGN verify fail


Log in to reply
 

438
Online

7.0k
Users

7.9k
Topics

84.8k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.