Weird: no thing with the UID 'xxx' could be found


  • Mod

    As in the subject line (see below for full message).

    The Ventilator is switched on and off as expected but the error is thrown anyway. What could cause this?

    2017-02-12 22:00:04.935 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate command 'ON' for item 'VentilatorSwitch_Status' to handler for channel 'mysensors:light:93054b95:status', because no thing with the UID 'mysensors:light:93054b95' could be found.
    2017-02-12 22:00:04.943 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update 'ON' for item 'VentilatorSwitch_Status' to handler for channel 'mysensors:light:93054b95:status', because no thing with the UID 'mysensors:light:93054b95' could be found.
    2017-02-12 22:00:27.591 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate command 'OFF' for item 'VentilatorSwitch_Status' to handler for channel 'mysensors:light:93054b95:status', because no thing with the UID 'mysensors:light:93054b95' could be found.
    2017-02-12 22:00:27.603 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update 'OFF' for item 'VentilatorSwitch_Status' to handler for channel 'mysensors:light:93054b95:status', because no thing with the UID 'mysensors:light:93054b95' could be found.


  • Hero Member

    Does a change in the channel definition in the *.items file produces this warning? Does a restart solve the problem?

    I've seen this error while moving nodes in the *.things and therefore in the *.items file from one gateway to another. I'm currently in the process of migrating from NRF24 to RFM69 and if I copy & paste the thing definition between the gateways and change the *.items file this error occures despite the fact that the thing continues to work. It looks like a phantom link to the old thing is left / not deleted.


  • Mod

    @TimO A restart does not change things.

    Maybe it is a phantom link, as mentioned by you, because I did delete the first thing and item I created.
    Is there a way to check this?
    I only see the given_ids.cache file in user data.


  • Hero Member

    @marceltrapman I'm not yet sure if this is a bug in the binding or of Openhab itself. Openhab stores the information from paper ui in jsondb files. Mine are empty. Could you take a look in your files?


  • Mod

    @TimO Apologies for my late reply, I was on a business trip for a couple of days. Will check soon...


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.