Need help adding MySensors items to sitemap



  • Hi,

    I'm new to OpenHab2, and have a rather newbie question.

    I have OpenHab2 installed on my Raspberry Pi 2 with the MySensors plug-in installed and working with an Wifi-Gateway. I can add devices easily using discovery, and have gotten things like relays and temperature to show in the Paper UI easily. I'm not trying to work on creating the .sitemap and .item files in Notepad so I can build the UI the way I want for the iOS app. I'm stuck now on trying to get any data taht displays form text or number in the Basic UI part. Ex. I have a temperature and barometic pressure sensor that works fine in PaperUI, but not when I try to add it manually to the Basic UI.

    Here is my weather.items and default.sitemap file

    Number temp_living "Living Room Temperature [%.1f]" <temperature> { mysensors:temperature:ca1e2cbb:Temperature_5_1:temp }
    Number baro_living "Living Room Pressure [%.1f]" <temperature> { mysensors:baro:ca1e2cbb:Baro_5_0:pressure }
    
    Number upstairs_humidity "Upstairs Humidity [%.1f %%]" <temperature> { mysensors:humidity:ca1e2cbb:Humidity_1_0:hum }
    Number upstairs_temp "Upstairs Temperature [%.1f °C]" <temperature> { mysensors:temperature:ca1e2cbb:Temperature_1_1:temp }
    

    default.sitemap

    sitemap default label="My first sitemap"
    {
        Switch item=light_mancave_1 label="Man Cave Lamp 1"
        Switch item=light_mancave_2 label="Man Cave Lamp 2"
        Text item=temp_living 
        Text item=baro_living 
        Switch item=NestSmoke_is_online label="Nest Online?"
    }
    

    Thanks,


  • Mod

    @drock1985 You may have guessed it by now but this is not the best place to ask how to use OpenHAB(2).

    I have lots of questions still myself so I can't help you but I am sure you can get your answers on the OpenHAB forum or here: http://docs.openhab.org/configuration/sitemaps.html...


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.