SmartSleep and multiple messages on HVAC sensor



  • Hello to all and thanks for this incredible library!

    I have a sensor that is controlling my climate system through an IR led.
    I have Openhab2.2 as controller with mysensors 2.3 addon, a mysensors 2.1.1 serial gateway, and a mysensors 2.1.1 NRF24 node presenting an S_HVAC sensor:

      present(CHILD_ID_HVAC,  S_HVAC, "Controllo Climatizzatore");
    

    it implements all the functionalities of an HVAC system by receiving and sending back several message types:

    MyMessage msgSmHvacTemp(CHILD_ID_HVAC, V_TEMP);                         //mapped to temperature
    MyMessage msgSmHvacFlowState(CHILD_ID_HVAC, V_HVAC_FLOW_STATE);           //mapped to HvacMode
    MyMessage msgSmHvacSpeed(CHILD_ID_HVAC, V_HVAC_SPEED);               //mapped to HvacFanMode
    MyMessage msgSmHvacFlowMode(CHILD_ID_HVAC, V_HVAC_FLOW_MODE);          //mapped to HvacVanneMode
    MyMessage msgSmHvacSetPointCool(CHILD_ID_HVAC, V_HVAC_SETPOINT_COOL); //mapped to temperature
    MyMessage msgSmHvacSetPointHeat(CHILD_ID_HVAC, V_HVAC_SETPOINT_HEAT); //mapped to temperature
    

    the sensor goes in smartsleep mode every 30 seconds.

    everything works fine if I adjust one parameter per sleep cycle on my controller, but if I set more than one parameter (e.g. temperature and fan speed) only one message is sent from openhab:

    2018-04-28 15:53:40.906 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsReader] - Message from gateway received: 0;255;3;0;9;TSF:MSG:READ,9-9-0,s=255,c=3,t=22,pt=5,l=4,sg=0:3098
    2018-04-28 15:53:40.907 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsReader] - Message from gateway received: 9;255;3;0;22;3098
    2018-04-28 15:53:40.908 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsWriter] - Sending to MySensors: 9;0;1;1;22;3
    2018-04-28 15:53:40.908 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsWriter] - Message for nodeId: 9 in queue needs to be send immediately!
    2018-04-28 15:53:40.962 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsReader] - Message from gateway received: 0;255;3;0;9;TSF:MSG:SEND,0-0-9-9,s=0,c=1,t=22,pt=0,l=1,sg=0,ft=0,st=OK:3
    2018-04-28 15:53:40.963 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsReader] - Message from gateway received: 0;255;3;0;9;TSF:MSG:READ,9-9-0,s=0,c=1,t=22,pt=0,l=1,sg=0:3
    2018-04-28 15:53:40.964 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsReader] - Message from gateway received: 0;255;3;0;9;TSF:MSG:ACK
    2018-04-28 15:53:40.965 [DEBUG] [otocol.MySensorsAbstractConnection$MySensorsReader] - Message from gateway received: 9;0;1;1;22;3
    

    is this a bug or I misunderstood the queue system of smartsleep? there a workaround for this?


  • Mod

    I can't help you on the openhab side, but I can tell you that you may consider also other options https://forum.mysensors.org/topic/8018/mqtt-ir-remote or Broadlink RM devices



  • @gohan thanks, however the issue i'm having is not in the HVAC implementation, but in the messaging..


 

318
Online

8.0k
Users

8.8k
Topics

94.3k
Posts