fody weather station



  • Re: [fody weather station](wind sensor)

    I found one of these on ebay for €26 and then found this thread
    https://forum.mysensors.org/topic/6645/fody-weather-station-wind-sensor
    WOW did that just save me loads of time.

    At the moment I am happy that everything is working ok with the unit and sending the data to the gateway, But...
    I am trying to get the data into iobroker and it all works apart from the wind direction.

    iobroker shows the node wind with only V_GUST and V_WIND but not V_DIRECTION

    1871203 TSF:MSG:SEND,1-1-0-0,s=200,c=1,t=8,pt=7,l=5,sg=0,ft=0,st=OK:0.3
    Wind speed: 0.27
    1871212 TSF:MSG:SEND,1-1-0-0,s=200,c=1,t=9,pt=7,l=5,sg=0,ft=0,st=OK:29.7
    Wind gust: 29.65
    1871221 TSF:MSG:SEND,1-1-0-0,s=200,c=1,t=10,pt=7,l=5,sg=0,ft=0,st=OK:180
    Wind direction: 180
    1871228 TSF:MSG:READ,0-0-1,s=200,c=1,t=8,pt=7,l=5,sg=0:0.3
    1871235 TSF:MSG:ACK
    1871237 TSF:MSG:READ,0-0-1,s=200,c=1,t=9,pt=7,l=5,sg=0:29.7
    1871242 TSF:MSG:ACK
    1871255 TSF:MSG:READ,0-0-1,s=200,c=1,t=10,pt=7,l=5,sg=0:180
    1871260 TSF:MSG:ACK
    

    Can anyone point me in the right direction to sort this out?
    Thanks in advance

    I have tried the iobroker forum without luck.



  • @stephen205

    I have looked in the iobroker/mysensors/getmeta.js

    line 10 'S_WIND': {index: 9, role: 'direction', vars: ['V_WIND', 'V_GUST']},

    Is V_DIRECTION supposed to be included there and could that be the cause of the problem?



  • So i have given up with iobroker and used FHEM instead, worked well first time.


 

263
Online

8.6k
Users

9.4k
Topics

99.1k
Posts