Values not presenting in DisplaySSD1306



  • @user2684

    Hi, I have a problem with values not showing in the DisplaySSD1306.

    I have made a temperature and distance node with a Ds18b20 and a VL53L0X and also connected a DisplaySSD1306. Debug and sketch below. The thing is the values from the sensors are showing up correctly in the controller but the not in the display, only 0.00 is presenning in the display, any ideas of what is wrong?

    Thanks!
    0_1549052752726_IMG_20190201_212118.jpg

    Debug:

    0 NM:INIT:VER=1.8
    0 NM:INIT:INO=BMEDallas84 v1.1
    0 NM:INIT:LIB VER=2.2.0 CP=RNNNA---
    0 NM:INIT:RBT p=255
    20 NM:BFR:INIT
    2115 NM:BFR:OK
    2135 NM:PRES:Temperatur(1) p=6 t=0
    2173 NM:PRES:Avstånd(2) p=15 t=13
    2212 NM:PRES:SSD1306(3) p=36 t=47
    2259 NM:STP:ID=3 M=1
    2443 NM:STP:HW V=4957 F=16 M=803
    3210 NM:LOOP:Temperatur(1):SET t=0 v=20.00
    4187 NM:LOOP:Temperatur(1):SET t=0 v=20.00
    5164 NM:LOOP:Temperatur(1):SET t=0 v=20.02
    6140 NM:LOOP:Temperatur(1):SET t=0 v=20.03
    7116 NM:LOOP:Temperatur(1):SET t=0 v=20.03
    7434 NM:LOOP:Avstånd(2):SET t=13 v=8190
    7748 NM:LOOP:Avstånd(2):SET t=13 v=8190
    8060 NM:LOOP:Avstånd(2):SET t=13 v=8190
    8356 NM:LOOP:Avstånd(2):SET t=13 v=8190
    8670 NM:LOOP:Avstånd(2):SET t=13 v=8190
    8983 NM:SLP:SLEEP s=300

    /**********************************
     * MySensors node configuration
     */
    
    // General settings
    #define SKETCH_NAME "BMEDallas84"
    #define SKETCH_VERSION "1.1"
    
    
    // NRF24 radio settings
    #define MY_RADIO_NRF24
    //#define MY_RF24_ENABLE_ENCRYPTION
    #define MY_RF24_CHANNEL 84
    
    #define MY_BAUD_RATE 9600
    //#define MY_SMART_SLEEP_WAIT_DURATION_MS 500
    #define MY_SPLASH_SCREEN_DISABLED
    
    #define NODEMANAGER_DEBUG ON
    #define NODEMANAGER_INTERRUPTS OFF
    #define NODEMANAGER_SLEEP ON
    #define NODEMANAGER_RECEIVE OFF
    #define NODEMANAGER_DEBUG_VERBOSE OFF
    #define NODEMANAGER_POWER_MANAGER OFF
    #define NODEMANAGER_CONDITIONAL_REPORT OFF
    #define NODEMANAGER_EEPROM OFF
    #define NODEMANAGER_TIME OFF
    #define NODEMANAGER_RTC OFF
    #define NODEMANAGER_SD OFF
    #define NODEMANAGER_HOOKING OFF
    #define NODEMANAGER_OTA_CONFIGURATION OFF
    #define NODEMANAGER_SERIAL_INPUT OFF
    
    // import NodeManager library (a nodeManager object will be then made available)
    #include <MySensors_NodeManager.h>
    
    /***********************************
     * Add your sensors
     */
    #include <sensors/SensorDs18b20.h>
    SensorDs18b20 ds18b20(5);
    
    #include <sensors/SensorVL53L0X.h>
    SensorVL53L0X vl53l0x(4);
    
    #include <sensors/DisplaySSD1306.h>
    DisplaySSD1306 ssd1306;
    
    
    
    // before
    void before() {
    	
      /***********************************
       * Configure your sensors
       */
       
      
      ds18b20.children.get(1)->setDescription("Temperatur");
      vl53l0x.children.get(1)->setDescription("Avstånd");
      ds18b20.setSamples(5);
      ds18b20.setSamplesInterval(200);
      vl53l0x.setSamples(5);
      vl53l0x.setSamplesInterval(200);
        nodeManager.setSleepMinutes(5);
      
      // call NodeManager before routine
      nodeManager.before();
    }
    
    // presentation
    void presentation() {
      // call NodeManager presentation routine
      nodeManager.presentation();
    }
    
    // setup
    void setup() {
      // call NodeManager setup routine
      nodeManager.setup();
    }
    
    // loop
    void loop() {
      // call NodeManager loop routine
      nodeManager.loop();
    }
    
    #if NODEMANAGER_RECEIVE == ON
    // receive
    void receive(const MyMessage &message) {
      // call NodeManager receive routine
      nodeManager.receive(message);
    }
    #endif
    
    #if NODEMANAGER_TIME == ON
    // receiveTime
    void receiveTime(unsigned long ts) {
      // call NodeManager receiveTime routine
      nodeManager.receiveTime(ts);
    }
    #endif
    


  • @getz99 Can you do us a favor and edit your post and highlight your code section and click the "</>" icon to convert it to a code block. It makes it much easier to read.

    Thanks


  • Contest Winner

    @getz99 I remember we had a similar issue with the display before releasing v1.8 but I was sure it was fixed. Do the values stay at 0 forever or just at the very beginning? Meanwhile I've opened https://github.com/mysensors/NodeManager/issues/469 so to track this down. Thanks



  • @user2684 the values stay at 0 forever in the display, everything else is working fine. Thanks



  • I have a motion sensor, DHT22, and DisplaySSD1306 connected. I am experiencing the same issue. The values are read from the sensors and sent to the controller. However, the display shows lines for battery, DHT22 temp and humidity, and motion, but they are showing 0 for values.


 

205
Online

8.5k
Users

9.3k
Topics

98.5k
Posts